source: projects/specs/tags/6_0_REL/i/irrlicht/irrlicht-vl.spec @ 3061

Revision 3061, 5.9 KB checked in by kazutaka, 13 years ago (diff)

supertuxkart の更新に伴い新規作成

Line 
1%global irrxml_version 1.2
2
3Name:           irrlicht
4Summary:        A high performance realtime 3D engine
5Version:        1.7.2
6Release:        1%{?_dist_release}
7License:        zlib
8Group:          System Environment/Libraries
9Source0:        http://downloads.sourceforge.net/irrlicht/%{name}-%{version}.zip
10# Various fixes, optflags, system libraries/headers
11# http://irrlicht.sourceforge.net/phpBB2/viewtopic.php?t=24076&highlight=
12Patch0:         irrlicht-1.7.1-optflags.patch
13# Get the code compiling
14Patch1:         irrlicht-1.5.1-glext.patch
15# Use system libaesgm
16Patch2:         irrlicht-1.7.1-libaesgm.patch
17# Use improved fastatof from assimp
18Patch3:         irrlicht-1.7.2-fastatof-improvements.patch
19# Make libIrrXML.so
20Patch4:         irrlicht-1.7.2-irrXML-shared-library.patch
21
22URL:            http://irrlicht.sourceforge.net/
23BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
24BuildRequires:  libXxf86vm-devel, mesa-libGL-devel, mesa-libGLU-devel
25BuildRequires:  libjpeg-devel, zlib-devel, libaesgm-devel
26BuildRequires:  libpng-devel, bzip2-devel, unzip
27
28%description
29The Irrlicht Engine is an open source high performance realtime 3D engine
30written and usable in C++ and also available for .NET languages. It is
31completely cross-platform, using D3D, OpenGL and its own software renderer,
32and has all of the state-of-the-art features which can be found in
33commercial 3d engines.
34
35%package devel
36Summary:        Development headers and libraries for irrlicht
37Requires:       %{name} = %{version}-%{release}
38Requires:       mesa-libGL-devel, mesa-libGLU-devel, libXxf86vm-devel
39Requires:       libjpeg-devel, zlib-devel, libpng-devel
40Requires:       irrXML-devel = %{irrxml_version}
41Group:          Development/Libraries
42
43%description devel
44Development headers and libraries for irrlicht.
45
46%package -n irrXML
47Summary:        Simple and fast XML parser for C++
48Group:          System Environment/Libraries
49Version:        %{irrxml_version}
50
51%description -n irrXML
52irrXML is a simple and fast open source xml parser for C++.
53
54%package -n irrXML-devel
55Summary:        Development headers and libraries for irrXML
56Version:        %{irrxml_version}
57Requires:       irrXML = %{irrxml_version}-%{release}
58Group:          Development/Libraries
59
60%description -n irrXML-devel
61Development headers and libraries for irrXML.
62
63%prep
64%setup -q
65%patch0 -p1 -b .optflags
66%patch1 -p1 -b .glext
67%patch2 -p1 -b .libaesgm
68%patch3 -p1 -b .fastatof
69%patch4 -p1 -b .irrXML
70
71sed -i 's/\r//' readme.txt
72iconv -o readme.txt.iso88591 -f iso88591 -t utf8 readme.txt
73mv readme.txt.iso88591 readme.txt
74# We don't use any of this. Deleting it so the debuginfo doesn't pick it up.
75rm -rf source/Irrlicht/jpeglib source/Irrlicht/zlib source/Irrlicht/libpng source/Irrlicht/aesGladman
76
77for i in include/*.h doc/upgrade-guide.txt source/Irrlicht/*.cpp source/Irrlicht/*.h; do
78        sed -i 's/\r//' $i
79        chmod -x $i
80        touch -r changes.txt $i
81done
82
83%build
84cd source/Irrlicht
85make %{?_smp_mflags} sharedlib
86
87%install
88rm -rf %{buildroot}
89mkdir -p %{buildroot}%{_libdir}
90mkdir -p %{buildroot}%{_includedir}/%{name}
91make -C source/Irrlicht INSTALL_DIR=%{buildroot}%{_libdir} install
92cp -a include/* %{buildroot}%{_includedir}/%{name}/
93cd %{buildroot}%{_libdir}
94ln -s libIrrlicht.so.%{version} libIrrlicht.so.1
95
96%clean
97rm -rf %{buildroot}
98
99%post -p /sbin/ldconfig
100%postun -p /sbin/ldconfig
101
102%post -n irrXML -p /sbin/ldconfig
103%postun -n irrXML -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc readme.txt
108%{_libdir}/libIrrlicht*.so.*
109%{_libdir}/libIrrXML*.so.*
110
111%files devel
112%defattr(-,root,root,-)
113%doc doc/upgrade-guide.txt
114%{_includedir}/%{name}/
115%exclude %{_includedir}/%{name}/fast_atof.h
116%exclude %{_includedir}/%{name}/heapsort.h
117%exclude %{_includedir}/%{name}/irrArray.h
118%exclude %{_includedir}/%{name}/irrString.h
119%exclude %{_includedir}/%{name}/irrTypes.h
120%exclude %{_includedir}/%{name}/irrXML.h
121%{_libdir}/libIrrlicht*.so
122%{_libdir}/libIrrXML*.so
123
124%files -n irrXML
125%defattr(-,root,root,-)
126%doc readme.txt
127%{_libdir}/libIrrXML*.so.*
128
129%files -n irrXML-devel
130%defattr(-,root,root,-)
131%dir %{_includedir}/%{name}/
132%{_includedir}/%{name}/fast_atof.h
133%{_includedir}/%{name}/heapsort.h
134%{_includedir}/%{name}/irrArray.h
135%{_includedir}/%{name}/irrString.h
136%{_includedir}/%{name}/irrTypes.h
137%{_includedir}/%{name}/irrXML.h
138%{_libdir}/libIrrXML*.so
139
140%changelog
141* Wed Mar 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 1.7.2-1
142- initial build for Vine Linux based of fedora development
143
144* Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-4
145- add post/postun scripts for irrXML
146
147* Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-3
148- fix versioning on irrXML-devel
149
150* Wed Dec 15 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-2
151- make subpackages for irrXML
152- use assimp patch for performance improvement in IrrXML
153
154* Wed Nov 17 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.2-1
155- update to 1.7.2
156
157* Mon May 24 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.1-2
158- rebuild against fixed libaesgm
159
160* Thu Feb 18 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.7.1-1
161- update to 1.7.1
162
163* Thu Jan 14 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-1
164- update to 1.6.1
165
166* Wed Sep 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6-1
167- update to 1.6
168
169* Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.5.1-1
170- update to 1.5.1
171
172* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-4
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
174
175* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
176- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
177
178* Sat Jan 10 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-2
179- fix libpng calls so we can use system libpng (thanks to tom lane)
180- fix license tag
181
182* Thu Jan 8 2009 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-1
183- build against system libpng
184- update to 1.5 final
185
186* Thu Dec 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-0.2.beta
187- fix optflags patch so that ldconfig isn't called during make install
188
189* Wed Dec 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5-0.1.beta
190- Initial package for Fedora
Note: See TracBrowser for help on using the repository browser.