source: projects/specs/tags/6_0_REL/i/iksemel/iksemel-vl.spec @ 521

Revision 521, 4.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        An XML parser library designed for Jabber applications
2Summary(ja):    Jabber アプリケーションのために設計された XML パーサ
3
4Name:           iksemel
5Version:        1.3
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://code.google.com/p/iksemel/
11Source0:        http://iksemel.googlecode.com/files/iksemel-%{version}.tar.gz
12Patch0:         iksemel-gcrypt-sha.patch
13Patch1:         iksemel-64bit.patch
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15
16BuildRequires:  gnutls-devel > 2
17BuildRequires:  libgcrypt-devel
18BuildRequires:  autoconf
19BuildRequires:  automake
20BuildRequires:  libtool > 2
21BuildRequires:  texinfo
22
23%description
24An XML parser library designed for Jabber applications. It is coded in
25ANSI C for POSIX compatible environments, thus highly portable.
26
27%package devel
28Summary:        Development files for iksemel
29Summary(ja):    iksemel の開発ファイル
30Group:          Development/Libraries
31Requires:       %{name} = %{version}-%{release}
32Requires:       gnutls-devel
33Requires:       pkgconfig
34
35Requires(post): /sbin/install-info
36Requires(preun): /sbin/install-info
37
38%description devel
39Development files for iksemel.
40
41%package utils
42Summary:        Utilities for iksemel
43Summary(ja):    iksemel 用のユーティリティ
44Group:          Applications/Internet
45Requires:       %{name} = %{version}-%{release}
46
47%description utils
48Utlity programs for iksemel.
49
50%prep
51%setup0 -q
52%patch0 -p1
53%patch1 -p1
54
55# force rebuilding of the info file
56rm doc/iksemel
57
58%build
59# We need to re-run the autotools because the patch we apply modifies
60# the configure.ac and src/Makefile.am
61libtoolize --copy --force --automake
62aclocal
63autoheader
64automake --add-missing --force-missing --gnu --include-deps
65autoconf
66%configure --disable-static --disable-rpath
67make %{?_smp_mflags}
68
69%install
70rm -rf %{buildroot}
71make install DESTDIR=%{buildroot}
72
73rm -f %{buildroot}%{_libdir}/*.la
74
75mv %{buildroot}%{_infodir}/iksemel %{buildroot}%{_infodir}/iksemel.info
76
77%check
78%ifnarch ppc
79make check
80%endif
81
82%clean
83rm -rf %{buildroot}
84
85%postun -p /sbin/ldconfig
86
87%post -p /sbin/ldconfig
88
89%post devel
90/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
91
92%preun devel
93if [ $1 = 0 ]; then
94    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
95fi
96
97%files
98%defattr(-,root,root,-)
99%doc AUTHORS ChangeLog COPYING HACKING NEWS README TODO
100
101%{_libdir}/libiksemel.so.*
102
103%files devel
104%defattr(-,root,root,-)
105%doc COPYING
106
107%{_libdir}/libiksemel.so
108%{_includedir}/iksemel.h
109%{_libdir}/pkgconfig/iksemel.pc
110%{_infodir}/iksemel.info*
111
112%files utils
113%defattr(-,root,root,-)
114%doc COPYING
115
116%{_bindir}/ikslint
117%{_bindir}/iksperf
118%{_bindir}/iksroster
119
120%changelog
121* Tue May 05 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3-2vl5
122- rebuild with gnutls 2.6.6, libtool 2.2.6
123
124* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.3-1vl5
125- applied new versioning policy, spec in utf-8
126
127* Wed Dec 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
128- initial build for Vine Linux
129
130* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-2
131- Disable "make check" on PPC again.
132
133* Sat Aug 25 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3-1
134- Update to 1.3
135- Don't need to BR pkgconfig because gnutls-devel now requires it properly.
136- Update license.
137- Run "make check" on PPC
138- Update patches so that they apply to 1.3
139- Update URLs
140
141* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-13
142- ppp != ppc
143
144* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-12
145- Don't run make check on PPC - tests failing.
146
147* Thu Nov 16 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-11
148- Add patch from Hans de Goede that fixes 64 bit issues
149- Re-enable "make check".
150- Remove tabs from specfile.
151
152* Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-10
153- Bump release and rebuild.
154
155* Wed Aug  2 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-6
156- Temporarily disable make check until problems with it can be figured out.
157
158* Thu Jul 27 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-5
159- Patch to use SHA1 hashing routines from libgcrypt rather than
160  broken internal code.  This means that we need to BR autoools
161  to regenerate comfigure script and makefiles.
162
163* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-4
164- Don't re-run autotools, fix rpath in a different way.
165
166* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-3
167- Add a %check section.
168- Add BR for libtool.
169
170* Tue May 30 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-2
171- Add texinfo BR
172
173* Mon May 29 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.2-1
174- First version for Fedora Extras.
175
Note: See TracBrowser for help on using the repository browser.