source: projects/specs/tags/6_0_REL/i/icu/icu-vl.spec @ 818

Revision 818, 4.8 KB checked in by owa, 14 years ago (diff)

add libicutest.so

Line 
1%define sover 44
2Summary: International Components for Unicode
3Summary(ja): ユニコード用国際化コンポーネント
4Name: icu
5Version: 4.4
6Release: 2%{?_dist_release}
7Group:   Development/Tools
8License: MIT
9URL:     http://icu-project.org/
10
11Source0: http://download.icu-project.org/files/icu4c/4.0.1/icu4c-4_4-src.tgz
12Source1: http://download.icu-project.org/files/icu4c/4.0.1/icu4c-4_4-docs.zip
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: gcc-c++
16BuildRequires: unzip perl
17#Requires: libicu%{sover} = %{version}
18Requires: libicu = %{version}-%{release}
19
20%description
21ICU is a C++ and C library that provides robust and full-featured Unicode
22support. This package contains the Unicode character database and derived
23properties, along with converters and time zones data.
24
25#package -n libicu%{sover}
26%package -n libicu
27Summary: International Components for Unicode (library)
28Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
29Group: System Environment/Libraries
30Provides: libicu%{sover} = %{version}-%{release}
31
32#description -n libicu%{sover}
33%description -n libicu
34ICU is a C++ and C library that provides robust and full-featured Unicode
35support. This package contains the runtime libraries for ICU. It does not
36contain any of the data files needed at runtime.
37
38%package -n libicu-devel
39Summary: Header files, libraries and development documentation for libicu
40Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
41Group: Development/Libraries
42Requires: libicu = %{version}-%{release}
43
44%description -n libicu-devel
45This package contains the header files, static libraries for %{name}.
46If you like to develop programs using %{name}, you will need to install
47%{name}-devel.
48
49%package -n libicu-doc
50Summary: Documentation for International Components for Unicode
51Summary(ja): ユニコード用国際化コンポーネントのドキュメント
52Group: Applications/Documentation
53
54%description -n libicu-doc
55This package contains the development documentation for %{name}.
56
57%prep
58%setup -q -n %{name}
59find . -name CVS -o -name .cvsignore | xargs -r rm -rf
60perl -pi -e 's/^(HAVE_DOT\b.*=).*$/$1 YES/' source/Doxyfile.in
61
62mkdir docs
63pushd docs
64unzip %{SOURCE1}
65popd
66
67%build
68cd source
69export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
70export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
71%configure --disable-static --with-data-packaging=library --disable-samples
72make
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make -C source install DESTDIR=$RPM_BUILD_ROOT
77cp -pR ./source/tools/ctestfw/libicutest.so* $RPM_BUILD_ROOT/%{_libdir}
78chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
79
80%check || :
81make -C source check
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -n libicu -p /sbin/ldconfig
87
88%postun -n libicu -p /sbin/ldconfig
89
90%files
91%defattr(-, root, root, 0755)
92%doc license.html readme.html
93%{_bindir}/derb
94%{_bindir}/genbrk
95%{_bindir}/gencfu
96%{_bindir}/gencnval
97%{_bindir}/genctd
98%{_bindir}/genrb
99%{_bindir}/icuinfo
100%{_bindir}/makeconv
101%{_bindir}/pkgdata
102%{_bindir}/uconv
103%{_sbindir}/*
104%{_mandir}/man?/*
105%exclude %{_mandir}/man1/icu-config.1*
106
107%files -n libicu
108%defattr(-, root, root, 0755)
109%{_libdir}/*.so.*
110
111%files -n libicu-devel
112%defattr(-, root, root, 0755)
113%{_bindir}/icu-config
114%{_includedir}/layout
115%{_includedir}/unicode
116%{_libdir}/*.so
117#{_libdir}/*.a
118%{_libdir}/%{name}
119%{_mandir}/man1/icu-config.1*
120%dir %{_datadir}/icu/
121%dir %{_datadir}/icu/4.4
122%{_datadir}/icu/4.4/config
123%{_datadir}/icu/4.4/install-sh
124%{_datadir}/icu/4.4/mkinstalldirs
125%doc %{_datadir}/icu/4.4/license.html
126
127%files -n libicu-doc
128%defattr(-,root,root,-)
129%doc docs/*
130
131%changelog
132* Tue Apr 13 2010 Shu KONNO <owa@bg.wakwak.com> 4.4-2
133- install libicutest.so*
134
135* Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4-1
136- new upstream release
137- built with new toolchain
138
139* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.1-1vl5
140- new upstream release
141- updated URL
142
143* Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 3.6-1vl5
144- applied new versioning policy, spec in utf-8
145
146* Tue Sep  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.6-0vl1
147- updated to 3.6
148- removed ".so ver" from libicu package name
149- changed Group to Development/Tools
150- changed libicu-doc Group to Applications/Documentation
151
152* Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.4.1-0vl1
153- updated to 3.4.1
154
155* Sun Jul 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.2-3vl1
156- updated to 3.2 based on Fedora extra
157- new subpackage libicu-doc for API document
158
159* Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0-0vl1
160- Build for Vine Linux
161- add developers document to devel package
162- add Japanese summary
163
164* Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-1
165- Fixed a typo in the dependencies "libuci" should be "libicu". (Daniel Demus)
166
167* Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-0
168- Initial package. (using DAR)
Note: See TracBrowser for help on using the repository browser.