source: projects/specs/tags/6_0_REL/g/grep/grep-vl.spec @ 2671

Revision 2671, 11.9 KB checked in by daisuke, 13 years ago (diff)

grep: update to 2.7

Line 
1Summary: The GNU versions of grep pattern matching utilities.
2Summary(ja): GNU版 grep パターンマッチングユーティリティ
3Name: grep
4Version: 2.7
5Release: 1%{?_dist_release}
6
7License: GPLv3+
8Group: System Environment/Base
9URL: http://www.gnu.org/software/grep/
10
11Source: ftp://ftp.gnu.org/pub/gnu/grep/grep-%{version}.tar.xz
12Source1: colorgrep.sh
13Source2: colorgrep.csh
14Source3: GREP_COLORS
15Patch0: grep-2.7-const-range-exp.patch
16
17Requires(post): install-info
18Requires(preun): install-info
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: pcre-devel, texinfo, gettext, gzip
21
22%description
23The GNU versions of commonly used grep utilities.  Grep searches
24through textual input for lines which contain a match to a specified
25pattern and then prints the matching lines.  GNU's grep utilities
26include grep, egrep and fgrep.
27
28You should install grep on your system, because it is a very useful
29utility for searching through text.
30
31%description -l ja
32一般に使われるgrepユーティリティのGNU版です。Grep は指定したパターンと一致
33する行を入力ファイルから捜し出して、その行を表示します。GNUのgrepユーティリ
34ティにはgrep, egrep, fgrepが入っています。
35
36テキストファイルの検索や、システム管理にとても役に立つので、是非インストール
37してください。
38
39%prep
40%setup -q
41%patch0 -p1 -b .const-range-exp
42
43%build
44%configure CPPFLAGS="-I%{_includedir}/pcre" \
45        --without-included-regex
46%__make %{?_smp_mflags}
47
48%install
49[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
50%__make DESTDIR=$RPM_BUILD_ROOT install
51gzip $RPM_BUILD_ROOT%{_infodir}/grep*
52rm -f $RPM_BUILD_ROOT%{_infodir}/dir
53mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
54install -pm 644 %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
55install -pm 644 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
56mkdir -p $RPM_BUILD_ROOT/bin
57mv $RPM_BUILD_ROOT%{_prefix}/bin/* $RPM_BUILD_ROOT/bin/
58rm -rf $RPM_BUILD_ROOT%{_bindir}
59
60
61%find_lang %{name}
62
63%check
64make check
65
66%clean
67[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
68
69%post
70[ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/grep.info.gz || :
71
72%preun
73if [ $1 = 0 ]; then
74        [ -e %{_infodir}/grep.info.gz ] && /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/grep.info.gz
75fi
76
77%files -f %{name}.lang
78%defattr(-,root,root)
79%doc ABOUT-NLS AUTHORS THANKS TODO NEWS README ChangeLog COPYING
80/bin/*
81%config(noreplace) %{_sysconfdir}/profile.d/colorgrep.*sh
82%config(noreplace) %{_sysconfdir}/GREP_COLORS
83%{_infodir}/*.info.gz
84%{_mandir}/*/*
85
86%changelog
87* Tue Feb 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
88- new upstream release
89- drop unneeded old patches
90- add BR: pcre-devel
91
92* Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-60
93- rebuilt against current toolchain
94- fix license tag
95- use CPPFLAGS= argument to configure to add an -I option.
96- Do not set LDFLAGS=-s for "make install".
97
98* Wed Sep 17 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-57
99- rebuilt for VineSeed (previous version in VineSeed was 2.5.1-50 somehow)
100  - Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.5.1-50vl5
101  - applied new versioning policy, spec in utf-8
102
103* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl0.1
104- rebuild for Vine Linux 4.x
105
106* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-57vl1
107- add Patch100 to fix infinite loop with 'grep -F'
108  thanks to M.H (<BTS:484>)
109- based on Fedora devel 2.5.1-57
110  * Mon Jan 22 2007 Tim Waugh <twaugh@redhat.com> 2.5.1-57
111  - Make preun scriptlet unconditionally succeed (bug #223697).
112  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-56
113  - Fixed count of patterns when the last is an empty string (bug #204255).
114  * Wed Nov 22 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-55
115  - Fix 'memory exhausted' errors by limiting in-memory buffer (bug #198165).
116  * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-54.1
117  - rebuild
118  * Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-54
119  - Applied upstream patch to fix '-D skip' (bug #189580).
120  * Mon Feb 20 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-53
121  - Applied Tim Robbins' patch for 'grep -w' (bug #179698).
122  * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.2
123  - bump again for double-long bug on ppc(64)
124  * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.5.1-52.1
125  - rebuilt for new gcc4.1 snapshot and glibc changes
126  * Fri Feb  3 2006 Tim Waugh <twaugh@redhat.com> 2.5.1-52
127  - Prevent 'grep -P' from segfaulting (bug #171379).
128
129* Sat Oct  7 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl2
130- changed Group to System Environment/Base
131
132* Tue Aug  2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-50vl1
133- based on Fedora development 2.5.1-50
134  * Tue Jun 28 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-50
135  - Futher fixing for bug #161700.
136  * Mon Jun 27 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-49
137  - Fix 'grep -Fw' for encodings other than UTF-8 (bug #161700).
138  * Wed Apr 13 2005 Tim Waugh <twaugh@redhat.com>
139  - Build requires recent pcre-devel (bug #154626).
140  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-47
141  - Run 'make check'.
142  - Fixed -w handling for EGexecute.  Now 'make check' passes.
143  - Cache MB_CUR_MAX value in egf-speedup patch.
144  - Fixed variable shadowing in egf-speedup patch.
145  - Removed redundant (and incorrect) code in prline.
146  * Fri Jan  7 2005 Tim Waugh <twaugh@redhat.com> 2.5.1-46
147  - More -w tests from Jakub Jelinek.
148  - Rebased on 2.5.1a.
149  * Fri Dec 31 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-45
150  - More tests (Jakub Jelinek).
151  - Jakub Jelinek's much improved -Fi algorithm.
152  - Removed bogus part of grep-2.5.1-fgrep patch.
153  * Tue Dec 21 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-44
154  - Fixed -Fi for multibyte input (bug #143079).
155  * Thu Dec 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-43
156  - Bypass kwset matching when ignoring case and processing multibyte input
157    (bug #143079).
158  * Tue Dec 14 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-42
159  - Further UTF-8 processing avoided since a '\n' byte is always an
160    end-of-line character in that encoding.
161  * Fri Dec  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-41
162  - Fixed a busy loop in the egf-speedup patch (bug #140781).
163  * Thu Nov 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-40
164  - Fixed a bug in the fgrep patch, exposed by the dfa-optional patch
165    (bug #138558).
166  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-39
167  - Fixed last patch.
168  * Tue Nov 16 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-38
169  - Applied patch from Karsten Hopp to fix background colour problems with
170    --color output (bug #138913).
171  * Wed Nov 10 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-37
172  - Prevent false matches when DFA is disabled (bug #138558).
173  * Mon Nov  8 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-36
174  - Automatically disable DFA when processing multibyte input.  GREP_USE_DFA
175    environment variable overrides.
176  * Fri Nov  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-35
177  - Fixes to egf-speedup patch: now it does not change any functionality,
178    as intended.
179  - GREP_NO_DFA now turns off the DFA engine, for performance testing.
180  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-34
181  - More improvements to egf-speedup patch (bug #138076).
182  * Thu Nov  4 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-33
183  - Small improvements to egf-speedup patch.
184  * Wed Nov  3 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-32
185  - Remove mb-caching hack.
186  - Better multibyte handling in EGexecute() and Fexecute().
187  - Don't need regex.c changes in grep-2.5-i18n.patch.
188  * Wed Oct 13 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-31
189  - Make 'grep -F' avoid UTF-8 processing if the pattern contains no
190    multibyte characters (bug #133932).
191  * Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-30
192  - Applied patch from Robert Scheck to tidy spec file and add a URL
193    tag (bug #135185).
194
195* Sun Sep  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-29vl1
196- based on Fedora development 2.5.1-29
197  * Fri Jun  4 2004 Tim Waugh <twaugh@redhat.com>
198  - More build requirements (bug #125323).
199  * Tue May 18 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-27
200  - Fix dfa multibyte character class matching when -i is used (bug #123363).
201  - Use bracket patch before i18n patch to make it clear that the bug exists
202    upstream.
203  * Thu Feb 26 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-26
204  - Fix fgrep (bug #116909).
205  * Mon Jan  5 2004 Tim Waugh <twaugh@redhat.com> 2.5.1-24
206  - Work around glibc bug #112869 (segfault in re_compile_pattern).
207  - Avoid patching Makefile.am, to avoid automake/autoconf weirdness.
208  * Wed Dec 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-23
209  - Another multibyte efficiency bug-fix (bug #111800).
210  * Mon Dec  8 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-22
211  - Fixed [:alpha:]-type character classes (bug #108484).
212  - Fixed -o -i properly (bug #111489).
213  * Sat Dec  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-21
214  - Fixed 'fgrep -i' (bug #111614).
215  * Fri Nov 21 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-20
216  - Another two multibyte efficiency bug-fixes (bug #110524).
217  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-19
218  - Fixed a multibyte efficiency bug.
219  * Thu Nov  6 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-18
220  - Turn on multibyte efficiency patch again to shake out bugs.
221  * Wed Oct  8 2003 Tim Waugh <twaugh@redhat.com>
222  - Fixed man page bug (bug #106267).
223  * Thu Sep 18 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-17
224  - Use symlinks for egrep/fgrep, rather than shell script wrappers.
225  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com>
226  - Fix debuginfo package.
227  * Fri Jun 27 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-16
228  - Finally give up on making grep go fast. :-(
229  * Thu Jun 26 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-15
230  - Fixed grep -i bug introduced by cache.
231  * Mon Jun 23 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-14
232  - Redo the gofast patch (bug #97785).
233  * Thu Jun 12 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-13
234  - Fixed a bug in the gofast patch (bug #97266).
235  * Tue Jun 10 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-12
236  - Go faster (bug #69900).
237  - Fix man page.
238  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-10
239  - Use system regex again.
240  * Thu May 29 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-9
241  - Fixed bug in go-fast patch.
242  * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 2.5.1-8
243  - Go fast (bug #69900).
244  - Run test suite.
245- rebuild with new toolchains
246- build with --disable-prel-regexp option
247
248* Wed Feb 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.1-7vl3
249- based on Rawhide 2.5.1-7
250  - Don't install /usr/share/info/dir.
251  - Fix -o -i (bug #72641).
252  - i18n patch.
253
254* Sat Jul  6 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
255- 2.5-0vl1
256- update to 2.5
257- change i18n patch
258
259* Sat Jan 20 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
260- 2.5-0vl1
261- update to 2.5
262- change i18n patch
263
264* Sat Jan 20 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
265- 2.4.2-4vl1
266- usr better macros (%%configure/%%makeinstall)
267
268* Mon Jun 19 2000 Jun Nishii <jun@vinelinux.org>
269- 2.4-3vl1
270- merge ja patch
271
272* Thu Feb 03 2000 Bernhard Rosenkraenzer <bero@redhat.com>
273- gzip info pages (Bug #9035)
274
275* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
276- fix description
277
278* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
279- update to 2.4.
280
281* Wed Oct 20 1999 Bill Nottingham <notting@redhat.com>
282- prereq install-info
283
284* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
285- auto rebuild in the new build environment (release 2)
286
287* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
288- upgraded to grep 2.3, added install-info %post/%preun for info
289
290* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
291- Injected new description and group.
292
293* Sat May 09 1998 Prospector System <bugs@redhat.com>
294- translations modified for de, fr, tr
295
296* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
297- updated to 2.2
298
299* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
300- updated from 2.0 to 2.1
301- spec file cleanups
302- added BuildRoot
303
304* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
305- built against glibc
Note: See TracBrowser for help on using the repository browser.