source: projects/specs/tags/6_0_REL/g/google-gadgets/google-gadgets-vl.spec @ 1961

Revision 1961, 8.3 KB checked in by inagaki, 14 years ago (diff)

update: libmal, google-gadgets, pilot-link

Line 
1#define svnrev   1449
2#define alphatag 20090430svn%{svnrev}
3
4Name:           google-gadgets
5Summary:        Google Gadgets platform for Linux
6Version:        0.11.2
7Release:        1%{?_dist_release}
8
9Group:          User Interface/Desktops
10License:        ASL 2.0
11URL:            http://code.google.com/p/google-gadgets-for-linux/
12
13Source0:        http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
14#Source0:        %{name}-%{version}-r%{svnrev}.tar.bz2
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  curl-devel libxml2-devel zlib-devel libtool-ltdl-devel
19# still needed even if we're not buliding gtkmoz element, for JavaScript
20%if %{?_dist_release} == "vl5"
21BuildRequires:  xulrunner-devel-unstable
22%else
23BuildRequires:  xulrunner-devel
24%endif
25BuildRequires:  WebKit-gtk-devel
26BuildRequires:  dbus-devel gstreamer-devel gstreamer-plugins-base-devel
27BuildRequires:  cairo-devel gtk2-devel librsvg2-devel
28BuildRequires:  qt4-devel zip
29# Desktop integration
30BuildRequires:  NetworkManager-devel startup-notification-devel
31# libxml2-devel needed for desktop file generation
32BuildRequires:  libxml2-devel desktop-file-utils
33BuildRequires:  pkgconfig
34Requires:       %{name}-frontend = %{version}-%{release}
35Requires:       hicolor-icon-theme
36
37%description
38Google Gadgets for Linux provides a platform for running desktop
39gadgets under Linux, catering to the unique needs of Linux users. It
40can run, without modification, many Google Desktop gadgets as well as
41the Universal Gadgets on iGoogle.
42
43
44%package        gtk
45Summary:        GTK+ front-end for %{name}
46Summary(ja):    Google Gadgets の GTK+ 版フロントエンド
47Group:          User Interface/Desktops
48Requires:       %{name} = %{version}-%{release}
49Provides:       %{name}-frontend = %{version}-%{release}
50
51%description    gtk
52The %{name}-gtk package contains the GTK+ front-end for %{name}.
53
54
55%package        qt
56Summary:        Qt front-end for %{name}
57Summary(ja):    Google Gadgets の Qt 版フロントエンド
58Group:          User Interface/Desktops
59Requires:       %{name} = %{version}-%{release}
60Provides:       %{name}-frontend = %{version}-%{release}
61
62%description    qt
63The %{name}-qt package contains the Qt front-end for %{name}.
64
65
66%package        devel
67Summary:        Development files for %{name}
68Summary(ja):    %{name} の開発用ファイル
69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
71Requires:       pkgconfig dbus-devel gtk2-devel qt4-devel
72Requires:       %{name}-gtk
73Requires:       %{name}-qt
74
75%description    devel
76The %{name}-devel package contains libraries and header files for
77developing applications that use %{name}.
78
79
80%prep
81%setup -q -n %{name}-for-linux-%{version}
82# Permission fixes
83chmod -x ggadget/qt/utilities.h
84# Fix invalid desktop file MIME type
85# http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=360
86for f in hosts/*/ggl-*.desktop.in; do
87    sed -i 's|;app/gg;|;|' $f
88done
89
90
91%build
92#autotools/bootstrap.sh
93#ln -s %{_datadir}/automake-*/mkinstalldirs libltdl/
94
95%configure --disable-static \
96           --with-browser-plugins-dir=%{_libdir}/mozilla/plugins
97
98# Rpath fix by Mamoru Tasaka
99# we don't want to obliterate all RPATHs, since it is used during build
100# Add library search path
101sed -i.libdir_syssearch -e \
102 '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
103 configure
104# Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
105sed -i.extra_R -e \
106 's|-R\$(libdir)||' \
107 hosts/*/Makefile.in
108
109# default compile flags are impossibly strict
110make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
111
112# Remove quotes from .pc files
113find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
114
115
116%install
117rm -rf $RPM_BUILD_ROOT
118make install DESTDIR=$RPM_BUILD_ROOT \
119     INSTALL="install -p" CPPROG="cp -p"
120find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
121
122# reinstall desktop files
123for i in gtk qt; do
124  desktop-file-install \
125    --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
126    --delete-original \
127    $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
128done
129
130# wipe prematurely-generated MIME info
131rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
132rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
133
134%clean
135rm -rf $RPM_BUILD_ROOT
136
137
138%post
139/sbin/ldconfig
140touch --no-create %{_datadir}/icons/hicolor || :
141
142%postun
143/sbin/ldconfig
144if [ $1 -eq 0 ] ; then
145    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
146    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
147fi
148
149%posttrans
150gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
151
152%post gtk
153/sbin/ldconfig
154update-desktop-database &> /dev/null || :
155
156%postun gtk
157/sbin/ldconfig
158update-desktop-database &> /dev/null || :
159
160%post qt
161/sbin/ldconfig
162update-desktop-database &> /dev/null || :
163
164%postun qt
165/sbin/ldconfig
166update-desktop-database &> /dev/null || :
167
168
169%files
170%defattr(-,root,root,-)
171%doc AUTHORS COPYING README
172%{_libdir}/google-gadgets
173%exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
174%exclude %{_libdir}/google-gadgets/modules/gtk*.so
175%exclude %{_libdir}/google-gadgets/modules/qt*.so
176%exclude %{_libdir}/google-gadgets/include
177%{_libdir}/lib*.so.*
178%exclude %{_libdir}/lib*gtk*
179%exclude %{_libdir}/lib*qt*
180%{_datadir}/google-gadgets
181%{_datadir}/pixmaps/google-gadgets.png
182%{_datadir}/icons/hicolor/*/*/*.png
183
184%files gtk
185%defattr(-,root,root,-)
186%{_bindir}/ggl-gtk
187%{_libdir}/libggadget-gtk*.so.*
188%{_libdir}/google-gadgets/gtkmoz-browser-child
189%{_libdir}/google-gadgets/modules/gtk*.so
190%{_datadir}/applications/*gtk.desktop
191%{_datadir}/applications/*designer.desktop
192
193%files qt
194%defattr(-,root,root,-)
195%{_bindir}/ggl-qt
196%{_libdir}/libggadget-qt*.so.*
197%{_libdir}/google-gadgets/modules/qt*.so
198%{_datadir}/applications/*qt.desktop
199
200%files devel
201%defattr(-,root,root,-)
202%{_includedir}/google-gadgets
203%{_libdir}/lib*.so
204%{_libdir}/google-gadgets/include
205%{_libdir}/pkgconfig/*.pc
206
207
208%changelog
209* Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.2-1
210- new upstream release
211- built with rpm-4.8.1 for pkg-config
212- dropt Patch0
213- added BR: WebKit-gtk-devel
214- removed invalid MIME entry from .desktop files
215
216* Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
217- new upstream release
218
219* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
220- Initial build for Vine Linux
221
222* Wed Jul  1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
223- Update to 0.11.0
224
225* Sat May  2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
226- Update to SVN checkout, for xulrunner 1.9.1 compatibility
227
228* Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
229- Rebuild against newer gecko
230
231* Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
232- Rebuild against newer gecko
233
234* Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
235- Rebuild against newer gecko
236
237* Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
238- Rebuild against newer gecko
239
240* Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
241- 0.10.5, req'd by kde
242
243* Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
244- BR: Network-Manager-devel, startup-notification-devel
245- Pass the browser plugin directory to ./configure
246- Move designer desktop entry to -gtk subpackage
247
248* Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
249- Update to 0.10.4 (#477251)
250- -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
251- BR: pkgconfig (automatic pkgconfig deps)
252
253* Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
254- Update to 0.10.3
255
256* Sat Nov  8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
257- s/qt-devel/qt4-devel/
258- -qt: fix summary
259
260* Tue Sep  2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
261- Unquote version strings in .pc files
262
263* Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
264- RPATH and timestamp fixes from Mamoru Tasaka
265
266* Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
267- Fix desktop file creation
268
269* Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
270- Update to 0.10.1
271
272* Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
273- Update to 0.10.0
274- Add missing dependencies for -devel subpackage
275
276* Sun Jul  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
277- Update to 0.9.3
278
279* Fri Jun  6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
280- Initial package
Note: See TracBrowser for help on using the repository browser.