source: projects/specs/tags/6_0_REL/g/gnome-shell/gnome-shell-vl.spec @ 915

Revision 915, 3.4 KB checked in by Takemikaduchi, 14 years ago (diff)

new upstream release and add Requires

Line 
1%define pkg_version 2.29.1
2%define pkg_release 2%{?_dist_release}
3
4Summary:     Window management and application launching for GNOME
5Name:        gnome-shell
6Version:     %{pkg_version}
7Release:     %{pkg_release}
8Source0:     %{name}-%{version}.tar.bz2
9License:     GPLv2+
10Group:       User Interface/Desktops
11URL:         http://live.gnome.org/GnomeShell
12
13Requires(post,postun): scrollkeeper >= 0.1.4
14Requires(post,pre,preun): GConf2 >= 2.14
15Requires: mutter
16
17BuildRequires: gnome-common
18BuildRequires: libtool
19BuildRequires: automake
20BuildRequires: autoconf
21
22BuildRequires: pkgconfig
23BuildRequires: gtk2-devel
24BuildRequires: clutter-devel
25BuildRequires: mutter-devel
26BuildRequires: gjs-devel
27BuildRequires: gnome-desktop-devel
28BuildRequires: gnome-menus-devel
29BuildRequires: libSM-devel
30BuildRequires: libffi-devel
31BuildRequires: GConf2-devel
32BuildRequires: startup-notification-devel
33BuildRequires: gnome-doc-utils
34BuildRequires: desktop-file-utils
35BuildRequires: xulrunner-devel
36BuildRequires: libcroco-devel
37BuildRequires: librsvg2-devel
38BuildRequires: gir-repository-devel
39BuildRequires: gobject-introspection-devel
40BuildRequires: gstreamer-devel
41BuildRequires: dbus-glib-devel
42BuildRequires: intltool
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-root
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50
51%description
52GNOME Shell is the defining technology of the GNOME 3 desktop user experience. It provides core interface functions like switching to windows and launching applications. GNOME Shell takes advantage of the capabilities of modern graphics hardware and introduces innovative user interface concepts to provide a delightful and easy to use experience.
53
54
55%prep
56%setup -q
57
58
59%build
60%configure --disable-static
61%{__make} %{?_smp_mflags}
62
63
64%install
65%{__rm} -rf ${RPM_BUILD_ROOT}
66%{__make} install DESTDIR=${RPM_BUILD_ROOT}
67
68%find_lang %{name}
69
70%{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/*.la
71
72
73%clean
74%{__rm} -rf ${RPM_BUILD_ROOT}
75
76
77%post
78/sbin/ldconfig
79export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
80gconftool-2 --makefile-install-rule \
81    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
82  > /dev/null || :
83/sbin/ldconfig
84touch --no-create %{_datadir}/icons/hicolor
85if [ -x /usr/bin/gtk-update-icon-cache ]; then
86  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
87fi
88
89%pre
90if [ "$1" -gt 1 ]; then
91  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
92  gconftool-2 --makefile-uninstall-rule \
93    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
94    > /dev/null || :
95fi
96
97%preun
98if [ "$1" -eq 0 ]; then
99  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
100  gconftool-2 --makefile-uninstall-rule \
101    %{_sysconfdir}/gconf/schemas/gnome-shell.schemas \
102    > /dev/null || :
103fi
104
105%postun
106scrollkeeper-update -q || :
107/sbin/ldconfig
108touch --no-create %{_datadir}/icons/hicolor
109if [ -x /usr/bin/gtk-update-icon-cache ]; then
110  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
111fi
112
113
114%files -f %{name}.lang
115%defattr(-,root,root)
116%doc COPYING ChangeLog NEWS README
117%{_bindir}/gnome-shell
118%{_libdir}/gnome-shell/*
119%{_libdir}/mutter/plugins/*
120%{_datadir}/applications/*
121%{_datadir}/gnome-shell/*
122%{_datadir}/man/man1/*.1.gz
123%{_sysconfdir}/gconf/schemas/*
124
125
126%changelog
127* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-2
128- add Requires: mutter
129
130* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.1-1
131- new upstream release
132
133* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
134- initial build for Vine Linux
135
Note: See TracBrowser for help on using the repository browser.