source: projects/specs/tags/6_0_REL/d/dblatex/dblatex-vl.spec @ 4375

Revision 4375, 7.5 KB checked in by munepi, 13 years ago (diff)

added d/dblatex/dblatex-vl.spec, p/python-which/python-which-vl.spec

Line 
1%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2
3Name:           dblatex
4Version:        0.3
5Release:        1%{?_dist_release}
6Summary:        DocBook to LaTeX/ConTeXt Publishing
7BuildArch:      noarch
8Group:          Applications/Publishing
9License:        GPLv2+
10URL:            http://dblatex.sourceforge.net/
11Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
12#Source1:        http://docbook.sourceforge.net/release/xsl/current/COPYING
13Source1:        COPYING-docbook-xsl
14Patch0:         dblatex-0.2.7-external-which.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  python-devel
18BuildRequires:  python-which
19BuildRequires:  libxslt docbook-dtds ImageMagick
20## Need epstopdf, fig2dev
21BuildRequires:  texlive-collection-fontutils
22BuildRequires:  transfig
23##BuildRequires:  tex(latex)
24##BuildRequires:  tex(xetex)
25BuildRequires:  texlive-common >= 2009
26## appendix.sty, changebar.sty, footmisc.sty, multirow.sty,
27## overpic.sty, subfigure.sty, titlesec.sty
28BuildRequires:  texlive-collection-latexextra
29## stmaryrd.sty
30BuildRequires:  texlive-collection-mathextra
31BuildRequires:  texlive-collection-htmlxml
32Requires:       libxslt docbook-dtds ImageMagick
33##Requires:       tex(xetex)
34Requires:       texlive-common >= 2009
35Requires:       texlive-collection-latexextra
36Requires:       transfig
37BuildRequires:  texlive-collection-mathextra
38##Requires:     passivetex
39Requires:       texlive-collection-htmlxml
40
41%description
42dblatex is a program that transforms your SGML/XMLDocBook
43documents to DVI, PostScript or PDF by translating them
44into pure LaTeX as a first process.  MathML 2.0 markups
45are supported, too. It started as a clone of DB2LaTeX.
46
47Authors:
48--------
49   Benoît Guillon <marsgui at users dot sourceforge dot net>
50   Andreas Hoenen <andreas dot hoenen at arcor dot de>
51
52
53%prep
54%setup -q
55%patch0 -p1 -b .external-which
56%__rm -rf lib/contrib
57
58%build
59%{__python} setup.py build
60
61
62%install
63%__rm -rf $RPM_BUILD_ROOT
64#%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
65%{__python} setup.py install --root $RPM_BUILD_ROOT
66# these are already in tetex-latex:
67for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
68  %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
69done
70
71%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex
72for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
73  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file`;
74done
75
76## also move .xetex files
77for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
78  %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file`;
79done
80
81%__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
82
83%__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/dblatex
84# shipped in %%docs
85%__rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/
86
87%__sed -e 's/\r//' xsl/mathml2/README > README-xsltml
88touch -r xsl/mathml2/README README-xsltml
89%__cp -p %{SOURCE1} COPYING-docbook-xsl
90
91 
92%clean
93%__rm -rf $RPM_BUILD_ROOT
94
95
96%files
97%defattr(-,root,root,-)
98%{_mandir}/man1/dblatex.1*
99%doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
100%{python_sitelib}/dbtexmf/
101%{python_sitelib}/dblatex-*.egg-info
102%{_bindir}/dblatex
103%{_datadir}/dblatex/
104%{_datadir}/texmf/tex/latex/dblatex/
105%dir %{_sysconfdir}/dblatex
106
107%post -p /usr/bin/texhash
108
109%postun -p /usr/bin/texhash
110
111%changelog
112* Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.3-1
113- initial build
114
115* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
117
118* Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3-2
119- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
120
121* Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
122- Update to 0.3
123- Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
124
125* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
127
128* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-2
129- remove dblatex-0.2.9-xetex.patch
130
131* Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-1
132- Update to 0.2.10
133
134* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
136
137* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.9-3
138- Rebuild for Python 2.6
139
140* Fri Jul  4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-2
141- BR: texlive-xetex -> tex(xetex) for F-10 and later
142
143* Thu Jun 12 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-1
144- Update to latest upstream (0.2.9) (#448953)
145- Remove some redundant Requires and BuildRequires (passivetex pulls
146  in the tetex/tex requires, python dep added automatically)
147- For F-9+ BR on tex(latex) and texlive-xetex, fix the installation
148  scripts to install extra new files.
149- Add patch from dblatex mailing list for better handling of a missing
150  xetex.
151- Conditionally add .egg-info file only if F9+ to allow for unified
152  spec file
153
154* Sun Dec 16 2007 Patrice Dumas <pertusus@free.fr> - 0.2.8-2.1
155- don't install in docbook directory, it is a link to a versioned
156  directory and may break upon docbook update (#425251,#389231)
157
158* Sun Nov 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.8-1
159- Update to 0.2.8
160
161* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-16
162- convert spec to utf8
163- change to gplv2+
164
165* Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-15
166- Add copyright info
167
168* Mon Nov  5 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-14
169- Req tetex-fonts for texhash
170- Fix post, postun
171
172* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-13
173- Add texhash
174
175* Sun Nov  4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
176- Fix xsl link
177
178* Sat Nov  3 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
179- Various fixes from pertusus@free.fr:
180- rm iconv stuff
181- simplify docs installation
182
183* Fri Nov  2 2007  <ndbecker2@gmail.com> - 0.2.7-11
184- Various minor fixes
185
186* Thu Nov  1 2007  <ndbecker2@gmail.com> - 0.2.7-10
187- Add some reqs and brs
188- rmdir /usr/share/dblatex/latex/{misc,contrib/example,style}
189
190* Sat Oct 27 2007  <ndbecker2@gmail.com> - 0.2.7-9
191- link /usr/share/dblatex/xsl -> /usr/share/sgml/docbook/xsl-stylesheets/dblatex
192- rmdir /usr/share/dblatex/latex/{misc,specs,style}
193- own /etc/dblatex
194- change $(...) -> `...`
195- Preserve timestamps on iconv
196
197* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-9
198- mv all .sty files to datadir/texmf/tex/latex/dblatex
199- Add Conflicts tetex-tex4ht
200- mv all xsl stuff to datadir/sgml/docbook/xsl-stylesheets/dblatex/
201
202* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
203- rm redundant latex files
204
205* Tue Sep 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
206- Fixed encodings in docs directory
207- Install docs at correct location
208
209* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-7
210- Revert back to GPLv2
211- untabify
212
213* Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-6
214- Fix source URL
215- Install all docs
216- Tabify
217
218* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-5
219- Add BR tetex-latex
220
221* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-4
222- Add  BR tetex, ImageMagick
223
224* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-3
225- Add BR libxslt
226
227* Wed Sep 19 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-2
228- Add BR python-devel
229
230* Fri Sep  7 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-1
231- Initial
232
233
234
Note: See TracBrowser for help on using the repository browser.