source: projects/specs/tags/6_0_REL/c/chromium/chromium13-vl.spec @ 4467

Revision 4467, 28.6 KB checked in by munepi, 13 years ago (diff)

updated chromium: added chromium13-vl.spec, pack_chromium13_source-vine.sh

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15#Name:           chromium13
16Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        13.0.782.107
21Release:        1%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-13.0.782.XXX.tar.bz2
28Source3:        pack_chromium13_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31# Patch template which adds vendor to user agent
32##!!Source20:       chromium-vendor.patch.in
33Source20:       chromium-vendor-vine.patch.in
34# Set default prefs
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37##!!Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39Source99:       chrome-wrapper
40##!!Source100:      chromium-browser.sh
41Source100:      chromium-browser-vine.sh
42##!!Source101:      chromium-browser.desktop
43Source101:      chromium-browser-vine.desktop
44Source102:      chromium-browser.xml
45Source103:      chromium-browser-rpmlintrc
46##!!Source104:      chromium-icons.tar.bz2
47
48%{?nosrc:NoSource: 0}
49
50# Provides:       chromium-unstable = %{version}
51# Conflicts:      chromium-stable
52Provides:       chromium-stable = %{version}
53Conflicts:      chromium-unstable
54
55## Start Patches
56# OpenSuse and Fedora
57# Many changes to the gyp systems so we can use system libraries
58#Patch1:         chromium-gcc46.patch
59Patch4:         chromium-no-sqlite-debug.patch
60Patch8:         chromium-codechanges-zlib.patch
61Patch12:        chromium-no-test-sources.patch
62Patch13:        chromium-no-courgette.patch
63Patch14:        chromium-master-prefs-path.patch
64Patch17:        chromium-system-glew.patch
65Patch18:        chromium-system-expat.patch
66Patch19:        chromium-system-zlib.patch
67Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
68Patch21:        chromium-7.0.542.0-media-probe.patch
69Patch25:        tcmalloc-factory.patch
70Patch26:        chromium-remoting-build-fix.diff
71Patch28:        chromium-7.0.500.0-system-speex.patch
72Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
73Patch32:        chromium-7.0.542.0-system-libvpx.patch
74Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
75Patch62:        chromium-norpath.patch
76Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
77
78# Vine
79Patch100:       chromium-13.0.782.13-no-tests.patch
80
81
82##!!BuildRequires:  Mesa-devel
83BuildRequires:  mesa-libGLU-devel
84##!!BuildRequires:  alsa-devel
85BuildRequires:  alsa-lib-devel
86BuildRequires:  bison
87BuildRequires:  cups-devel
88BuildRequires:  desktop-file-utils
89BuildRequires:  fdupes
90BuildRequires:  flex
91BuildRequires:  freetype2-devel
92BuildRequires:  gcc gcc-c++
93BuildRequires:  gperf
94BuildRequires:  hunspell-devel
95##!!BuildRequires:  libbz2-devel
96BuildRequires:  bzip2-devel
97BuildRequires:  libevent
98##!!BuildRequires:  libexpat-devel
99BuildRequires:  expat-devel
100##!!BuildRequires:  libgnutls-devel
101BuildRequires:  gnutls-devel
102BuildRequires:  libjpeg-devel
103BuildRequires:  libpng-devel
104BuildRequires:  libstdc++-devel >= 4.4
105%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
106BuildRequires:  libxslt-devel
107BuildRequires:  libzip-devel
108##!!BuildRequires:  lzma
109BuildRequires:  xz
110##!!BuildRequires:  mozilla-nspr-devel
111BuildRequires:  nspr-devel
112##!!BuildRequires:  mozilla-nss-devel
113BuildRequires:  nss-devel
114BuildRequires:  openssl-devel
115BuildRequires:  pam-devel
116##!!BuildRequires:  perl(Switch)
117BuildRequires:  perl
118##!!BuildRequires:  pkg-config
119BuildRequires:  cairo-devel >= 1.6
120BuildRequires:  dbus-devel
121##!!BuildRequires:  gconf2-devel
122BuildRequires:  GConf2-devel
123BuildRequires:  glib2-devel
124BuildRequires:  gtk2-devel
125BuildRequires:  libxml2-devel
126BuildRequires:  python
127##!!BuildRequires:  python-xml
128BuildRequires:  python-pyxml
129BuildRequires:  sqlite3-devel
130##!!BuildRequires:  update-desktop-files
131%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
132##!!BuildRequires:  wdiff
133BuildRequires:  zlib-devel
134
135BuildRequires:  libgnome-keyring-devel
136BuildRequires:  python-devel
137
138#BuildRequires:  glew-devel
139BuildRequires:  libevent-devel
140%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
141#BuildRequires:  libjingle-devel >= 0.4.0-7
142#BuildRequires:  srtp-devel
143BuildRequires:  speex-devel
144
145##Vine Linux
146#BuildRequires:  libpaper-devel
147BuildRequires:  libXScrnSaver-devel
148BuildRequires:  libXtst-devel
149BuildRequires:  libXdamage-devel
150BuildRequires:  libXt-devel
151%ifarch x86_64
152Requires:  nspluginwrapper
153%endif
154
155##!!Requires:       alsa
156Requires:       alsa-lib
157Requires:       xdg-utils
158%{?with_system_v8:Requires:       v8 = %{v8_ver}}
159
160BuildRoot:      %{_tmppath}/%{name}-%{version}-root
161
162%description
163Chromium is the open-source project behind Google Chrome.
164We invite you to join us in our effort to help build a safer, faster,
165and more stable way for all Internet users to experience the web,
166and to create a powerful platform for developing a new generation of
167web applications.
168
169%description -l ja
170Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
171ウェブを体験しているすべてのインターネットユーザに対して
172より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
173そして、ウェブアプリケーションの新しい世代を発展させ、
174強力なプラットホームを作成するために、
175私たちの取り組みにぜひ参加してください。
176
177
178%prep
179#%setup -q
180[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
181xz -dc %{SOURCE0} | %__tar -xf - || exit 1
182%setup -D -T -n %{pkgname}-%{version}
183
184#%patch1 -p1
185%patch62 -p1
186%{?with_system_v8:%patch63 -p1}
187%patch100 -p1 -b .vine
188%patch4 -p1
189%patch8 -p1
190%patch12 -p1
191%patch13 -p1
192%patch14 -p1
193%patch17 -p1
194%patch18 -p1
195%patch19 -p1
196%patch20 -p1
197%patch21 -p1
198%patch25 -p1
199%patch26 -p1
200%patch28 -p1
201%patch29 -p1
202%{?with_system_vpx:%patch32 -p1}
203%{?with_system_v8:%patch34 -p1}
204
205pushd src/third_party/ffmpeg/
206%__tar xf %{SOURCE8} || exit 1
207## built header file: avconfig.h
208[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
209cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
210/* Generated by ffconf */
211#ifndef AVUTIL_AVCONFIG_H
212#define AVUTIL_AVCONFIG_H
213#define AV_HAVE_BIGENDIAN 0
214#endif /* AVUTIL_AVCONFIG_H */
215EOF
216popd
217
218#%__rm -rf src/third_party/libvpx/
219%__rm -rf src/third_party/speex/
220%__rm -rf src/third_party/nss src/third_party/nspr
221
222# apply vendor patch after substitution
223%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
224
225%build
226
227## create make files
228
229PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
230for i in src/build/common.gypi; do
231        %__sed -i "s|'-march=pentium4',||g" $i
232        %__sed -i "s|'-mfpmath=sse',||g" $i
233        %__sed -i "s|'-O<(debug_optimize)',||g" $i
234        %__sed -i "s|'-m32',||g" $i
235        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
236        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
237done
238# '
239
240pushd src
241
242./build/gyp_chromium -f make build/all.gyp \
243    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
244    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
245    -Duse_openssl=0 \
246    -Duse_system_ffmpeg=1 \
247    -Duse_system_zlib=1 \
248    -Duse_system_libpng=1 \
249    -Duse_system_bzip2=1 \
250    -Duse_system_libbz2=1 \
251    -Duse_system_libjpeg=1 \
252    -Duse_system_libxml=1 \
253    -Duse_system_libxslt=1 \
254    -Duse_system_libevent=1 \
255    %{?with_system_vpx:-Duse_system_vpx=1} \
256    %{!?with_system_vpx:-Duse_system_vpx=0} \
257    -Dremove_webcore_debug_symbols=1 \
258    %{?with_system_v8:-Duse_system_v8=1} \
259    %{!?with_system_v8:-Duse_system_v8=0} \
260    %{?with_system_icu:-Duse_system_icu=1} \
261    %{!?with_system_icu:-Duse_system_icu=0} \
262    %{?_with_shared_library:-Dlibrary=shared_library} \
263    -Dproprietary_codecs=1 \
264    -Djavascript_engine=v8 \
265    -Dlinux_fpic=1 \
266    %ifarch %{ix86}
267        -Dtarget_arch=ia32 \
268        -Ddisable_sse2=1 \
269    %endif
270    %ifarch x86_64
271        -Dtarget_arch=x64 \
272    %endif
273    -Dno_strict_aliasing=1 \
274    -Drelease_extra_cflags=-fPIC \
275    %if %{?_dist_release} == "vl6"
276        -Dgcc_version=44 \
277    %endif
278    ;
279
280#%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
281%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
282
283popd
284
285%install
286%{__rm} -rf %{buildroot}
287
288%__mkdir -p %{buildroot}%{_bindir}
289%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
290# x86_64 capable systems need this
291%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
292%__mkdir -p %{buildroot}%{_libdir}/chromium/
293%__mkdir -p %{buildroot}%{_mandir}/man1/
294pushd src/out/Release
295%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
296%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
297%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
298%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
299%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
300%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
301%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
302fdupes %{buildroot}%{_mandir}/man1/
303popd
304
305%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
306%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
307for i in 16 22 24 32 48 64 128 256; do
308    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
309    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
310done
311
312%__mkdir_p %{buildroot}%{_datadir}/applications/
313desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
314
315%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
316%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
317
318# # link to browser plugin path.  Plugin patch doesn't work. Why?
319# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
320# pushd %{buildroot}%{_libdir}/%{pkgname}
321# %{__ln_s} %{_libdir}/browser-plugins plugins
322# popd
323pushd %{buildroot}%{_libdir}/%{pkgname}
324%ifarch x86_64
325%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
326%else
327%{__ln_s} %{_libdir}/mozilla/plugins plugins
328%endif
329
330## support ffmpeg libs
331touch %{buildroot}%{_libdir}/libavcodec.so.52
332%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
333touch %{buildroot}%{_libdir}/libavformat.so.52
334%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
335touch %{buildroot}%{_libdir}/libavutil.so.50
336%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
337popd
338
339# Install the master_preferences file
340%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
341#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
342%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
343#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
344
345%clean
346%{__rm} -rf %{buildroot}
347
348%post
349touch --no-create %{_datadir}/icons/hicolor
350if [ -x %{_bindir}/gtk-update-icon-cache ]; then
351  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
352fi
353%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
354
355%postun
356%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
357touch --no-create %{_datadir}/icons/hicolor
358if [ -x %{_bindir}/gtk-update-icon-cache ]; then
359  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
360fi || :
361
362
363%files
364%defattr(-,root,root,-)
365%config %{_sysconfdir}/%{pkgname}
366%dir %{_datadir}/gnome-control-center
367%dir %{_datadir}/gnome-control-center/default-apps
368%dir %{_libdir}/chromium/
369%{_bindir}/chromium
370%{_libdir}/chromium/chromium
371%{_libdir}/chromium/plugins/
372%{_libdir}/chromium/resources/
373%{_libdir}/chromium/xdg-settings
374%{_mandir}/man1/chrom*
375%{_datadir}/pixmaps/chromium-browser.png
376%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
377%{_datadir}/applications/*.desktop
378%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
379#%{_datadir}/icons/oxygen/
380%{_libdir}/chromium/chrome.pak
381%{_libdir}/chromium/resources.pak
382%{_libdir}/chromium/locales/
383%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
384%{_libdir}/chromium/libavcodec.so.52
385%{_libdir}/chromium/libavutil.so.50
386%{_libdir}/chromium/libavformat.so.52
387%exclude %{_libdir}/libavcodec.so.52
388%exclude %{_libdir}/libavutil.so.50
389%exclude %{_libdir}/libavformat.so.52
390
391%changelog
392* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
393- changed to Name: chromium
394- updated to 13.0.782.107
395
396* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
397- updated to 13.0.782.88
398- added BuildRequires: libzip-devel
399- added Provides: chromium-unstable = %%{version}
400- added Conflicts: chromium-stable
401
402* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
403- fix user-agent string (chromium-vendor-vine.patch.in)
404  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
405
406* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
407- updated to 12.0.742.93
408- fixed icon field of chromium-browser-vine.desktop
409
410* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
411- updated to 12.0.742.91
412
413* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
414- updated to 12.0.742.77
415
416* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
417- updated to 12.0.742.63
418
419* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
420- updated to 12.0.742.42
421
422* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
423- updated to 12.0.742.6
424- dropped/upstreamed patches
425- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
426
427* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
428- updated to 11.0.696.50
429- dropped some Patches for MeeGo Netbook
430
431* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
432- updated to 11.0.696.35
433
434* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
435- updated to 11.0.696.29
436- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
437
438* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
439- updated to 11.0.696.22
440- improved chromium-browser-vine.sh
441  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
442
443* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
444- updated to 11.0.696.20
445- improved chromium-browser-vine.desktop
446
447* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
448- updated to 11.0.696.17
449
450* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
451- updated to 11.0.696.15
452  - ready for Vine Linux 6 release
453- dropped BuildRequires: v8-devel, libicu-devel
454
455* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
456- updated to 11.0.696.5 with v8 3.2.0
457- added BuildRequires: pam-devel
458
459* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
460- rebuilt with libevent-2.0.10
461
462* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
463- updated to 10.0.651.0 with v8 3.0.12
464- added BuildRequires:
465  - libpaper-devel
466  - python-devel
467- added built header file: libavutil/avconfig.h %%prep
468- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
469
470* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
471- updated to 10.0.622.0
472- added BuildRequires: libXt-devel
473
474* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
475- updated to 10.0.605.0
476- added BuildRequires:
477  - libXdamage-devel
478  - hunspell-devel
479
480* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
481- updated to 9.0.598
482
483* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
484- updated to 9.0.593
485
486* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
487- updated to 9.0.582
488- added Requires: xdg-utils
489
490* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
491- updated to 9.0.578
492
493* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
494- updated to 9.0.569
495
496  * Mon Oct 25 2010 tittiatcoke@gmail.com
497  - Update to 9.0.564 build
498    * Added specific patches for MeeGo.
499    * We are now using shared libraries for Chromium
500    * Spec-file cleanup (Thanks to prusnak)
501
502* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
503- updated to snapshot 8.0.556
504
505* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
506- updated to snapshot 8.0.551
507
508* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
509- updated to snapshot 7.0.527
510
511* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
512- updated to snapshot 7.0.519
513
514* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
515- updated to snapshot 7.0.513
516  - updated chromium-vendor-vine.patch.in
517
518* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
519- updated to snapshot 7.0.507
520
521* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
522- updated to snapshot 7.0.498
523
524* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
525- updated to snapshot 6.0.493
526- used with_system_icu (for vl6)
527  - added BuildRequires: libicu-devel
528
529* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
530- build for Vine Linux 5.x
531  - add BuildRequires: gnome-keyring-devel
532
533* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
534- updated to snapshot 6.0.454
535- added BuildRequires:
536  - sqlite3-devel
537  - gnutls-devel
538  - libgnome-keyring-devel
539
540* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
541- updated to snapshot 6.0.431.0 r49253
542- added BuildRequires: cups-devel
543
544* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
545- updated to snapshot 6.0.405.0 r47263
546
547* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
548- unused with_system_icu (for vl6)
549  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
550
551* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
552- updated to snapshot 5.0.378.0 r44472
553  - used with_system_icu (for vl6)
554  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
555
556* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
557- updated to snapshot 5.0.372.0 r43947
558- added BuildRequires: glew-devel
559- changed Group tag to Applications/Internet
560- added Summary(ja) and %%description -l ja
561
562* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
563- updated to snapshot 5.0.365.0 r42966
564- merged 5.0.353.0-4vl5
565 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
566 - build on Vine Linux 5.1
567   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
568
569* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
570- updated to snapshot 5.0.364.0 r42779
571
572* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
573- updated to snapshot 5.0.359.0 r42116
574- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
575
576* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
577- fixed master_preferences.vine, little
578
579* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
580- fixed to install master_preferences
581- dropped chromium-5.0.353-no-ffmpeg-vine.patch
582
583* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
584- applied chromium-5.0.353-no-ffmpeg-vine.patch
585
586* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
587- updated to snapshot 5.0.353.0 r41449
588  * Wed Mar 10 2010 bgmerrell@novell.com
589  - Add master_preferences source file and install it to /etc/chromium.
590  - Create a new patch (chromium-master-prefs-path.patch) which tells
591    chromium to look in /etc/chromium for the master_preferences file
592    (instead of looking in the default directory, which is the same
593    directory as the 'chrome' binary).
594
595* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
596- updated to snapshot 5.0.335.0 r39556
597
598* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
599- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
600
601* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
602- updated to snapshot 5.0.330.0 r39074
603
604* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
605- use_system_ffmpeg
606
607* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
608- added Requires:  nspluginwrapper
609- fixed a symbolic link of plugins directory with nspluginwrapper
610
611* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
612- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
613
614* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
615- added BuildRequires: mesa-libGLU-devel
616- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
617
618* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
619- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
620
621  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
622  - Update to 4.0.260
623  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
624  - Update to 4.0.259
625  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
626  - Update to 4.0.258
627  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
628  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
629    changed to having an built-in v8
630  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
631  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
632  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
633  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
634  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
635  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
636  - update to newer svn snapshot
637    + Obsoletes fwrite patch (included upstream)
638  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
639  - update to newer svn snapshot
640    + Requires newer version of v8
641  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
642  - do not force SSE on x86 (drop-sse.patch)
643  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
644  - Update to newer svn snapshot
645  - Fixed spec file in order to build
646  - Included patch to build with system zlib
647  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
648  - package renamed to chromium
649  - cleaned up spec file
650  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
651  - v8 is now built as a separate package, and is required
652  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
653  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
654  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
655  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
656  - initial build
657
658#% changelog
659* Sun Jan 24 2010 prusnak@suse.cz
660- added vendor to user agent (chromium-vendor.patch.in)
661* Sun Nov 29 2009 prusnak@suse.cz
662- added --enable-sync to wrapper to enable bookmark sync
663* Sun Nov 29 2009 tittiatcoke@gmail.com 
664- Update to 4.0.260
665* Fri Nov 27 2009 tittiatcoke@gmail.com 
666- Update to 4.0.259
667* Thu Nov 26 2009 tittiatcoke@gmail.com 
668- Update to 4.0.258
669* Tue Nov 24 2009 tittatcoke@gmai.com 
670- In order to complete prevent the wrong v8 version to be used,
671  the Chromium build has been changed to having an built-in v8
672* Tue Nov 24 2009 dbuck@example.com 
673- Re-base patches.
674- Fixed a few patch errors.
675- Rename some patches to better correspond with function.
676- Removed some patches.
677- Minor SPEC changes.
678- I changed the v8 requirement to be exact, instead of greater than a specific version.
679* Fri Nov 13 2009 tittiatcoke@gmail.com
680- update to 247.0 svn 31928
681* Fri Oct 30 2009 tittiatcoke@gmail.com
682- update to 229.0 svn 30454
683  + Fix regression where popups and app frames lost their titlebars.
684  + Makes it so that when a folder is open on the bookmark bar
685    and the mouse moves over another folder, the menu for that
686    folder is shown.
687  + Lazily create the find bar.
688  + Polish to the gmail checker sample.
689  * New, crisper icons that are exactly 19x19
690  * Add a loading animation at the beginning before Gmail
691    responds.
692  * Fix a bug where we sometimes don't update the UI after a
693    logout/login cycle.
694  + Refactor widget methods to support desktop notifications,
695    including GTK stubs.
696  + Find-in-page should not ding while deleting characters.
697  + Add SSL wrapper for linux and mac.  This allows notifier to
698    use chrome's SSL layer instead of OpenSSL.
699  + Add three of the six extensions to PAC that Internet Explorer supports.
700  + WebSocket support in chromium. (Run with --enable-web-sockets
701    enables WebSocket features.)
702  + Do not allow GTK File Chooser dialogs to return directories.
703  + Fix the notifier SSL layer to make notifications work for
704    Linux Bookmark sync.
705  + linux: don't override mouse selection behavior in omnibox
706* Sun Oct 25 2009 tittiatcoke@gmail.com
707- Update to 224.4 svn 30027
708  + First cut at new page and browser action docs based
709    on new API. Deleted old stuff.
710  + Add suppression for new memory leak caused by WebKit merge 49830:49844
711  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
712  + Minimize dependency of user scripts
713  + Fixup the flip_framer eof-handling semantics now that we have
714    the FIN bit in place
715  + app depends on x11 because of active_window_watcher_x
716  + Adding two images for the new Extension managment UI
717  + Removing hard-coded Chrome Frame output path
718  + Rearrange clipboard code
719  + Fix crash bug when attempting to download a url with unsupported scheme,
720    e.g. 'data:', by 'Alt + Click'
721  + GTK: Change text for extension download UI
722  + Ignore invalid urls on command line
723  + Make dropped tabs animate from where they were dropped.
724  + Make room for the full width of the tab placeholder.
725  + Make tab dragging as smooth as glass.
726  + Remove an annoying NOTIMPLEMNETED
727  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
728  + If we're in the middle of a drag, don't allow the user to middle
729    click to close or right click for the context menu
730  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
731  + Remove +x bit from files that shouldn't have it
732  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
733  + Adding new image needed for the managment UI
734  + Fix a race bug where content scripts would not apply to the first page load
735  + Make escape remove a bookmark if it's just been added (but not if it already existed)
736  + Fix bubbles deactivating the opaque frame
737  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
738  + ake all pepper plugins default to windowless and transparent
739  + Add styles for printing
740  + Implement the new extension management UI
741  + Add support for to automation interface load install and load extensions
742  + GTK: theme the info bar border
743  + Update V8 to version 1.3.16.1
744  + Introduce WebSecurityPolicy for security related methods
745  + New button scheme...borders are separate from the inner contents so
746    that they can be highlighted / depressed independently
747  + When opening Chrome maximized with an application window already
748    running, the Chrome window was not activated
749  + Fix compatibility problems with FileZilla FTP Server
750  + Remove the extension shelf on Linux
751  + Fix the proxy host and port string to start with http:// if it does not already
752  + Enable HTML5 databases for all extension renderer processes
753* Sat Oct 24 2009 prusnak@opensuse.org 
754- don't create desktop files in wrapper
755- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
756* Tue Oct 20 2009 tittiatcoke@gmail.com 
757- update to newer svn snapshot
758  + Obsoletes fwrite patch (included upstream)
759* Fri Oct 16 2009 tittiatcoke@gmail.com 
760- update to newer svn snapshot
761  + Requires newer version of v8
762* Thu Oct 15 2009 prusnak@suse.cz 
763- do not force SSE on x86 (drop-sse.patch)
764* Tue Oct 13 2009 tittiatcoke@gmail.com 
765- Update to newer svn snapshot
766- Fixed spec file in order to build
767- Included patch to build with system zlib
768* Mon Oct 12 2009 prusnak@suse.cz 
769- package renamed to chromium
770- cleaned up spec file
771* Tue Oct  6 2009 dbuck@example.com 
772- v8 is now built as a separate package, and is required
773- included many patches to use system libraries:
774    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
775* Thu Oct  1 2009 dbuck@example.com 
776- included a newer DEP than is in svn, native_client@823
777- things should compile cleanly now
778* Mon Aug 31 2009 dbuck@example.com 
779- initial build
Note: See TracBrowser for help on using the repository browser.