source: projects/specs/tags/6_0_REL/S/SysVinit/SysVinit-vl.spec @ 4097

Revision 4097, 11.7 KB checked in by daisuke, 13 years ago (diff)

SysVinit: update to 2.88dsf, build tools only

Line 
1Summary: Programs which control basic system processes.
2Summary(ja): 基本的なシステムプロセスを制御するプログラム
3Name: SysVinit
4Version: 2.88dsf
5Release: 1%{_dist_release}
6License: GPLv2+
7Group: System Environment/Base
8Source: http://download.savannah.gnu.org/releases/sysvinit/sysvinit-%{version}.tar.bz2
9URL: http://savannah.nongnu.org/projects/sysvinit/
10Patch1: sysvinit-2.78-man.patch
11Patch2: sysvinit-2.86-autofsck.patch
12Patch3: sysvinit-2.86-loginshell.patch
13Patch4: sysvinit-2.86-inittab.patch
14Patch5: sysvinit-2.86-single.patch
15Patch6: sysvinit-2.88-quiet.patch
16Patch14: sysvinit-2.88-ipv6.patch
17Patch15: sysvinit-2.88-omit.patch
18Patch16: sysvinit-2.88-wall-maxlines.patch
19Patch17: sysvinit-2.88-wall-broadcast-message.patch
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21Requires: pam >= 0.66-5
22Requires: %{name}-tools = %{version}-%{release}
23Requires: filesystem
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: daisuke
28
29
30%description
31The SysVinit package contains a group of processes that control
32the very basic functions of your system. SysVinit includes the init
33program, the first program started by the Linux kernel when the
34system boots. Init then controls the startup, running, and shutdown
35of all other programs.
36
37%description -l ja
38SysVinit パッケージには,システムの非常に基本的な機能を制御する
39プロセスが収められています.例えば,システム起動時に Linux カーネルに
40よって最初に起動されるプログラムである init 等です.init はその後
41システムの起動や,他のプログラムの起動/終了を制御します.
42
43%package tools
44Summary: Tools used for process management.
45Summary(ja): プロセス管理に使用するツール
46Group: System Environment/Base
47
48%description tools
49The sysvinit-tools package contains various tools used for process
50management.
51
52$description -l ja tools
53SysVinit-tools パッケージにはプロセス管理に使用するさまざまなツール
54が含まれています。
55
56%prep
57%setup -q -n sysvinit-%{version}
58# We use a shell, not sulogin. Other random man fixes go here (such as #192804)
59%patch1 -p1 -b .manpatch
60# Unlink /.autofsck on shutdown -f
61%patch2 -p1 -b .autofsck
62# Invoke single-user shell as a login shell (#105653)
63%patch3 -p1 -b .loginshell
64# Adjust examples in inittab(5) to more accurately reflect RH/Fedora
65# usage (#173572)
66%patch4 -p1 -b .inittabdocs
67# Fix single user mode (#176348)
68%patch5 -p1 -b .single
69# Be less verbose when booted with 'quiet'
70%patch6 -p1 -b .quiet
71# Change accepted ipv6 addresses (#573346)
72%patch14 -p1 -b .ipv6
73# Add option to pidof to exclude similar processes to omitted processes (#632321)
74%patch15 -p1 -b .omit
75# Fix counting MAXLINES in wall
76%patch16 -p1 -b .maxlines
77# Raise limit for broadcast message
78%patch17 -p1 -b .broadcast
79
80%build
81make %{?_smp_mflags} CC=%{__cc} CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE" LDFLAGS="-lcrypt" -C src
82
83%install
84rm -rf $RPM_BUILD_ROOT
85for I in bin sbin %{_bindir} %{_mandir}/man{1,3,5,8} etc var/run dev %{_includedir}; do
86        mkdir -p $RPM_BUILD_ROOT/$I
87done
88make -C src ROOT=$RPM_BUILD_ROOT MANDIR=%{_mandir} STRIP=/bin/true \
89        BIN_OWNER=`id -nu` BIN_GROUP=`id -ng` install
90
91rm -f $RPM_BUILD_ROOT/bin/pidof
92ln -snf killall5 $RPM_BUILD_ROOT/sbin/pidof
93rm -f $RPM_BUILD_ROOT/sbin/bootlogd
94rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/bootlogd*
95chmod 755 $RPM_BUILD_ROOT/usr/bin/utmpdump
96
97# Remove these files, as we use upstart as /sbin/init.
98rm -f $RPM_BUILD_ROOT/sbin/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}
99rm -f $RPM_BUILD_ROOT/%{_includedir}/initreq.h
100rm -f $RPM_BUILD_ROOT/%{_mandir}/man5/*
101rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/{halt,init,poweroff,reboot,runlevel,shutdown,telinit}*
102
103# /sbin/fstab-decode is part of initscripts
104rm -f $RPM_BUILD_ROOT/sbin/fstab-decode
105rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/fstab-decode.8
106
107%post
108[ -x /sbin/telinit -a -p /dev/initctl -a -f /proc/1/exe -a -d /proc/1/root ] && /sbin/telinit u
109exit 0
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%files tools
115%defattr(-,root,root)
116%doc doc/Changelog COPYRIGHT
117%{_bindir}/last
118%{_bindir}/lastb
119%{_bindir}/mesg
120%{_bindir}/utmpdump
121%{_sysbindir}/mountpoint
122%attr(2555,root,tty)  %{_bindir}/wall
123/sbin/pidof
124/sbin/killall5
125/sbin/sulogin
126%{_mandir}/man1/*
127%{_mandir}/man8/killall5*
128%{_mandir}/man8/pidof*
129%{_mandir}/man8/sulogin*
130
131
132%changelog
133* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.88dsf-1
134- update to 2.88dsf
135- only build -tools subpackage
136
137* Fri Apr 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.87dsf-1
138- new upstream release (2.87dsf)
139- remove upstreamed or obsoleted patches
140- split off a -tools subpackage to avoid upstart conflicts
141
142* Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.86-1
143- new upstream release
144
145* Thu Jul 06 2006 Shu KONNO <owa@bg.wakwak.com> 2.85-5vl3
146- add script to create $RPM_BUILD_ROOT/bin in %%install section
147
148* Wed Dec 10 2003 <tkoba@vinelinux.org> 2.85-5vl2
149- install initreq.h
150
151* Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.85-5vl1
152- new upstream release
153- merged with fedora package.
154  * Tue Jul 17 2001 <sagami@vinelinux.org>
155  - 2.78-10vl3: fix orphan symlink in %%doc
156  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
157  - 2.78-10vl1
158  - rebuilt under new %%{_mandir} definition
159  - added Japanese summary and description
160  * Sat Nov 18 2000 Satoshi MACHINO <machino@vinelinux.org> 2.78-10vl1
161  - build with gcc-2.95.3
162  - partially used rpmmacros
163
164* Mon Sep 22 2003 Bill Nottingham <notting@redhat.com> 2.85-5
165- add change_console, for changing console used by init
166
167* Wed Jun 25 2003 Bill Nottingham <notting@redhat.com> 2.85-4
168- block signals when calling syslog() (#97534, <joden@lee.k12.nc.us>)
169
170* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
171- rebuilt
172
173* Fri May 23 2003 Bill Nottingham <notting@redhat.com> 2.85-2
174- clean up killall5 some
175
176* Thu May 22 2003 Florian La Roche <Florian.LaRoche@redhat.de>
177- update to 2.85, remove already applied patches
178
179* Mon Feb 10 2003 Bill Nottingham <notting@redhat.com> 2.84-13
180- fix s390x build
181- fix silly warning (#83943)
182
183* Mon Feb 10 2003 Arjan van de Ven <arjanv@redhat.com>
184- fix wait() handling wrt setting SIGCHLD to SIG_IGN in shutdown
185- fix segfault in spawn() function in shutdown
186
187* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
188- rebuilt
189
190* Thu Dec 05 2002 Elliot Lee <sopwith@redhat.com> 2.84-7
191- Pass __cc macro to build, to facilitate cross-compiling
192- _smp_mflags
193
194* Mon Dec  2 2002 Bill Nottingham <notting@redhat.com> 2.84-6
195- rebuild on all arches
196- change sulogin message to be slightly more correct (#65828)
197
198* Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
199- don't strip binaries
200- have wall not write to non-ttys (#65412)
201- update usage for halt/reboot (#57753)
202- allow '-t' argument to last for checking state at certain times (#56863)
203- make 'pidof /foo/bar' not match /baz/bar (#53918)
204
205* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
206- automated rebuild
207
208* Thu May 23 2002 Tim Powers <timp@redhat.com>
209- automated rebuild
210
211* Thu Mar 12 2002 Bill Nottingham <notting@redhat.com> 2.84-2
212- add patch to log messages on shutdown/reboot
213
214* Fri Feb 22 2002 Bill Nottingham <notting@redhat.com> 2.84-1
215- update to 2.84
216
217* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
218- automated rebuild
219
220* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.79-2
221- Fix pidof -o (#55954)
222- Handle RPM_OPT_FLAGS
223- s/Copyright/License/
224
225* Mon Sep 17 2001 Bill Nottingham <notting@redhat.com>
226- update to 2.79
227
228* Tue Aug 28 2001 Bill Nottingham <notting@redhat.com>
229- unlink /.autofsck on shutdown -f
230
231* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
232- Bump release + rebuild.
233
234* Thu Jun 21 2001 Bill Nottingham <notting@redhat.com>
235- update 'no logout' patch
236- fix setting of CREAD to work with 2.4.3+ kernels (#45284)
237
238* Tue Jun 12 2001 Bill Nottingham <notting@redhat.com>
239- show users with no login pid but no logout record as gone (#42550,
240  <cwolf@starclass.com>)
241- fix sulogin to *always* work without a tty (#40934)
242
243* Tue Apr  3 2001 Bill Nottingham <notting@redhat.com>
244- set umask 022 on startup
245- manpage tweaks (#21628, #27173)
246
247* Mon Apr  2 2001 Bill Nottingham <notting@redhat.com>
248- fix dangling symlink in %%doc (#34383)
249
250* Thu Mar 15 2001 Bill Nottingham <notting@redhat.com>
251- don't run telinit u if we don't appear to be on the root fs
252
253* Fri Feb 16 2001 Bill Nottingham <notting@redhat.com>
254- run telinit u on upgrade
255
256* Wed Jan 31 2001 Bill Nottingham <notting@redhat.com>
257- document '-n' option to wall, make it root-only (#18672)
258- don't open files in sulogin unless they're really ttys (#21862)
259
260* Tue Aug  8 2000 Bill Nottingham <notting@redhat.com>
261- set SHLVL in sulogin so /etc/profile.d stuff isn't run by default
262
263* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
264- automatic rebuild
265
266* Thu Jun  8 2000 Bill Nottingham <notting@redhat.com>
267- fix the md5 code (#11534)
268- rebuild for FHS & the like
269
270* Wed Apr 19 2000 Bill Nottingham <notting@redhat.com>
271- ignore sigint in sulogin (#9803)
272- touch file in root directory if powering off (#7318)
273
274* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
275- rebuild for sparc baud rates > 38400.
276
277* Thu Feb 24 2000 Bill Nottingham <notting@redhat.com>
278- update to 2.78-final
279
280* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
281- handle compressed manpages
282
283* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
284- build to fix dependency problem
285
286* Tue Jan 10 2000 Bill Nottingham <notting@redhat.com>
287- update to 2.78
288
289* Mon Sep 06 1999 Jakub Jelinek <jj@ultra.linux.cz>
290- on big endian machines use a kludge for broken pam md5 passwords
291
292* Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
293- update to 2.77
294
295* Tue Jul 06 1999 Bill Nottingham <notting@redhat.com>
296- move pam_console stuff to usermode package
297
298* Fri Jul 02 1999 Cristian Gafton <gafton@redhat.com>
299- requires usermode to express the dependency on /usr/bin/consolehelper
300(#2813)
301
302* Wed Jun 23 1999 Bill Nottingham <notting@redhat.com>
303- make man page references to single-user mode consistent with RH usage
304
305* Sat Apr 17 1999 Jeff Johnson <jbj@redhat.com>
306- remove /etc/initlvl compatibility symlink from file list (#2236).
307
308* Fri Mar 26 1999 Michael Johnson <johnsonm@redhat.com>
309- pam.d files marked noreplace
310- added poweroff as a console application
311
312* Mon Mar 22 1999 Michael Johnson <johnsonm@redhat.com>
313- marked config files as such in consolehelper part of filelist
314
315* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
316- auto rebuild in the new build environment (release 8)
317
318* Fri Mar 19 1999 Michael Johnson <johnsonm@redhat.com>
319- consolehelper support
320
321* Wed Jan 06 1999 Cristian Gafton <gafton@redhat.com>
322- glibc 2.1
323
324* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
325- poweroff symlink not included (problem #762)
326
327* Thu Jul 09 1998 Chris Evans <chris@ferret.lmh.ox.ac.uk>
328- Fix a securelevel releated security hole. Go on, try and break append
329  only files + securelevel now ;-)
330
331* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
332- remove /etc/nologin at end of shutdown.
333- compile around missing SIGPWR on sparc
334
335* Thu May 07 1998 Prospector System <bugs@redhat.com>
336- translations modified for de, fr, tr
337
338* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
339- upgraded to 2.74
340- fixed the package source url... (yeah, it was wrong !)
341
342* Wed Oct 1 1997 Cristian Gafton <gafton@redhat.com>
343- fixed the MD5 check in sulogin (128 hash bits encoded with base64 gives
344  22 bytes, not 24...). Fix in -md5.patch
345
346* Thu Sep 11 1997 Christian 'Dr. Disk' Hechelmann <drdisk@ds9.au.s.shuttle.de>
347- /etc/initrunlvl gets linked to /tmp/init-root/var/run/initrunlvl which is
348  just plain wrong..
349- /usr/bin/utmpdump was missing in the files section, although it was
350  explicitly patched into PROGS.
351- added attr's to the files section.
352- various small fixes.
353
354* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
355- updated to 2.71
356- built against glibc 2.0.4
357
358* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
359- Added sulogin.8 man page to file list.
Note: See TracBrowser for help on using the repository browser.