source: projects/specs/branches/6/y/ypserv/ypserv-vl.spec @ 5569

Revision 5569, 12.3 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1##%define initdir /etc/rc.d/init.d
2
3Summary: The NIS (Network Information Service) server.
4Summary(ja): NIS (Network Information Service) サーバ
5Name: ypserv
6Version: 2.19
7Release: 5%{_dist_release}
8License: GPLv2
9Group: System Environment/Daemons
10URL: http://www.linux-nis.org/
11Source0: ftp://ftp.kernel.org/pub/linux/utils/net/NIS/ypserv-%{version}.tar.bz2
12Source1: ypserv-ypserv.init
13Source2: ypserv-yppasswdd.init
14Source3: ypserv-ypxfrd.init
15Patch0: ypserv-2.5-redhat.patch
16Patch1: ypserv-2.11-path.patch
17Patch2: ypserv-2.5-nfsnobody2.patch
18Patch3: ypserv-2.11-nomap.patch
19Patch4: ypserv-2.11-iface-binding3.patch
20Patch6: ypserv-2.13-yplib-memleak.patch
21Patch7: ypserv-2.13-ypxfr-zeroresp.patch
22Patch8: ypserv-2.19-inval-ports.patch
23Patch9: ypserv-2.13-nonedomain.patch
24Patch10: ypserv-2.19-quieter.patch
25Patch11: ypserv-2.19-debuginfo.patch
26Patch12: ypserv-2.19-slp-warning.patch
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: gdbm-devel
30Requires: gawk portmap tcp_wrappers bash gdbm
31Requires(post): /sbin/chkconfig
32Requires(preun): /sbin/chkconfig /sbin/service
33Requires(postun): /sbin/service
34Obsoletes: yppasswd
35
36%description
37The Network Information Service (NIS) is a system which provides
38network information (login names, passwords, home directories, group
39information) to all of the machines on a network.  NIS can enable
40users to login on any machine on the network, as long as the machine
41has the NIS client programs running and the user's password is
42recorded in the NIS passwd database.  NIS was formerly known as Sun
43Yellow Pages (YP).
44
45This package provides the NIS server, which will need to be running on
46your network.  NIS clients do not need to be running the server.
47
48Install ypserv if you need an NIS server for your network.  You'll
49also need to install the yp-tools and ypbind packages onto any NIS
50client machines.
51
52%description -l ja
53Network Information Service (NIS) とは各種ネットワーク情報
54(ログイン名,パスワード,ホームディレクトリ,グループ情報等) を
55ネットワーク上の全マシンに提供する為のシステムです.
56NIS を使うと,そのユーザのパスワードが NIS データベースに登録されて
57さえいれば,NIS クライアントが動作しているどのマシンからでも
58ログインすることが出来ます.NIS はかつて Sun Yellow Pages (YP) と
59して広く知られていました.
60
61このパッケージは NIS サーバを提供します.NIS サーバは
62NIS サービスを利用する際ネットワーク上に必ず稼働していなければなりません.
63NIS クライアント機上で動作する必要はありません.
64
65ネットワーク上に NIS サーバが必要な場合,この ypserv パッケージを
66インストールして下さい.同時に NIS クライアント機に yp-tools と
67ypbind パッケージをインストールする必要があります.
68
69
70%prep
71%setup -q
72%patch0 -p1 -b .redhat
73%patch1 -p1 -b .path
74%patch2 -p1 -b .nfsnobody
75%patch3 -p1 -b .nomap
76%patch4 -p1 -b .iface
77%patch6 -p1 -b .memleak
78%patch7 -p1 -b .respzero
79%patch8 -p1 -b .ports
80%patch9 -p1 -b .nonedomain
81%patch10 -p1 -b .quieter
82%patch11 -p1 -b .debuginfo
83%patch12 -p1 -b .slp-warning
84
85%build
86cp etc/README etc/README.etc
87%configure --enable-checkroot --enable-fqdn --enable-yppasswd --libexecdir=%{_libdir}/yp
88make %{?_smp_mflags}
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93#make install ROOT=$RPM_BUILD_ROOT
94%makeinstall libexecdir=$RPM_BUILD_ROOT%{_libdir}/yp INSTALL_PROGRAM=install
95mkdir -p $RPM_BUILD_ROOT%{_initdir}
96install -m644 etc/ypserv.conf $RPM_BUILD_ROOT%{_sysconfdir}
97install -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_initdir}/ypserv
98install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_initdir}/yppasswdd
99install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_initdir}/ypxfrd
100
101mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
102cat > $RPM_BUILD_ROOT/etc/sysconfig/yppasswdd <<EOF
103# The passwd and shadow files are located under the specified
104# directory path. rpc.yppasswdd will use these files, not /etc/passwd
105# and /etc/shadow.
106#ETCDIR=/etc
107
108# This options tells rpc.yppasswdd to use a different source file
109# instead of /etc/passwd
110# You can't mix usage of this with ETCDIR
111#PASSWDFILE=/etc/passwd
112
113# This  options  tells rpc.yppasswdd to use a different source file
114# instead of /etc/passwd.
115# You can't mix usage of this with ETCDIR
116#SHADOWFILE=/etc/shadow
117
118# Additional arguments passed to yppasswd
119YPPASSWDD_ARGS=
120EOF
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%post
126/sbin/chkconfig --add ypserv
127/sbin/chkconfig --add yppasswdd
128/sbin/chkconfig --add ypxfrd
129
130%triggerpostun -- yppasswd
131/sbin/chkconfig --add yppasswdd
132
133%preun
134if [ $1 = 0 ]; then
135        /sbin/service ypserv stop > /dev/null 2>&1
136        /sbin/chkconfig --del ypserv
137        /sbin/service yppasswdd stop > /dev/null 2>&1
138        /sbin/chkconfig --del yppasswdd
139        /sbin/service ypxfrd stop > /dev/null 2>&1
140        /sbin/chkconfig --del ypxfrd
141fi
142
143%postun
144if [ "$1" -ge "1" ]; then
145        /sbin/service ypserv condrestart > /dev/null 2>&1
146        /sbin/service yppasswdd condrestart > /dev/null 2>&1
147        /sbin/service ypxfrd condrestart > /dev/null 2>&1
148fi
149exit 0
150
151 
152%files
153%defattr(-,root,root)
154%doc AUTHORS README INSTALL ChangeLog TODO NEWS
155%doc etc/ypserv.conf etc/securenets etc/README.etc
156%doc etc/netgroup etc/locale etc/netmasks etc/timezone
157%config(noreplace) %{_sysconfdir}/ypserv.conf
158%config(noreplace) %{_sysconfdir}/sysconfig/yppasswdd
159%config(noreplace) /var/yp/*
160%dir /var/yp
161%config %{initdir}/*
162%{_libdir}/yp
163%{_sbindir}/*
164%{_mandir}/*/*
165%{_includedir}/*/*
166
167%changelog
168* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.19-5
169- rebuild witn Vine6 environment
170
171* Sun Dec  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.19-4
172- added Patches from Fedora
173  * Tue Mar  3 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-12
174  - Mark apropriate config files as noreplace
175  * Thu Sep 25 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-10
176  - Rediff all patches to work with patch --fuzz=0
177  * Wed Feb 13 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-9
178  - Mark /var/yp/Makefile as %%config(noreplace)
179    Resolves: #432582
180  - Comment "slp" part of ypserv.conf to avoid ypserv warnings
181    Resolves: #154806
182  - Spec file cleanup - remove period from end of Summary,
183    fix license, remove macros from Changelog
184  * Mon Feb  4 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.19-8
185  - Fix Buildroot
186  - Fix /var/yp/Makefile
187    Resolves: #431008
188  * Tue Jan  8 2008 Steve Dickson <steved@redhat.com> 2.19-7
189  - Changed Makefiles.in so binaries are not stripped.
190  * Sat Sep 15 2007 Steve Dickson <steved@redhat.com> 2.19-6
191  - Fixed init scripts to return correct exit code on
192   'service status' (bz 248097)
193  * Tue Jul 31 2007 Steve Dickson <steved@redhat.com> 2.19-5
194  - Changed install process to create an useful debuginfo package (bz 249961)
195  * Fri Dec 22 2006 Steve Dickson <steved@redhat.com> - 2.19-4
196  - Made ypserver less verbose on common errors (bz #199236)
197  - Don't allow a make for empty domainname's or domainname's set to (none)
198    (bz #197646)
199  * Wed Sep 13 2006 Steve Dickson <steved@redhat.com> - 2.19-3
200  - Added range checks to port values given on command line
201    (bz 205354)
202  * Tue Jul 25 2006 Steve Dickson <steved@redhat.com> - 2.19-2
203  - fixed typo in ypxfrd initscript (bz 185403)
204
205* Mon May  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19-3
206- spec in UTF-8
207
208* Sun Apr 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.19-2
209- rebuilt without openslp-devel
210
211* Thu Apr 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.19-1
212- new upstream release.
213
214* Sun May 21 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.18-0vl2
215- use License instead of Copyright
216
217* Tue Sep  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.18-0vl1
218- new upstream release.
219
220* Sun Jun 20 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.13-0vl1
221- new upstream release.
222- remove patch2 (no longer needed).
223
224* Fri Apr  9 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.12.1-0vl1
225- new upstream release.
226- replace patch3.
227
228* Mon Dec  8 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.9-0vl1
229- add gdbm[-devel] to 'Requires:' / 'BuildPreReq:'.
230- new upstream release.
231
232* Mon May 19 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.8-1vl1
233- new upstream release.
234
235* Fri Feb  7 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.7-1vl1
236- updated ypserv-2.7
237
238* Fri Dec 13 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.5-1vl3
239- rebuild with new toolchain.
240
241* Tue Oct 22 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.5-1vl2
242- updated ypserv-2.5
243- merge patches from RedHat-8.0.
244- add some files to %%doc.
245
246* Thu Jun 06 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-10-0vl1
247- updated ypserv-2.2
248- fixed patches
249        -- merged Rawhide's ypserv-2.2-10
250       
251* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
252- 1.3.11-9vl1
253- based on 1.3.11-9 from Rawhide
254- %%{initdir} -> %%{_initdir}
255- added Japanese summary and description
256
257* Wed Aug 16 2000 Than Ngo <than@redhat.com>
258- fix typo in startup script (Bug #15999)
259
260* Wed Jul 19 2000 Than Ngo <than@redhat.de>
261- inits back to rc.d/init.d, using service
262- fix initscript again
263
264* Mon Jul 17 2000 Bill Nottingham <notting@redhat.com>
265- move initscript back
266- fix format syslog bug
267
268* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
269- automatic rebuild
270
271* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
272- prereq /etc/init.d
273
274* Tue Jun 27 2000 Than Ngo <than@redhat.de>
275- /etc/rc.d/init.d -> /etc/init.d
276- fix initscript
277
278* Sun Jun 18 2000 Than Ngo <than@redhat.de>
279- FHS fixes,
280- fix docdir
281
282* Fri May 19 2000 Florian La Roche <Florian.LaRoche@redhat.com>
283- disable "netgrp" target in default all: (/var/yp/Makefile)
284
285* Thu May 18 2000 Florian La Roche <Florian.LaRoche@redhat.com>
286- update to 1.3.11
287
288* Mon Mar 06 2000 Cristian Gafton <gafton@redhat.com>
289- add patch to avoid potential deadlock on the server (fix #9968)
290
291* Wed Feb  2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
292- fix typo in %triggerpostun
293
294* Mon Oct 25 1999 Bill Nottingham <notting@redhat.com>
295- update to 1.3.9
296- use gdbm, move back to /usr/sbin
297
298* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
299- initscript munging
300- ypserv goes on root partition
301
302* Fri Aug 13 1999 Cristian Gafton <gafton@redhat.com>
303- version 1.3.7
304
305* Thu Jul  1 1999 Bill Nottingham <notting@redhat.com>
306- start after network FS
307
308* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
309- update to 1.3.6.94.
310
311* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
312- improved daemonization.
313
314* Sat May 29 1999 Jeff Johnson <jbj@redhat.com>
315- fix buffer overflow in rpc.yppasswd (#3126).
316
317* Fri May 28 1999 Jeff Johnson <jbj@redhat.com>
318- update to 1.3.6.92.
319
320* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
321- version 1.3.6.91
322
323* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
324- auto rebuild in the new build environment (release 4)
325
326* Mon Feb  8 1999 Bill Nottingham <notting@redhat.com>
327- move to start before ypbind
328
329* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
330- build for glibc 2.1
331- upgraded to 1.3.5
332
333* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
334- yppasswd.init: lock file must have same name as init.d script, not daemon
335
336* Sat Jul 11 1998 Cristian Gafton <gafton@redhat.com>
337- upgraded to 1.3.4
338- fixed the fubared Makefile
339- link against gdbm instead of ndbm (it seems to work better)
340
341* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
342- upgraded to 1.3.1
343- enhanced init scripts
344
345* Fri May 01 1998 Jeff Johnson <jbj@redhat.com>
346- added triggerpostun
347- Use libdb fro dbp_*().
348
349* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
350- translations modified for de, fr, tr
351
352* Mon Apr 13 1998 Cristian Gafton <gafton@redhat.com>
353- updated to 1.3.0
354
355* Wed Dec 03 1997 Cristian Gafton <gafton@redhat.com>
356- updated to 1.2.5
357- added buildroot; updated spec file
358- added yppasswdd init file
359
360* Tue Nov 04 1997 Erik Troan <ewt@redhat.com>
361- init script shouldn't set the domain name
362
363* Tue Oct 14 1997 Erik Troan <ewt@redhat.com>
364- supports chkconfig
365- updated initscript for status and restart
366- turned off in all runlevels, by default
367- removed postinstall script which didn't do anything
368
369* Thu Oct 09 1997 Erik Troan <ewt@redhat.com>
370- added patch to build against later glibc
371
372* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
373- built against glibc
374
375* Wed Apr 23 1997 Erik Troan <ewt@redhat.com>
376- updated to 1.1.7.
377
378* Fri Mar 14 1997 Erik Troan <ewt@redhat.com>
379- Updated to ypserv 1.1.5, ported to Alpha (glibc).
380
381* Fri Mar 07 1997 Erik Troan <ewt@redhat.com>
382- Removed -pedantic which confuses the SPARC :-(
Note: See TracBrowser for help on using the repository browser.