source: projects/specs/branches/6/y/yakuake/yakuake-vl.spec @ 5569

Revision 5569, 4.2 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1%define dt_vendor fedora
2
3Name:           yakuake
4Summary:        Terminal emulator
5Summary(ja):    端末エミュレータ
6Version:        2.9.7
7Release:        3%{?_dist_release}
8
9Group:          User Interface/Desktops
10License:        GPLv2+
11URL:            http://extragear.kde.org/apps/yakuake/
12Source0:        http://download.berlios.de/yakuake/%{name}-%{version}.tar.bz2
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  desktop-file-utils
16BuildRequires:  gettext
17BuildRequires:  kdelibs4-devel
18BuildRequires:  soprano-devel
19# konsolepart
20Requires:       kdebase4
21
22%description
23Yakuake is a "Quake console" like terminal emulator.
24
25%description
26Quake console ライクな端末エミュレータです.
27
28%prep
29%setup -q
30
31
32%build
33mkdir -p %{_target_platform}
34pushd %{_target_platform}
35unset QTDIR || : ; . /etc/profile.d/qt4.sh
36%{cmake} \
37    -DCMAKE_BUILD_TYPE=release \
38    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
39    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
40    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
41    ..
42popd
43
44make %{?_smp_mflags} -C %{_target_platform}
45
46
47%install
48rm -rf %{buildroot}
49make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
50
51## --vendor is discouraged/deprecated these days -- Rex
52#desktop-file-install --vendor=""                          \
53#        --dir=%{buildroot}%{_datadir}/applications         \
54#        --add-category=Utility                                  \
55#        --delete-original                                       \
56#        %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
57
58%find_lang %{name}
59
60
61%check
62desktop-file-validate  %{buildroot}%{_datadir}/applications/kde4/yakuake.desktop
63
64
65%post
66touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
67
68%posttrans
69gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
70
71%postun
72if [ $1 -eq 0 ] ; then
73touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
74gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
75fi
76
77
78%clean
79rm -rf %{buildroot}
80
81
82%files -f %{name}.lang
83%defattr(-,root,root,-)
84%doc AUTHORS COPYING ChangeLog TODO
85%{_bindir}/yakuake
86%{_datadir}/applications/kde4/yakuake.desktop
87%{_datadir}/kde4/apps/yakuake/
88%{_datadir}/icons/hicolor/*/*/*
89
90
91%changelog
92* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.9.7-3
93- rebuild with Vine6 environment
94- add BuildRequires: soprano-devel
95
96* Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.7-2
97- Initial build for Vine Linux
98
99* Sun Jul 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.9.7-1
100- 2.9.7
101- optimize scriptlets
102- use _kde4_ macros
103
104* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.6-2
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
106
107* Thu Jul 10 2009 Johan Cwiklinski <johan AT x-tnd DOT be> 2.9.6-1
108- 2.9.6
109
110* Sat Apr 17 2009 Johan Cwiklinski <johan AT x-tnd DOT be>  2.9.4-3
111- Fix crash with QT 4.5
112
113* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.9.4-2
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Thu Sep 4 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.4-1
117- 2.9.4
118- change BR from kdelibs4-devel to kdelibs-devel
119
120* Fri Jun 20 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.3-1
121- 2.9.3
122- kdebase is required
123
124* Sat Apr 05 2008 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9.1-1
125- 2.9.1
126- use of %%{cmake_kde4} macro
127- remove no longer needeed chrpath
128
129* Wed Apr 02 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.9-2.beta1
130- BR: kdelibs4-devel
131- description/summary: s/for KDE//
132
133* Mon Feb 11 2008 Johan Cwiklinski <johan AT x-tnd DOT be> - 2.9-1.beta1
134- upstream release for KDE4
135
136* Mon Oct 30 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-4
137- Add support for KonsoleScripts (#212862)
138
139* Fri Sep 15 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-3
140- Rebuild for FE6
141- Update e-mail address
142- Fix mixed-use-of-spaces-and-tabs rpmlint warning
143
144* Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-2
145- Add dist tag
146
147* Sat May 20 2006 Dawid Gajownik <gajownik[AT]gmail.com> - 2.7.5-1
148- Update to 2.7.5
149- Add `--disable-dependency-tracking' and `--enable-final' options
150- Include translations
151
152* Mon Oct 24 2005 Mickael <dreadyman@gmail.com>
153- initial release
154
Note: See TracBrowser for help on using the repository browser.