source: projects/specs/branches/6/x/xulrunner/xulrunner-vl.spec @ 4002

Revision 4002, 26.5 KB checked in by daisuke, 13 years ago (diff)

xulrunner: fix gre.conf to promote internal gecko version

Line 
1%define nspr_version 4.8.7
2%define nss_version 3.12.9
3%define cairo_version 1.10.2-2
4%define libnotify_version 0.4
5%define tarballdir mozilla-2.0
6%define libjpeg-turbo_version 1.1.0
7
8%define build_vine6 0
9%define build_vine5 0
10%if "%{?_dist_release}" == "vl6"
11%define build_vine6 1
12%define build_vine5 1
13%endif
14%if "%{?_dist_release}" == "vl5"
15%define build_vine5 1
16%endif
17
18%if %build_vine6
19%define sqlite_version 3.7.5
20%endif
21
22%define version_internal  2.0
23%define mozappdir         %{_libdir}/%{name}-%{version_internal}
24
25# Separated plugins are supported on x86(64) only
26%ifarch %{ix86} x86_64
27%define separated_plugins 1
28%else
29%define separated_plugins 0
30%endif
31
32Summary:        XUL Runtime for Gecko Applications
33Summary(ja):    Gecko アプリケーションのための XUL ランタイム
34Name:           xulrunner
35Version:        2.0.1
36Release:        2%{?_dist_release}
37URL:            http://www.mozilla.org/projects/xulrunner/
38License:        MPLv1.1 or GPLv2+ or LGPLv2+
39Group:          Applications/Internet
40Source0:        %{name}-%{version}.source.tar.bz2
41Source10:       %{name}-mozconfig
42Source11:       %{name}-mozconfig-vine5
43Source12:       %{name}-vine-default-prefs.js
44Source21:       %{name}.sh.in
45Source23:       %{name}.1
46
47# locale sources
48%define MOZ_BUILD_LOCALES "ja"
49Source1000:     xulrunner-%{version}-ja.tar.bz2
50
51# build patches
52Patch0:         xulrunner-version.patch
53Patch1:         mozilla-build.patch
54Patch7:         xulrunner-1.9.2.1-build.patch
55#Patch8:         mozilla-plugin.patch
56Patch9:         mozilla-build-sbrk.patch
57Patch10:        mozilla-libjpeg-turbo.patch
58
59# patches from Fedora
60Patch100:       mozilla-193-pkgconfig.patch
61
62# Upstream patches
63Patch130:        xulrunner-omnijar.patch
64
65
66
67# ---------------------------------------------------
68
69BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
70BuildRequires:  nspr-devel >= %{nspr_version}
71BuildRequires:  nss-devel >= %{nss_version}
72BuildRequires:  cairo-devel >= %{cairo_version}
73BuildRequires:  libpng-devel
74BuildRequires:  libjpeg-turbo-devel >= %{libjpeg-turbo_version}
75BuildRequires:  bzip2-devel
76BuildRequires:  zlib-devel
77BuildRequires:  lcms-devel
78BuildRequires:  libIDL-devel
79BuildRequires:  gtk2-devel
80BuildRequires:  gnome-vfs2-devel
81BuildRequires:  libgnome-devel
82BuildRequires:  libgnomeui-devel
83BuildRequires:  pango-devel
84BuildRequires:  freetype2-devel >= 2.1.9
85BuildRequires:  libXt-devel
86BuildRequires:  libXrender-devel
87%if %{build_vine6}
88BuildRequires:  sqlite3-devel >= %{sqlite_version}
89%endif
90BuildRequires:  libnotify-devel >= %{libnotify_version}
91BuildRequires:  startup-notification-devel
92BuildRequires:  alsa-lib-devel
93BuildRequires:  lcms-devel
94BuildRequires:  zip
95# For -sqlite.patch
96BuildRequires:  autoconf213
97BuildRequires:  libvpx-devel
98
99Requires:       nspr >= %{nspr_version}
100Requires:       nss >= %{nss_version}
101
102Provides:       gecko-libs = %{version}
103
104%description
105XULRunner provides the XUL Runtime environment for Gecko applications.
106
107%package devel
108Summary: Development files for Gecko
109Group: Development/Libraries
110
111Obsoletes: mozilla-devel
112Obsoletes: firefox-devel < 2.1
113Obsoletes: xulrunner-devel-unstable
114
115Provides: gecko-devel = %{version}
116Provides: gecko-devel-unstable = %{version}
117
118Requires: xulrunner = %{version}-%{release}
119Requires: nspr-devel >= %{nspr_version}
120Requires: nss-devel >= %{nss_version}
121Requires: cairo-devel >= %{cairo_version}
122Requires: libjpeg-turbo-devel >= %{libjpeg-turbo_version}
123Requires: zip
124Requires: bzip2-devel
125Requires: zlib-devel
126Requires: lcms-devel
127Requires: libIDL-devel
128Requires: gtk2-devel
129Requires: gnome-vfs2-devel
130Requires: libgnome-devel
131Requires: libgnomeui-devel
132Requires: pango-devel
133Requires: freetype2-devel >= 2.1.9
134Requires: libXt-devel
135Requires: libXrender-devel
136%if %{build_vine6}
137Requires: sqlite3-devel >= %{sqlite_version}
138%endif
139Requires: startup-notification-devel
140Requires: alsa-lib-devel
141
142%description devel
143Gecko development files.
144
145#---------------------------------------------------------------------
146
147%prep
148%setup -q -c -b 1000
149cd %{tarballdir}
150
151sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
152    %{P:%%PATCH0} > version.patch
153%{__patch} -p1 -b --suffix .version < version.patch
154
155%patch1  -p2 -b .build
156%patch7  -p2 -b .del
157%patch9  -p2 -b .sbrk
158%patch10 -p2 -b .libjpeg-turbo
159
160%patch100 -p2 -b .pkgconfig
161%patch130 -p1 -b .omnijar
162
163
164%{__rm} -f .mozconfig
165%if %{build_vine6}
166%{__cp} %{SOURCE10} .mozconfig
167%else
168%{__cp} %{SOURCE11} .mozconfig
169%endif
170
171%if !%{?separated_plugins}
172echo "ac_add_options --disable-ipc" >> .mozconfig
173%endif
174
175#---------------------------------------------------------------------
176
177%build
178cd %{tarballdir}
179
180INTERNAL_GECKO=%{version_internal}
181MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
182
183# Mozilla builds with -Wall with exception of a few warnings which show up
184# everywhere in the code; so, don't override that.
185MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
186export CFLAGS=$MOZ_OPT_FLAGS
187export CXXFLAGS=$MOZ_OPT_FLAGS
188
189export PREFIX='%{_prefix}'
190export LIBDIR='%{_libdir}'
191
192MOZ_SMP_FLAGS=-j1
193%ifnarch ppc ppc64 s390 s390x
194[ -z "$RPM_BUILD_NCPUS" ] && \
195     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
196[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
197%endif
198
199export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
200make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
201make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
202
203# build locales
204LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
205            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
206for dir in $LOCALEDIRS
207do
208  for lang in %{MOZ_BUILD_LOCALES} ; do
209    make -C $dir/locales AB_CD=$lang
210  done
211done
212
213#---------------------------------------------------------------------
214
215%install
216cd %{tarballdir}
217%{__rm} -rf $RPM_BUILD_ROOT
218
219INTERNAL_GECKO=%{version_internal}
220
221INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
222MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
223
224INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
225MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
226
227# set up our default preferences
228%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
229%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
230%{__rm} vl-default-prefs
231
232DESTDIR=$RPM_BUILD_ROOT make install
233
234%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
235             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
236             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
237
238%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
239
240# Start script install
241%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
242%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
243  $RPM_BUILD_ROOT%{_bindir}/%{name}
244%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
245
246%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
247
248cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
249find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
250cd -
251
252# install locales
253#for lang in %{MOZ_BUILD_LOCALES} ; do
254#  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
255#done
256
257# Prepare our devel package
258%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
259%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
260%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
261
262%{__cp} -rL dist/include/* \
263  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
264
265# Copy pc files (for compatibility with 1.9.1)
266%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
267        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
268%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
269        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
270
271# Fix multilib devel conflicts...
272%ifarch x86_64 ia64 s390x ppc64
273%define mozbits 64
274%else
275%define mozbits 32
276%endif
277
278function install_file() {
279genheader=$*
280mv ${genheader}.h ${genheader}%{mozbits}.h
281cat > ${genheader}.h << EOF
282// This file exists to fix multilib conflicts
283#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
284#include "${genheader}64.h"
285#else
286#include "${genheader}32.h"
287#endif
288EOF
289}
290
291pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
292install_file "mozilla-config"
293install_file "jsautocfg"
294install_file "js-config"
295popd
296
297%{__install} -p -c -m 755 dist/bin/xpcshell \
298  dist/bin/xpidl \
299  dist/bin/xpt_dump \
300  dist/bin/xpt_link \
301  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
302
303%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
304%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
305
306%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
307ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
308       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
309
310%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
311ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
312       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
313
314%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
315ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
316       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
317
318%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
319ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
320       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
321
322find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
323find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
324
325%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
326pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
327for i in *.so; do
328    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
329done
330popd
331
332# GRE stuff
333%ifarch x86_64 ia64 ppc64 s390x
334%define gre_conf_file gre64.conf
335%else
336%define gre_conf_file gre.conf
337%endif
338
339MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
340%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
341        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
342sed -i -e "s/\[%{version}\]/\[$INTERNAL_GECKO\]/g" $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
343chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
344
345# Library path
346%ifarch x86_64 ia64 ppc64 s390x
347%define ld_conf_file xulrunner-64.conf
348%else
349%define ld_conf_file xulrunner-32.conf
350%endif
351
352%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
353%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
354${MOZ_APP_DIR}
355EOF
356                       
357# Copy over the LICENSE
358%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
359
360# Use the system hunspell dictionaries
361%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
362ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
363
364# ghost files
365%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
366touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
367touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
368
369#---------------------------------------------------------------------
370
371%clean
372%{__rm} -rf $RPM_BUILD_ROOT
373
374#---------------------------------------------------------------------
375
376%post
377/sbin/ldconfig
378
379%postun
380/sbin/ldconfig
381
382%preun
383# is it a final removal?
384if [ $1 -eq 0 ]; then
385  %{__rm} -rf ${MOZ_APP_DIR}/components
386fi
387
388%files
389%defattr(-,root,root,-)
390%{_bindir}/xulrunner
391%dir /etc/gre.d
392/etc/gre.d/%{gre_conf_file}
393%dir %{mozappdir}
394%doc %attr(644, root, root) %{mozappdir}/LICENSE
395%doc %attr(644, root, root) %{mozappdir}/README.txt
396%{mozappdir}/chrome
397%{mozappdir}/chrome.manifest
398%{mozappdir}/dictionaries
399%dir %{mozappdir}/components
400%ghost %{mozappdir}/components/compreg.dat
401%ghost %{mozappdir}/components/xpti.dat
402%{mozappdir}/components/*.so
403#%{mozappdir}/components/*.xpt
404%{mozappdir}/components/*.manifest
405#%attr(644, root, root) %{mozappdir}/components/*.js
406%{mozappdir}/defaults
407%dir %{mozappdir}/icons
408%attr(644, root, root) %{mozappdir}/icons/*
409%{mozappdir}/omni.jar
410#%{mozappdir}/modules
411%{mozappdir}/plugins
412#%{mozappdir}/res
413%{mozappdir}/*.so
414%{mozappdir}/mozilla-xremote-client
415%{mozappdir}/run-mozilla.sh
416%{mozappdir}/xulrunner
417%{mozappdir}/xulrunner-bin
418%{mozappdir}/xulrunner-stub
419%if %{?separated_plugins}
420%{mozappdir}/plugin-container
421%endif
422%{mozappdir}/platform.ini
423%{mozappdir}/dependentlibs.list
424#%{mozappdir}/greprefs.js
425%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
426
427# XXX See if these are needed still
428%{mozappdir}/updater*
429%exclude %{mozappdir}/update.locale
430
431%files devel
432%defattr(-,root,root,-)
433%{_datadir}/idl/%{name}*%{version_internal}
434%{_includedir}/%{name}*%{version_internal}
435%{_libdir}/%{name}-sdk-*/
436%{_libdir}/pkgconfig/*.pc
437%{mozappdir}/xpcshell
438%{mozappdir}/xpidl
439%{mozappdir}/xpt_dump
440%{mozappdir}/xpt_link
441
442#---------------------------------------------------------------------
443
444%changelog
445* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
446- modify gre.conf to promote internal gecko version.
447
448* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
449- update to 2.0.1 (sync with firefox-4.0.1)
450
451* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
452- update to 2.0 (sync with firefox-4.0)
453- BR: libjpeg-turbo-devel >= 1.1.0
454- BR: nspr-devel >= 4.8.7
455- BR: nss-devel >= 3.12.9
456- BR: cairo-devel >= 1.10.2-2
457- add Patch130 to use omni.jar (upstream patch)
458
459* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
460- update to 1.9.2.15 (sync with firefox-3.6.15)
461
462* Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
463- update to 1.9.2.14 (sync with firefox-3.6.14)
464
465* Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
466- update to 1.9.2.13 (sync with firefox-3.6.13)
467
468* Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
469- update to 1.9.2.11 (sync with firefox-3.6.11)
470
471* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
472- rebuild with rpm-4.8.1 for pkg-config file
473
474* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
475- update to 1.9.2.9 (sync with firefox-3.6.9)
476- add patch10 to build with libjpeg-turbo
477- build with sqlite-3.7.2
478- BR: nspr >= 4.8.6
479
480* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
481- update tp 1.9.2.8 (sync with firefox-3.6.8)
482
483* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
484- update tp 1.9.2.7 (sync with firefox-3.6.7)
485
486* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
487- enable ipc only on ix86/x86_64 arches
488
489* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
490- update to 1.9.2.4 (sync with firefox-3.6.4)
491- add patch10 to fix build failure
492
493* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
494- update to 1.9.2.3 (sync with firefox-3.6.3)
495
496* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
497- update to 1.9.2.2 (sync with firefox-3.6.2)
498- add patch7,9 for fix build failure
499
500* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
501- enable libnotify support
502  - add ac_add_options --enable-libnotify
503- disable Necko wifi monitor
504  - add ac_add_options --disable-necko-wifi
505  - remove BR: wireless-tools-devel
506- fix %%files devel
507- add patch3,5 to fix jemalloc alignment assertion
508- add Patch8 to fix mozilla-plugin.pc
509
510* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
511- add BR: libnotify-devel, wireless-tools-devel
512
513* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
514- update to 1.9.2 (sync with firefox-3.6)
515- obsoletes xulrunner-devel-unstable
516
517* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
518- use internal sqlite3 on vine5
519
520* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
521- update to 1.9.1.7
522
523* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
524- update to 1.9.1.6
525- build with sqlite3-3.6.21
526
527* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
528- update to 1.9.1.5
529
530* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
531- update to 1.9.1.3
532
533* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
534- really update to 1.9.1.2 (<BTS:0748>)
535
536* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
537- update to 1.9.1.2 (sync with firefox-3.5.2)
538
539* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
540- update to 1.9.1.1 (sync with firefox-3.5.1)
541- add missing Requires to -devel
542- add missing BR
543
544* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
545- enable-system-cairo
546
547* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
548- update to 1.9.1 (based on firefox 3.5)
549
550* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
551- update to 1.9.1rc3 (sync with firefox 3.5rc3)
552
553* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
554- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
555- remove old patches
556- require nspr >= 4.8
557
558* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
559- new upstream release
560
561* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
562- update mozconfig
563  - disable-system-cairo for stability
564
565* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
566- new upstream release
567
568* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
569- new upstream release
570- add ja locale
571
572* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
573- new upstream release
574
575* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
576- new upstream release
577
578* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
579- add Patch3
580
581* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
582- update to xulrunner 1.9.0.2 byild 6
583- build with gnome-2.24
584
585* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
586- new upstream release
587
588* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
589- initial build for Vine Linux
590
591* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
592- Update to 1.9 final
593
594* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
595- Simplify PS/PDF operators
596
597* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
598- Upstream patch to fsync() less
599
600* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
601- Ensure we enable startup notification; add BR and modify config
602  (bug #445543)
603
604* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
605- Some files moved to mozilla-filesystem; kill them and add the Req
606
607* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
608- Clean up the %%files list and get rid of the executable bit on some files
609
610* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
611- Fix font scaling
612
613* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
614- Enabled phishing protection (#443403)
615
616* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
617- Changed "__ppc64__" to "__powerpc64__",
618  "__ppc64__" doesn't work anymore
619- Added fix for #443725 - Critical hanging bug with fix
620  available upstream (mozbz#429903)
621
622* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
623- Fixed multilib issues, added starting script instead of a symlink
624  to binary (#436393)
625
626* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
627- Add upstream patches for dpi, toolbar buttons, and invalid keys
628- Re-enable system cairo
629
630* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
631- Spec cleanups
632
633* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
634- Beta 5
635
636* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
637- Beta 5 RC2
638
639* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
640- Update to latest trunk (2008-03-27)
641
642* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
643- Update to latest trunk (2008-03-26)
644
645* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
646- Update to latest trunk (2008-03-25)
647
648* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
649- Update to latest trunk (2008-03-24)
650
651* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
652- Update to latest trunk (2008-03-20)
653
654* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
655- Update to latest trunk (2008-03-17)
656
657* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
658- Revert to trunk from the 15th to fix crashes on HTTPS sites
659
660* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
661- Update to latest trunk (2008-03-16)
662- Add patch to negate a11y slowdown on some pages (#431162)
663
664* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
665- Update to latest trunk (2008-03-15)
666
667* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
668- Avoid conflicts between gecko debuginfo packages
669
670* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
671- Update to latest trunk (2008-03-12)
672
673* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
674- Update to latest trunk (2008-03-11)
675
676* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
677- Update to latest trunk (2008-03-10)
678
679* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
680- Update to latest trunk (2008-03-09)
681
682* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
683- Update to latest trunk (2008-03-07)
684
685* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
686- Update to latest trunk (2008-03-06)
687
688* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
689- Update to latest trunk (2008-03-04)
690
691* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
692- Update to latest trunk (2008-03-02)
693
694* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
695- Update to latest trunk (2008-03-01)
696
697* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
698- Update to latest trunk (2008-02-29)
699
700* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
701- Update to latest trunk (2008-02-28)
702
703* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
704- Update to latest trunk (2008-02-27)
705
706* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
707- Update to latest trunk (2008-02-26)
708
709* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
710- Update to latest trunk (2008-02-23)
711
712* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
713- Update to latest trunk (2008-02-22)
714
715* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
716- Update to latest trunk (2008-02-21)
717
718* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
719- Update to latest trunk (2008-02-20)
720
721* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
722- Update to latest trunk (2008-02-17)
723
724* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
725- Update to latest trunk (2008-02-15)
726
727* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
728- Update to latest trunk (2008-02-14)
729- Use system hunspell
730
731* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
732- Update to latest trunk (2008-02-11)
733
734* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
735- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
736  you know, debuginfo.
737
738* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
739- Update to latest trunk (2008-02-10)
740
741* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
742- Update to latest trunk (2008-02-09)
743
744* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
745- Update to latest trunk (2008-02-06)
746
747* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
748- Update to latest trunk (2008-01-30)
749
750* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
751- rebuild agains new nss
752- enabled gnome vfs
753
754* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
755- fixed stable pkg-config files (#429654)
756- removed sqlite patch
757
758* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
759- Update to latest trunk (2008-01-21)
760
761* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
762- Update to latest trunk (2008-01-15)
763- Now with system extensions directory support
764
765* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
766- Update to latest trunk (2008-01-13)
767- Use CFLAGS instead of configure arguments
768- Random cleanups: BuildRequires, scriptlets, prefs, etc.
769
770* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
771- Provide gecko-devel-unstable as well
772
773* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
774- divided devel package to devel and devel-unstable
775
776* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
777- removed fedora specific pkg-config files
778- updated to the latest trunk (2008-01-07)
779- removed unnecessary patches
780- fixed idl dir (#427965)
781
782* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
783- Re-enable camellia256 support now that NSS supports it
784
785* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
786- updated to the latest trunk (2008-01-03)
787
788* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
789- Don't Provide webclient (xulrunner is not itself a webclient)
790- Don't Obsolete old firefox, only firefox-devel
791- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
792
793* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
794- added java and plugin subdirs to plugin includes
795
796* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
797- dependency fixes, obsoletes firefox < 3 and firefox-devel now
798
799* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
800- updated to Beta 2.
801- moved SDK to xulrunner-sdk
802
803* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
804- fixed mozilla-plugin.pc (#412971)
805
806* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
807- export /etc/gre.d/gre.conf (it's used by python gecko applications)
808
809* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
810- added xulrunner/js include dir to xulrunner-js
811
812* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
813- update to beta 1
814
815* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
816- packed all gecko libraries (#389391)
817
818* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
819- registered xulrunner libs system-wide
820- added xulrunner-gtkmozembed.pc
821
822* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
823- added proper nss/nspr dependencies
824
825* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
826- more build fixes, use system nss libraries
827
828* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
829- build fixes
830
831* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
832- updated to the latest trunk
833
834* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
835- build fixes for ppc/ppc64
836
837* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
838- removed conflicts with the current gecko-based apps
839- added updated ppc64 patch
840
841* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
842- build fixes
843
844* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
845- Initial cut at XULRunner 1.9 Alpha 7
846- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.