source: projects/specs/branches/6/x/xscreensaver/xscreensaver-vl.spec @ 2170

Revision 2170, 25.2 KB checked in by Takemikaduchi, 13 years ago (diff)

bluez,obexd:new upstream release, others:fix issue that package could not be installed

Line 
1%define modular_conf  1
2
3%define default_text  %{_datadir}/doc/HTML/README-Accessibility
4
5%define pam_ver       1.1
6%define autoconf_ver  2.65
7
8%define update_po     1
9
10Buildroot:       %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12Summary:         X screen saver and locker
13Summary(ja):     X ウィンドウシステム・スクリーンセーバ
14Name:            xscreensaver
15Version:         5.12
16Release:         1%{?_dist_release}
17Epoch:           1
18License:         BSD
19Group:           User Interface/X
20URL:             http://www.jwz.org/xscreensaver/
21
22Source0:         http://www.jwz.org/xscreensaver/xscreensaver-%{version}%{?beta_ver}.tar.gz
23%if %{modular_conf}
24Source10:        update-xscreensaver-hacks
25%endif
26Patch1:          xscreensaver-5.00b5-sanitize-hacks.patch
27Patch3:          xscreensaver-5.05-addopts-jwz.patch
28Patch21:         xscreensaver-5.05-webcollage-default-nonet.patch
29Patch22:         xscreensaver-5.05-penetrate-font.patch
30Requires:        xscreensaver-base = %{epoch}:%{version}-%{release}
31Requires:        xscreensaver-extras = %{epoch}:%{version}-%{release}
32Requires:        xscreensaver-gl-extras = %{epoch}:%{version}-%{release}
33
34%package base
35Summary:         A minimal installation of xscreensaver
36Group:           User Interface/Desktops
37BuildRequires:   autoconf
38BuildRequires:   bc
39BuildRequires:   desktop-file-utils
40BuildRequires:   gawk
41BuildRequires:   gettext
42BuildRequires:   libtool
43BuildRequires:   pam-devel > %{pam_ver}
44BuildRequires:   sed
45BuildRequires:   xdg-utils
46BuildRequires:   xorg-x11-proto-devel
47BuildRequires:   libX11-devel
48BuildRequires:   libXScrnSaver-devel
49BuildRequires:   libXext-devel
50BuildRequires:   libXinerama-devel
51BuildRequires:   libXmu-devel
52BuildRequires:   libXpm-devel
53BuildRequires:   libXt-devel
54BuildRequires:   libXxf86misc-devel
55BuildRequires:   libXxf86vm-devel
56BuildRequires:   gtk2-devel     
57BuildRequires:   libjpeg-devel
58BuildRequires:   libglade2-devel
59Requires:        %{_sysconfdir}/pam.d/system-auth
60Requires:        pam > %{pam_ver}
61Requires:        xdg-utils
62Requires:        xorg-x11-resutils
63Requires:        xorg-x11-fonts-ISO8859-1-100dpi
64
65%package extras
66Summary:         An enhanced set of screensavers
67Group:           User Interface/Desktops
68BuildRequires:   desktop-backgrounds
69Requires:        %{name}-base = %{epoch}:%{version}-%{release}
70
71%package gl-base
72Summary:         A base package for screensavers that require OpenGL
73Group:           User Interface/Desktops
74Requires:        %{name}-base = %{epoch}:%{version}-%{release}
75
76%package gl-extras
77Summary:         An enhanced set of screensavers that require OpenGL
78Group:           User Interface/Desktops
79Provides:        xscreensaver-gl = %{epoch}:%{version}-%{release}
80Obsoletes:       xscreensaver-gl <= 1:5.00
81BuildRequires:   libGL-devel
82BuildRequires:   libGLU-devel
83%if %{modular_conf}
84Requires:        %{name}-gl-base = %{epoch}:%{version}-%{release}
85%else
86Requires:        %{name}-base = %{epoch}:%{version}-%{release}
87%endif
88
89%package extras-gss
90Summary:         Desktop files of extras for gnome-screensaver
91Group:           User Interface/Desktops
92Requires:        %{name}-extras = %{epoch}:%{version}-%{release}
93Requires:        gnome-screensaver
94
95%package gl-extras-gss
96Summary:         Desktop files of gl-extras for gnome-screensaver
97Group:           User Interface/Desktops
98Requires:        %{name}-gl-extras = %{epoch}:%{version}-%{release}
99Requires:        gnome-screensaver
100
101
102%description
103A modular screen saver and locker for the X Window System.
104More than 200 display modes are included in this package.
105
106This is a metapackage for installing all default packages
107related to XScreenSaver.
108
109%description base
110A modular screen saver and locker for the X Window System.
111This package contains the bare minimum needed to blank and
112lock your screen.  The graphical display modes are the
113"xscreensaver-extras" and "xscreensaver-gl-extras" packages.
114
115%description extras
116A modular screen saver and locker for the X Window System.
117This package contains a variety of graphical screen savers for
118your mind-numbing, ambition-eroding, time-wasting, hypnotized
119viewing pleasure.
120
121%description gl-base
122A modular screen saver and locker for the X Window System.
123This package contains minimal files to make screensaver hacks
124that require OpenGL work for XScreenSaver.
125
126%description gl-extras
127A modular screen saver and locker for the X Window System.
128This package contains a variety of OpenGL-based (3D) screen
129savers for your mind-numbing, ambition-eroding, time-wasting,
130hypnotized viewing pleasure.
131
132%description extras-gss
133This package contains desktop files of extras screensavers
134for gnome-screensaver compatibility.
135
136%description gl-extras-gss
137This package contains desktop files of gl-extras screensavers
138for gnome-screensaver compatibility.
139
140
141
142%prep
143%setup -q -n %{name}-%{version}%{?beta_ver}
144
145%patch1 -p1 -b .sanitize-hacks
146## %patch3 -p1 -b .opts
147## %patch21 -p1 -b .nonet
148## %patch22 -p1 -b .font
149
150change_option(){
151   set +x
152   ADFILE=$1
153   if [ ! -f ${ADFILE}.opts ] ; then
154      cp -p $ADFILE ${ADFILE}.opts
155   fi
156   shift
157
158   for ARG in "$@" ; do
159      TYPE=`echo $ARG | sed -e 's|=.*$||'`
160      VALUE=`echo $ARG | sed -e 's|^.*=||'`
161
162      eval sed -i \
163         -e \'s\|\^\\\(\\\*$TYPE\:\[ \\t\]\[ \\t\]\*\\\)\[\^ \\t\]\.\*\$\|\\1$VALUE\|\' \
164         $ADFILE
165   done
166   set -x
167}
168
169silence_hack(){
170   set +x
171   ADFILE=$1
172   if [ ! -f ${ADFILE}.hack ] ; then
173      cp -p $ADFILE ${ADFILE}.hack
174   fi
175   shift
176
177   for hack in "$@" ; do
178      eval sed -i \
179         -e \'\/\^\[ \\t\]\[ \\t\]\*$hack\/s\|\^\|-\|g\' \
180         -e \'s\|\^@GL_\.\*@.*\\\(GL\:\[ \\t\]\[ \\t\]\*$hack\\\)\|-\\t\\1\|g\' \
181         $ADFILE
182   done
183   set -x
184}
185
186# change some files to UTF-8
187for f in \
188   driver/XScreenSaver.ad.in \
189   hacks/glx/sproingies.man \
190   ; do
191   iconv -f ISO-8859-1 -t UTF-8 $f > $f.tmp || cp -p $f $f.tmp
192   touch -r $f $f.tmp
193   mv $f.tmp $f
194done
195
196# change some options
197change_option driver/XScreenSaver.ad.in \
198   captureStderr=False \
199   passwdTimeout=0:00:15 \
200   grabDesktopImages=False \
201   lock=True \
202   splash=False \
203   ignoreUninstalledPrograms=True \
204   textProgram=fortune\ -s
205
206# silence the following hacks by default
207silence_hack driver/XScreenSaver.ad.in \
208   bsod flag
209
210# record time, version
211eval sed -i.ver \
212   -e \'s\|version \[45\]\.\[0-9a-z\]\[0-9a-z\]\*\|version %{version}-`echo \
213      %{release} | sed -e 's|\.[a-z][a-z0-9].*$||'`\|\' \
214      driver/XScreenSaver.ad.in
215
216eval sed -i.date \
217   -e \'s\|\[0-9\].\*-.\*-20\[0-9\]\[0-9\]\|`LANG=C date -u +'%%d-%%b-%%Y'`\|g\' \
218   driver/XScreenSaver.ad.in
219
220eval sed -i.ver \
221   -e \'s\|\(\[0-9\].\*-.\*-20\[0-9\]\[0-9\]\)\|\(`LANG=C \
222      date -u +'%%d-%%b-%%Y'`\)\|g\' \
223   -e \'s\|\\\(5.\[0-9\]\[0-9\]\\\)[a-z]\[0-9\]\[0-9\]\*\|\\\1\|\' \
224   -e \'s\|5.\[0-9\]\[0-9\]\|%{version}-`echo %{release} | \
225      sed -e 's|\.[a-zA-Z][a-zA-Z0-9].*$||'`\|\' \
226   utils/version.h
227
228# move man entry to 6x.
229for f in `find hacks -name Makefile.in` ; do
230   sed -i.mansuf \
231      -e '/^mansuffix/s|6|6x|'\
232      $f
233done
234
235# search first 6x entry, next 1 entry for man pages
236sed -i.manentry -e 's@man %%s@man 6x %%s 2>/dev/null || man 1 %%s @' \
237   driver/XScreenSaver.ad.in
238
239# suppress rpmlint booing.
240# suppress about pam config (although this is
241# not the fault of xscreensaver.pam ......).
242sed -i.rpmlint -n -e '1,5p' driver/xscreensaver.pam
243
244if [ -x %{_datadir}/libtool/config.guess ]; then
245  # use system-wide copy
246   cp -p %{_datadir}/libtool/config.{sub,guess} .
247fi
248
249# fix for desktop-file-utils 0.14+
250sed -i.icon -e 's|xscreensaver\.xpm|xscreensaver|' \
251   driver/screensaver-properties.desktop.in
252
253%build
254autoconf
255
256archdir=`./config.guess`
257mkdir $archdir
258cd $archdir
259
260export CFLAGS="${CFLAGS:-${RPM_OPT_FLAGS}}"
261
262CONFIG_OPTS="--prefix=%{_prefix} --with-pam --without-shadow --without-kerberos"
263CONFIG_OPTS="$CONFIG_OPTS --without-setuid-hacks"
264CONFIG_OPTS="$CONFIG_OPTS --with-text-file=%{default_text}"
265CONFIG_OPTS="$CONFIG_OPTS --with-x-app-defaults=%{_datadir}/X11/app-defaults"
266CONFIG_OPTS="$CONFIG_OPTS --disable-root-passwd"
267CONFIG_OPTS="$CONFIG_OPTS --with-browser=xdg-open"
268
269# This is flaky:
270# CONFIG_OPTS="$CONFIG_OPTS --with-login-manager"
271
272ln -s ../configure .
273%configure $CONFIG_OPTS
274rm -f configure
275
276%if %{update_po}
277( cd po ; make generate_potfiles_in update-po )
278%endif
279
280make %{?_smp_mflags}
281
282%if %{modular_conf}
283# Make XScreenSavar.ad modular
284CONFD=xscreensaver
285rm -rf $CONFD
286mkdir $CONFD
287
288# preserve the original adfile
289cp -p driver/XScreenSaver.ad $CONFD
290
291# First split XScreenSaver.ad into 3 parts
292cat driver/XScreenSaver.ad | \
293   sed -n -e '1,/\*programs/p' > $CONFD/XScreenSaver.ad.header
294cat driver/XScreenSaver.ad | sed -e '1,/\*programs/d' | \
295   sed -n -e '1,/\\n$/p' > $CONFD/XScreenSaver.ad.hacks
296cat driver/XScreenSaver.ad | sed -e '1,/\\n$/d' > $CONFD/XScreenSaver.ad.tail
297
298# Seperate XScreenSaver.ad.hacks into each hacks
299cd $CONFD
300mkdir hacks.conf.d ; cp -p XScreenSaver.ad.hacks hacks.conf.d/xscreensaver.conf
301cd ..
302
303%endif
304
305%install
306archdir=`./config.guess`
307cd $archdir
308
309rm -rf ${RPM_BUILD_ROOT}
310
311# We have to make sure these directories exist,
312# or nothing will be installed into them.
313#
314mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
315
316make install_prefix=$RPM_BUILD_ROOT INSTALL="install -c -p" install
317
318desktop-file-install --vendor "" --delete-original       \
319   --dir $RPM_BUILD_ROOT%{_datadir}/applications         \
320   --add-only-show-in GNOME                              \
321   --add-category    DesktopSettings                     \
322%if 0
323   --add-category X-Red-Hat-Base                         \
324%else
325   --remove-category Appearance                          \
326   --remove-category AdvancedSettings                    \
327   --remove-category Application                         \
328%endif
329   $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
330
331# This function prints a list of things that get installed.
332# It does this by parsing the output of a dummy run of "make install".
333list_files() {
334   echo "%%defattr(-,root,root,-)"
335   make -s install_prefix=${RPM_BUILD_ROOT} INSTALL=true "$@"  \
336      | sed -n -e 's@.* \(/[^ ]*\)$@\1@p'                      \
337      | sed    -e "s@^${RPM_BUILD_ROOT}@@"                     \
338               -e "s@/[a-z][a-z]*/\.\./@/@"                    \
339      | sed    -e 's@\(.*/man/.*\)@%%doc \1\*@'                      \
340               -e 's@\(.*/pam\.d/\)@%%config(noreplace) \1@'    \
341      | sort  \
342      | uniq
343}
344
345# Generate three lists of files for the three packages.
346#
347dd=%{_builddir}/%{name}-%{version}%{?beta_ver}
348
349# In case rpm -bi --short-circuit is tried multiple times:
350rm -f $dd/*.files
351
352(  cd hacks     ; list_files install ) >  $dd/extras.files
353(  cd hacks/glx ; list_files install ) >  $dd/gl-extras.files
354(  cd driver    ; list_files install ) >  $dd/base.files
355
356# Move %%{_bindir}/xscreensaver-gl-helper to gl-base
357# (bug 336331).
358%if %{modular_conf}
359echo "%%defattr(-,root,root,-)" >> $dd/gl-base.files
360
361sed -i -e '/xscreensaver-gl-helper/d' $dd/gl-extras.files
362pushd $RPM_BUILD_ROOT
363for dir in `find . -name \*xscreensaver-gl-helper\*` ; do
364   echo "${dir#.}" >> $dd/gl-base.files
365done
366popd
367sed -i -e 's|^\(%{_mandir}.*\)$|\1*|' $dd/gl-base.files
368%endif
369
370%if %{modular_conf}
371# install update script
372mkdir -p $RPM_BUILD_ROOT%{_sbindir}
373install -cpm 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sbindir}
374echo "%{_sbindir}/update-xscreensaver-hacks" >> $dd/base.files
375
376# make hack conf modular
377mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/xscreensaver
378mkdir -p $RPM_BUILD_ROOT%{_datadir}/xscreensaver/hacks.conf.d
379cp -p xscreensaver/XScreenSaver.ad* \
380   $RPM_BUILD_ROOT%{_sysconfdir}/xscreensaver
381cp -p xscreensaver/hacks.conf.d/xscreensaver.conf \
382   $RPM_BUILD_ROOT%{_datadir}/xscreensaver/hacks.conf.d/
383
384for adfile in xscreensaver/XScreenSaver.ad.* ; do
385   filen=`basename $adfile`
386   echo "%%config(noreplace) %{_sysconfdir}/xscreensaver/$filen" >> $dd/base.files
387done
388echo -n "%%verify(not size md5 mtime) " >> $dd/base.files
389echo "%{_sysconfdir}/xscreensaver/XScreenSaver.ad" >> \
390   $dd/base.files
391echo "%{_datadir}/xscreensaver/hacks.conf.d/xscreensaver.conf" \
392   >> $dd/base.files
393
394# check symlink
395rm -f $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults/XScreenSaver
396
397pushd $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults
398pushd ../../../..
399if [ ! $(pwd) == $RPM_BUILD_ROOT ] ; then
400   echo "Possibly symlink broken"
401   exit 1
402fi
403popd
404popd
405
406ln -sf ../../../..%{_sysconfdir}/xscreensaver/XScreenSaver.ad \
407   $RPM_BUILD_ROOT%{_datadir}/X11/app-defaults/XScreenSaver
408
409%endif
410
411# add documents
412pushd $dd &> /dev/null
413for f in README* ; do
414   echo "%%doc $f" >> $dd/base.files
415done
416popd
417
418# add directory
419pushd $RPM_BUILD_ROOT
420for dir in `find . -type d | grep xscreensaver` ; do
421   echo "%%dir ${dir#.}" >> $dd/base.files
422done
423popd
424
425%find_lang %{name}
426cat %{name}.lang | uniq >> $dd/base.files
427
428# suppress rpmlint booing
429# sanitize path in script file
430for f in ${RPM_BUILD_ROOT}%{_bindir}/xscreensaver-getimage-* \
431   ${RPM_BUILD_ROOT}%{_libexecdir}/xscreensaver/vidwhacker \
432   ${RPM_BUILD_ROOT}%{_bindir}/xscreensaver-text ; do
433   if [ -f $f ] ; then
434      sed -i -e 's|%{_prefix}//bin|%{_bindir}|g' $f
435   fi
436done
437
438# create desktop entry for gnome-screensaver
439create_desktop(){
440   COMMAND=`cat $1 | sed -n -e 's|^<screen.*name=\"\([^ ][^ ]*\)\".*$|\1|p'`
441   NAME=`cat $1 | sed -n -e 's|^<screen.*_label=\"\(.*\)\">.*$|\1|p'`
442   ARG=`cat $1 | sed -n -e 's|^.*<command arg=\"\([^ ][^ ]*\)\".*$|\1|p'`
443   ARG=`echo $ARG`
444   COMMENT="`cat $1 | sed -e '1,/_description/d' | \
445     sed -e '/_description/q' | sed -e '/_description/d'`"
446   COMMENT=`echo $COMMENT`
447
448# webcollage treatment
449   if [ "x$COMMAND" = "xwebcollage" ] ; then
450      ARG="$ARG -directory %{_datadir}/backgrounds/images"
451   fi
452
453   if [ "x$NAME" = "x" ] ; then NAME=$COMMAND ; fi
454
455   rm -f $2
456   echo "[Desktop Entry]" >> $2
457   echo "Encoding=UTF-8" >> $2
458   echo "Name=$NAME" >> $2
459   echo "Comment=$COMMENT" >> $2
460   echo "TryExec=$COMMAND" >> $2
461   echo "Exec=$COMMAND $ARG" >> $2
462   echo "StartupNotify=false" >> $2
463   echo "Type=Application" >> $2
464   echo "Categories=GNOME;Screensaver;" >> $2
465}
466
467cd $dd
468
469SAVERDIR=%{_datadir}/applications/screensavers
470mkdir -p ${RPM_BUILD_ROOT}${SAVERDIR}
471echo "%%dir $SAVERDIR" >> base.files
472
473for list in *extras.files ; do
474
475   glist=gnome-$list
476   rm -f $glist
477
478   echo "%%defattr(-,root,root,-)" > $glist
479##  move the owner of $SAVERDIR to -base
480##   echo "%%dir $SAVERDIR" >> $glist
481
482   set +x
483   for xml in `cat $list | grep xml$` ; do
484      file=${RPM_BUILD_ROOT}${xml}
485      desktop=xscreensaver-`basename $file`
486      desktop=${desktop%.xml}.desktop
487
488      echo + create_desktop $file  ${RPM_BUILD_ROOT}${SAVERDIR}/$desktop
489      create_desktop $file  ${RPM_BUILD_ROOT}${SAVERDIR}/$desktop
490      echo ${SAVERDIR}/$desktop >> $glist
491   done
492   set -x
493done
494
495# Make sure all files are readable by all, and writable only by owner.
496#
497chmod -R a+r,u+w,og-w ${RPM_BUILD_ROOT}
498
499%clean
500rm -rf ${RPM_BUILD_ROOT}
501
502%if %{modular_conf}
503%post base
504%{_sbindir}/update-xscreensaver-hacks
505exit 0
506%endif
507
508%files
509%defattr(-,root,root,-)
510
511%files -f base.files base
512%defattr(-,root,root,-)
513
514%files -f extras.files extras
515%defattr(-,root,root,-)
516
517%if %{modular_conf}
518%files -f gl-base.files gl-base
519%defattr(-,root,root,-)
520%endif
521
522%files -f gl-extras.files gl-extras
523%defattr(-,root,root,-)
524
525%files -f gnome-extras.files extras-gss
526%defattr(-,root,root,-)
527
528%files -f gnome-gl-extras.files gl-extras-gss
529%defattr(-,root,root,-)
530
531%changelog
532* Sun Oct 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.12-1
533- new upstream release
534
535* Sun Jul 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.11-1
536- new upstream release
537- drop Patch3, Patch21, Patch22
538
539* Wed May 21 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.05-1
540- new upstream release
541- remove unneeded patches
542
543* Sat Sep  9 2006 Ryoichi INAGAKI <daisuke@linux.or.jp> 4.18-0vl3
544- rebuilt for Vine Linux 4.0
545- changed Group to User Interface/X
546
547* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.18-0vl2
548- add Patch3 to use htmlview by default
549- add Patch5 to use blank screen by default instead of random screensaver
550- move desktopfile to %{_datadir}/applications/
551
552* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.18-0vl1
553- new upstream release
554
555* Wed Dec 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.14-0vl1
556- new upstream release
557
558* Mon Dec 30 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.06-4vl2
559- update ja.po
560- copy xscreensaver.xpm to /usr/share/pixmaps directory
561
562* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.06-4vl1
563- merged with rawhide release
564- build on gnome2.1.5/gtk2.2
565  * Fri Nov 29 2002 Tim Powers <timp@redhat.com> 1:4.06-4
566  - call autoconf instead of autoconf-2.53
567  * Mon Nov 11 2002 Bill Nottingham <notting@redhat.com> 4.06-3
568  - put glade tweaks back in
569  - switch pam package to not specify directories, to work on multilib
570    arches
571  * Fri Nov  8 2002 Nalin Dahyabhai <nalin@redhat.com> 4.06-1
572  - add a BuildPrereq on bc, which configure requires
573  - replace use of fortune with an innocuous-and-editable stand-in script in
574    %{stand_in_path}
575  - define FORTUNE_PROGRAM at compile-time to force apps to use what's specified
576    even if it doesn't happen to be installed at compile-time
577  * Sun Sep  2 2002 Bill Nottingham <notting@redhat.com> 4.05-6
578  - fix typo (#73246)
579  * Wed Aug 28 2002 Bill Nottingham <notting@redhat.com> 4.05-5
580  - revert to non-gtk unlock dialog
581  - fix translations
582  * Mon Aug 12 2002 Bill Nottingham <notting@redhat.com> 4.05-4
583  - twiddle titlebar (#67844)
584  - fix extraneous text (#70975)
585  - tweak desktop entry (#69502)
586  * Fri Aug 9 2002 Yu Shao <yshao@redhat.com> 4.05-3
587  - use GTK_IM_MODULE=gtk-im-context-simple in lock widget
588  - to avoid CJK IM weirdness (#70655, #68216)
589  - xscreensaver-rh-imcjk.patch
590  * Wed Jul 17 2002 Elliot Lee <sopwith@redhat.com> 4.05-2
591  - Add fortune-mod to buildprereq to make beehive happy
592  - Fix find_lang usage - install translations properly by specifying datadir
593  * Tue Jun 11 2002 Bill Nottingham <notting@redhat.com> 4.05-1
594  - update to 4.05
595  - use gtk2 lock widget (<jacob@ximian.com>)
596  - some Red Hat-ifications
597  - fix critical (#63916)
598  * Mon Jun 10 2002 Bill Nottingham <notting@redhat.com> 4.04-2
599  - remove no longer needed xloadimage dependency
600  * Mon Jun  3 2002 Bill Nottingham <notting@redhat.com> 4.04-1
601  - update to 4.04, gtk2 property dialog is now mainline
602  * Thu May 16 2002 Bill Nottingham <notting@redhat.com> 4.03-1
603  - update to 4.03
604  - use gtk2 properties dialog
605
606* Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.01-2vl5
607- rebuilt with new toolchain
608
609* Sun Mar 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.01-2vl4
610- provides screensaver capplet entry for control-center
611
612* Wed Mar 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.01-2vl2
613- change Requires fortune-mod ( not file-depend )
614
615* Tue Mar 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.01-2vl1
616- merged with rawhide release
617
618* Thu Mar 14 2002 Bill Nottingham <notting@redhat.com> 4.01-2
619- don't show screensavers that aren't available
620
621* Sun Feb 24 2002 Bill Nottingham <notting@redhat.com>
622- update to 4.01
623
624* Mon Feb 11 2002 Bill Nottingham <notting@redhat.com>
625- update to 4.00
626
627* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
628- automated rebuild
629
630* Thu Aug 23 2001 Bill Nottingham <notting@redhat.com>
631- fix segfault on ia64 (#52336)
632
633* Thu Aug  9 2001 Bill Nottingham <notting@redhat.com>
634- never mind, back to 3.33 (wheeee)
635- hack window-id back in for the time being
636- disable memlimit so GL works
637
638* Mon Jul 23 2001 Bill Nottingham <notting@redhat.com>
639- oops, back to 3.32 for now
640- remove optflags override (oops)
641- add pam-devel buildprereq
642
643* Mon Jul 16 2001 Bill Nottingham <notting@redhat.com>
644- update to 3.33, fix broken last build
645- fix build weirdness on some package sets (#48905)
646- don't document non-existent options for forest (#49139)
647
648* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
649- Bump release + rebuild.
650
651* Tue May 22 2001 Havoc Pennington <hp@redhat.com>
652- putting in tree for David
653
654* Tue May 22 2001 David Sainty <dsainty@redhat.com>
655- added DPMS options to command line help
656
657* Sun Apr 22 2001 Bill Nottingham <notting@redhat.com>
658- update to 3.32
659- add patch to specify DPMS settings on the command line
660
661* Wed Apr 11 2001 Bill Nottingham <notting@redhat.com>
662- update to 3.31
663
664* Wed Apr  4 2001 Bill Nottingham <notting@redhat.com>
665- fix extrusion exclusion (#34742)
666
667* Tue Apr  3 2001 Bill Nottingham <notting@redhat.com>
668- disable GL screensavers by default (bleah)
669
670* Mon Feb 19 2001 Bill Nottingham <notting@redhat.com>
671- update to 3.29 (#27437)
672
673* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
674- update to 3.27
675
676* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
677- rebuild because of broken fileutils
678
679* Fri Nov 10 2000 Bill Nottingham <notting@redhat.com>
680- 3.26
681
682* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
683- Up Epoch and release
684
685* Wed Jul 26 2000 Bill Nottingham <notting@redhat.com>
686- hey, vidmode works again
687
688* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
689- update to 3.25
690
691* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
692- automatic rebuild
693
694* Sat Jun 17 2000 Bill Nottingham <notting@redhat.com>
695- xscreensaver.kss is not a %%config file.
696
697* Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
698- tweak kss module (#11872)
699
700* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
701- modify PAM configuration to use system-auth
702
703* Thu May 18 2000 Preston Brown <pbrown@redhat.com>
704- added Red Hat screensaver (waving flag has logo now).
705
706* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
707- tweaks for ia64
708
709* Mon Apr 10 2000 Bill Nottingham <notting@redhat.com>
710- turn off xf86vidmode ext, so that binaries built against XFree86 4.0
711  work on 3.x servers
712
713* Wed Apr  5 2000 Bill Nottingham <notting@redhat.com>
714- turn off gnome support for now
715
716* Mon Apr  3 2000 Bill Nottingham <notting@redhat.com>
717- update to 3.24
718
719* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
720- wmconfig entry gone.
721
722* Mon Jan 31 2000 Bill Nottingham <notting@redhat.com>
723- update to 3.23
724
725* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
726- rebuild to fix GL depdencies
727
728* Tue Dec 14 1999 Bill Nottingham <notting@redhat.com>
729- everyone in GL
730- single package again
731
732* Fri Dec 10 1999 Bill Nottingham <notting@redhat.com>
733- update to 3.22
734- turn off xf86vmode on alpha
735
736* Tue Dec  7 1999 Bill Nottingham <notting@redhat.com>
737- mmm... hardware accelerated GL on i386. :) :)
738
739* Mon Nov 22 1999 Bill Nottingham <notting@redhat.com>
740- 3.21
741- use shm on alpha, let's see what breaks
742
743* Tue Nov 16 1999 Bill Nottingham <notting@redhat.com>
744- update to 3.20
745
746* Wed Nov  3 1999 Bill Nottingham <notting@redhat.com>
747- update to 3.19
748
749* Thu Oct 14 1999 Bill Nottingham <notting@redhat.com>
750- update to 3.18
751
752* Sat Sep 25 1999 Bill Nottingham <notting@redhat.com>
753- add a '-oneshot' single time lock option.
754
755* Mon Sep 20 1999 Bill Nottingham <notting@redhat.com>
756- take webcollage out of random list (for people who pay for bandwidth)
757
758* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
759- patch webcollage to use xloadimage
760- in the random list, run petri with -size 2 to save memory
761- extend RPM silliness to man pages, too.
762
763* Mon Jul 19 1999 Bill Nottingham <notting@redhat.com>
764- update to 3.17
765- add a little RPM silliness to package GL stuff if it's built
766
767* Thu Jun 24 1999 Bill Nottingham <notting@redhat.com>
768- update to 3.16
769
770* Mon May 10 1999 Bill Nottingham <notting@redhat.com>
771- update to 3.12
772
773* Tue May  4 1999 Bill Nottingham <notting@redhat.com>
774- remove security problem introduced earlier
775
776* Wed Apr 28 1999 Bill Nottingham <notting@redhat.com>
777- update to 3.10
778
779* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
780- kill setuid the Right Way(tm)
781
782* Mon Apr 12 1999 Bill Nottingham <notting@redhat.com>
783- fix xflame on alpha
784
785* Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
786- upgrade to 3.09, fixes vmware interaction problems.
787
788* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
789- remove setuid bit. Really. I mean it.
790
791* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
792- auto rebuild in the new build environment (release 3)
793
794* Fri Mar 19 1999 Bill Nottingham <notting@redhat.com>
795- kill setuid, since pam works OK
796
797* Tue Mar 16 1999 Bill Nottingham <notting@redhat.com>
798- update to 3.08
799
800* Wed Feb 24 1999 Bill Nottingham <notting@redhat.com>
801- wmconfig returns, and no one is safe...
802
803* Tue Feb 23 1999 Bill Nottingham <notting@redhat.com>
804- remove bsod from random list because it's confusing people???? *sigh*
805
806* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
807- call libtoolize to get it to compile cleanely on the arm
808
809* Tue Jan  5 1999 Bill Nottingham <notting@redhat.com>
810- update to 3.07
811
812* Mon Nov 23 1998 Bill Nottingham <notting@redhat.com>
813- update to 3.06
814
815* Tue Nov 17 1998 Bill Nottingham <notting@redhat.com>
816- update to 3.04
817
818* Thu Nov 12 1998 Bill Nottingham <notting@redhat.com>
819- update to 3.02
820- PAMify
821
822* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
823- take out Noseguy module b/c of possible TMv
824- install modules in /usr/X11R6/lib/xscreensaver
825- don't compile support for xshm on the alpha
826- properly buildrooted
827- updated to version 2.34
828
829* Fri Aug  7 1998 Bill Nottingham <notting@redhat.com>
830- update to 2.27
831
832* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
833- translations modified for de
834
835* Mon Jun 08 1998 Erik Troan <ewt@redhat.com>
836- added fix for argv0 buffer overflow
837
838* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
839- translations modified for de, fr, tr
840
841* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
842- updated from 2.10 to 2.16
843- added buildroot
844
845* Wed Oct 25 1997 Marc Ewing <marc@redhat.com>
846- wmconfig
847
848* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
849- new version, configure
850
851* Fri Aug 22 1997 Erik Troan <ewt@redhat.com>
852- built against glibc
853
Note: See TracBrowser for help on using the repository browser.