source: projects/specs/branches/6/x/xorg-x11-xsm/xorg-x11-xsm-vl.spec @ 3757

Revision 3757, 6.6 KB checked in by Takemikaduchi, 13 years ago (diff)

fix xorg-x11

Line 
1%define pkgname xsm
2
3Summary: X.Org X11 X Session Manager
4Summary(ja): X.Org X11 X セッションマネージャ
5Name: xorg-x11-%{pkgname}
6# NOTE: The Version field should be the version of the xsm tarball.
7Version: 1.0.2
8# Bump the release on rebuilds/bugfixes/etc.
9Release: 4%{?_dist_release}
10License: MIT
11Group: User Interface/X
12URL: http://www.x.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Source0: ftp://ftp.x.org/pub/individual/app/xsm-1.0.2.tar.bz2
16Source1: ftp://ftp.x.org/pub/individual/app/smproxy-1.0.4.tar.bz2
17Source2: ftp://ftp.x.org/pub/individual/app/rstart-1.0.4.tar.bz2
18
19# Patches for xsm (10-19)
20Patch10: xsm-1.0.2-xsm-installation-location-fixes.patch
21
22# Patches for smproxy (20-29)
23
24
25# Patches for rstart (30-39)
26Patch30: rstart-1.0.4-rstart-installation-location-fixes.patch
27
28# FIXME: Temporary dependency on automake/autoconf while they're still needed.
29BuildRequires: automake autoconf
30
31BuildRequires: pkgconfig
32BuildRequires: xorg-x11-util-macros
33BuildRequires: xorg-x11-proto-devel
34BuildRequires: libXaw-devel libXext-devel libXt-devel libXpm-devel
35BuildRequires: rsh
36
37# NOTE: xorg-x11-filesystem >= 0.99.2-3 is required for OS upgrades from
38# monolithic X releases to modular X releases to work properly.
39Requires(pre): xorg-x11-filesystem
40# rstart script invokes xauth, rsh
41Requires: xauth, rsh
42
43Provides: xsm, smproxy, rstart, rstartd
44
45# NOTE: xsm, smproxy, rstart used to be part of the XFree86/xorg-x11 package
46Obsoletes: XFree86
47
48%description
49X.Org X11 X Session Manager
50
51%prep
52%setup -q -c %{name}-%{version} -a1 -a2
53%patch10 -p0 -b .xsm-installation-location-fixes
54%patch30 -p0 -b .rstart-installation-location-fixes
55
56
57%build
58# Build everything
59{
60   for pkg in xsm smproxy rstart ; do
61      pushd $pkg-*
62
63      sed -i '/XAW_/ s/)/, xaw7)/; /XAW_/ s/XAW_CHECK_XPRINT_SUPPORT/PKG_CHECK_MODULES/' configure.ac
64      aclocal ; automake ; autoconf
65
66      %configure --disable-xprint
67      make
68      popd
69   done
70}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74
75# Install everything
76{
77   for pkg in xsm smproxy rstart ; do
78      pushd $pkg-*
79      make install DESTDIR=$RPM_BUILD_ROOT
80      popd
81   done
82}
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%files
88%defattr(-,root,root,-)
89# FIXME: The rpm package version was accidentally bumped to 1.0.2, so we
90# can't use the %%version macro here until a upstream xsm is released as
91# version 1.0.2 or higher.
92#%doc xsm-%{version}/AUTHORS xsm-%{version}/COPYING xsm-%{version}/INSTALL
93#%doc xsm-%{version}/NEWS xsm-%{version}/README xsm-%{version}/ChangeLog
94%doc xsm-1.0.2/AUTHORS xsm-1.0.2/COPYING xsm-1.0.2/INSTALL
95%doc xsm-1.0.2/NEWS xsm-1.0.2/README xsm-1.0.2/ChangeLog
96
97%{_bindir}/rstart
98%{_bindir}/rstartd
99%{_bindir}/smproxy
100%{_bindir}/xsm
101%dir %{_datadir}/X11
102%dir %{_datadir}/X11/rstart
103%dir %{_datadir}/X11/rstart/commands
104%{_datadir}/X11/rstart/commands/@List
105%{_datadir}/X11/rstart/commands/ListContexts
106%{_datadir}/X11/rstart/commands/ListGenericCommands
107%dir %{_datadir}/X11/rstart/commands/x11r6
108%{_datadir}/X11/rstart/commands/x11r6/@List
109%{_datadir}/X11/rstart/commands/x11r6/LoadMonitor
110%{_datadir}/X11/rstart/commands/x11r6/Terminal
111%dir %{_datadir}/X11/rstart/contexts
112%{_datadir}/X11/rstart/contexts/@List
113%{_datadir}/X11/rstart/contexts/default
114%{_datadir}/X11/rstart/contexts/x
115%{_datadir}/X11/rstart/contexts/x11
116%{_datadir}/X11/rstart/contexts/x11r6
117%{_datadir}/X11/app-defaults/XSm
118%dir %{_libdir}/X11
119%dir %{_libdir}/X11/rstart
120# NOTE: This binary can and probably should sit in /usr/sbin, but oh well.
121%{_libdir}/X11/rstart/rstartd.real
122#%dir %{_mandir}/man1x
123%{_mandir}/man1/rstart.1*
124%{_mandir}/man1/rstartd.1*
125%{_mandir}/man1/smproxy.1*
126%{_mandir}/man1/xsm.1*
127%dir %{_sysconfdir}/X11
128%dir %{_sysconfdir}/X11/rstart
129%config %{_sysconfdir}/X11/rstart/config
130%dir %{_sysconfdir}/X11/xsm
131%config %{_sysconfdir}/X11/xsm/system.xsm
132
133%changelog
134* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-4
135- delete Obsoletes: xorg-x11
136
137* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
138- xsm-1.0.2
139- smproxy-1.0.4
140- rstart-1.0.4
141- update Patch10, Patch30
142- fix %%files
143
144* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
145- smproxy-1.0.3
146- rstart-1.0.3
147
148* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
149- initial build for Vine Linux
150
151* Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.2-8
152- Fix license tag.
153
154* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-7
155- Autorebuild for GCC 4.3
156
157* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-6
158- Rebuild for build id
159
160* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 1.0.2-5
161- Fix man page globs and rebuild for FC7.
162
163* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4.fc6
164- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
165- Add 'dist' tag to package release string.
166
167* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1
168- rebuild
169
170* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
171- Added xsm documentation to doc macro.
172- The 1.0.2-1 build had the version accidentally bumped to 1.0.2 before
173  an xsm-1.0.2 was available, so I had to hard code the actual 1.0.1 version
174  in a few places temporarily until xsm-1.0.2 is available.
175
176* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
177- Fix BuildRequires (#191802)
178
179* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
180- Update smproxy and rstart
181
182* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
183- bump again for double-long bug on ppc(64)
184
185* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
186- rebuilt for new gcc4.1 snapshot and glibc changes
187
188* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
189- Updated all apps to version 1.0.1 from X11R7.0
190
191* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
192- Updated all apps to version 1.0.0 from X11R7 RC4.
193- Changed manpage dir from man1x to man1 to match upstream default.
194
195* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
196- Add "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to avoid bug (#173384).
197- Added rstart-0.99.1-rstart-installation-location-fixes.patch and
198  xsm-0.99.2-xsm-installation-location-fixes.patch to put config files in
199 /etc and data files in /usr/share where they belong.
200- Added "Requires: xauth, rsh" as rstart invokes xauth, rsh.
201
202* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
203- require newer filesystem package (#172610)
204
205* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
206- Added "Obsoletes: XFree86, xorg-x11", as all of these used to be in there.
207- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
208
209* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
210- Initial build of xsm, smproxy, and rstart from X11R7 RC1
Note: See TracBrowser for help on using the repository browser.