source: projects/specs/branches/6/x/xorg-x11-xdm/xorg-x11-xdm-vl.spec @ 2203

Revision 2203, 10.7 KB checked in by Takemikaduchi, 13 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1%define pkgname xdm
2
3Summary: X.Org X11 xdm - X Display Manager
4Summary(ja): X.Org X11 xdm - X ディスプレイマネージャ
5Name: xorg-x11-%{pkgname}
6Version: 1.1.10
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0: ftp://ftp.x.org/pub/individual/app/xdm-%{version}.tar.bz2
14Source1: Xsetup_0
15Source10: xdm.init
16Source11: xdm.pamd
17Source13: xserver.pamd
18
19# NOTE: Change xdm-config to invoke Xwilling with "-s /bin/bash" instead
20# of "-c" to fix bug (#86505)
21Patch10: xdm-1.0.1-redhat-xdm-config-fix.patch
22Patch11: xdm-1.0.5-sessreg-utmp-fix-bug177890.patch
23
24# FIXME: Temporary build dependencies for autotool dependence.
25BuildRequires: autoconf, automake, libtool
26
27BuildRequires: pkgconfig
28BuildRequires: xorg-x11-util-macros
29BuildRequires: xorg-x11-xtrans-devel
30BuildRequires: libXaw-devel
31BuildRequires: libXmu-devel
32BuildRequires: libXt-devel
33BuildRequires: libSM-devel
34BuildRequires: libICE-devel
35BuildRequires: libXext-devel
36BuildRequires: libXpm-devel
37BuildRequires: libX11-devel
38BuildRequires: libXdmcp-devel
39BuildRequires: libXau-devel
40BuildRequires: libXinerama-devel
41BuildRequires: pam-devel
42
43Provides: xdm
44
45Obsoletes: XFree86-xdm, XOrg-xdm
46Obsoletes: xinitrc
47
48# NOTE: xorg-x11-filesystem is required by all packages that put files into
49# /usr/lib/X11 or /usr/include/X11 to ensure that on OS upgrades, they are
50# real directories, and not symbolic links.
51Requires(pre): xorg-x11-filesystem
52
53Requires: pam
54
55# We want to use the system Xsession script
56Requires: xorg-x11-xinit
57
58%description
59X.Org X11 xdm - X Display Manager
60
61%description -l ja
62X.Org X11 xdm - X ディスプレイマネージャ
63
64%prep
65%setup -q -n %{pkgname}-%{version}
66
67%patch10 -p0 -b .redhat-xdm-config-fix
68%patch11 -p0 -b .sessreg-utmp-fix-bug177890
69
70%build
71# FIXME: Work around pointer aliasing warnings from compiler for now
72export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
73# NOTE: We invoke aclocal/automake/autoconf to enable the changes present in
74# xdm-0.99.3-xdm-app-defaults-in-datadir.patch & xdm-0.99.3-xdm-configdir.patch
75#aclocal
76#libtoolize --force
77#automake
78#autoconf
79autoreconf -if
80%configure \
81        --disable-static \
82        --disable-xprint \
83        --with-xdmconfigdir=%{_sysconfdir}/X11/xdm \
84        --with-xdmscriptdir=%{_sysconfdir}/X11/xdm \
85        --with-pixmapdir=%{_datadir}/xdm/pixmaps
86
87make %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91make install DESTDIR=$RPM_BUILD_ROOT
92
93# FIXME: Remove all libtool archives (*.la) from modules directory.  This
94# should be fixed in upstream Makefile.am or whatever.
95find $RPM_BUILD_ROOT -name '*.la' | xargs rm -f --
96
97install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm/Xsetup_0
98
99# Install pam xdm config files
100{
101   mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
102   install -c -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/xserver
103   install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/xdm
104}
105
106rm -f $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm/Xsession
107(cd $RPM_BUILD_ROOT%{_sysconfdir}/X11/xdm; ln -sf ../xinit/Xsession .)
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files
113%defattr(-,root,root,-)
114%doc AUTHORS COPYING INSTALL NEWS README ChangeLog
115%{_bindir}/xdm
116%{_bindir}/xdmshell
117%dir %{_sysconfdir}/X11/xdm
118# NOTE: The Xaccess file from our "xinitrc" package had no customizations,
119# and was out of sync with upstream, so we ship the upstream one now.
120%{_sysconfdir}/X11/xdm/Xaccess
121%{_sysconfdir}/X11/xdm/Xresources
122%{_sysconfdir}/X11/xdm/Xservers
123%{_sysconfdir}/X11/xdm/xdm-config
124# NOTE: In Fedora Core 4 and earlier, most of these config files and scripts
125# were kept in the "xinitrc" package as forked copies, however they were
126# quite out of date, and did not contain anything useful, so we now ship the
127# upstream files and can patch them as needed to make changes.
128%{_sysconfdir}/X11/xdm/GiveConsole
129%{_sysconfdir}/X11/xdm/TakeConsole
130%{_sysconfdir}/X11/xdm/Xreset
131%{_sysconfdir}/X11/xdm/Xsession
132%{_sysconfdir}/X11/xdm/Xsetup_0
133%{_sysconfdir}/X11/xdm/Xstartup
134%{_sysconfdir}/X11/xdm/Xwilling
135# NOTE: For security, upgrades of this package will install the new pam.d
136# files and make backup copies by default.  'noreplace' is intentionally avoided
137# here.
138%config %attr(0644,root,root) %{_sysconfdir}/pam.d/xdm
139%config %attr(0644,root,root) %{_sysconfdir}/pam.d/xserver
140%dir %{_datadir}/X11
141# NOTE: We intentionally default to OS supplied file being favoured here on
142# OS upgrades.
143%config %{_datadir}/X11/app-defaults/Chooser
144%dir %{_datadir}/xdm
145%dir %{_datadir}/xdm/pixmaps
146%{_datadir}/xdm/pixmaps/xorg-bw.xpm
147%{_datadir}/xdm/pixmaps/xorg.xpm
148%dir %{_libdir}/X11/xdm
149%{_libdir}/X11/xdm/chooser
150%{_libdir}/X11/xdm/libXdmGreet.so
151%{_mandir}/man1/*.1*
152
153%changelog
154* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.10-1
155- new upstream release
156
157* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.9-1
158- new upstream release
159
160* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.8-1
161- new upstream release
162
163* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
164- initial build for Vine Linux
165
166* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.1.6-3
167- Autorebuild for GCC 4.3
168
169* Fri Aug 24 2007 Ray Strode <rstrode@redhat.com> 1:1.1.6-2
170- Use system Xsession script (bug 244264)
171
172* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 1:1.1.6-1
173- Update to 1.1.6
174
175* Sat Aug 11 2007 Dave Airlie <airlied@redhat.com> 1:1.1.5-1
176- Update to 1.1.5
177
178* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:1.1.3-1
179- Update to 1.1.3
180
181* Mon Jul 24 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-5.fc6
182- Added xdm-1.0.5-sessreg-utmp-fix-bug177890.patch to restore GiveConsole to
183  what we shipped in 6.8.2, and also fix bug (#177890)
184
185* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-4.fc6
186- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
187
188* Mon Jul 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-3.fc6
189- Added pam_keyinit.so support to xdm.pamd and xserver.pamd (#198631)
190- Flag pam.d{xdm,xserver} as attr(0644,root,root) replaceable config files.
191- Flag app-defaults/Chooser as a replaceable config file.
192- Add conditional {dist} flag to Release field.
193
194* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.5-2
195- rebuild
196
197* Wed Jun 28 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.5-1
198- Updated xdm to version 1.0.5.
199- Remove xdm-1.0.4-setuid.diff as it is integrated in 1.0.5
200
201* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.4-4
202- Add missing documentation to doc macro.
203- Clean cruft out of specfile.
204
205* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.4-3
206- Added xdm-1.0.4-setuid.diff to fix potential security issue (#196094)
207- Added temporary "BuildRequires: autoconf, automake, libtool" dependencies
208  for mock builds, for as long as we need to run autotools at compile time.
209
210* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.4-2
211- Fix BuildRequires (#191858)
212
213* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.4-1
214- Updated to version 1.0.4
215
216* Fri Mar 31 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.3-1
217- Updated to version 1.0.3.  Forcibly relibtoolize to avoid present and future
218  bogons on libXdmGreet.so losing the .so extension.
219
220* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
221- bump again for double-long bug on ppc(64)
222
223* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
224- rebuilt for new gcc4.1 snapshot and glibc changes
225
226* Mon Jan 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
227- Updated xdm to version 1.0.1 from X11R7.
228- Added --with-xdmscriptdir option to ./configure to put scripts in /etc
229- Updated xdm-1.0.1-redhat-xdm-config-fix.patch to work with xdm 1.0.1
230
231* Thu Nov 24 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-6
232- Updated xdm.pamd to work with recent pam changes, and bumped the minimum
233  pam requirement up to 0.78-0 for FC5 builds. (#170661)
234- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3", as the xdm package
235  puts files into /usr/lib/X11, so we have to make sure it is not a symlink.
236- Removed "filesystem" package dependency, as xorg-x11-filesystem carries
237  that dependency now, so it can be updated in one spot.
238- Added missing "BuildRequires: pkgconfig".
239- Added xdm-0.99.3-xdm-app-defaults-in-datadir.patch to force app-defaults
240  files to install into _datadir instead of _libdir.
241- Added xdm-0.99.3-xdm-scripts-in-configdir.patch to put the xdm scripts in
242  _sysconfdir, and removed older xdm-0.99.3-xdm-configdir.patch which hacked
243  up Makefile.in.  Fixes a typo that caused Xreset to not get installed
244  properly also.
245
246* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.3-5
247- require newer filesystem package (#172610)
248
249* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.3-4
250- install scripts into /etc/X11/xdm instead of %%{_libdir} (#173081)
251- use our Xsetup_0 instead of xorg one (#173083)
252
253* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-3
254- Added "Obsoletes: xinitrc", as xdm now provides files that were previously
255  part of that package.  xorg-x11-xinit now provides the xinitrc scripts.
256
257* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-2
258- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME.
259- Added xdm-0.99.3-redhat-xdm-config-fix.patch which merges in an
260  xdm-config fix present in the forked Red Hat xdm-config from the FC4
261  xinitrc package, which invokes Xwilling with "-s /bin/bash" instead
262  of "-c" to fix bug (#86505).
263- Removed ancient xdm rpm preinstall script, as it should be unnecessary now.
264
265* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.3-1
266- Update xdm to 0.99.3 from X11R7 RC2.
267
268* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.3
269- Build with -fno-strict-aliasing to work around possible pointer aliasing
270  issues
271
272* Tue Nov 01 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.2
273- It is _sysconfdir not _sysconfigdir goofball!
274- Add {_sysconfdir}/pam.d/xdm and {_sysconfdir}/pam.d/xserver files that were
275  missing from file manifest.
276
277* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.1
278- Make sure all dirs are owned that xdm creates.
279- Misc spec file cleanups
280
281* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1.20051031.0
282- Update xdm to 0.99.2 from X11R7 RC1.
283- Update to CVS snapshot from 20051031
284- Add Epoch 1, and change package to use the xdm version number.  Later, if
285  we decide to rename the package to "xdm", we can drop the Epoch tag.
286- Disable Xprint support
287- Use _smp_mflags
288- Add xdm-0.99.2-to-20051031.patch to pick up fixes from CVS head that allow
289  us to set the config dir and other dirs.
290
291* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
292- Use Fedora-Extras style BuildRoot tag
293- Update BuildRequires to use new library package names
294
295* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
296- Initial build.
Note: See TracBrowser for help on using the repository browser.