source: projects/specs/branches/6/x/xorg-x11-utils/xorg-x11-utils-vl.spec @ 2357

Revision 2357, 6.0 KB checked in by Takemikaduchi, 13 years ago (diff)

update xorg packages

Line 
1%define pkgname utils
2
3Summary: X.Org X11 X client utilities
4Summary(ja): X.Org X11 X クライアントユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.5
7Release: 4%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0:  ftp://ftp.x.org/pub/individual/app/xdpyinfo-1.2.0.tar.bz2
14Source1:  ftp://ftp.x.org/pub/individual/app/xdriinfo-1.0.4.tar.bz2
15Source2:  ftp://ftp.x.org/pub/individual/app/xev-1.1.0.tar.bz2
16Source3:  ftp://ftp.x.org/pub/individual/app/xfd-1.1.0.tar.bz2
17Source4:  ftp://ftp.x.org/pub/individual/app/xfontsel-1.0.3.tar.bz2
18Source5:  ftp://ftp.x.org/pub/individual/app/xlsatoms-1.1.0.tar.bz2
19Source6:  ftp://ftp.x.org/pub/individual/app/xlsclients-1.1.1.tar.bz2
20Source7:  ftp://ftp.x.org/pub/individual/app/xlsfonts-1.0.3.tar.bz2
21Source8:  ftp://ftp.x.org/pub/individual/app/xprop-1.2.0.tar.bz2
22Source9:  ftp://ftp.x.org/pub/individual/app/xvinfo-1.1.1.tar.bz2
23Source10: ftp://ftp.x.org/pub/individual/app/xwininfo-1.1.1.tar.bz2
24
25Source100: edid-decode-20100205.tar.xz
26Source101: make-edid-decode-snapshot.sh
27
28BuildRequires: pkgconfig
29BuildRequires: libdmx-devel
30BuildRequires: libGL-devel
31BuildRequires: libXaw-devel >= 1.0.5
32BuildRequires: libXext-devel
33BuildRequires: libXft-devel
34BuildRequires: libXi-devel
35BuildRequires: libXinerama-devel
36BuildRequires: libXpm-devel
37BuildRequires: libXt-devel
38BuildRequires: libXtst-devel
39BuildRequires: libXv-devel
40BuildRequires: libXxf86dga-devel
41BuildRequires: libXxf86misc-devel
42BuildRequires: libXxf86vm-devel
43
44BuildRequires: xcb-util-devel
45BuildRequires: xz
46
47# FIXME: check if still needed for X11R7
48Requires(pre): filesystem
49
50Provides: xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo
51
52%description
53A collection of client utilities which can be used to query the X server
54for various information, view and select fonts, etc.
55
56%prep
57%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a100
58
59%build
60# Build all apps
61{
62   for app in * ; do
63      pushd $app
64      if [ -e ./configure ]; then
65        %configure
66      fi
67      make
68      popd
69   done
70}
71
72%install
73rm -rf $RPM_BUILD_ROOT
74# Install all apps
75{
76   for app in * ; do
77      pushd $app
78      make install DESTDIR=$RPM_BUILD_ROOT
79      popd
80   done
81}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%files
87%defattr(-,root,root,-)
88%doc
89%{_bindir}/edid-decode
90%{_bindir}/xdpyinfo
91%{_bindir}/xdriinfo
92%{_bindir}/xev
93%{_bindir}/xfd
94%{_bindir}/xfontsel
95%{_bindir}/xlsatoms
96%{_bindir}/xlsclients
97%{_bindir}/xlsfonts
98%{_bindir}/xprop
99%{_bindir}/xvinfo
100%{_bindir}/xwininfo
101%dir %{_datadir}/X11
102%{_datadir}/X11/app-defaults/XFontSel
103%{_datadir}/X11/app-defaults/Xfd
104%{_mandir}/man1/xdpyinfo.1*
105%{_mandir}/man1/xdriinfo.1*
106%{_mandir}/man1/xev.1*
107%{_mandir}/man1/xfd.1*
108%{_mandir}/man1/xfontsel.1*
109%{_mandir}/man1/xlsatoms.1*
110%{_mandir}/man1/xlsclients.1*
111%{_mandir}/man1/xlsfonts.1*
112%{_mandir}/man1/xprop.1*
113%{_mandir}/man1/xvinfo.1*
114%{_mandir}/man1/xwininfo.1*
115
116%changelog
117* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
118- xdpyinfo-1.2.0
119- xdriinfo-1.0.4
120
121* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
122- xev-1.1.0
123- xfd-1.1.0
124- xprop-1.2.0
125- xwininfo-1.1.1
126- xfontsel-1.0.3
127- xlsatoms-1.1.0
128- xlsclients-1.1.1
129- xlsfonts-1.0.3
130- xvinfo-1.1.1
131- add BuildRequires: xcb-utils-devel, xz
132
133* Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-2
134- add edid-decode snapshot
135
136* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
137- xdpyinfo-1.1.0
138- xdriinfo-1.0.3
139- xev-1.0.4
140- xlsatoms-1.0.2
141- xlsclient-1.0.2
142- xprop-1.1.0
143- xvinfo-1.1.0
144- xwininfo-1.0.5
145
146* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
147- rebuild with libXaw.so.7 (libXaw-1.0.5)
148
149* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
150- xdpyinfo 1.0.3
151- xev 1.0.3
152- xprop 1.0.4
153- xwininfo 1.0.4
154
155* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
156- initial build for Vine Linux
157
158* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.3-2
159- Autorebuild for GCC 4.3
160
161* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
162- xdriinfo 1.0.2
163- xwininfo 1.0.3
164- Bump to 7.3
165
166* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 7.2-1
167- xfontsel 1.0.2, xlsfonts 1.0.2, xvinfo 1.0.2, xprop 1.0.3
168
169* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 7.1-4
170- xdpyinfo 1.0.2
171
172* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-3
173- Fix man page glob and rebuild for FC7.
174
175* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
176- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
177- Add 'dist' tag to package release string.
178
179* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
180- rebuild
181
182* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
183- Bump package version to 7.1 to reflect the X11 release the utilities
184  are aggregated from.
185- Updated to xdriinfo-1.0.1, xev-1.0.2, xwininfo-1.0.2 from X11R7.1
186
187* Wed May 31 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
188- Fix BuildRequires (#191966)
189
190* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
191- Remove a spurious Xprint dependency from xdpyinfo.
192
193* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
194- bump again for double-long bug on ppc(64)
195
196* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
197- rebuilt for new gcc4.1 snapshot and glibc changes
198
199* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
200- Updated all tarballs to versions from X11R7.0
201
202* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
203- Updated all tarballs to version 1.0.0 from X11R7 RC4.
204- Changed manpage dir from man1x to man1 to match upstream RC4 default.
205- Moved all app-defaults files from _libdir to _datadir
206
207* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
208- require newer filesystem package (#172610)
209
210* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-2
211- rebuild
212
213* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
214- Initial build, with all apps taken from X11R7 RC2
215- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
216  some packages.
Note: See TracBrowser for help on using the repository browser.