source: projects/specs/branches/6/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 3757

Revision 3757, 10.8 KB checked in by Takemikaduchi, 13 years ago (diff)

fix xorg-x11

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 3%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.4.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.4.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.0.6.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.3.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.4.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.4.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.5.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.3.4.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.0.9.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.4.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.2.1.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.1.0.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.2.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.2.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62BuildRequires: libXcursor-devel
63# ENDNOTE
64
65# xrdb requires the C preprocessor to work properly
66Requires: cpp
67
68Requires: libXrandr
69
70Provides: iceauth rgb sessreg xcmsdb xgamma xhost
71Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
72Provides: xsetroot xstdcmap xvidtune
73
74# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
75# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
76# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
77# them to ensure upgrades work.
78Obsoletes: XFree86
79
80%description
81A collection of utilities used to tweak and query the runtime configuration
82of the X server.
83
84%prep
85%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
86
87## %patch1100 -p0 -b .datadir-rgbpath-fix
88## %patch1700 -p1 -b .buffer-stomp
89## %patch1710 -p1 -b .xaw7
90
91
92%build
93
94# Build all apps
95{
96   for app in * ; do
97      pushd $app
98      case $app in
99         rgb-*)
100            # FIXME: run autotools junk to kick in our patch
101            aclocal --force
102            automake -f
103            autoconf
104            %configure ;# --with-rgb-db=%{_datadir}/X11
105            ;;
106         xset-*)
107            # FIXME: run autotools junk to kick in our patch
108            aclocal --force
109            automake -f
110            autoconf
111            %configure
112            ;;
113         xvidtune-*)
114            # FIXME: run autotools junk to kick in our patch
115            aclocal --force
116            automake -f
117            autoconf
118            %configure
119            ;;
120         *)
121            %configure
122            ;;
123      esac
124
125      make
126      popd
127   done
128}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132# Install all apps
133{
134   for app in * ; do
135      pushd $app
136      case $app in
137         *)
138            make install DESTDIR=$RPM_BUILD_ROOT
139            ;;
140      esac
141      popd
142   done
143}
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%files
149%defattr(-,root,root,-)
150%doc
151%{_bindir}/iceauth
152%{_bindir}/sessreg
153%{_bindir}/showrgb
154%{_bindir}/xcmsdb
155%{_bindir}/xgamma
156%{_bindir}/xhost
157%{_bindir}/xkeystone
158%{_bindir}/xmodmap
159%{_bindir}/xrandr
160%{_bindir}/xrdb
161%{_bindir}/xrefresh
162%{_bindir}/xset
163%{_bindir}/xsetmode
164%{_bindir}/xsetpointer
165%{_bindir}/xsetroot
166%{_bindir}/xstdcmap
167%{_bindir}/xvidtune
168%dir %{_datadir}/X11
169%{_datadir}/X11/rgb.txt
170%{_datadir}/X11/app-defaults/Xvidtune
171%{_mandir}/man1/iceauth.1*
172%{_mandir}/man1/sessreg.1*
173%{_mandir}/man1/showrgb.1*
174%{_mandir}/man1/xcmsdb.1*
175%{_mandir}/man1/xgamma.1*
176%{_mandir}/man1/xhost.1*
177%{_mandir}/man1/xmodmap.1*
178%{_mandir}/man1/xrandr.1*
179%{_mandir}/man1/xrdb.1*
180%{_mandir}/man1/xrefresh.1*
181%{_mandir}/man1/xset.1*
182%{_mandir}/man1/xsetmode.1*
183%{_mandir}/man1/xsetpointer.1*
184%{_mandir}/man1/xsetroot.1*
185%{_mandir}/man1/xstdcmap.1*
186%{_mandir}/man1/xvidtune.1*
187
188%changelog
189* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
190- delete Obsoletes: xorg-x11
191
192* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
193- xrdb-1.0.9
194  (including security fix for CVE-2011-0465)
195
196* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
197- xrdb-1.0.8
198
199* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
200- xgamma-1.0.4
201- xrdb-1.0.7
202- xrefresh-1.0.4
203- xset-1.2.1
204
205* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
206- iceauth-1.0.4
207- rgb-1.0.4
208- sessreg-1.0.6
209- xcmsdb-1.0.3
210- xhost-1.0.4
211- xmodmap-1.0.5
212- xrandr-1.3.4
213- xset-1.2.0
214- xsetroot-1.1.0
215- xstdcmap-1.0.2
216- xvidtune-1.0.2
217- drop Patch1100,1700,1710
218- add BuildRequires: libXcursor-devel
219- fix %%files
220
221* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
222- iceauth-1.0.3
223- sessreg-1.0.5
224- xcmsdb-1.0.2
225- xgamma-1.0.3
226- xhost-1.0.3
227- xmodmap-1.0.4
228- xrandr-1.3.2
229- xrdb-1.0.6
230- xrefresh-1.0.3
231- xset-1.1.0
232- xsetroot-1.0.3
233- drop xtrap (deprecated upstream)
234
235* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
236- xrandr-1.3.0
237
238* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
239- xrandr-1.2.99.4
240
241* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
242- rebuild with libXaw.so.7 (libXaw-1.0.5)
243
244* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
245- rgb 1.0.3
246- sessreg 1.0.4
247- xhost 1.0.2
248- xrandr 1.2.3
249- xrdb 1.0.5
250- xset 1.0.4
251- xsetpointer 1.0.1
252
253* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
254- new versioning policy
255
256* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
257- initial build for Vine Linux
258
259* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
260- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
261- xrandr-1.2.2-verify-crtc-against-prev-config.patch
262- Patches from upstream to fix some bug in xrandr app
263
264* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
265- sessreg 1.0.3
266- xgamma 1.0.2
267- xmodmap 1.0.3
268- xrdb 1.0.4
269- xset 1.0.3
270- xsetroot 1.0.2
271- Bump to 7.3
272
273* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
274- Rebuild for ppc toolchain bug
275
276* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
277- rebuild for toolchain bug
278
279* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
280- iceauth 1.0.2
281
282* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
283- xrandr 1.2.2
284
285* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
286- xrandr 1.2.1
287
288* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
289- Superstition bump to 7.2
290- xrandr 1.2.0
291
292* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
293- Fix man page globs and rebuild for FC7.
294
295* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
296- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
297
298* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
299- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
300- Add 'dist' tag to package release string.
301
302* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
303- rebuild
304
305- Update to rgb-1.0.2 from X11R7.1
306
307* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
308- Bump the package version to 7.1 to have it match the X11 release that the
309  tarballs came from going forward.
310- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
311- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
312
313* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
314- Clean up Source lines in spec file, and other minor cleanups.
315
316* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
317- Added a whackload of BuildRequires for bug (#191987)
318
319* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
320- Updated xmodmap, xrandr, xrdb, and xset.
321
322* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
323- Eliminate a spurious Xprint dependency from xset.
324
325* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
326- Drop lbxproxy, LBX is deprecated upstream
327- Update to xhost 1.0.1
328
329* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
330- bump again for double-long bug on ppc(64)
331
332* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
333- rebuilt for new gcc4.1 snapshot and glibc changes
334
335* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
336- Updated all packages to the versions from X11R7.0
337
338* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
339- Updated all packages to version 1.0.0 from X11R7 RC4
340- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
341- Updated lbxproxy-datadir-AtomControl-fix.patch
342- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
343- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
344
345* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
346- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
347
348* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
349- Bump "filesystem" Requires(pre) to 2.3.7-1.
350
351* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
352- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
353  independent data files from libdir to datadir.
354- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
355  data files from libdir to datadir.
356- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
357  into datadir.
358
359* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
360- require newer filesystem package (#172610)
361
362* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
363- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
364- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
365
366* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
367- Initial build, with all apps taken from X11R7 RC2
368- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
369  some packages.
Note: See TracBrowser for help on using the repository browser.