source: projects/specs/branches/6/x/xorg-x11-font-utils/xorg-x11-font-utils-vl.spec @ 2357

Revision 2357, 10.0 KB checked in by Takemikaduchi, 13 years ago (diff)

update xorg packages

Line 
1%define pkgname font-utils
2
3Summary: X.Org X11 font utilities
4Summary(ja): X.Org X11 font ユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.5
7Release: 4%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.0.3.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.4.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.6.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.0.8.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.2.0.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20# xorg-x11-libXfont-devel needed for bdftopcf
21BuildRequires: libXfont-devel
22# xorg-x11-libX11-devel needed for fonttosfnt
23BuildRequires: libX11-devel
24# xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
25BuildRequires: libfontenc-devel >= 0.99.2-2
26# freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
27BuildRequires: freetype2-devel
28# zlib-devel needed for bdftopcf
29BuildRequires: zlib-devel
30# xorg-x11-proto-devel is needed for mkfontscale, which includes headers
31# from it directly.
32BuildRequires: xorg-x11-proto-devel
33BuildRequires: autoconf
34
35Requires(pre): xorg-x11-filesystem
36
37# NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
38# bug #173875 is installed in order for mkfontscale/mkfontdir to work
39# properly.  It is a "pre" dep, to ensure libfontenc gets installed before
40# xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
41# set, avoiding a possible race condition.
42Requires(pre): libfontenc
43
44Provides: %{pkgname}
45Provides: XOrg-%{pkgname} = %{version}
46Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
47# NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
48# is needed for upgrades to work properly from OS releases that had XFree86
49Obsoletes: XFree86-font-utils, XOrg-font-utils
50# NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
51# this is needed for upgrades to work.
52Obsoletes: XFree86
53# NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
54# xorg-x11-font-utils in 6.7.99.903-3
55Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
56# NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
57Obsoletes: XOrg-tools <= 6.7.99.903-3
58
59%description
60X.Org X11 font utilities required for font installation, conversion,
61and generation.
62
63%package -n bdftruncate
64Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
65Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
66Group:   Applications/System
67
68%description -n bdftruncate
69bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
70other ISO10646-1 BDF fonts in which all characters above a threshold
71code value are stored unencoded. This is often desirable because the
72Xlib API and X11 protocol data structures used for representing font
73metric information are extremely inefficient when handling sparsely
74populated fonts.
75
76%prep
77%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
78
79%build
80# Build all apps
81{
82   for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
83      pushd $app-*
84      # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
85      case $app in
86         font-util)
87            autoconf
88            ;;
89      esac
90      %configure
91      make
92      popd
93   done
94}
95
96%install
97rm -rf $RPM_BUILD_ROOT
98# Install all apps
99{
100    for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
101        pushd $app-*
102        make install DESTDIR=$RPM_BUILD_ROOT
103        popd
104    done
105    for i in */README ; do
106        [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
107    done
108    for i in */COPYING ; do
109        grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
110    done
111}
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%files
117%defattr(-,root,root,-)
118%doc README-* COPYING-*
119%{_bindir}/bdftopcf
120%{_bindir}/fonttosfnt
121%{_bindir}/mkfontdir
122%{_bindir}/mkfontscale
123%{_bindir}/ucs2any
124# blech.  this one should be in -filesystem
125%dir %{_datadir}/fonts/X11
126%dir %{_datadir}/fonts/X11/util
127%{_datadir}/fonts/X11/util/map-*
128%{_datadir}/aclocal/fontutil.m4
129%{_libdir}/pkgconfig/fontutil.pc
130%{_mandir}/man1/bdftopcf.1*
131%{_mandir}/man1/fonttosfnt.1*
132%{_mandir}/man1/mkfontdir.1*
133%{_mandir}/man1/mkfontscale.1*
134%{_mandir}/man1/ucs2any.1*
135
136%files -n bdftruncate
137%defattr(-,root,root,-)
138%{_bindir}/bdftruncate
139%{_mandir}/man1/bdftruncate.1*
140
141
142%changelog
143* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
144- mkfontdir-1.0.6
145
146* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
147- bdftopcf-1.0.3
148- mkfontscale-1.0.8
149- font-util-1.2.0
150
151* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
152- rebuild with rpm-4.8.1 for pkg-config file
153
154* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
155- bdftopcf-1.0.2
156- mkfontdir-1.0.5
157- mkfontscale-1.0.7
158- font-util-1.1.1
159
160* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
161- mkfontscale 1.0.6
162
163* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
164- fonttosfnt 1.0.4
165- mkfontdir 1.0.4
166- mkfontscale 1.0.5
167
168* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
169- new versioning policy
170
171* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
172- initial build for Vine Linux
173
174* Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
175- Move bdftruncate (and its perl dependency) to a subpackage.
176- %%doc for the non-empty READMEs and non-stub COPYINGs.
177
178* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
179- Rebuild for build id
180
181* Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
182- bdftopcf 1.0.1
183- Superstition bump to 7.2-1
184
185* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
186- mkfontdir 1.0.3
187
188* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
189- fonttosfnt 1.0.3
190
191* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
192- Remove X11R6 symlinks.
193
194* Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
195- Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
196  with new freetype 2.2.
197
198* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
199- rebuild
200
201* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
202- Update to font-util-1.0.1 from X11R7.1
203- Set package version to X11 release the tarballs are based from.
204
205* Thu Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
206- Update mkfontdir
207
208* Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
209- Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
210  itself.  Leftover from the original package template it seems.  (#182439)
211
212* Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
213- Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
214  mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
215  binaries.  This will provide backward compatibilty for Fedora Core 5, however
216  3rd party developers and rpm package maintainers should update to using the
217  new X11R7 locations immediately, as these compatibility links are temporary,
218  and will be removed from a future OS release.
219- Remove system directories from file manifest to appease the banshees.
220
221* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
222- bump again for double-long bug on ppc(64)
223
224* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
225- rebuilt for new gcc4.1 snapshot and glibc changes
226
227* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
228- Updated all utilities to the versions shipped in X11R7.0.
229
230* Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
231- Updated all utilities to version 1.0.0 from X11R7 RC4.
232- Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
233- Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
234  variable "fontdir" to the fontutil.pc file which all of the font packages
235  can autodetect and use instead of having to put manual fontdir overrides
236  in every single rpm package.
237
238* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
239- Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
240  and font-util to version 0.99.2 from X11R7 RC3.
241- Changed manpage dir from man1x back to man1 due to another upstream change.
242- Added fontutil.m4 to file manifest.
243
244* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
245- Changed package version to 0.99.1 to match the upstream font-util tarball
246  version, and added "Epoch: 1" to the package for upgrades.
247- Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
248  mapfiles data to install into datadir instead of libdir (#173943)
249- Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
250  libfontenc to be installed that fixes bug #173453, and to also force it
251  to be installed before xorg-x11-font-utils in a multi-package rpm
252  transaction, which will ensure that when font packages get installed
253  during upgrades via anaconda or yum, that the right libfontenc is being
254  used by mkfontscale/mkfontdir.
255- Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
256  people rebuilding xorg-x11-font-utils, as they'll need to install the new
257  libfontenc now anyway before they can install the font-utils package.
258
259* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
260- require newer filesystem (#172610)
261
262* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
263- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
264  X11R7 RC1.
265
266* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
267- Glob util/map-* files in file manifest.
268- Added missing "Obsoletes: xorg-x11-font-utils".
269- Added "BuildRequires: pkgconfig".
270
271* Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
272- Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
273  ucs2any, bdftruncate.
274
275* Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
276- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
277  X11R7 RC1.
278- Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
279- Updated file manifest to to find the manpages in "man1x".
280
281* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
282- Initial build.
Note: See TracBrowser for help on using the repository browser.