source: projects/specs/branches/6/x/xorg-x11-drv-openchrome/xorg-x11-drv-openchrome-vl.spec @ 7730

Revision 7730, 8.2 KB checked in by Takemikaduchi, 11 years ago (diff)

security fix

Line 
1%define tarball xf86-video-openchrome
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir       %{moduledir}/drivers
4
5%define cvsdate xxxxxxx
6
7%define with_xvmc 1
8
9Summary:        Xorg X11 openchrome video driver
10Summary(ja):    Xorg X11 openchrome ビデオドライバ
11Name:           xorg-x11-drv-openchrome
12Version:        0.2.904
13Release:        8%{?_dist_release}
14URL:            http://www.openchrome.org
15License:        MIT
16Group:          User Interface/X Hardware Support
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18
19Source0:        http://www.openchrome.org/releases/%{tarball}-%{version}.tar.bz2
20Source1:        openchrome.xinf
21
22# Patches from upstream trunk :
23# svn diff -x -p http://svn.openchrome.org/svn/tags/release_0_2_904 http://svn.openchrome.org/svn/trunk
24# revision: r925
25Patch0:         openchrome-0.2.904-latest_trunk.patch
26
27# fix CVE-2013-1994
28Patch1:                 xf86-video-openchrome-0.2.904-CVE-2013-1994.patch
29
30# Patches from Fedora :
31Patch13:        openchrome-0.2.904-fix_tvout_flickering.patch
32Patch20:        openchrome-0.2.904-I420_Xv_surface_for_CME.patch
33
34ExclusiveArch:  %{ix86} x86_64
35
36BuildRequires:  pkgconfig
37BuildRequires:  xorg-x11-server-sdk
38BuildRequires:  automake
39BuildRequires:  libtool
40BuildRequires:  libX11-devel
41BuildRequires:  libXext-devel
42BuildRequires:  mesa-libGL-devel
43%if %{with_xvmc}
44BuildRequires:  libXvMC-devel
45%endif
46BuildRequires:  libdrm-devel >= 2.0-1
47Requires:       xorg-x11-server-Xorg
48
49Obsoletes:  XOrg-drv-via <= 0.2.2-4
50Provides:   xorg-x11-drv-via = 0.2.2-5
51
52%description
53X.Org X11 openchrome video driver.
54
55%if %{with_xvmc}
56%package devel
57Summary:        Xorg X11 openchrome video driver XvMC development package
58Summary(ja):    Xorg X11 openchrome ビデオドライバ XvMC 開発パッケージ
59Group:          Development/System
60Requires:       %{name} = %{version}-%{release}
61Obsoletes:      XOrg-drv-via-devel <= 0.2.2-4
62Provides:       xorg-x11-drv-via-devel = 0.2.2-5
63
64%description devel
65X.Org X11 openchrome video driver XvMC development package.
66%endif
67
68%prep
69%setup -q -n %{tarball}-%{version}
70%patch0 -p0
71%patch1 -p1
72%patch13 -p0
73%patch20 -p1
74
75%build
76%configure --disable-static --enable-dri
77make
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82make install DESTDIR=$RPM_BUILD_ROOT
83
84mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
85install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/openchrome.xinf
86
87# FIXME: Remove all libtool archives (*.la) from modules directory.  This
88# should be fixed in upstream Makefile.am or whatever.
89find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%post
95if [ -e /etc/X11/xorg.conf ]; then
96    sed -i "/Driver/s/via/openchrome/" /etc/X11/xorg.conf || :
97fi
98
99%files
100%defattr(-,root,root,-)
101%doc COPYING NEWS README
102%{driverdir}/openchrome_drv.so
103%{_datadir}/hwdata/videoaliases/openchrome.xinf
104%if %{with_xvmc}
105%{_libdir}/libchromeXvMC.so.1
106%{_libdir}/libchromeXvMC.so.1.0.0
107%{_libdir}/libchromeXvMCPro.so.1
108%{_libdir}/libchromeXvMCPro.so.1.0.0
109%endif
110%{_mandir}/man4/openchrome.4.gz
111
112%if %{with_xvmc}
113%files devel
114%defattr(-,root,root,-)
115%{_libdir}/libchromeXvMC.so
116%{_libdir}/libchromeXvMCPro.so
117%endif
118
119
120%changelog
121* Sat Jun 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-8
122- add Patch1 (xf86-video-openchrome-0.2.904-CVE-2013-1994.patch)
123
124* Thu May 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-7
125- rebuild (missing to replace patch).
126
127* Wed May 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-6
128- update to svn trunk (r925)
129- delete Patch1
130
131* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-5
132- rebuild with xserver-1.10.0
133
134* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-4
135- rebuild with xserver-1.9.2
136
137* Tue Oct 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.904-3
138- update to svn trunk (r854)
139- add patch13,20 from fedora
140
141* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.2.904-2
142- rebuild with xserver-1.8rc
143
144* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.904-1
145- new upstream release
146
147* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.903-2
148- rebuild with X server 1.6.0
149
150* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.903-1
151- new upstream release
152
153* Sat May 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp>  0.2.902-1
154- initial build for Vine Linux
155
156* Thu Apr 17 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-3
157- Strip leading /trunk/ from patch #2 and #3.
158
159* Sun Apr 13 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-2
160- Add patch to properly report driver version in the libpciaccess code path.
161- Add patch to properly report chipset revision in the libpciaccess code path.
162
163* Wed Apr 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.902-1
164- New upstream release.
165- Re-enable AGPDMA for K8M800 and VM800, as the drm bug is fixed in kernel
166  >= 2.6.25rc7 (Patch #1).
167
168* Mon Mar 17 2008 Jesse Keating <jkeating@redhat.com> - 0.2.901-16
169- Remove dangerous unversioned obsoletes/provides.
170
171* Sun Mar 16 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-15
172- Update to latest svn snapshot (Rev. 553).
173
174* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-14
175- Revert to last good version of the libpciaccess patch.
176
177* Sun Mar 09 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-13
178- Temporarily revert to old memory detection method. We need something that
179  works out of the box for F9 Beta.
180
181* Sat Mar 08 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-12
182- Yet another revision of the libpciaccess patch.
183
184* Fri Mar 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-11
185- Fix a typo in libpciaccess patch.
186
187* Fri Mar 07 2008 Adam Jackson <ajax@redhat.com> 0.2.901-10
188- Fix -devel subpackage to obsolete via-devel properly.
189
190* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-9
191- Fix libpciaccess patch.
192
193* Thu Mar 06 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-8
194- Add patch to fix XV on LCD for VM800.
195- Improved libpciaccess patch.
196
197* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.901-7
198- Autorebuild for GCC 4.3
199
200* Wed Jan 23 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-6
201- Add patch to properly set fifo on P4M900.
202
203* Fri Jan 19 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-5
204- Add patch to replace xf86memcpy by plain memcpy.
205
206* Thu Jan 10 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-4
207- Another try at fixing the libpciaccess patch.
208
209* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-3
210- And now fix patch filename...
211
212* Mon Jan 07 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-2
213- Fix broken libpciaccess patch.
214
215* Wed Jan 02 2008 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.901-1
216- Update to 0.2.901.
217- Remove obsoleted patches.
218- Update libpciaccess patch.
219
220* Fri Dec 08 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-9
221- Add patch for preliminary libpciaccess support.
222
223* Wed Nov 28 2007 Adam Jackson <ajax@redhat.com> 0.2.900-8
224- Obsolete xorg-x11-drv-via.  The king is dead, long live the king.
225- Munge xorg.conf in %%post to change from via to openchrome.
226- Drive-by spec cleanups.
227
228* Fri Nov 02 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-7
229- Replace broken VT1625 NTSC patch.
230- Add patch to announce as release not as development build.
231- First official Fedora build.
232
233* Thu Oct 18 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-6
234- Update to official 0.2.900
235
236* Wed Oct 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-5
237- Update to release_0_3_0 branch rev. 410
238- Add VT1625 patch for 720x576 PAL
239
240* Mon Sep 10 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-4
241- Update to release_0_3_0 branch rev. 384 plus all changes from experimental
242  merged back
243- Remove upstream patch #2
244
245* Wed Aug 01 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-3
246- Update to release_0_3_0 branch rev. 380 (fix a bug with XvMC acceleration)
247- Add a patch to allow proper detection of DDR667 (patch #2)
248
249* Mon Jul 16 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-2
250- Update to release_0_3_0 branch rev. 373
251- Add release notes to %%doc
252
253* Thu Jul 05 2007 Xavier Bachelot <xavier AT bachelot DOT org> - 0.2.900-1
254- Initial build (release_0_3_0 branch rev. 365)
255- Add some NTSC modes for the VT1625 (patch #1)
Note: See TracBrowser for help on using the repository browser.