source: projects/specs/branches/6/x/xorg-x11-drv-nouveau/xorg-x11-drv-nouveau-vl.spec @ 2894

Revision 2894, 11.1 KB checked in by Takemikaduchi, 13 years ago (diff)

xorg-x11-drv-nouveau: new upstream release, libdrm: fix %%files

Line 
1%define tarball xf86-video-nouveau
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/drivers
4%define nouveau_version 0.0.16
5
6# Tarfile created using git
7# git clone git://git.freedesktop.org/git/nouveau/xf86-video-nouveau
8# git-archive --format=tar --prefix=xf86-video-nouveau-0.0.10/ %{git_version} | bzip2 > xf86-video-nouveau-0.0.10-%{gitdate}.tar.bz2
9
10%define gitdate 20110117
11%define git_version 38e8809
12
13%define snapshot %{gitdate}git%{git_version}
14
15%define tarfile %{tarball}-%{nouveau_version}-%{snapshot}.tar.bz2
16
17Summary:   Xorg X11 nouveau video driver for NVIDIA graphics chipsets
18Summary(ja): Xorg X11 nouveau ビデオドライバ - NVIDIA グラフィックスチップセット用
19Name:      xorg-x11-drv-nouveau
20Version:   %{nouveau_version}
21Release:   3.%{snapshot}%{?_dist_release}
22URL:       http://www.x.org
23License:   MIT
24Group:     User Interface/X Hardware Support
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26
27# Fedora specific snapshot no upstream release
28Source0:   %{tarfile}
29
30ExcludeArch: s390 s390x
31
32BuildRequires: libtool automake autoconf
33BuildRequires: xorg-x11-server-sdk >= 1.7.0
34BuildRequires: libdrm-devel >= 2.4.24
35BuildRequires: mesa-libGL-devel
36BuildRequires: libudev-devel
37BuildRequires: kernel-headers >= 2.6.32
38
39Requires:  hwdata
40Requires:  xorg-x11-server-Xorg > 1.7.0
41Requires:  libdrm >= 2.4.24
42Requires:  libudev
43
44Patch2: nouveau-nva3-noaccel-info.patch
45
46%description
47X.Org X11 nouveau video driver.
48
49%prep
50%setup -q -n %{tarball}-%{version}
51%patch2 -p1 -b .nva3info
52
53%build
54autoreconf -v --install
55%configure --disable-static
56
57make
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make install DESTDIR=$RPM_BUILD_ROOT
63
64find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%files
70%defattr(-,root,root,-)
71%{driverdir}/nouveau_drv.so
72%{_mandir}/man4/nouveau.4*
73
74%changelog
75* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.16-3.20110117git38e8809
76- update to new git snapshot
77- drop all patches
78- add Patch2: nouveau-nva3-noaccel-info.patch
79- add BuildRequires: libudev-devel
80- add Requires: libudev
81
82* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.16-2.20100218git2964702
83- rebuild with xserver-1.8rc
84
85* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.16-1.20100218git2964702
86- update to new git snapshot
87- BR: libdrm-devel >= 2.4.18
88
89* Wed Dec 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.15-1.20091216git03c7d6
90- initial build for Vine Linux
91- update to new git snapshot
92- BR: libdrm-devel >= 2.4.16
93
94* Thu Nov 05 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-17.20091105gite1c2efd
95- handle reloc failures more gracefully (rh#531058)
96- fix for rh#532322
97
98* Mon Nov 02 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-16.20091030git5587f40
99- force all pixmaps into system memory initally on low memory cards
100
101* Tue Oct 27 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-15.20091022git718a41b
102- misc fixes, initial NVA8 support
103
104* Thu Oct 09 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-14.20091008git3f020b0
105- update from upstream, fixes various issues, especially with recent xservers
106
107* Tue Sep 29 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-13.20090929gitdd8339f
108- fix driver to work again with recent EXA changes
109
110* Fri Sep 25 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-12.20090924gitde0b095
111- G80: small performance fix
112
113* Mon Sep 21 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-11.20090921gitdf95ebd
114- fix an accel pitch issue seen in rh#523281
115
116* Mon Sep 14 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-10.20090914git1b72020
117- wait for fbcon copy to complete before switching mode (rh#522688)
118
119* Thu Sep 10 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-9.20090910git806eaf6
120- fix a hang/crash issue that could occur during a modeset
121- nouveau-transition-hack.patch: drop, supported with driver pixmaps anyway
122
123* Wed Sep 09 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-8.20090904git2b5ec6a
124- nouveau-tile7000.patch: workaround some display corruption on G8x
125
126* Fri Sep 04 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-7.20090904git2b5ec6a
127- fix cursor being left enabled on wrong display
128
129* Thu Aug 27 2009 Adam Jackson <ajax@redhat.com> 0.0.15-6.20090820git569a17a
130- nouveau-bgnr.patch: Enable seamless plymouth->gdm transition.
131
132* Fri Aug 21 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-5.20090820git569a17a
133- a couple more minor fixes
134
135* Thu Aug 20 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-4.20090819gitfe2b5e6
136- various fixes from upstream, build pending new xorg-x11-server update
137
138* Tue Aug 11 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-3.20090810git85b1c86
139- wfb fixes, driver pixmaps enabled by default
140
141* Wed Aug 05 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-2.20090803git712064e
142- dri2 fixes, no wfb without kms, non-kms fb resize fixes, other misc fixes
143
144* Tue Aug 04 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-1.20090803git619103a
145- upstream update, misc fixes
146
147* Tue Jul 28 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.15-0.20090728git4d20547
148- Update to latest upstream
149
150* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:0.0.14-4.20090717gitb1b2330
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
152
153* Fri Jul 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-3.20090717gitb1b2330
154- somehow missed updated patches to go on top
155
156* Fri Jul 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-2.20090717gitb1b2330
157- build fixes for recent X changes
158
159* Wed Jul 15 2009 Adam Jackson <ajax@redhat.com> - 1:0.0.14-1.20090701git6d14327.1
160- ABI bump
161
162* Mon Jul 7 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-1.20090701git6d14327
163- update from upstream + bring back additional features found in F11
164
165* Fri Jun 26 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.14-0.20090625gitc0bf670
166- rebase onto latest upstream.  missing some features that were patched into
167  F11, they'll come back soon.
168
169* Fri Apr 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-29.20090417gitfa2f111
170- avoid post-beta hangs experienced by many people (rh#495764, rh#493222).
171  - the bug here was relatively harmless, but exposed a more serious issue
172    which has been fixed in libdrm-2.4.6-6.fc11
173- kms: speed up transitions, they could take a couple of seconds previously
174- framebuffer resize support (rh#495838, rh#487356, lots of dups)
175
176* Wed Apr 15 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-27.20090413git7100c06
177- fix rh#495843
178
179* Mon Apr 13 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-26.20090413git7100c06
180- nouveau-fedora.patch: split out into indivdual functionality
181- nv50: disable acceleration on NVAx chipsets, it won't work properly yet
182- drop nouveau-eedid.patch, it's upstream now
183
184* Wed Apr 08 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-25.20090408gitd8545e6
185- correct logic error in vbios parser (rh#493981)
186
187* Wed Apr 08 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-24.20090408git960a5c8
188- modify nv50 ddc regs again, fix kms edid property
189
190* Tue Apr 07 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-23.20090407git11451ca
191- upstream update: rh#492399, nv50 PROM fixes
192
193* Sat Apr 04 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-22.20090404git836d985
194- use consistent connector names across all modesetting paths
195- rh#493981
196
197* Fri Apr 03 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-21.20090403git11be9a9
198- upstream update, loads of modesetting fixes
199- rh#492819, rh#492427, rh#492289, rh#492289
200
201* Mon Mar 30 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-20.20090330git9d46930
202- xv bugfix
203
204* Mon Mar 30 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-19.20090330git9213c39
205- fix rh#492239, and various modesetting changes
206- nouveau-eedid.patch: remove nv50 hunk, is upstream now
207
208* Fri Mar 27 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-18.20090327gitf1907dc
209- nv50: add default modes to mode pool for lvds panels (rh#492360)
210- kms: fix getting edid blob from kernel
211
212* Fri Mar 27 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-17.20090327gitf431e20
213- fix partially obscured xv rendering without compmgr (rh#492227,rh#492229,rh#492428)
214- fix crash when rotation requested (fdo#20848)
215- additional sanity checks for kernel modesetting enabled
216
217* Thu Mar 26 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-16.20090326git01cee29
218- update, should fix rh#497173
219
220* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-15.20090324git4067ab4
221- more ppc build fixes
222
223* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-14.20090323git3063486
224- fix ppc build
225
226* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-13.20090323gitd80fe78
227- modesetting fixes, should handle rh#487456
228
229* Mon Mar 23 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-12.20090318git3e7fa97
230- upstream update, various fixes to pre-nv50 modesetting, cleanups
231
232* Fri Mar 13 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-11.20090313git79d23d8
233- kms: dpms fixes
234- kms: nicer reporting of output properties to users
235- improve init paths, more robust
236- support for multiple xservers (fast user switching)
237
238* Tue Mar 10 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-10.20090310git8f9a580
239- upstream update, should fix #455194
240
241* Mon Mar 09 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-9.20090309gited9bd88
242- upstream update, fixes
243- store used vbios image in /var/run, will potentially help debugging later
244
245* Thu Mar 05 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-8.20090305git42f99e6
246- upstream update, fixes
247- kms: support gamma and dpms calls
248- kms: nicer transition to gdm from plymouth
249
250* Mon Mar 02 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-7.20090302gite6c3b98
251- upstream update, fixes
252
253* Fri Feb 27 2009 Adam Jackson <ajax@redhat.com> 0.0.12-6.20090224gitd91fc78
254- nouveau-eedid.patch: Do EEDID.
255
256* Tue Feb 24 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-5.20090224gitd91fc78
257- improve description of package
258
259* Tue Feb 24 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-4.20090224gitd91fc78
260- new upstream snapshot
261
262* Tue Feb 17 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-1.20090216git7b25a30
263- fixes from upstream
264- append git version to tarball filename
265
266* Mon Feb 16 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-1.20090213git2573c06
267- latest snapshot
268- add patches to improve G80/G90 desktop performance
269
270* Sat Feb 7 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-3.20090205git945f0cb
271- build with kms paths enabled, so things don't blow up with kms turned on
272
273* Thu Feb 5 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.12-1.20090205git945f0cb
274- latest snapshot - kernel interface 0.0.12
275
276* Tue Feb 03 2009 Kyle McMartin <kyle@redhat.com> 0.0.11-2.20090106git133c1a5
277- add build-dep on mesa (missing GL/gl.h due to glxint.h)
278
279* Tue Jan 13 2009 Ben Skeggs <bskeggs@redhat.com> 0.0.11-1.20090106git133c1a5
280- update to latest snapshot
281
282* Wed Nov 19 2008 Dave Airlie <airlied@redhat.com> 0.0.11-1.20081119git65b956f
283- update to latest upstream snapshot
284
285* Tue Sep 02 2008 Dave Airlie <airlied@redhat.com> 0.0.11-1.20080902git6dd8ad4
286- update to snapshot with new kernel interface 0.0.11
287
288* Tue May 20 2008 Dave Airlie <airlied@redhat.com> 0.0.10-3.20080520git9c1d87f
289- update to latest snapshot - enables randr12
290
291* Tue Apr 08 2008 Dave Airlie <airlied@redhat.com> 0.0.10-2.20080408git0991281
292- Update to latest snapshot
293
294* Tue Mar 11 2008 Dave Airlie <airlied@redhat.com> 1:0.0.10-1.20080311git460cb26
295- update to latest snapshot
296
297* Fri Feb 29 2008 Dave Airlie <airlied@redhat.com> 1:0.0.10-1.20080221git5db7920
298- Initial package for nouveau driver.
Note: See TracBrowser for help on using the repository browser.