source: projects/specs/branches/6/x/xml-commons-apis/xml-commons-apis-vl.spec @ 5569

Revision 5569, 9.8 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1# Copyright (c) 2000-2007, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31Name:           xml-commons-apis
32Summary:        APIs for DOM, SAX, and JAXP
33Version:        1.3.04
34Release:        2%{?_dist_release}
35
36#Group:          Text Processing/Markup/XML
37Group:          System Environment/Libraries
38License:        ASL 2.0 and W3C and Public Domain
39URL:            http://xml.apache.org/commons/
40
41
42# using binary package for bootstrap
43Source0:        xml-commons-external-%{version}-bin.tar.gz
44# svn export http://svn.apache.org/repos/asf/xml/commons/tags/xml-commons-external-1_4_01/java/external/
45# tar czf xml-commons-external-1.4.01-src.tar.gz external
46
47BuildRoot:      %{_tmppath}/%{name}-%{version}-root
48BuildArch:      noarch
49BuildRequires:  jpackage-utils >= 1.5
50#BuildRequires:  ant
51Requires:       jpackage-utils >= 1.5
52
53Obsoletes:      xml-commons <= 1.3.02
54Provides:       xml-commons = %{version}-%{release}
55
56Provides:       jaxp = 1.3
57Provides:       xml-commons-jaxp-1.3-apis = %{version}-%{release}
58
59%description
60xml-commons-apis is designed to organize and have common packaging for
61the various externally-defined standard interfaces for XML. This
62includes the DOM, SAX, and JAXP.
63
64%package manual
65Summary: Manual for %{name}
66Group: Applications/Documentation
67
68%description manual
69Manual for %{name}.
70
71# -----------------------------------------------------------------------------
72
73%prep
74%setup -q -n xml-commons-external-%{version}
75
76# -----------------------------------------------------------------------------
77
78%build
79
80# -----------------------------------------------------------------------------
81
82%install
83rm -rf $RPM_BUILD_ROOT
84
85# Jars
86mkdir -p $RPM_BUILD_ROOT%{_javadir}
87cp -p xml-apis.jar \
88  $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
89cp -p xml-apis-ext.jar \
90  $RPM_BUILD_ROOT%{_javadir}/%{name}-ext-%{version}.jar
91
92# Jar versioning
93(cd $RPM_BUILD_ROOT%{_javadir} && for jar in %{name}-%{version}.jar; do ln -sf ${jar} dom3-${jar}; done)
94(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
95# for better interoperability with the jpp apis packages
96ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/jaxp13.jar
97ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/jaxp.jar
98ln -sf %{name}.jar $RPM_BUILD_ROOT%{_javadir}/xml-commons-jaxp-1.3-apis.jar
99
100# -----------------------------------------------------------------------------
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105# -----------------------------------------------------------------------------
106
107%files
108%defattr(-,root,root,-)
109%doc LICENSE NOTICE
110%doc LICENSE.dom-documentation.txt README.dom.txt
111%doc LICENSE.dom-software.txt
112%doc LICENSE.sax.txt README.sax.txt
113%{_javadir}/*
114
115%files manual
116%defattr(-,root,root,-)
117%doc docs/*
118
119#files javadoc
120#defattr(-,root,root,-)
121#{_javadocdir}/*
122
123# -----------------------------------------------------------------------------
124
125%changelog
126* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.04-2
127- rebuild with Vine6 environment
128
129* Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.04-1
130- Initial build for Vine Linux
131- used version 1.3.04
132
133* Sat Jan 9 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.4.01-1
134- Update to 1.4.01.
135
136* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3.04-3.5
137- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
138
139* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3.04-2.5
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
141
142* Fri Feb 6 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.3.04-1.5
143- Add osgi metadata to the ext jar too.
144
145* Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:1.3.04-1.4
146- Add osgi metadata.
147
148* Fri Sep 19 2008 Matt Wringe <mwringe@redhat.com> - 0:1.3.04-1.3
149- Remove natively compiled bits from the javadoc package (462809)
150
151* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.3.04-1.2
152- drop repotag
153- fix license tag
154
155* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.3.04-1jpp.1
156- Autorebuild for GCC 4.3
157
158* Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:1.3.04-0jpp.1
159- Update to 1.3.04
160
161* Tue Mar 06 2007 Matt Wringe <mwringe@redhat.com> - 0:1.3.03-0jpp.1
162- Split xml-commons package up into 2 separate package: xml-commons-apis
163  and xml-commons-which.
164
165* Mon Aug 21 2006 Fernando Nasser <fnasser@redhat.com> - 0:1.3.02-0.b2.7jpp.10
166- Add missing Requires for post and postun javadoc sections
167
168* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:1.3.02-0.b2.7jpp_9fc
169- Rebuilt
170
171* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:1.3.02-0.b2.7jpp_8fc
172- rebuild
173
174* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:1.3.02-0.b2.7jpp_7fc
175- stop scriptlet spew
176
177* Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:1.3.02-0.b2.7jpp_6fc
178- Updated to 1.3
179
180* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:1.0-0.b2.7jpp_5fc
181- bump again for double-long bug on ppc(64)
182
183* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:1.0-0.b2.7jpp_4fc
184- rebuilt again
185
186* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
187- rebuilt for new gcj
188
189* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
190- rebuilt
191
192* Fri Jul 15 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_3fc
193- Build on ia64, ppc64, s390 and s390x.
194- Switch to aot-compile-rpm (also BC-compiles the which jar).
195
196* Wed Jun 15 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_2fc
197- Remove all prebuilt stuff from the tarball.
198
199* Thu May 26 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.7jpp_1fc
200- Upgrade to 1.0-0.b2.7jpp.
201- Remove now-unnecessary workaround for #130162.
202- Rearrange how BC-compiled stuff is built and installed.
203
204* Mon May 23 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_13fc
205- Add alpha to the list of build architectures (#157522).
206- Use absolute paths for rebuild-gcj-db.
207
208* Thu May  5 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_12fc
209- Add dependencies for %%post and %%postun scriptlets (#156901).
210
211* Tue May  3 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_11fc
212- BC-compile the API jar.
213
214* Tue Apr 26 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_10fc
215- Remove gcj endorsed dir support (#155693).
216
217* Mon Apr 25 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_9fc
218- Provide a default transformer when running under libgcj.
219
220* Mon Apr 25 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_8fc
221- Provide a default DOM builder when running under libgcj (#155693).
222
223* Fri Apr 22 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_7fc
224- Provide a default SAX parser when running under libgcj (#155693).
225
226* Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_6fc
227- Add gcj endorsed dir support.
228
229* Tue Jan 11 2005 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_5fc
230- Sync with RHAPS.
231
232* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_4fc
233- Build into Fedora.
234
235* Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> - 0:1.0-0.b2.6jpp_3fc
236- Bootstrap into Fedora.
237
238* Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> - 0:1.0-0.b2.6jpp_3rh
239- add coreutils BuildRequires
240
241* Thu Mar  4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:1.0-0.b2.6jpp_2rh
242- RH vacuuming part II
243
244* Tue Mar  2 2004 Frank Ch. Eigler <fche@redhat.com> - 0:1.0-0.b2.6jpp_1rh
245- RH vacuuming
246
247* Thu Aug 26 2003 Ralph Apel <r.apel at r-apel.de> - 0:1.0-0.b2.7jpp
248- Build with ant-1.6.2
249
250* Mon May  5 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.0-0.b2.6jpp
251- Fix non-versioned javadoc symlinking.
252
253* Mon Apr 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:1.0-0.b2.5jpp
254- Fix xml-which script.
255- Include non-versioned javadoc symlinks.
256- Add Epoch: 0.
257- Fix jpackage-utils dependency versions.
258
259* Thu Mar 13 2003 Nicolas Mailhot <Nicolas.Mailhot at jpackage.org> - 1.0-0.b2.4jpp
260- For jpackage-utils 1.5
261
262* Wed Nov 13 2002 Ville Skyttä <ville.skytta at iki.fi> - 1.0-0.b2.3jpp
263- Following upstream changes, resolver is now built from its own package.
264
265* Sun Nov  3 2002 Ville Skyttä <ville.skytta at iki.fi> 1.0-0.b2.2jpp
266- Split resolver into its own subpackage.
267- Fix Group, Vendor and Distribution tags.
268- Use sed instead of bash 2 extension when symlinking jars.
269- Add resolver and which shell scripts.
270
271* Thu Jul 11 2002 Henri Gomez <hgomez@users.sourceforge.net> 1.0-0.b2.1jpp
272- 1.0.b2
273- get tarball from xml.apache.org
274- add macro section
275
276* Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 1.0-0.b1.1jpp
277- first jpp release
Note: See TracBrowser for help on using the repository browser.