source: projects/specs/branches/6/x/xinetd/xinetd-vl.spec @ 3330

Revision 3330, 19.2 KB checked in by Takemikaduchi, 13 years ago (diff)

fix: failed to build package

Line 
1%define _use_internal_dependency_generator 0
2%define __find_requires %{SOURCE99}
3
4Summary: A secure replacement for inetd.
5Name: xinetd
6Version: 2.3.14
7Release: 3%{?_dist_release}
8License: Distributable (BSD-like)
9Group: System Environment/Daemons
10Source: http://www.xinetd.org/xinetd-%{version}.tar.gz
11Source1: xinetd.init
12Source2: xinetd.conf
13Source3: xinetd-inetdconvert
14Source4: xinetd-ttime
15Source5: xinetd-utime
16Source6: xinetd-tdtime
17Source7: xinetd-udtime
18Source8: xinetd-echo
19Source9: xinetd-uecho
20Source10: xinetd-chargen
21Source11: xinetd-uchargen
22Source12: xinetd.sysconf
23Source13: xinetd-services
24Source99: filter-requires-xinetd.sh
25Patch0: xinetd-2.3.11-pie.patch
26Patch1: xinetd-2.3.13-libwrap.patch
27Patch2: xinetd-2.3.12-tcp_rpc.patch
28Requires(pre): chkconfig initscripts
29Requires: initscripts setup fileutils
30BuildRequires: tcp_wrappers
31URL: http://www.xinetd.org/
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33Provides: inetd
34
35%description
36Xinetd is a secure replacement for inetd, the Internet services
37daemon. Xinetd provides access control for all services based on the
38address of the remote host and/or on time of access and can prevent
39denial-of-access attacks. Xinetd provides extensive logging, has no
40limit on the number of server arguments, and lets you bind specific
41services to specific IP addresses on your host machine. Each service
42has its own specific configuration file for Xinetd; the files are
43located in the /etc/xinetd.d directory.
44
45%prep
46%setup -q 
47#%patch0 -p0 -b .pie
48#%patch1 -p1 -b .libwrap
49%patch2 -p1 -b .tcp_rpc
50
51%build
52libtoolize --copy --force
53%configure --with-loadavg --with-inet6 --with-libwrap
54make
55
56%install
57rm -rf $RPM_BUILD_ROOT
58mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
59mkdir -p $RPM_BUILD_ROOT/%{_mandir}
60%makeinstall DAEMONDIR=$RPM_BUILD_ROOT/usr/sbin MANDIR=$RPM_BUILD_ROOT/%{_mandir}
61mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d/
62install -m 755 %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/xinetd
63install -m 644 %SOURCE2 $RPM_BUILD_ROOT/etc/xinetd.conf
64install -m 755 %SOURCE3 $RPM_BUILD_ROOT/usr/sbin/inetdconvert
65install -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/xinetd.d/time
66install -m 644 %SOURCE5 $RPM_BUILD_ROOT/etc/xinetd.d/time-udp
67install -m 644 %SOURCE6 $RPM_BUILD_ROOT/etc/xinetd.d/daytime
68install -m 644 %SOURCE7 $RPM_BUILD_ROOT/etc/xinetd.d/daytime-udp
69install -m 644 %SOURCE8 $RPM_BUILD_ROOT/etc/xinetd.d/echo
70install -m 644 %SOURCE9 $RPM_BUILD_ROOT/etc/xinetd.d/echo-udp
71install -m 644 %SOURCE10 $RPM_BUILD_ROOT/etc/xinetd.d/chargen
72install -m 644 %SOURCE11 $RPM_BUILD_ROOT/etc/xinetd.d/chargen-udp
73install -m 644 %SOURCE13 $RPM_BUILD_ROOT/etc/xinetd.d/services
74
75rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/itox*
76rm -f $RPM_BUILD_ROOT/usr/sbin/itox
77rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/xconv.pl*
78rm -f $RPM_BUILD_ROOT/usr/sbin/xconv.pl
79rm -f $RPM_BUILD_ROOT/%{_mandir}/*.3
80
81mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
82install -m 644 %SOURCE12 $RPM_BUILD_ROOT/etc/sysconfig/xinetd
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post
88if [ $1 = 1 ]; then
89    /sbin/chkconfig --add xinetd
90fi
91
92%preun
93if [ $1 = 0 ]; then
94    /sbin/service xinetd stop > /dev/null 2>&1
95    /sbin/chkconfig --del xinetd
96fi
97
98%postun
99if [ $1 -ge 1 ]; then
100    /sbin/service xinetd condrestart >/dev/null 2>&1
101fi
102
103
104%files
105%defattr(-,root,root)
106%doc INSTALL CHANGELOG COPYRIGHT README xinetd/sample.conf
107
108%config(noreplace) /etc/xinetd.conf
109%config(noreplace) /etc/sysconfig/xinetd
110%{_sbindir}/xinetd
111%{_sbindir}/inetdconvert
112%{_mandir}/*/*
113%config /etc/rc.d/init.d/xinetd
114%config(noreplace) /etc/xinetd.d/*
115
116%changelog
117* Wed Apr 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.14-3
118- add BuildRequires: tcp_wrappers
119
120* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.14-2
121- rebuild for Vine 6
122
123* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.14-1vl5
124- applied new versioning policy
125
126* Sun Nov 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.3.14-0vl2
127- fix dependencies ([VineSeed:11559,12368], <bts:398>)
128  - remove Conflicts: inetd
129  - add Provides: inetd
130
131* Wed Mar  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.14-0vl1
132- new upstream release
133- drop patch1
134- remove Provides: inetd
135
136* Sun Feb 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.13-2vl3
137- remove Obosletes: inetd, add Conflicts: inetd
138
139* Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl2
140- rebuild
141
142* Sat Sep 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl1
143- build for VineSeed
144- remove Epoch
145- remove patch0
146- remove Requires: filesystem >= 2.0.1
147- remove BuildRequires: glibc-devel (included in build-essential)
148
149* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
150- rebuilt
151
152* Thu Jan 29 2004 Jay Fenlason <fenlason@redhat.com> 2.3.13-1
153- Upgrade to new upstream version, which obsoletes most patches.
154- Add new tcp_rpc patch, to turn on the nolibwrap flag on tcp rpc services,
155  since libwrap cannot be used on them.
156
157* Sun Dec 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
158- use new technology to filter python dep for inetdconvert instead
159  of changing the -x bit on file permissions
160
161* Wed Nov 12 2003 Jay Fenlason <fenlason@redhat.com> 2.3.12-3
162- build in HEAD for pre FC-2
163- merge from xinetd-3E-branch to fix bugzilla #103009
164  also includes:
165   New upstream version, which obsoletes most of my patches
166   Remove %{_mandir}/man8/xconv.pl*  fixing #90730
167   Remove the servers service, which was removed from 2.3.12
168   Change localization: instead of using en_US in /etc/rc.d/init.d/xinetd
169    (overriding the system default and preventing any customization),
170    /etc/sysconfig/xinetd sets XINETD_LANG, which is either a locale to use
171    or the word "none", which causes all locale environment variables to be
172    cleared before xinetd is started.  This fixes #91403
173   #77724 was fixed by the upgrade to 2.3.12
174   include post 2.3.12 patch from upstream (originally by
175    Matthias Andree <ma+xi@dt.e-technik.uni-dortmund.de>) to add a new
176    "libwrap" parameter.
177    This closes bugs (#91555,#91135,#77724) by making xinetd's behavior
178    documented and user-configurable.
179   Removed the old libwrap/TCP/wait patch.  If anyone actually cares,
180    they can add "flags = NOLIBWRAP" to the configuration of TCP/wait
181    services to get the old behavior.
182   Mark /etc/sysconfig/xinetd as a config file in xinetd.spec
183   Add pie support
184
185* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
186- allow compiling without tcp_wrappers
187
188* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
189- rebuilt
190
191* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
192- rebuilt
193
194* Fri Feb 21 2003 Jay Fenlason <fenlason@redhat.com> 2.3.10-5
195- Merge various patches from xinetd-CVS, since 2.3.11 won't be
196  out in time for our Red Hat Linux release.  One improves range checking
197  on file descriptors.  (A potential security problem.)  Another
198  fixes bugzilla #84840: tcpmux doesn't work at all.  A third improves
199  error checking on tcpmux service entries.  The last improves error
200  checking on service startup. 
201
202* Tue Feb 11 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-4
203- rebuild
204
205* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-3
206- rebuild
207
208* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
209- rebuilt
210
211* Tue Jan  7 2003 Jay Fenlason <fenlason.redhat.com> 2.3.10-1
212- Fix #81770, #80612, #79219, #79274: New upstream version
213- May also fix #79085, #78903, #78699, #77781, #77760, #76727
214- ... #73805, #60049, #58881, #58855
215- Fix #79999: remove xinetd-ipv6 executable
216- Fix #82021: changed preun to turn off the server
217- try to Fix #74198 by quoting "${NETWORKING}" in xinetd.init
218
219
220* Tue Dec 10 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-6
221- Fix Service startup script to check for id=0
222
223* Tue Nov 19 2002 Bill Nottingham <notting@redhat.com> 2.3.7-5
224- add new stream_wait patch (#74696)
225
226* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-4
227- Fix Service Descriptions
228
229* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-3
230- Fix #77710 Fix Service Descriptions
231
232* Thu Aug 15 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 2.3.7-2
233- Fix #71506 (mixed internal services)
234
235* Mon Aug 12 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.7-1
236- 2.3.7 - this fixes #70504
237
238* Mon Aug  5 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-6
239- Initscript fixes (#70730)
240
241* Wed Jul 17 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-5
242- Add patch for improved cross compiling (#55927)
243
244* Wed Jul  3 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-4
245- #67701
246
247* Wed Jun 26 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5=3
248- Fix maks for access control (#65743)
249- some fixes for config file parsing
250
251* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
252- automated rebuild
253
254* Thu May 30 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-1
255- 2.3.5
256
257* Thu May 23 2002 Tim Powers <timp@redhat.com>
258- automated rebuild
259
260* Mon Apr 22 2002 Trond Eivind Glomsr綬d <teg@redhat.com>
261- 2.3.4 final (bah, never announced... has been out for 3 weeks)
262
263* Thu Apr  4 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.8
264- Add a patch to avoid fam haunting the system
265
266* Tue Apr  2 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.7
267- Add patch from Alex Larson in order not to use tcp_wrappers on tcp/wait -
268  they'd always be 0.0.0.0
269
270* Thu Mar 28 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.6
271- 2002-03-26. 2.3.4 final RSN
272
273* Fri Mar  1 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.5
274- 2002-02-28-1
275
276* Sun Jan  6 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.4
277- 2002-01-04
278- Update URLs
279
280* Fri Dec 14 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.3
281- 2001-12-13
282
283* Mon Dec  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.2
284- 2001-12-03 (fixes #57001, #55738)
285
286* Fri Nov 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.1
287- 2001-11-29, which fixes #56487
288- Add configuration files for the xinetd internal services listing
289  current servers and services. It's off by default, and restricted
290  to localhost when enabled (#52707)
291- Use SIGHUP for configuration reload (change in program)
292
293* Wed Aug 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.3-1
294- 2.3.3
295- parser patch now obsolete
296
297* Thu Aug 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.2-1
298- 2.3.2, which contains the memory overwrite patch,
299  the audit fixes, the conn_free patch and the filelog patch.
300- Fix handling of rpc_version with ranges (like "1-2") (#51737)
301
302* Wed Aug 15 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-7
303- Don't apply the skipjunk patch anymore - xinetd now skips files with ".",
304  which include .rpmsave etc.
305- fix memory overwrite bug in env.c:grow()
306
307* Mon Aug 13 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-6
308- conn_free was called twice...
309- add cps = 25 30 to xinetd.conf. Thus, if a service has many
310  connections (25 in a 1 second period), it will be disabled
311  for 30 seconds. Without this, 10 connections to a service in
312  a second would permanently disable the service (#49122)
313
314* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-5
315- add the patch from "Solar Designer"'s audit
316
317* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-4
318- Make it handle stop and status when IPv6 is enabled (#49621)
319
320* Mon Jul 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
321- Add IPv6 support - separate binary, invoked if
322  NETWORKING_IPV6 is set (#49621)
323- Make inetdconvert handle the "/usr/sbin/in.telnetd in.telnetd"
324  scenario of inetd (#46449)
325
326* Tue Jul  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
327- redo skipjunkfile patch
328
329* Fri Jun 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
330- 2.3.0
331
332* Thu Jun 21 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
333- 2.1.8.9pre16
334
335* Mon Jun  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
336- Remove explicit dependancy on initscripts version
337
338* Sun May 20 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
339- 2.1.8.9pre15, which should fix wait=yes with tcp (linuxconf is
340  the only program I know of using this)
341- fix some problems with UDP internal services (#38669)
342- make /etc/xinetd.conf noreplace
343
344* Wed Apr 25 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
345- Add the tcp wait=yes patch from the xinetd version in a different tree
346
347* Wed Apr  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
348- Add /etc/sysconfig/xinetd so users can add extra options (#34321)
349
350* Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
351- noreplace the xinetd.d files
352
353* Mon Feb  5 2001 Preston Brown <pbrown@redhat.com>
354- built against newer tcp_wrappers that fixes name resolution problem (#16949)
355
356* Mon Feb  5 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
357- Patch from nalin@redhat.com for terminating the environment variables properly
358
359* Tue Jan 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
360- remove PID from log_on_failure flags (#22687)
361
362* Tue Jan 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
363- improve gettextization
364- add "UNLISTED" to the internal udp services (#24279)
365
366* Thu Jan 18 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
367- 2.1.8.9pre14
368
369* Wed Jan 17 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
370- gettextize
371
372* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
373- remove python dependency.
374
375* Tue Dec 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
376- remove RECORD from xinetd.conf for security reasons
377  (no known holes, but better safe than sorry #22687)
378
379* Mon Dec 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
380- unset a couple of environment variables(HOME,MAIL) in the initscript.
381  This should avoid problems like bug #21663
382
383* Fri Dec 01 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
384- rebuild
385
386* Tue Nov 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
387- 2.1.8.9pre13, which should fix #19355
388- changes to initscript - set all locale environment variables
389  to en_US, as the server doesn't know what locale the client
390  expects  and error messages can otherwise be confusing
391  (partially #20566)
392
393* Thu Nov 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
394- fix mismatch in documentation vs. reality, introduced
395  when we changed the behaviour of the access control
396  to use server names (#20567)
397
398* Tue Oct 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
399- obsolete netkit-base, which was inetd's home until 6.2
400 
401* Thu Oct 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
402- 2.1.8.9pre12, which has a new "-stayalive" option so
403  xinetd stays alive even if no services are enabled.
404- use the above in the initscript (#18819)
405
406* Tue Oct 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
407- 2.1.8.9pre11, which includes the previous bugfixes.
408- don't convert the internal services, include
409  such files with xinetd (#17331, #18899)
410
411* Mon Oct 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
412- Add patch to fix segfault problem (#18686)
413
414* Fri Oct 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
415- apply patch from nalin@redhat.com for handling tcp
416  connections with wait=yes properly
417
418* Tue Sep 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
419- add explicit dependency on a modern version of initscripts
420  (#17533)
421
422* Wed Aug 30 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
423- 2.1.8.9pre10 - remove tcpwrapper and pidfile patches,
424  as they are now in.
425- change default startup position to 56, so it
426  starts after bind (#17047)
427
428* Thu Aug 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
429- use the server name not the service name for libwrap
430  checking (#16516). The new way was better, but
431  this is sacrificed so old systems will continue to work
432  and the documentation for tcp_wrappers can be correct.
433
434* Wed Aug 16 2000 Than Ngo <than@redhat.com>
435- fix initscript, test network file before source it (Bug #16247)
436
437* Tue Aug 15 2000 Trond Eivind Glomsr綬d <teg@redhat.com
438- make the pidfile 0644, not 0300 (#16256)
439
440* Tue Aug 08 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
441- added support for "-pidfile" option (#15531)
442
443* Fri Aug 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
444- added patch to ignore .rpmsave, .rpmorig, .rpmnew, ~
445  suffixed files (#15304)
446
447* Thu Aug 03 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
448- 2.1.8.9pre9, old patches are now integrated.
449
450* Wed Aug 02 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
451- fix converting of "wait" argument (#13884)
452- remove tcpd and /usr/sbin/tcpd from inetd.conf services
453  before converting - xinetd is linked against tcp_wrappers
454
455* Mon Jul 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
456- fix linuxconf restart problem (#14856)
457- fix conditional restart
458- mark /etc/xinetd.conf as a configuration file
459
460* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
461- um, we *need* to prereq /etc/init.d
462
463* Mon Jul 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
464- Don't require /etc/init.d
465
466* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
467- rebuild
468
469* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
470- fix the sections of the man pages (#14244)
471
472* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
473- remove itox, as it wouldn't do the right thing with our
474  configuration
475- same with xconv.pl
476- some changes to the installation process
477
478* Mon Jul 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
479- move initscript back to /etc/rc.d/init.d
480
481* Fri Jul 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
482- change process name in init file
483
484* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
485- automatic rebuild
486
487* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
488- start the daemon with the "-reuse" flag
489
490* Thu Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
491- "Prereq:", not "Requires:" for /etc/init.d
492
493* Wed Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
494- require /etc/init.d
495
496* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
497- upper the number of instances to 60
498
499* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
500- fix a memory-allocation bug
501
502* Wed Jun 28 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
503- 2.1.8.9pre8
504
505* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
506- moved to /etc/init.d
507
508* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
509- changed specfile and initfile to implement conditional
510  restart
511
512* Sun Jun 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
513- 2.1.8.9pre7
514- now obsoletes inetd
515- use %%{_tmppath}
516
517* Sun Jun 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
518- 2.1.8.9pre6
519- added converter script which can convert specified or
520  remaing uncoverted services
521- use %%{_mandir}
522- removed +x on xinetd.conf
523
524* Wed May 24 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
525- 2.1.8.9pre4
526- authpriv patch no longer needed
527
528* Tue May 23 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
529- /etc/xinetd.d is now part of the filesystem package
530- more fixes to xinetd.init
531
532* Mon May 22 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
533- fixed some obvious bugs in xinetd.init
534- added a default xinetd.conf
535- patched xinetd to understand LOG_AUTHPRIV
536
537* Fri May 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
538- updated version
539- removed a define %ver (we already have %version)
540- removed some extra CFLAGS declarations
541- added configuration directory, /etc/xinetd.d
542
543* Mon Feb 21 2000 Tim Powers <timp@redhat.com>
544- fixed broken postun sections, should have been *preun*
545- fixed broken gzip of manpages
546
547* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
548- 2.1.8.8p8
549- Fix the init script (Bug #7277)
550- remove our patches (no longer required)
551
552* Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>
553- add -lnsl
554
555* Tue Sep 7 1999 Tim Powers <timp@redhat.com>
556- modification top install routine
557
558* Mon Jul 26 1999 Tim Powers <timp@redhat.com>
559- updated source to 2.1.8.6b6
560- built for 6.1
561
562* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
563- update to 2.1.8.6b5
564- build for PowerTools
565
566* Mon Jan 10 1999 Bill Nottingham <notting@redhat.com>
567- update to 2.1.8.5p2
568
569* Tue Dec  1 1998 Bill Nottingham <notting@redhat.com>
570- intial build
Note: See TracBrowser for help on using the repository browser.