source: projects/specs/branches/6/x/xerces-j2/xerces-j2-vl.spec @ 5569

Revision 5569, 16.6 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1%global cvs_version 2_9_0
2
3Name:          xerces-j2
4Summary:       Java XML parser
5Summary(ja):   Java XML パーサ
6Version:       2.9.0
7Release:       6%{?_dist_release}
8
9Group:         Development/Libraries
10License:       ASL 2.0
11URL:           http://xerces.apache.org/xerces2-j/
12
13# using binary for bootstrap
14Source0:       http://archive.apache.org/dist/xml/xerces-j/Xerces-J-bin.%{version}.tar.gz
15#Source0:       http://archive.apache.org/dist/xml/xerces-j/source/Xerces-J-src.%{version}.tar.gz
16Source1:       %{name}-version.sh
17Source2:       %{name}-constants.sh
18
19
20BuildRoot:     %{_tmppath}/%{name}-%{version}-root
21BuildArch:     noarch
22
23#BuildRequires: java-devel >= 1:1.6.0
24#BuildRequires: jpackage-utils
25#BuildRequires: xml-commons-apis >= 1.3
26#BuildRequires: xml-commons-resolver >= 1.1
27#BuildRequires: ant
28#BuildRequires: xalan-j2
29#BuildRequires: xml-stylebook
30#BuildRequires: jaxp_parser_impl
31#BuildRequires: dejavu-sans-fonts
32Requires:      java
33Requires:      jpackage-utils
34Requires:      xml-commons-apis >= 1.3
35#Requires:      xml-commons-resolver >= 1.1
36
37Provides:      jaxp_parser_impl = 1.3
38Requires(post):  alternatives jaxp_parser_impl
39Requires(preun): alternatives jaxp_parser_impl
40
41# This documentation is provided by xml-commons-apis
42#Obsoletes:     %{name}-javadoc-apis < %{version}-%{release}
43
44%description
45Welcome to the future! Xerces2 is the next generation of high performance,
46fully compliant XML parsers in the Apache Xerces family. This new version of
47Xerces introduces the Xerces Native Interface (XNI), a complete framework for
48building parser components and configurations that is extremely modular and
49easy to program.
50
51The Apache Xerces2 parser is the reference implementation of XNI but other
52parser components, configurations, and parsers can be written using the Xerces
53Native Interface. For complete design and implementation documents, refer to
54the XNI Manual.
55
56Xerces2 is a fully conforming XML Schema processor. For more information,
57refer to the XML Schema page.
58
59Xerces2 also provides a complete implementation of the Document Object Model
60Level 3 Core and Load/Save W3C Recommendations and provides a complete
61implementation of the XML Inclusions (XInclude) W3C Recommendation. It also
62provides support for OASIS XML Catalogs v1.1.
63
64Xerces2 is able to parse documents written according to the XML 1.1
65Recommendation, except that it does not yet provide an option to enable
66normalization checking as described in section 2.13 of this specification. It
67also handles namespaces according to the XML Namespaces 1.1 Recommendation,
68and will correctly serialize XML 1.1 documents if the DOM level 3 load/save
69APIs are in use.
70
71#%package        javadoc-impl
72#Summary:        Javadoc for %{name} implementation
73#Group:          Documentation
74#
75#%description    javadoc-impl
76#%{summary}.
77
78#%package        javadoc-xs
79#Summary:        Javadoc for %{name} XML schema API
80#Group:          Documentation
81#
82#%description    javadoc-xs
83#%{summary}.
84
85#%package        javadoc-xni
86#Summary:        Javadoc for %{name} XNI
87#Group:          Documentation
88#
89#%description    javadoc-xni
90#%{summary}.
91
92#%package        javadoc-other
93#Summary:        Javadoc for other %{name} components
94#Group:          Documentation
95#
96#%description    javadoc-other
97#%{summary}.
98
99#%package        manual
100#Summary:        Manual for %{name}
101#Group:          Documentation
102#Requires:       xml-commons-apis-javadoc
103#Requires:       %{name}-javadoc-impl = %{version}-%{release}
104#Requires:       %{name}-javadoc-xs = %{version}-%{release}
105#Requires:       %{name}-javadoc-xni = %{version}-%{release}
106#Requires:       %{name}-javadoc-other = %{version}-%{release}
107#
108#%description    manual
109#%{summary}.
110
111#%package        demo
112#Summary:        Demonstrations and samples for %{name}
113#Group:          Development/Libraries
114#Requires:       %{name} = %{version}-%{release}
115#
116#%description    demo
117#%{summary}.
118
119#%package        scripts
120#Summary:        Additional utility scripts for %{name}
121#Group:          Development/Libraries
122#Requires:       %{name} = %{version}-%{release}
123#
124#%description    scripts
125#%{summary}.
126
127%prep
128%setup -q -n xerces-2_9_0
129#patch0 -p0 -b .orig
130
131%build
132
133%install
134rm -rf $RPM_BUILD_ROOT
135
136# jars
137install -pD -T xercesImpl.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
138(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
139
140# scripts
141install -pD -m755 -T %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}-version
142install -pD -m755 -T %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}/%{name}-constants
143
144# demo
145#install -pD -T xercesSamples.jar $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
146#cp -pr data $RPM_BUILD_ROOT%{_datadir}/%{name}
147
148# jaxp_parser_impl ghost symlink
149#ln -s %{_sysconfdir}/alternatives \
150#  $RPM_BUILD_ROOT%{_javadir}/jaxp_parser_impl.jar
151
152%clean
153rm -rf $RPM_BUILD_ROOT
154
155%post
156/sbin/update-alternatives --install %{_javadir}/jaxp_parser_impl.jar \
157    jaxp_parser_impl %{_javadir}/%{name}.jar 40
158
159%preun
160if [ $1 = 0 ]; then
161    /sbin/update-alternatives --remove jaxp_parser_impl \
162        %{_javadir}/%{name}.jar
163fi
164
165%files
166%defattr(-,root,root,-)
167%doc LICENSE NOTICE
168%{_javadir}/%{name}*
169#ghost %{_javadir}/jaxp_parser_impl.jar
170
171#%files javadoc-impl
172#%defattr(-,root,root,-)
173#%{_javadocdir}/%{name}-impl-%{version}
174#%{_javadocdir}/%{name}-impl
175
176#%files javadoc-xs
177#%defattr(-,root,root,-)
178#%{_javadocdir}/%{name}-xs-%{version}
179#%{_javadocdir}/%{name}-xs
180
181#%files javadoc-other
182#%defattr(-,root,root,-)
183#%{_javadocdir}/%{name}-other-%{version}
184#%{_javadocdir}/%{name}-other
185
186#%files javadoc-xni
187#%defattr(-,root,root,-)
188#%{_javadocdir}/%{name}-xni-%{version}
189#%{_javadocdir}/%{name}-xni
190
191#%files manual
192#%defattr(-,root,root,-)
193#%dir %{_docdir}/%{name}-%{version}
194#%{_docdir}/%{name}-%{version}/manual
195
196#%files demo
197#%defattr(-,root,root,-)
198#%{_datadir}/%{name}
199
200#%files scripts
201#%defattr(-,root,root,-)
202%{_bindir}/*
203
204%changelog
205* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.9.0-6
206- rebuild with Vine6 environment
207
208* Fri Aug 27 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.9.0-5
209- Initial build for Vine Linux
210
211* Sat Jun 12 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-4
212- Fix broken links in manual and fix javadoc requires.
213- Build 1.5 bytecode instead of 1.6, for compatibility.
214
215* Fri Jan 22 2010 Andrew Overholt <overholt@redhat.com> - 2.9.0-3
216- Fix unversioned Provides for jaxp_parser_impl (make it 1.3).
217
218* Thu Jan 14 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-2
219- Add a build dep on a font package because the JDK is missing a dependency
220  to function correctly in headless mode. See RHBZ #478480 and #521523.
221- Fix groups.
222
223* Tue Jan 5 2010 Mat Booth <fedora@matbooth.co.uk> - 2.9.0-1
224- Update to 2.9.0: This is the version Eclipse expects, previously the OSGi
225  manifest was lying about its version :-o
226- Enable manual sub-package now xml-stylebook is in Fedora.
227- Drop GCJ support.
228- Minor changes to spec to make it more conforming to the guidelines.
229- Drop the libgcj patch, we don't seem to need it anymore.
230- Add the OSGi manifest as part of the build instead of the install.
231- Fix packaging bug RHBZ #472646.
232
233* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-12.3
234- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
235
236* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.1-11.3
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
238
239* Fri Jan 30 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-10.3
240- Add osgi manifest.
241
242* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.1-10.2
243- drop repotag
244- fix license tag
245
246* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.1-10jpp.1
247- Autorebuild for GCC 4.3
248
249* Wed Mar 28 2007 Matt Wringe <mwringe@redhat.com> 0:2.7.1-9jpp.1
250- Update with newest jpp version
251- Clean up spec file for Fedora Review
252
253* Sun Aug 13 2006 Warren Togami <wtogami@redhat.com> 0:2.7.1-7jpp.2
254- fix typo in preun req
255
256* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp.1
257- Merge with upstream version
258
259* Sat Aug 12 2006 Matt Wringe <mwringe at redhat.com> 0:2.7.1-7jpp
260- Add conditional native compiling
261- Add missing requires for javadocs
262- Add missing requires for post and preun
263- Update version to 7jpp at Fedora's request
264
265* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.1-6jpp_9fc
266- Rebuilt
267
268* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0:2.7.1-6jpp_8fc
269- rebuild
270
271* Thu Mar 30 2006 Fernando Nasser <fnasser@redhat.com> 0:2.7.1-3jpp
272- Add missing BR for xml-stylebook
273
274* Wed Mar 22 2006 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-2jpp
275- First JPP-1.7 release
276- use tools subdir and give it as java.endorsed.dirs (for java-1.4.2-bea e.g.)
277
278* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.7.1-6jpp_7fc
279- stop scriptlet spew
280
281* Wed Feb 22 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.7.1-6jpp_6fc
282- Updated to 2.7.1
283
284* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_5fc
285- bump again for double-long bug on ppc(64)
286
287* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.2-6jpp_4fc
288- rebuilt for new gcc4.1 snapshot and glibc changes
289
290* Thu Feb  2 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_3fc
291- build xerces without using native code
292
293* Mon Jan  9 2006 Archit Shah <ashah@redhat.com> 0:2.6.2-6jpp_2fc
294- rebuilt for new gcj
295
296* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.2-6jpp_1fc
297- rebuilt for new gcj
298
299* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com>
300- rebuilt for new gcj
301
302* Fri Oct 07 2005 Ralph Apel <r.apel at r-apel.de> 0:2.7.1-1jpp
303- Upgrade to 2.7.1
304
305* Thu Jul 21 2005 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-7jpp
306- Include target jars-dom3
307- Create new subpackage dom3
308
309* Mon Jul 18 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_2fc
310- Build on ia64, ppc64, s390 and s390x.
311- Switch to aot-compile-rpm (also BC-compiles samples).
312
313* Wed Jul 13 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-6jpp
314- Build with Sun JDK (from <gareth.armstrong at hp.com>).
315
316* Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp_1fc
317- Upgrade to 2.6.2-5jpp.
318
319* Tue Jun 14 2005 Gary Benson <gbenson at redhat.com> 0:2.6.2-5jpp
320- Remove the tools tarball, and build xjavac from source.
321- Patch xjavac to fix the classpath under libgcj too.
322
323* Fri Jun 10 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_8fc
324- Remove the tools tarball, and build xjavac from source.
325- Replace classpath workaround to xjavac task and use
326  xml-commons classes again (#152255).
327
328* Thu May 26 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_7fc
329- Rearrange how BC-compiled stuff is built and installed.
330
331* Mon May 23 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_6fc
332- Add alpha to the list of build architectures (#157522).
333- Use absolute paths for rebuild-gcj-db.
334
335* Thu May  5 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_5fc
336- Add dependencies for %%post and %%postun scriptlets (#156901).
337
338* Fri Apr 29 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_4fc
339- BC-compile.
340
341* Thu Apr 28 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_3fc
342- Revert xjavac classpath workaround, and patch to use libgcj's
343  classes instead of those in xml-commons (#152255).
344
345* Thu Apr 21 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_2fc
346- Add classpath workaround to xjavac task (#152255).
347
348* Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.2-4jpp_1fc
349- Reenable building of classes that require javax.swing (#130006).
350- Sync with RHAPS.
351
352* Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com>  0:2.6.2-4jpp_1rh
353- Merge with upstream for 2.6.2 upgrade
354
355* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_5fc
356- Build into Fedora.
357
358* Thu Oct 28 2004 Gary Benson <gbenson@redhat.com> 0:2.6.2-2jpp_4fc
359- Bootstrap into Fedora.
360
361* Fri Oct 1 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_4rh
362- add coreutils BuildRequires
363
364* Thu Sep 30 2004 Andrew Overholt <overholt@redhat.com> 0:2.6.2-2jpp_3rh
365- Remove xml-commons-resolver as a Requires
366
367* Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> 0:2.6.2-4jpp
368- Build with ant-1.6.2
369- Dropped jikes requirement, built for 1.4.2
370
371* Wed Jun 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-3jpp
372- Updated Patch #0 to fix breakage using BEA 1.4.2 SDK, new patch
373  from <mwringe@redhat.com> and <vivekl@redhat.com>.
374
375* Mon Jun 21 2004 Vivek Lakshmanan <vivekl@redhat.com> 0:2.6.2-2jpp_2rh
376- Added new Source1 URL and added new %%setup to expand it under the
377  expanded result of Source0.
378- Updated Patch0 to fix version discrepancies.
379- Added build requirement for xml-commons-apis
380 
381* Mon Jun 14 2004 Matt Wringe <mwringe@redhat.com> 0:2.6.2-2jpp_1rh
382- Update to 2.6.2
383- made patch names comformant
384
385* Mon Mar 29 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-2jpp
386- Rebuilt with jikes 1.18 for java 1.3.1_11
387
388* Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_2rh
389- add RHUG upgrade cleanup
390
391* Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.2-1jpp
392- 2.6.2
393
394* Thu Mar 11 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.6.1-1jpp_1rh
395- RH vacuuming
396- remove jikes dependency
397- add nonjikes-cast.patch
398
399* Sun Feb 08 2004 David Walluck <david@anti-microsoft.org> 0:2.6.1-1jpp
400- 2.6.1
401- update Source0 URL
402- now requires xml-commons-resolver
403
404* Fri Jan  9 2004 Kaj J. Niemi <kajtzu@fi.basen.net> - 0:2.6.0-1jpp
405- Update to 2.6.0
406- Patch #1 (xerces-j2-manifest.patch) is unnecessary (upstream)
407
408* Tue Oct 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.0-1jpp
409- Update to 2.5.0.
410- Clean up versionless javadoc dir symlinking, own (ghost) the symlinks.
411- Mark javadocs as %%doc.
412
413* Wed Jun  4 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.4.0-3jpp
414- Own (ghost) %%{_javadir}/jaxp_parser_impl.jar.
415- Remove alternatives in preun instead of postun.
416
417* Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-2jpp
418- bug #17325 fixed upstream
419
420* Mon May 12 2003 David Walluck <david@anti-microsoft.org> 0:2.4.0-1jpp
421- 2.4.0
422- BuildRequires: jikes
423- update for JPackage 1.5
424- re-diff'ed build patch for 2.4.0
425- bug #17325 handled by perl now
426- scripts: s|find-jar|build-classpath| and don't test for java-functions
427
428* Wed Mar 26 2003 Nicolas Mailhot <Nicolas.Mailhot (at) JPackage.org> - 2.3.0-2jpp
429- For jpackage-utils 1.5
430- zapped manual, since it doesn't want to build
431- as a consequence, removed uneeded dependencies
432
433* Mon Feb 24 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.3.0-1jpp
434- Update to 2.3.0.
435- Add a crude patch to work around invalid XML in doc sources, see
436  <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17325>.
437- Built with IBM's 1.3.1 SR3.
438
439* Sat Dec 28 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-2jpp
440- Add upstream patch which fixes problems with Tomcat's webapps.
441  <http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13282>
442  <http://marc.theaimsgroup.com/?l=xerces-cvs&m=103791990130308>
443- Separate scripts subpackage.
444
445* Fri Nov 15 2002 Ville Skyttä <ville.skytta at iki.fi> - 2.2.1-1jpp
446- Update to 2.2.1.
447- Change alternative to point to non-versioned jar.
448- Don't remove alternative on upgrade.
449- Fix Group tag for demo, javadoc and manual subpackages.
450- Add version and constants scripts.
451- Some spec file cleanup.
452
453* Sun Oct  6 2002 Ville Skyttä <ville.skytta at iki.fi> 2.2.0-2jpp
454- Fix bad permissions for main jar.
455
456* Sun Sep 29 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
457- Update to 2.2.0.
458
459* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-2jpp
460- Rebuild with -Dcompiler=modern, not a Jikes bug this time, but sloppy code
461  that is tolerated by javac.  See <http://www-124.ibm.com/developerworks/bugs/?func=detailbug&bug_id=3218&group_id=10> for details.
462
463* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.1.0-1jpp
464- 2.1.0.
465- Updated description.
466- Changed javadoc and manual group to Documentation.
467- Spec file cleanups.
468
469* Fri Jul 12 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-4jpp
470- add BuildRequires xerces-j1 and xalan-j2
471- removed BuildRequires xml-commons-api since ant require jaxp_parser_impl
472  which in turn require xml-commons-api ;)
473
474* Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-3jpp
475- vendor, distribution, group tags
476- provides jaxp_parser_impl
477- dropped api jar
478- renamed lone jar to %%{name}.jar
479- priority bumped to 40
480- fixed stylebook build (add xerces-j1 in classpath)
481
482* Wed Jun 26 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.2-2jpp
483- rebuild for missing symlinks
484- use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
485
486* Mon Jun 24 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.0.2-1jpp
487- 2.0.2
488
489* Sun Mar 10 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.1-1jpp
490- 2.0.1
491- provides jaxp_parser2 virtual resource
492- drop wrapper
493
494* Sun Feb 03 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.0.0-1jpp
495- first JPackage release
Note: See TracBrowser for help on using the repository browser.