source: projects/specs/branches/6/x/xchat/xchat-vl.spec @ 3144

Revision 3144, 21.4 KB checked in by tomop, 13 years ago (diff)

xchat-2.8.8-1

Line 
1# Nobody likely uses this so we disable it
2%define with_tclplugin 0
3
4%define name xchat
5%define version 2.8.8
6%define release 1%{?_dist_release}
7
8Summary:   GTK2 based graphical IRC client
9Summary(ja):   GTK2 ベースのグラフィカル IRC クライアント
10Name:      %{name}
11Version:   %{version}
12Release:   %{release}
13Group:     Applications/Internet
14License:   GPL
15URL:       http://www.xchat.org/
16
17Source0: http://www.xchat.org/files/source/2.8/xchat-%{version}.tar.xz
18
19#Patch10: http://xchat.org/files/source/2.8/patches/xc286-smallfixes.diff
20
21# Patches 0-9 reserved for official xchat.org patches
22
23Patch12: xchat-1.8.7-use-sysconf-to-detect-cpus.patch
24# see #241923
25Patch35: xchat-2.8.4-disable-tray-icon-by-default.patch
26# Upstream XChat 2.8.6 defaults to Latin1 (what upstream calls the "IRC"
27# encoding). Default to UTF-8 instead (as previous versions did, at least when
28# running under a UTF-8 locale).
29# Both the "IRC" and "UTF-8" settings will try to accept both Latin1 and UTF-8
30# when it comes in, however "IRC" sends Latin1, "UTF-8" sends UTF-8.
31Patch41: xchat-2.8.6-default-utf8.patch
32# patch to add ability to change to tab with most recent activity
33# See http://sourceforge.net/tracker/?func=detail&aid=2022871&group_id=239&atid=350239
34Patch50: xchat-2.8.6-change-page-activity.patch
35# add port numbers for Freenode (Debarshi Ray)
36Patch51: xchat-2.8.6-freenode-ports.patch
37# work with libnotify 0.7
38# https://sourceforge.net/tracker/?func=detail&aid=3109838&group_id=239&atid=100239
39Patch52: xchat-2.8.8-libnotify07.patch
40
41# Vine
42#Source100: xchat-2.4.5-ja.po
43Patch100: http://takuo.jp/junk/xchat/99_plus.dpatch
44Patch110: http://takuo.jp/junk/xchat/99_x_dialog.dpatch
45Patch200: xchat-2.8.6_defaultserver-vine.patch
46#Patch201: xchat-2.8.6-x86_64.patch
47
48# xchat MUST have the version of perl installed which was used to compile
49# it, or else the embeded perl interpreter will break.
50Requires: %(perl -le 'use Config; print $Config{archlibexp}')
51
52BuildRequires: glib2-devel >= 2.2.0
53BuildRequires: gtk2-devel >= 2.2.0
54BuildRequires: bison >= 1.35
55BuildRequires: gettext, sed
56BuildRequires: perl, python-devel, openssl-devel, pkgconfig
57BuildRequires: autoconf
58BuildRequires: GConf2-devel
59BuildRequires: dbus-devel >= 1.0
60BuildRequires: tcl
61
62Requires(post): GConf2 >= 2.14
63Requires(preun): GConf2 >= 2.14
64
65Buildroot: %{_tmppath}/%{name}-%{version}-root
66
67
68%description
69X-Chat is an easy to use graphical IRC chat client for the X Window
70System.
71
72%description -l ja
73X-ChatはGTK2ベースのXウィンドウシステム用のIRCクライアントです。
74
75
76%prep
77%setup -q
78
79##%patch10 -p1
80
81%patch12 -p0 -b .use-sysconf-to-detect-cpus
82%patch35 -p1 -b .tray-icon
83%patch41 -p1 -b .default-utf8
84%patch50 -p1 -b .active-channel-switch
85%patch51 -p1 -b .freenode-ports
86%patch52 -p1 -b .libnotify07
87
88%patch100 -p1 -b .plus
89%patch110 -p1 -b .dialog
90
91%patch200 -p1 -b .servlist
92#%patch201 -p1 -b .x86_64
93
94sed -i -e 's/#define GTK_DISABLE_DEPRECATED//g' src/fe-gtk/*.c
95sed -i -e 's/GETTEXT_MACRO_VERSION = 0\.17/GETTEXT_MACRO_VERSION = 0.18/g' po/Makefile.in.in
96
97
98%build
99touch NEWS ABOUT-NLS
100libtoolize --copy --force
101aclocal
102automake
103autoconf
104# Remove CVS files from source dirs so they're not installed into doc dirs.
105find . -name CVS -type d | xargs rm -rf
106
107export CFLAGS="$RPM_OPT_FLAGS $(perl -MExtUtils::Embed -e ccopts)"
108export LDFLAGS=$(perl -MExtUtils::Embed -e ldopts)
109
110if pkg-config openssl ; then
111        export CFLAGS="$CFLAGS `pkg-config --cflags openssl`"
112        export CPPFLAGS="$CPPFLAGS `pkg-config --cflags-only-I openssl`"
113        export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
114fi
115%configure --disable-textfe \
116           --enable-openssl \
117           --enable-python \
118           --disable-spell \
119%if %{with_tclplugin}
120           --enable-tcl \
121%endif     
122           --enable-ipv6
123
124make %{?_smp_mflags}
125
126
127%install
128rm -rf $RPM_BUILD_ROOT
129make DESTDIR=$RPM_BUILD_ROOT install
130
131# Remove unwanted stuff
132rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
133rm -f $RPM_BUILD_ROOT%{_libdir}/xchat/plugins/*.la
134#rm -f $RPM_BUILD_ROOT%{_datadir}/applications/xchat.desktop
135#rm -f $RPM_BUILD_ROOT/etc/X11/applnk/Internet/xchat.desktop
136
137%find_lang %name
138
139
140%files -f %{name}.lang
141%defattr(-,root,root)
142%doc README ChangeLog
143%{_sysconfdir}/gconf/schemas/*
144%{_bindir}/xchat
145%{_libdir}/xchat/plugins/*.so
146%{_datadir}/applications/xchat.desktop
147%{_datadir}/dbus-1/services/*
148%{_datadir}/pixmaps/*
149
150
151%clean
152rm -rf $RPM_BUILD_ROOT
153
154
155%post
156# Install schema
157export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
158gconftool-2 --makefile-install-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
159
160%pre
161if [ "$1" -gt 1 -a -f "/etc/gconf/schemas/apps_xchat_url_handler.schemas" ]; then
162  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
163  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
164fi
165
166%preun
167if [ "$1" -eq 0 ]; then
168  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
169  gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/apps_xchat_url_handler.schemas > /dev/null || :
170fi
171
172
173%changelog
174* Sun Mar 27 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.8-1
175- new upstream release.
176- shipped some patches from Fedora development.
177
178* Sat Jan 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-5
179- rebuild with openssl-1.0.0c
180- add BuildRequires: tcl
181- add Patch201 (xchat-2.8.6-x86_64.patch)
182
183* Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.6-4
184- rebuilt with python-2.6.4-3
185
186* Tue Nov 03 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-3
187- updated Patch200 (Vine channel's default encoding to UTF-8)
188
189* Wed Apr 08 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-2
190- rebuilt with gtk2-2.16.0
191- don't #define GTK_DISABLE_DEPRECATED (fixes build against current GTK+)
192- add Patch200 (set default server connection for Vine people)
193- TODO: update ja.po
194
195* Mon Sep 01 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.6-1
196- updated to 2.8.6
197- drop/add patches
198
199* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-1
200- new versioning policy
201- rebuilt with perl-5.10.0
202- spec in UTF-8
203
204* Tue Jan 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.4-0vl1
205- updated to 2.8.4 with updated plus patch and upstream patches (14-16)
206
207* Tue Jun 19 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.2-0vl1
208- updated to 2.8.2 with plus patch
209
210* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.8-0vl4
211- rebuild with dbus-1.0
212
213* Wed Nov 29 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 2.6.8-0vl3
214- build without libsexy.
215
216* Thu Nov 23 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl2
217- added Patch10 and Patch20 for possible crashes under certain environments
218
219* Thu Oct 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.8-0vl1
220- updated to 2.6.8 with plus patch
221
222* Sun Sep 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.5-0vl1
223- new upstream release
224- updated ja.po
225- added Patch1 from http://www.xchat.org/files/source/2.4/patches/
226- added Patches from Fedora
227  * Sun May 15 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-3
228  - Prevent interception of down arrow during Input Method (#144588 tagoh)
229  * Thu Apr 14 2005 Warren Togami <wtogami@redhat.com> 1:2.4.3-2
230  - fix plugins on lib64 (#113188 Ville Skytta)
231  * Tue Jan  4 2005 Christopher Aillon <caillon@redhat.com> 1:2.4.1-2
232  - Add Dan Reed's CTCP patch to support multiline messages (#136545)
233  * Tue Aug 17 2004 Daniel Reed <djr@redhat.com> 1:2.4.0-2
234  - #125846 Change xchat.desktop names to "IRC"
235
236* Sun Jan 09 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl4
237- rebuild with perl-5.8.6-0vl2
238
239* Tue Jul  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl3
240- rebuild with perl-5.8.2-0vl2
241- updated ja.po
242
243* Mon Jun 21 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.9-0vl2
244- resume othersview patch (Patch21)
245
246* Sun Jun 20 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.9-0vl1
247- new upstream release
248- updated Patch10
249- dropped unneeded patches
250- updated ja.po
251
252* Fri Nov  7 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl5
253- build with perl-5.8.2
254
255* Fri Sep 26 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.2-0vl4
256- build with perl-5.8.1
257- change spec file's encoding: shift_jis -> euc-jp
258
259* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl3
260- add ja.po
261
262* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl2
263- add patch21 from debian to support othersview.
264
265* Thu Jun 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.2-0vl1
266- build for Vine Linux based on rawhide
267- some parts is merged with Vine Linux 1.8.10-0vl2
268  * Wed Jan 15 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.10-0vl2
269  - rebuilt against gnome-libs-1.4.2-0vl2 (for db1/db4 matters)
270  - add BuildRequires: automake14, autoconf213
271  - modified source10 (openprojects has been renamed to freenode)
272  * Tue Aug 13 2002 IWAI Masaharu <iwai@alib.jp> 1.8.10-0vl1
273  - upstream update
274  - updated plus patch
275  - moved xchat.desktop to %%{_sysconfdir}/X11/applnk/Internet by upstream
276  * Thu Jul 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl3
277  - use source10 instead of patch10 for server list
278  - default server for #VineUsers changed to OpenProjects Network's
279  * Wed Mar 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.8-0vl2
280  - now with 1.8.8 plus patch
281  * Sat Mar 16 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.8-0vl1
282  - upstream release
283  - updated vine-serverlist.patch
284  - stop to apply plus patch
285    ( xchat-1.8.4 has the security hole... )
286  * Tue Oct  2 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl3
287  - removed backup files for %%patch0 in Document Directory
288  * Sun Sep 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.8.4-0vl2
289  - updated to 1.8.4 release with plus patch :-)
290  * Sun Sep 30 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.8.4-0vl1
291  - upstream release
292  * Mon Sep  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
293  - 1.8.3-0vl1
294  - upstream release
295  - add xchat-text
296  - add docs: COPYING FAQ plugins/* scripts-perl/* scripts-python/*
297  * Fri Aug  3 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
298  - 1.8.2-0vl1
299  - upstream release
300  * Sat Jul 21 2001 <iwaim@cc.mbn.or.jp>
301  - 1.8.1-0vl1
302  - upstream release
303  - modified server.vine patch
304  * Sun Jul 15 2001 <sagami@vinelinux.org>
305  - 1.6.4.1-0vl3: prefix -> _prefix
306  - OLD_PO_FILE_INPUT=yes to build with new gettext
307  - use %%{find_lang}
308  * Wed Apr 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
309  - 1.6.4.1-0vl2
310  - fix CFLAGS for e-paned
311  * Tue Feb  6 2001 Takuo KITAME <kitame@northeye.org>
312  - 1.6.3.1-0vl1
313  - New upstream release
314  * Tue Oct 31 2000 Jun Nishii <jun@vinelinux.org>
315  - 1.5.9.4-0vl1
316  - This is the first release of xchat-plus.
317  * Mon Jul  3 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
318  - added w3m patch
319  * Wed Apr  12 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
320  - updated to 1.4.2
321  * Thu Mar  14 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
322  - updated to 1.4.1
323  - separated ja_nls patch to more_ja_nls and libjcode patches.
324  * Sat Mar  04 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
325  - modified mb_fix patch for cut & paste.
326  * Fri Feb  11 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
327  - updated to 1.4.0
328  * Wed Feb  2 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
329  - updated to 1.3.13
330  * Mon Jan 10 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
331  - modified mb_fix patch
332  * Wed Jan  5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
333  - updated to 1.3.10
334  * Wed Dec  8 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
335  - updated to 1.3.8
336  - added mb_fix patch
337  * Tue Nov  9 1999 Yasuyuki Furukawa <furukawa@vinelinux.org>
338  - update to 1.3.6
339  * Sun Oct 17 1999 Jun NISHII <jun@flatout.org>
340  - merge ja-patch
341
342* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-7
343- Added back BuildRequires autoconf, and call autoconf prior to ./configure
344  as it seems to make xchat build successfully.  Have not bothered to figure
345  out why calling autoconf is needed.  Something for a rainy day.
346
347* Thu May 29 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-6
348- Removed gnome-libs BuildRequires as it is bogus now
349- Removed autoconf BuildRequires and usage, as it should be unneeded
350- Added new BuildRequires on gettext, bison >= 1.35, glib2-devel >= 2.0.3,
351  gtk2-devel >= 2.0.3, /bin/sed  (#91676 - Warren Togami)
352- Removed dead patches: xchat-1.8.9-perlcrypt.patch, xchat-1.8.9-korean-fontset.patch
353
354* Wed May 21 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-5
355- Removed xchat.desktop file, as it was earlier replacedwith a patch
356- Converted xchat-2.0.2-redhat-desktop-file.patch to be UTF-8 clean now,
357  instead of the various random legacy mix of encodings it was, updating
358  the following: es, ko, uk, zh_TW
359
360* Tue May 20 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-4
361- Replace explicit perl package name-epoch-version Requires added in 2.0.2-3
362  with a more robust and generic solution of querying perl for the archlibexp
363  dir during building, and requiring it instead
364
365* Tue May 20 2003 Bill Nottingham <notting@redhat.com> 2.0.2-3
366- rebuild against new (old?) perl, add epoch to dependency
367
368* Sat May 17 2003 Mike A. Harris <mharris@redhat.com> 2.0.2-1
369- Updated to new xchat 2.0.2 based on GTK2
370- Dropped unneeded patches xchat-1.8.1-konqueror.patch,
371  xchat-1.8.4-fix-USE_GNOME.patch
372- Updated xchat-2.0.2-freenode.patch to refer to Openprojects.net
373- Removed doc/xchat.sgml doc/*.html scripts-python scripts-perl from %%doc
374- Added xchat-2.0.2-redhat-desktop-file.patch to patch the supplied xchat
375  desktop file, instead of replacing it and trying to stay in sync
376- Added xchat-2.0.2-lib64-cleanup-for-python.patch which fixes build problems
377  on lib64 archs, and replaces xchat-multilib.patch
378- Added with_tclplugin macro and default it to disabled
379
380* Mon Mar 17 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-8
381- Added xchat-1.8.11-nickall.patch which was written by Fabio Olive Leite,
382  sent to me by Rik van Riel
383
384* Wed Feb 19 2003 Bill Nottingham <notting@redhat.com> 1.8.11-7
385- ship single desktop in %{_datadir}/applications, not /etc/X11/applnk
386
387* Fri Jan 31 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-6
388- Added xchat-1.8.11-freenode.patch to rename all openprojects.net entries
389  to freenode.net in the default server list.  Patch courtesy of Dan Burcaw
390  from bug (#81704)
391
392* Wed Jan 22 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-5
393- Removed double .desktop file (#81874,82315)
394
395* Wed Jan 22 2003 Tim Powers <timp@redhat.com> 1.8.11-4
396- rebuilt
397
398* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-3
399- Add bugfix from xchat.org xc1811fixststint.diff
400
401* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-2
402- Remove CVS files from source dirs so they're not installed into doc dirs.
403
404* Tue Jan  7 2003 Mike A. Harris <mharris@redhat.com> 1.8.11-1
405- Update to xchat 1.8.11 bugfix release, fixes various runtime crashes
406- Remove now included patches: xchat-1.8.10-urlhandler-open-in-new-tab.patch,
407  xchat-1.8.10-beep-beep-beep.patch
408
409* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 1.8.10-13
410- Pick up OpenSSL configuration from pkgconfig, if available
411- Add openssl-devel and pkgconfig as buildreqs
412
413* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.8.10-12
414- Fix broken libpython path on multilibbed systems (patch13)
415- _smp_mflags
416
417* Tue Nov 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-11
418- Added xchat-1.8.10-urlhandler-open-in-new-tab.patch to offer the option of
419  opening a URL in a new tab of an existing browser window rather than a new
420  window
421
422* Sat Nov 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-10
423- Added BuildRequires: python-devel to hopefully pick up a missing dep
424  causing package build failure in timp's nightly builds.
425- Removed dead patches
426- Updated package summary and description to be more user friendly by
427  rewording, and removing scary words like GNOME, GTK and other irrelevance
428
429* Wed Nov 13 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-9
430- Made sure {_sysconfdir}/X11/applnk/Internet/xchat.desktop gets packaged
431- Removed some conditional weirdness in %%files list.  This may break xchat
432  erratum releases on Red Hat Linux 7.x.  May need to be fixed in future.
433
434* Fri Aug 23 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-7
435- Added Requires line so that xchat requires the exact version of perl
436  be installed, that was used to compile it, since the embedded perl
437  interpreter will break, if you upgrade perl
438
439* Thu Aug 15 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-6
440- Fix Bill's beep beep beep bug (#71651)
441
442* Wed Aug 14 2002 Jonathan Blandford <jrb@redhat.com> 1.8.10-5
443- actually install the desktop file.
444
445* Fri Aug  9 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-3
446- Added http://xchat.org/files/source/1.8/patches/xc1810fixme.diff to fix
447  bug with using /ME in a /QUERY window.  (#71179)
448
449* Wed Aug  7 2002 Mike A. Harris <mharris@redhat.com> 1.8.10-2
450- Updated to xchat 1.8.10 to fix a few bugs where a remote ircd could cause
451  the xchat client to crash.  This is a bugfix only release.
452
453* Tue Aug  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-10
454- Added Korean fontset support to fix bug (#69771)
455
456* Mon Aug  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-9
457- Enabled python scripting which was somehow disabled somewhere along the
458  line by default in upstream sources, and we missed catching it. (#70816)
459
460* Sun Aug  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-8
461- Created new-style net-xchat.desktop file (#69541)
462
463* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.8.9-7
464- automated rebuild
465
466* Tue Jun 18 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-6
467- updated the package description
468- Added CFLAGS and LDFLAGS export vars before configure to fix rpath problem
469
470* Sun May 26 2002 Tim Powers <timp@redhat.com>
471- automated rebuild
472
473* Mon May 20 2002 Mike A. Harris <mharris@redhat.com> 1.8.9-2
474- Updated to xchat 1.8.9
475
476* Mon Apr  8 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-5
477- Re-enabled GNOME support due to user complaints of pixmaps missing, key
478  bindings, and other fairly important features no longer working.
479
480* Tue Mar 27 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-4
481- Disabled GNOME support since it doesn't seem too useful anyways, and forces
482  all xchat users to install GNOME libs even if they use KDE. (#59626)
483- Updated URL and source lines in spec.
484
485* Wed Mar  6 2002 Mike A. Harris <mharris@redhat.com> 1.8.8-1
486- Updated to xchat 1.8.8
487
488* Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-6
489- Built in new buildroot
490
491* Tue Feb  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-5
492- Added xchat-1.8.7-use-sysconf-to-detect-cpus.patch to use glibc's sysconf()
493  to detect the number of processors available.
494
495* Mon Feb  4 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-4
496- Enabled IPv6 support as per the request for enhancement (#52124)
497
498* Thu Jan 24 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-3
499- Rebuilt in new build environment
500
501* Thu Jan 10 2002 Mike A. Harris <mharris@redhat.com> 1.8.7-2
502- Updated to xchat 1.8.7
503- New release fixes security vulnerability in CTCP reply
504- Built erratum for all supported releases (1.8.7-1.62.0, 1.8.7-1.70.0,
505  1.8.7-1.71.0, 1.8.7-1.72.0)
506- Removed konqueror patch as it is integrated now.
507
508* Sat Jan  5 2002 Mike A. Harris <mharris@redhat.com> 1.8.6-2
509- Enabled ssl support with --enable-openssl
510- Also built releases 1.72.0, 1.71.0, 1.70.0, 1.62.0 for erratum release
511
512* Mon Dec 10 2001 Mike A. Harris <mharris@redhat.com> 1.8.6-1
513- Updated to xchat 1.8.6
514
515* Tue Nov 13 2001 Mike A. Harris <mharris@redhat.com> 1.8.5-1
516- Updated to xchat 1.8.5
517- Added f to rm -r in install and clean sections
518
519* Sun Oct  7 2001 Mike A. Harris <mharris@redhat.com> 1.8.4-1
520- Updated to 1.8.4, now using tar.bz2
521- Removed kanjiconv-fix patch as it is integrated now
522- Added xchat-1.8.4-fix-USE_GNOME.patch to fix simple ifdef USE_GNOME typo
523
524* Fri Jul 13 2001 Akira TAGOH <tagoh@redhat.com> 1.8.1-2
525- fixed check locale.
526- don't save kanji_conv.
527  always check locale. however anyone can change the option from
528  the settings menu.
529
530* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
531- upgrade to 1.8.1
532- remove autoconnect patch since it's upstream
533- remove japanese patch, upstream seems to have applied
534  parts of it and changelog says there's upstream support.
535  (this patch was pretty huge to maintain in an SRPM anyway...)
536- put scripts-python scripts-perl in docs bug #28521
537- remove patch to include locale.h, gone upstream
538- upgrade konqueror patch
539
540* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
541- nevermind, BuildRequires gnome-libs, that should
542  close #48923
543
544* Thu Jul 12 2001 Havoc Pennington <hp@redhat.com>
545- fix file list to not include absolute path "/usr/share/..."
546  no idea how that ever worked at all. closes #48923
547
548* Mon Jun 25 2001 Karsten Hopp <karsten@redhat.de>
549- use konqueror, not kfmclient on URLs
550
551* Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
552- langify
553- use %%{_tmppath}
554- make it compile
555
556* Tue Feb 13 2001 Akira TAGOH <tagoh@redhat.com>
557- Added Japanese patch.
558
559* Tue Feb 13 2001 Havoc Pennington <hp@redhat.com>
560- patch that may fix autoconnections (bug 27093)
561
562* Mon Jan 22 2001 Havoc Pennington <hp@redhat.com>
563- 1.6.3
564- remove patch to desktop file (Internet->Application), seems to
565  have gone upstream
566
567* Sat Dec 9 2000 Havoc Pennington <hp@redhat.com>
568- Remove security fix which has been merged upstream
569- upgrade to 1.6.1
570
571* Sat Aug 19 2000 Havoc Pennington <hp@redhat.com>
572- Don't use /bin/sh to interpret URLs from the net
573
574* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
575- Updated Epoch
576
577* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
578- automatic rebuild
579
580* Mon Jun 19 2000 Havoc Pennington <hp@redhat.com>
581- Install HTML docs
582
583* Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
584- fix desktop entry
585
586* Fri May 19 2000 Havoc Pennington <hp@redhat.com>
587- rebuild for the Winston tree, update to 1.4.2
Note: See TracBrowser for help on using the repository browser.