source: projects/specs/branches/6/x/xarchiver/xarchiver-vl.spec @ 4335

Revision 4335, 8.5 KB checked in by kudoh, 13 years ago (diff)
Line 
1Name:           xarchiver
2Version:        0.5.2
3Release:        5%{?_dist_release}
4Summary:        Archive manager for Xfce
5Summary(ja):    Xfce のアーカイブマネージャ
6
7Group:          Applications/Archiving
8License:        GPLv2+
9URL:            http://xarchiver.xfce.org/
10Source0:        http://downloads.sourceforge.net/xarchiver/xarchiver-%{version}.tar.bz2
11
12Patch0:         xarchiver-0.5.2-no-donators-menu.patch
13Patch1:         xarchiver-0.5.2-default-archive-format.patch
14# add_xz_support.patch by Robby Workman taken from
15# http://slackbuilds.org/slackbuilds/13.1/system/xarchiver/xarchiver-0.5.2-add_xz_support.patch
16# sent upstream through
17# https://sourceforge.net/tracker/?func=detail&aid=2847624&group_id=140153&atid=745600
18Patch2:         xarchiver-0.5.2-add_xz_support.patch
19# rpm2cpio.patch by Daniel Hokka Zakrisson
20# taken from https://bugzilla.redhat.com/show_bug.cgi?id=577480
21# sent upstream through
22# https://sourceforge.net/tracker/?func=detail&aid=3310768&group_id=140153&atid=745602
23Patch3:         xarchiver-0.5.2-rpm2cpio.patch
24# segfault-open-with.patch by Bastiaan Jacques
25# taken from https://bugzilla.redhat.com/show_bug.cgi?id=690012
26# sent upstream through
27# https://sourceforge.net/tracker/?func=detail&aid=3310778&group_id=140153&atid=745600
28Patch4:         xarchiver-0.5.2-segfault-open-with.patch
29# fix-7z-support.patch by taken from
30# https://sourceforge.net/tracker/?func=detail&aid=3137589&group_id=140153&atid=745602
31Patch5:         xarchiver-0.5.2-fix_7z_support.patch
32
33BuildRoot:      %{_tmppath}/%{name}-%{version}-root
34
35BuildRequires:  gtk2-devel, libxml2-devel, gettext, desktop-file-utils
36BuildRequires:  glib2-devel >= 2.10.0 intltool >= 0.31 libtool
37#BuildRequires:  xfce4-dev-tools >= 4.3.90.2
38Requires:       binutils, bzip2, cpio, gzip, xdg-utils, tar, unzip, zip
39
40
41%description
42Xarchiver is a lightweight GTK2 only frontend for manipulating 7z, bzip2,
43gzip, iso, rar, lha, tar, zip, RPM and deb files. It allows you to create
44archives and add, extract, and delete files from them. Password protected
45archives in the 7z, rar, and zip formats are supported.
46
47
48%prep
49%setup -q
50# fix spurious executable permissions of some debug files
51chmod -x src/mime.*
52%patch0 -p2 -b .no-donators-menu
53%patch1 -p1 -b .default-archive-format
54%patch2 -p1 -b .add_xz_support
55%patch3 -p1 -b .rpm2cpio
56%patch4 -p1 -b .segfault-open-with
57%patch5 -p1 -b .fix_7z_support
58
59%build
60%configure
61make %{?_smp_mflags}
62
63
64%install
65rm -rf $RPM_BUILD_ROOT
66make install DESTDIR=$RPM_BUILD_ROOT
67
68# We need to install xarchiver.tap as fedora-xarchiver.tap, because the name
69# has to match the basename of the desktop-file in %{_datadir}/applications.
70rm $RPM_BUILD_ROOT%{_libexecdir}/thunar-archive-plugin/xarchiver.tap
71install -p -m 755 xarchiver.tap \
72   $RPM_BUILD_ROOT%{_libexecdir}/thunar-archive-plugin/vine-xarchiver.tap
73
74%find_lang %{name}
75desktop-file-install --vendor vine                         \
76        --dir ${RPM_BUILD_ROOT}%{_datadir}/applications         \
77        --add-category="Utility"                            \
78        --add-mime-type="application/x-xz"                      \
79        --add-mime-type="application/x-xz-compressed-tar"       \
80        --remove-mime-type="multipart/x-zip"                    \
81        --delete-original                                       \
82        ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
83
84# remove duplicate docs
85rm $RPM_BUILD_ROOT%{_docdir}/%{name}/{AUTHORS,COPYING,ChangeLog,NEWS,README,TODO}
86
87
88%post
89touch --no-create %{_datadir}/icons/hicolor
90if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
91  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
92fi
93update-desktop-database &> /dev/null || :
94
95
96%postun
97touch --no-create %{_datadir}/icons/hicolor
98if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
99  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
100fi
101update-desktop-database &> /dev/null || :
102
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107
108%files -f %{name}.lang
109%defattr(-,root,root,-)
110%doc AUTHORS COPYING ChangeLog NEWS README TODO
111%doc %{_docdir}/%{name}/
112%{_bindir}/%{name}
113%{_datadir}/applications/vine-%{name}.desktop
114%{_datadir}/icons/hicolor/*/apps/%{name}.png
115%{_datadir}/icons/hicolor/scalable/apps/%{name}.svg
116%dir %{_datadir}/pixmaps/%{name}/
117%{_datadir}/pixmaps/%{name}/%{name}*.png
118%dir %{_libexecdir}/thunar-archive-plugin/
119%{_libexecdir}/thunar-archive-plugin/vine-xarchiver.tap
120
121
122%changelog
123* Wed Jul 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-5
124- re-imported Fedora development patches
125- fixed desktop-file-install section
126  - added mime-type="application/x-xz" and "application/x-xz-compressed-tar"
127  - deleted mime-type="multipart/x-zip"
128
129* Fri Jun 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-4
130- added patch0,1,2,3,4,5 from Fedora development
131- added BuildRequires: libtool
132
133* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-3
134- fixed desktop-file-install --add-category section
135- added BuildRequires: glib2-devel >= 2.10.0 intltool >= 0.31
136
137* Sun Apr 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-2vl5
138- fixed BuildRoot tag
139
140* Mon Mar 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1vl5
141- initial release for VineSeed (import Fedora Package)
142
143* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.2-3
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
145
146* Tue Nov 25 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.2-2
147- Include HTML documentation
148
149* Tue Nov 25 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.2-1
150- Update to 0.5.2
151
152* Sun Nov 09 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.1-1
153- Update to 0.5.1 stable release
154
155* Sun Oct 26 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.rc1
156- Update to 0.5.0rc1
157- Fix crash when opening zipped PDF files (#467619)
158- Update gtk-icon-cache scriptlets
159
160* Sat Oct 11 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.beta2
161- Update to 0.5.0beta2
162
163* Sun Aug 31 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.5.0-0.1.beta1
164- Update to 0.5.0beta1
165- Remove xdg-open.patch as xarchiver now uses xdg-open by default
166
167* Sat Apr 19 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.6.20070103svn24249
168- Remove additional mime-types from desktop-file-install to make sure we don't break livecds
169
170* Fri Mar 14 2008 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.5.20070103svn24249
171- Use xdg-open instead of htmlview (#437554)
172
173* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.9-0.4.20070103svn24249
174- Autorebuild for GCC 4.3
175
176* Tue Aug 28 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.3.20070103svn24249
177- Rebuild for BuildID feature
178- Update license tag
179
180* Fri Mar 02 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.2.20070103svn24249
181- Downgrade to SVN release 24249 in order to fix #230154 temporarily.
182
183* Sun Jan 28 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20070128svn24772
184- Update to SVN release 24772 of January 28th 2007.
185
186* Wed Jan 03 2007 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20070103svn
187- Update to SVN r24249 of January 3rd 2007.
188- Add mimetype application/x-deb again since opening of debs now is secure.
189
190* Wed Dec 13 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.9-0.1.20061213svn
191- Update to SVN r24096 of December 13th 2006.
192
193* Wed Dec 06 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-3
194- Add deb.patch to prevent opening of .a files as debs.
195- Don't add mimetype for x-ar (archiver can't handle ar archive).
196
197* Wed Nov 29 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-2
198- Add htmlview.patch.
199
200* Tue Nov 28 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.6-1
201- Update to 0.4.6.
202- Update %%description.
203- Require binutils, cpio and htmlview.
204- Add mimetypes application/x-ar, application/x-cd-image and application/x-deb.
205
206* Tue Nov 27 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.4-1
207- Update to 0.4.4.
208
209* Sat Nov 25 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.3.rc2
210- Install xarchiver.png also in %%{_datadir}/icons/hicolor/48x48/apps/.
211
212* Sat Nov 25 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.2.rc2
213- Drop subpackage and own %%{_libexecdir}/thunar-archive-plugin/ (#198098).
214
215* Sun Nov 12 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.2-0.1.rc2
216- Update to 0.4.2.RC2.
217
218* Wed Sep 13 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.4.0-1
219- Update to 0.4.0.
220
221* Tue Sep 05 2006 Christoph Wickert <cwickert@fedoraproject.org> - 0.3.9.2-0.beta2
222- Initial package.
Note: See TracBrowser for help on using the repository browser.