source: projects/specs/branches/6/x/xalan-j2/xalan-j2-vl.spec @ 5569

Revision 5569, 16.9 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1# Copyright (c) 2000-2005, JPackage Project
2# All rights reserved.
3#
4# Redistribution and use in source and binary forms, with or without
5# modification, are permitted provided that the following conditions
6# are met:
7#
8# 1. Redistributions of source code must retain the above copyright
9#    notice, this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright
11#    notice, this list of conditions and the following disclaimer in the
12#    documentation and/or other materials provided with the
13#    distribution.
14# 3. Neither the name of the JPackage Project nor the names of its
15#    contributors may be used to endorse or promote products derived
16#    from this software without specific prior written permission.
17#
18# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
19# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
20# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
21# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
22# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
23# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
24# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
25# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
26# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
27# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
28# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
29#
30
31%define section free
32%define cvs_version 2_7_1
33
34Name:           xalan-j2
35Summary:        Java XSLT processor
36Summary(ja):    Java XSLT プロセッサ
37Version:        2.7.1
38Release:        3%{?_dist_release}
39
40Group:          Development/Libraries
41# samples/servlet/ApplyXSLTException.java is ASL 1.1
42# src/org/apache/xpath/domapi/XPathStylesheetDOM3Exception.java is W3C
43License:        ASL 1.1 and ASL 2.0 and W3C
44URL:            http://xalan.apache.org/
45
46# using binary for bootstrap
47#Source0:        http://www.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-src.tar.gz
48Source0:        http://www.apache.org/dist/xml/xalan-j/xalan-j_2_7_1-bin-2jars.tar.gz
49#Source1:        %{name}-serializer-MANIFEST.MF
50#Patch0:         %{name}-noxsltcdeps.patch
51#Patch1:         %{name}-manifest.patch
52#Patch2:         %{name}-crosslink.patch
53#This patch uses xalan-j2-serializer.jar in the MANIFEST files instead of serializer
54#Patch3:                %{name}-src-MANIFEST-MF.patch
55
56BuildRoot:      %{_tmppath}/%{name}-%{version}-root
57
58BuildArch:      noarch
59Provides:       jaxp_transform_impl
60Requires:       jaxp_parser_impl
61Requires(post):  alternatives
62Requires(preun): alternatives
63#BuildRequires:  jpackage-utils >= 0:1.6
64#BuildRequires: java-devel
65#BuildRequires:  ant
66#BuildRequires:  bcel
67#BuildRequires: jlex
68#BuildRequires: java_cup
69#BuildRequires: regexp
70#BuildRequires: sed
71#BuildRequires: servlet25
72#BuildRequires:  xerces-j2 >= 0:2.7.1
73#BuildRequires:  xml-commons-apis >= 0:1.3
74#BuildRequires:  xml-stylebook
75
76%description
77Xalan is an XSLT processor for transforming XML documents into HTML,
78text, or other XML document types. It implements the W3C Recommendations
79for XSL Transformations (XSLT) and the XML Path Language (XPath). It can
80be used from the command line, in an applet or a servlet, or as a module
81in other program.
82
83#%package        xsltc
84#Summary:        XSLT compiler
85#Group:          Text Processing/Markup/XML
86#Requires:       java_cup
87#Requires:      bcel
88#Requires:      jlex
89#Requires:      regexp
90#Requires:      jaxp_parser_impl
91#
92#%description    xsltc
93#The XSLT Compiler is a Java-based tool for compiling XSLT stylesheets into
94#lightweight and portable Java byte codes called translets.
95
96%package        manual
97Summary:        Manual for %{name}
98Group:          Documentation
99
100%description    manual
101Documentation for %{name}.
102
103#%package        javadoc
104#Summary:        Javadoc for %{name}
105#Group:          Development/Documentation
106#BuildRequires:  java-javadoc
107## for /bin/rm and /bin/ln
108#Requires(post):                coreutils
109#Requires(postun):      coreutils
110#
111#%description    javadoc
112#Javadoc for %{name}.
113
114#%package        demo
115#Summary:        Demo for %{name}
116#Group:          Text Processing/Markup/XML
117#Requires:       %{name} = %{epoch}:%{version}-%{release}, servlet25
118#
119#%description    demo
120#Demonstrations and samples for %{name}.
121
122%prep
123%setup -q -n xalan-j_%{cvs_version}
124
125%build
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130# jars
131install -d -m 755 $RPM_BUILD_ROOT%{_javadir}
132install -p -m 644 xalan.jar \
133  $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
134install -p -m 644 xsltc.jar \
135  $RPM_BUILD_ROOT%{_javadir}/xsltc-%{version}.jar
136install -p -m 644 serializer.jar \
137  $RPM_BUILD_ROOT%{_javadir}/%{name}-serializer-%{version}.jar
138(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
139
140# javadoc
141#install -d -m 755 $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
142#cp -pr build/docs/apidocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
143#ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
144#rm -rf build/docs/apidocs
145
146# demo
147#install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/%{name}
148#install -p -m 644 build/xalansamples.jar \
149#  $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-samples.jar
150#install -p -m 644 build/xalanservlet.war \
151#  $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}-servlet.war
152#cp -pr samples $RPM_BUILD_ROOT%{_datadir}/%{name}
153
154# fix link between manual and javadoc
155#(cd build/docs; ln -sf %{_javadocdir}/%{name}-%{version} apidocs)
156
157# jaxp_transform_impl ghost symlink
158ln -s %{_sysconfdir}/alternatives \
159  $RPM_BUILD_ROOT%{_javadir}/jaxp_transform_impl.jar
160
161
162%clean
163rm -rf $RPM_BUILD_ROOT
164
165
166%post
167/sbin/update-alternatives --install %{_javadir}/jaxp_transform_impl.jar \
168  jaxp_transform_impl %{_javadir}/%{name}.jar 30
169
170%preun
171{
172  [ $1 = 0 ] || exit 0
173  /sbin/update-alternatives --remove jaxp_transform_impl %{_javadir}/%{name}.jar
174} >/dev/null 2>&1 || :
175
176#%post javadoc
177#rm -f %{_javadocdir}/%{name}
178#ln -s %{name}-%{version} %{_javadocdir}/%{name}
179
180#%postun javadoc
181#if [ "$1" = "0" ]; then
182#    rm -f %{_javadocdir}/%{name}
183#fi
184
185%files
186%defattr(0644,root,root,0755)
187%doc LICENSE.txt NOTICE.txt readme.html
188%{_javadir}/%{name}-%{version}.jar
189%{_javadir}/%{name}.jar
190%{_javadir}/%{name}-serializer-%{version}.jar
191%{_javadir}/%{name}-serializer.jar
192%ghost %{_javadir}/jaxp_transform_impl.jar
193
194#%files xsltc
195#%defattr(0644,root,root,0755)
196%{_javadir}/xsltc-%{version}.jar
197%{_javadir}/xsltc.jar
198#%ghost %{_javadir}/jaxp_transform_impl.jar
199
200%files manual
201%defattr(0644,root,root,0755)
202%doc docs/*
203
204#%files javadoc
205#%defattr(0644,root,root,0755)
206#%doc %{_javadocdir}/%{name}-%{version}
207#%ghost %doc %{_javadocdir}/%{name}
208
209#%files demo
210#%defattr(0644,root,root,0755)
211#%{_datadir}/%{name}
212
213%changelog
214* Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.7.1-3
215- rebuild with Vine6 environment
216
217* Mon Aug 30 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.7.1-2
218- Initial build for VineLinux
219- using binary package for bootstrap
220
221* Wed Apr 7 2010 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.1-1
222- Update to 2.7.1.
223- Drop gcj_support.
224
225* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-9.5
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
227
228* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:2.7.0-8.5
229- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
230
231* Tue Feb 3 2009 Alexander Kurtakov <akurtako@redhat.com> 0:2.7.0-7.5
232- Add osgi manifest.
233
234* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0:2.7.0-7.4
235- fix license tag
236
237* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:2.7.0-7.3
238- drop repotag
239- fix license tag
240
241* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:2.7.0-7jpp.2
242- Autorebuild for GCC 4.3
243
244* Fri Apr 20 2007 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.2.fc7
245- Rebuild to fix incomplete .db/so files due to broken aot-compile-rpm
246
247* Fri Aug 18 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-6jpp.1
248- Resync with latest from JPP.
249
250* Fri Aug 11 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.3
251- Rebuild.
252
253* Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.2
254- Rebuild.
255
256* Thu Aug 10 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-5jpp.1
257- Resync with latest from JPP.
258- Partially adopt new naming convention (.1 suffix).
259- Use ln and rm explicitly instead of core-utils in Requires(x).
260
261* Thu Aug 10 2006 Karsten Hopp <karsten@redhat.de> 2.7.0-4jpp_5fc
262- Requires(post):     coreutils
263
264* Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_4fc
265- Extend patch to cover all applicable MANIFEST files in src directory.
266
267* Wed Jul 26 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_3fc
268- Apply patch to replace serializer.jar in MANIFEST file with
269  xalan-j2-serializer.jar.
270
271* Sat Jul 22 2006 Jakub Jelinek <jakub@redhat.com> - 0:2.7.0-4jpp_2fc
272- Rebuilt
273
274* Fri Jul 21 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-4jpp_1fc
275- Resync with latest JPP version.
276
277* Wed Jul 19 2006 Vivek Lakshmanan <vivekl@redhat.com> - 0:2.7.0-3jpp_1fc
278- Merge with latest version from jpp.
279- Undo ExcludeArch since eclipse available for all arch-es.
280- Remove jars from sources for new upstream version.
281- Purge unused patches from previous release.
282- Conditional native compilation with GCJ.
283- Use NVR macros wherever possible.
284
285* Wed Mar  8 2006 Rafael Schloming <rafaels@redhat.com> - 0:2.6.0-3jpp_10fc
286- excluded s390[x] and ppc64 due to eclipse
287
288* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 0:2.6.0-3jpp_9fc
289- stop scriptlet spew
290
291* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_8fc
292- bump again for double-long bug on ppc(64)
293
294* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0:2.6.0-3jpp_7fc
295- rebuilt for new gcc4.1 snapshot and glibc changes
296
297* Wed Dec 21 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_6fc
298- rebuild again
299
300* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.3
301- patch to not use target= in build.xml
302
303* Tue Dec 13 2005 Jesse Keating <jkeating@redhat.com> 0:2.6.0-3jpp_5fc.1
304- rebuild again with gcc-4.1
305
306* Fri Dec 09 2005 Warren Togami <wtogami@redhat.com> 0:2.6.0-3jpp_5fc
307- rebuild with gcc-4.1
308
309* Tue Nov  1 2005 Archit Shah <ashah at redhat.com> 0:2.6.0-3jpp_4fc
310- Exclude war which blocks aot compilation of main jar (#171005).
311
312* Tue Jul 19 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_3fc
313- Build on ia64, ppc64, s390 and s390x.
314- Switch to aot-compile-rpm (also BC-compiles xsltc and samples).
315
316* Tue Jun 28 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_2fc
317- Remove a tarball from the tarball too.
318- Fix demo subpackage's dependencies.
319
320* Wed Jun 15 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp_1fc
321- Remove jarfiles from the tarball.
322
323* Fri May 27 2005 Gary Benson <gbenson at redhat.com> 0:2.6.0-3jpp
324- Add NOTICE file as per Apache License version 2.0.
325- Build with servletapi5.
326
327* Fri May 27 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_3fc
328- Remove now-unnecessary workaround for #130162.
329- Rearrange how BC-compiled stuff is built and installed.
330
331* Tue May 24 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_2fc
332- Add DOM3 stubs to classes that need them (#152255).
333- BC-compile the main jarfile.
334
335* Fri Apr  1 2005 Gary Benson <gbenson@redhat.com>
336- Add NOTICE file as per Apache License version 2.0.
337
338* Wed Jan 12 2005 Gary Benson <gbenson@redhat.com> 0:2.6.0-2jpp_1fc
339- Sync with RHAPS.
340
341* Mon Nov 15 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-2jpp_1rh
342- Merge with latest community release
343
344* Thu Nov  4 2004 Gary Benson <gbenson@redhat.com> 0:2.6.0-1jpp_2fc
345- Build into Fedora.
346
347* Thu Aug 26 2004 Ralph Apel <r.ape at r-apel.de> 0:2.6.0-2jpp
348- Build with ant-1.6.2
349- Try with -Djava.awt.headless=true
350
351* Mon Jul 26 2004 Fernando Nasser <fnasser@redhat.com> 0:2.6.0-1jpp_1rh
352- Merge with latest community version
353
354* Fri Mar 26 2004 Frank Ch. Eigler <fche@redhat.com> 0:2.5.2-1jpp_2rh
355- add RHUG upgrade cleanup
356
357* Tue Mar 23 2004 Kaj J. Niemi <kajtzu@fi.basen.net> 0:2.6.0-1jpp
358- Updated to 2.6.0
359- Patches supplied by <aleksander.adamowski@altkom.pl>
360
361* Thu Mar  4 2004 Frank Ch. Eigler <fche@redhat.com> - 0:2.5.2-1jpp_1rh
362- RH vacuuming
363
364* Sat Nov 15 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.2-1jpp
365- Update to 2.5.2.
366- Re-enable javadocs, new style versionless symlink handling, crosslink
367  with local J2SE javadocs.
368- Spec cleanups.
369
370* Sat Jun  7 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:2.5.1-1jpp
371- Update to 2.5.1.
372- Fix jpackage-utils version in BuildRequires, add xerces-j2.
373- Non-versioned javadoc symlinking.
374- Add one missing epoch.
375- Clean up manifests from Class-Path's and other stuff we don't include.
376- xsltc no longer provides a jaxp_transform_impl because of huge classpath
377  and general unsuitablity for production-use, system-installed transformer.
378- Own (ghost) %%{_javadir}/jaxp_transform_impl.jar.
379- Remove alternatives in preun instead of postun.
380- Disable javadoc subpackage for now:
381  <http://issues.apache.org/bugzilla/show_bug.cgi?id=20572>
382
383* Thu Mar 27 2003 Nicolas Mailhot <Nicolas.Mailhot@One2team.com> 0:2.5.0.d1-1jpp
384- For jpackage-utils 1.5
385
386* Wed Jan 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 2.4.1-2jpp
387- bsf -> oldbsf.
388- Use non-versioned jar in alternative, don't remove it on upgrade.
389- Remove hardcoded packager tag.
390
391* Mon Nov 04 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4.1-1jpp
392- 2.4.1
393
394* Tue Sep 10 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4.0-1jpp
395- 2.4.0.
396
397* Thu Aug 22 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.4-0.D1.3jpp
398- corrected case for Group tag
399- fixed servlet classpath
400
401* Tue Aug 20 2002 Ville Skyttä <ville.skytta at iki.fi> 2.4-0.D1.2jpp
402- Remove xerces-j1 runtime dependency.
403- Add bcel, jlex, regexp to xsltc runtime requirements:
404  <http://xml.apache.org/xalan-j/xsltc_usage.html>
405- Build with -Dbuild.compiler=modern (IBM 1.3.1) to avoid stylebook errors.
406- XSLTC now provides jaxp_transform_impl too.
407- Earlier changes by Henri, from unreleased 2.4-D1.1jpp:
408    Mon Jul 15 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.4-D1.1jpp
409  - 2.4D1
410  - use the jlex 1.2.5-5jpp (patched by Xalan/XSLTC team) rpm
411  - use the stylebook-1.0-b3_xalan-2.jar included in source file till it will
412    be packaged in jpackage
413  - use jaxp_parser_impl (possibly xerces-j2) instead of xerces-j1 for docs
414    generation, since it's tuned for stylebook-1.0-b3_xalan-2.jar
415  - build and provide xsltc in a separate rpm
416
417* Mon Jul 01 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-2jpp
418- provides jaxp_transform_impl
419- requires jaxp_parser_impl
420- stylebook already requires xml-commons-apis
421- jaxp_parser_impl already requires xml-commons-apis
422- use sed instead of bash 2.x extension in link area to make spec compatible with distro using bash 1.1x
423
424* Wed Jun 26 2002 Henri Gomez <hgomez@users.sourceforge.net> 2.3.1-2jpp
425- fix built classpath (bsf, bcel are existing jpackage rpms),
426- add buildrequires for javacup and JLex
427
428* Wed May 08 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.1-1jpp
429- 2.3.1
430- vendor, distribution, group tags
431
432* Mon Mar 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-2jpp
433- generic servlet support
434
435* Wed Feb 20 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.3.0-1jpp
436- 2.3.0
437- no more compat jar
438
439* Sun Jan 27 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-2jpp
440- adaptation to new stylebook1.0b3 package
441- used source tarball
442- section macro
443
444* Fri Jan 18 2002 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.0-1jpp
445- 2.2.0 final
446- versioned dir for javadoc
447- no dependencies for manual and javadoc packages
448- stricter dependency for compat and demo packages
449- fixed package confusion
450- adaptation for new servlet3 package
451- requires xerces-j1 instead of jaxp_parser
452- xml-apis jar now in required xml-commons-apis external package
453
454* Wed Dec 5 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D14-1jpp
455- 2.2.D14
456- javadoc into javadoc package
457- compat.jar into compat package
458- compat javadoc into compat-javadoc package
459
460* Wed Nov 21 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-2jpp
461- changed extension to jpp
462- prefixed xml-apis
463
464* Tue Nov 20 2001 Christian Zoffoli <czoffoli@littlepenguin.org> 2.2.D13-1jpp
465- 2.2.D13
466- removed packager tag
467
468* Sat Oct 6 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D11-1jpp
469- 2.2.D11
470
471* Sun Sep 30 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-2jpp
472- first unified release
473- s/jPackage/JPackage
474
475* Fri Sep 14 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D10-1mdk
476- cvs references
477- splitted demo package
478- moved demo files to %{_datadir}/%{name}
479- only manual package requires stylebook-1.0b3
480- only demo package requires servletapi3
481
482* Wed Aug 22 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D9-1mdk
483- 2.2.9
484- used new source packaging policy
485- added samples data
486
487* Wed Aug 08 2001 Guillaume Rousse <guillomovitch@users.sourceforge.net> 2.2.D6-1mdk
488- first Mandrake release
Note: See TracBrowser for help on using the repository browser.