source: projects/specs/branches/6/w/wxPython/wxPython-vl.spec @ 6073

Revision 6073, 10.1 KB checked in by munepi, 12 years ago (diff)

updated wxPython-vl.spec

Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4%define buildflags WXPORT=gtk2 UNICODE=1
5
6Name:           wxPython
7Version:        2.8.12.1
8Release:        1%{?dist}
9
10Summary:        GUI toolkit for the Python programming language
11
12Group:          Development/Languages
13License:        LGPLv2+ and wxWidgets
14URL:            http://www.wxpython.org/
15Source0:        http://downloads.sourceforge.net/wxpython/%{name}-src-%{version}.tar.bz2
16# fix aui imports
17# http://trac.wxwidgets.org/ticket/12107
18Patch0:         wxPython-2.8.12.0-aui.patch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
20# make sure to keep this updated as appropriate
21BuildRequires:  wxGTK-devel >= 2.8.11
22BuildRequires:  python-devel
23BuildRequires:  gtk2-devel
24BuildRequires:  mesa-libGL-devel mesa-libGLU-devel
25
26# packages should depend on "wxPython", not "wxPythonGTK2", but in case
27# one does, here's the provides for it.
28Provides:       wxPythonGTK2 = %{version}-%{release}
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34wxPython is a GUI toolkit for the Python programming language. It allows
35Python programmers to create programs with a robust, highly functional
36graphical user interface, simply and easily. It is implemented as a Python
37extension module (native code) that wraps the popular wxWindows cross
38platform GUI library, which is written in C++.
39
40%package        devel
41Group:          Development/Libraries
42Summary:        Development files for wxPython add-on modules
43Requires:       %{name} = %{version}-%{release}
44Requires:       wxGTK-devel
45
46%description devel
47This package includes C++ header files and SWIG files needed for developing
48add-on modules for wxPython. It is NOT needed for development of most
49programs which use the wxPython toolkit.
50
51%package        docs
52Group:          Documentation
53Summary:        Documentation and samples for wxPython
54Requires:       %{name} = %{version}-%{release}
55BuildArch:      noarch
56
57%description docs
58Documentation, samples and demo application for wxPython.
59
60
61%prep
62%setup -q -n wxPython-src-%{version}
63%patch0 -p1 -b .aui
64
65# fix libdir otherwise additional wx libs cannot be found
66%__sed -i -e 's|/usr/lib|%{_libdir}|' wxPython/config.py
67
68
69%build
70# Just build the wxPython part, not all of wxWindows which we already have
71# in Fedora
72cd wxPython
73# included distutils is not multilib aware; use normal
74%__rm -rf distutils
75python setup.py %{buildflags} build
76
77
78%install
79%__rm -rf $RPM_BUILD_ROOT
80cd wxPython
81python setup.py %{buildflags} install --root=$RPM_BUILD_ROOT
82
83# this is a kludge....
84%if "%{python_sitelib}" != "%{python_sitearch}"
85%__mv $RPM_BUILD_ROOT%{python_sitelib}/wx.pth  $RPM_BUILD_ROOT%{python_sitearch}
86%__mv $RPM_BUILD_ROOT%{python_sitelib}/wxversion.py* $RPM_BUILD_ROOT%{python_sitearch}
87%endif
88
89%clean
90%__rm -rf $RPM_BUILD_ROOT
91
92
93%files
94%defattr(-,root,root,-)
95%doc wxPython/licence
96%{_bindir}/*
97%{python_sitearch}/wx.pth
98%{python_sitearch}/wxversion.py*
99%dir %{python_sitearch}/wx-2.8-gtk2-unicode/
100%{python_sitearch}/wx-2.8-gtk2-unicode/wx
101%{python_sitearch}/wx-2.8-gtk2-unicode/wxPython
102%{python_sitelib}/*egg-info
103%{python_sitearch}/wx-2.8-gtk2-unicode/*egg-info
104
105%files devel
106%defattr(-,root,root,-)
107%dir %{_includedir}/wx-2.8/wx/wxPython
108%{_includedir}/wx-2.8/wx/wxPython/*.h
109%dir %{_includedir}/wx-2.8/wx/wxPython/i_files
110%{_includedir}/wx-2.8/wx/wxPython/i_files/*.i
111%{_includedir}/wx-2.8/wx/wxPython/i_files/*.py*
112%{_includedir}/wx-2.8/wx/wxPython/i_files/*.swg
113
114%files docs
115%defattr(-,root,root,-)
116%doc wxPython/docs wxPython/demo wxPython/samples
117
118
119%changelog
120* Fri Apr  6 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.1-1
121- updated to 2.8.12.1
122
123* Sun May 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.8.12.0-1
124- initial build based on Fedora rawhide
125
126* Tue Apr 26 2011 Dan Horák <dan[at]danny.cz> - 2.8.12.0-1
127- update to 2.8.12.0 (#699207)
128
129* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.11.0-5
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
131
132* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.8.11.0-4
133- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
134
135* Mon Jul 12 2010 Dan Horák <dan@danny.cz> - 2.8.11.0-3
136- rebuilt against wxGTK-2.8.11-2
137
138* Sun Jul 11 2010 Lubomir Rintel <lkundrak@v3.sk> - 2.8.11.0-2
139- Include egg-info when build on recent RHEL
140
141* Mon May 31 2010 Dan Horák <dan[at]danny.cz> - 2.8.11.0-1
142- update to 2.8.11.0 (#593837, #595936, #597639)
143
144* Sun May  2 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-3
145- rebuilt with wxGTK 2.8.11
146
147* Wed Mar 17 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-2
148- add missing module (#573961)
149
150* Sat Jan 16 2010 Dan Horák <dan[at]danny.cz> - 2.8.10.1-1
151- update to 2.8.10.1
152- backport to wxGTK 2.8.10 API
153- cleaned up BRs
154
155* Thu Jan  7 2010 Hans de Goede <hdegoede@redhat.com> - 2.8.9.2-4
156- Change python_foo macros to use %%global as the new rpm will break
157  using %%define here, see:
158  https://www.redhat.com/archives/fedora-devel-list/2010-January/msg00093.html
159
160* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.2-3
161- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
162
163* Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-2
164- add patch to fix compile failure for contrib/gizmos/_treelist.i
165
166* Fri Apr 10 2009 Dan Horák <dan[at]danny.cz> - 2.8.9.2-1
167- update to 2.8.9.2
168- create noarch docs subpackage
169
170* Thu Mar  5 2009 Lubomir Rintel <lkundrak@v3.sk> - 2.8.9.1-4
171- Rebuilt for newer wxgtk package
172
173* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.9.1-3
174- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
175
176* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.8.9.1-2
177- Rebuild for Python 2.6
178
179* Tue Sep 30 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.1-1
180- update to 2.8.9.1
181- fix libdir for additional wx libraries (#306761)
182
183* Mon Sep 29 2008 Dan Horak <dan[at]danny.cz> - 2.8.9.0-1
184- update to 2.8.9.0
185
186* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.8.8.0-2
187- fix license tag
188
189* Thu Jul 31 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.8.0-1
190- update to 2.8.8.0 (bug #457408)
191- a fix for bug #450073 is included in the upstream release, so
192  dropping that patch.
193
194* Thu Jun 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> - 2.8.7.1-5
195- Fix an attribute error when importing wxPython (compat) module
196  (redhat bugzilla 450073, 450074)
197
198* Sat Jun  6 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-4
199- gratuitously bump package release number to work around build system
200  glitch. again, but it will work this time.
201
202* Wed Jun  4 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-3
203- gratuitously bump package release number to work around build system
204  glitch
205
206* Thu Feb 21 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-2
207- include egg-info files for fedora 9 or greater
208
209* Wed Feb 20 2008 Matthew Miller <mattdm@mattdm.org> - 2.8.7.1-1
210- update to 2.8.7.1
211
212* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.8.4.0-3
213- Autorebuild for GCC 4.3
214
215* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.8.4.0-2
216- Rebuild for selinux ppc32 issue.
217
218* Wed Jul 11 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.4.0-1
219- update to 2.8.4.0
220- obsolete compat-wxPythonGTK
221
222* Sun Apr 15 2007 Matthew Miller <mattdm@mattdm.org> - 2.8.3.0-1
223- update to 2.8.3.0
224
225* Fri Dec 15 2006 Matthew Miller <mattdm@mattdm.org> - 2.8.0.1-1
226- update to 2.8.0.1
227- make buildrequire wxGTK of version-wxpythonsubrelease
228- add wxaddons to filelist
229
230* Mon Dec 11 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-3
231- bump release for rebuild against python 2.5.
232
233* Mon Aug 28 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-2
234- bump release for FC6 rebuild
235
236* Thu Apr 13 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.2-1
237- version 2.6.3.2
238- move wxversion.py _into_ lib64. Apparently that's the right thing to do. :)
239- upstream tarball no longer includes embedded.o (since I finally got around
240  to pointing that out to the developers instead of just kludging it away.)
241- buildrequires to just libGLU-devel instead of mesa-libGL-devel
242
243* Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-4
244- grr. bump relnumber.
245
246* Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-3
247- oh yeah -- wxversion.py not lib64.
248
249* Fri Mar 31 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-2
250- buildrequires mesa-libGLU-devel
251
252* Thu Mar 30 2006 Matthew Miller <mattdm@mattdm.org> - 2.6.3.0-1
253- update to 2.6.3.0
254- wxGTK and wxPython versions are inexorably linked; make BuildRequires
255  be exact, rather than >=.
256- make devel subpackage as per comment #7 in bug #163440.
257
258* Thu Nov 24 2005 Matthew Miller <mattdm@mattdm.org> - 2.6.1.0-1
259- update to 2.6.0.0
260- merge in changes from current extras 2.4.x package
261- Happy Thanksgiving
262- build animate extention again -- works now.
263
264* Thu Apr 28 2005 Matthew Miller <mattdm@bu.edu> - 2.6.0.0-bu45.1
265- get rid of accidental binaries in source tarball -- they generates
266  spurious dependencies and serve no purpose
267- update to 2.6.0.0 and build for Velouria
268- switch to Fedora Extras base spec file
269- enable gtk2 and unicode and all the code stuff (as FE does)
270- disable BUILD_ANIMATE extension from contrib -- doesn't build
271- files are in a different location now -- adjust to that
272- zap include files (needed only for building wxPython 3rd-party modules),
273  because I don't think this is likely to be very useful. Other option
274  would be to create a -devel package, but I think that'd be confusing.
275
276* Tue Feb 08 2005 Thorsten Leemhuis <fedora at leemhuis dot info> 0:2.4.2.4-4
277- remove included disutils - it is not multilib aware; this
278  fixes build on x86_64
279
280* Tue Jan 06 2004 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.3
281- rename package to wxPythonGTK2, provide wxPython (see bug 927)
282- dont ship binaries in /usr/share
283
284* Thu Nov 20 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.2
285- add missing buildrequires: python-devel, wxGTK2-gl
286
287* Sun Nov 02 2003 Panu Matilainen <pmatilai@welho.com> 0:2.4.2.4-0.fdr.1
288- Initial RPM release.
289~
Note: See TracBrowser for help on using the repository browser.