source: projects/specs/branches/6/w/wpa_supplicant/wpa_supplicant-vl.spec @ 2483

Revision 2483, 10.3 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1Summary: WPA/WPA2/IEEE 802.1X Supplicant
2Name: wpa_supplicant
3Version: 0.7.3
4Release: 2%{?_dist_release}
5License: BSD
6Group: System Environment/Base
7URL: http://w1.fi/wpa_supplicant/
8
9Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
10Source1: %{name}.build-config
11Source2: %{name}.conf
12Source3: %{name}.init.d
13Source4: %{name}.sysconfig
14Source6: %{name}.logrotate
15
16# import from Fedora package
17# distro specific customization and not suitable for upstream,
18# works around busted drivers
19Patch0: wpa_supplicant-assoc-timeout.patch
20# ensures that debug output gets flushed immediately to help diagnose driver
21# bugs, not suitable for upstream
22Patch1: wpa_supplicant-flush-debug-output.patch
23# disto specific customization for log paths, not suitable for upstream
24Patch2: wpa_supplicant-dbus-service-file-args.patch
25# quiet an annoying and frequent syslog message
26Patch3: wpa_supplicant-quiet-scan-results-message.patch
27# recover from streams of driver disconnect messages (iwl3945)
28Patch4: wpa_supplicant-squelch-driver-disconnect-spam.patch
29# allow more private key encryption algorithms
30Patch5: wpa_supplicant-openssl-more-algs.patch
31# Send PropertyChanged notificationes when the BSS list changes
32Patch7: wpa_supplicant-bss-changed-prop-notify.patch
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36BuildRequires: qt4-devel
37BuildRequires: qt4-designer
38BuildRequires: openssl-devel
39BuildRequires: readline-devel
40BuildRequires: dbus-devel
41BuildRequires: libnl-devel
42
43Requires(post): chkconfig
44Requires(preun): chkconfig
45
46%description
47wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
48for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
49component that is used in the client stations. It implements key negotiation
50with a WPA Authenticator and it controls the roaming and IEEE 802.11
51authentication/association of the wlan driver.
52
53%package gui
54Summary: Graphical User Interface for %{name}
55Summary(ja): wpa_supplicant のグラフィカルユーザインタフェース
56Group: Applications/System
57
58%description gui
59Graphical User Interface for wpa_supplicant written using QT4
60
61%description -l ja gui
62QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
63
64%prep
65%setup -q
66%patch0 -p1 -b .assoc-timeout
67%patch1 -p1 -b .flush-debug-output
68%patch2 -p1 -b .dbus-service-file
69%patch3 -p1 -b .quiet-scan-results-msg
70%patch4 -p1 -b .disconnect-spam
71%patch5 -p1 -b .more-openssl-algs
72%patch7 -p1 -b .bss-changed-prop-notify
73
74%build
75pushd wpa_supplicant
76  cp %{SOURCE1} ./.config
77  CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
78  CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
79  make %{_smp_mflags}
80  PATH=$PATH:%{_libdir}/qt4/bin QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{_smp_mflags}
81popd
82
83%install
84rm -rf %{buildroot}
85
86# init scripts
87install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
88install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
89install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
90
91# config
92install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
93
94# binary
95install -d %{buildroot}/%{_sbindir}
96install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
97install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
98install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
99install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
100install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
101install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
102
103# gui
104install -d %{buildroot}/%{_bindir}
105install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
106
107# running
108mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
109
110# man pages
111install -d %{buildroot}%{_mandir}/man{5,8}
112install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
113install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
114
115# some cleanup in docs
116rm -f  %{name}/doc/.cvsignore
117rm -rf %{name}/doc/docbook
118
119
120%clean
121rm -rf %{buildroot}
122
123%post
124if [ $1 = 1 ]; then
125        chkconfig --add %{name}
126fi
127
128%preun
129if [ $1 = 0 ]; then
130        service %{name} stop > /dev/null 2>&1
131        killall -TERM wpa_supplicant >/dev/null 2>&1
132        /sbin/chkconfig --del %{name}
133fi
134
135
136%files
137%defattr(-, root, root)
138%doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
139%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
140%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
141%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
142%{_sysconfdir}/rc.d/init.d/%{name}
143%{_sysconfdir}/dbus-1/system.d/%{name}.conf
144%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
145%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
146%{_sbindir}/wpa_passphrase
147%{_sbindir}/wpa_supplicant
148%{_sbindir}/wpa_cli
149%dir %{_localstatedir}/run/%{name}
150%dir %{_sysconfdir}/%{name}
151%{_mandir}/man8/*
152%{_mandir}/man5/*
153
154%files gui
155%defattr(-, root, root)
156%{_bindir}/wpa_gui
157
158%changelog
159* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
160- rebuild with openssl-1.0.0c
161- add BuildRequires: qt4-designer, libnl-devel
162
163* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
164- new upstream release
165- update patches
166- change License to BSD due to linkage against OpsnSSL since there is no
167  OpenSSL exception in upstream GPLv2 license text.
168- build with qt4
169- update build config
170
171* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
172- new upstream release
173- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
174- drop upstream patches
175- import some fedora patches
176  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
177  - Better scanning behavior on resume from suspend/hibernate
178  - Better interaction with newer kernels and drivers
179
180* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
181- start wpa_supplicant by default.
182
183* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
184- new upstream release
185- import some fedora patches
186
187* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
188- rebuild with new openssl
189
190* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
191- new upstream release
192
193* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
194- initial build for Vine Linux based on FC package.
195
196* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
197- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
198- Fix up madwifi-ng private ioctl()s for r1331 and later
199- Update madwifi headers to r1475
200
201* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
202- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
203
204* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
205- Fix control interface key obfuscation a bit
206
207* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
208- Work around older & incorrect drivers that return null-terminated SSIDs
209
210* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
211- Add patch to make orinoco happy with WEP keys
212- Enable Prism54-specific driver
213- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
214
215* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
216- Increase association timeout, mainly for drivers that don't
217        fully support WPA ioctls yet
218
219* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
220- Add additional BuildRequires #rh181914#
221- Add prereq on chkconfig #rh182905# #rh182906#
222- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
223
224* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
225- Install wpa_passphrase too #rh183480#
226
227* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
228- Don't expose private data on the control interface unless requested
229
230* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
231- Downgrade to 0.4.8 stable release rather than a dev release
232
233* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
234- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
235
236* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
237- Move initscript to /etc/rc.d/init.d
238
239* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
240- bump again for double-long bug on ppc(64)
241
242* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
243- rebuilt for new gcc4.1 snapshot and glibc changes
244
245* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
246- Update to 0.5.1
247- Add WE auth fallback to actually work with older drivers
248
249* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
250- Bring package into Fedora Core
251- Add ap_scan control interface patch
252- Enable madwifi-ng driver
253
254* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
255- upgrade to 0.4.7
256- added package w/ wpa_gui in it
257
258* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
259- upgrade to 0.4.6
260- adding ctrl interface changes recommended
261  by Hugo Paredes <hugo.paredes@e-know.org>
262
263* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
264- upgrade to 0.4.5
265- updated config file wpa_supplicant is built with
266  especially, the ipw2100 driver changed to just ipw
267  and enabled a bunch more EAP
268- disabled dist tag
269
270* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
271- fix typo in init script
272
273* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
274- fixing init script using fedora-extras' template
275- removing chkconfig default startup
276
277* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
278- upgrade to 0.4.2
279- new sample conf file that will use any unrestricted AP
280- make sysconfig config entry
281- new BuildRoot for Fedora Extras
282- adding dist tag to Release
283
284* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
285- upgrade to 0.3.8
286
287* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
288- compile ipw driver in
289
290* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
291- upgrade to 0.3.6
292
293* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
294- fixing init script
295
296* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
297- fixing init script
298- adding post/preun items to add/remove via chkconfig
299
300* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
301- adding sysV scripts
302
303* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
304- Initial RPM release.
305
Note: See TracBrowser for help on using the repository browser.