source: projects/specs/branches/6/w/wpa_supplicant/wpa_supplicant-vl.spec @ 11208

Revision 11208, 12.9 KB checked in by iwamoto, 7 years ago (diff)

wpa_supplicant: add patches to fix KRACK issue

Line 
1Summary: WPA/WPA2/IEEE 802.1X Supplicant
2Name: wpa_supplicant
3Version: 0.7.3
4Release: 4%{?_dist_release}
5License: BSD
6Group: System Environment/Base
7URL: http://w1.fi/wpa_supplicant/
8
9Source0: http://hostap.epitest.fi/releases/%{name}-%{version}.tar.gz
10Source1: %{name}.build-config
11Source2: %{name}.conf
12Source3: %{name}.init.d
13Source4: %{name}.sysconfig
14Source6: %{name}.logrotate
15
16# import from Fedora package
17# distro specific customization and not suitable for upstream,
18# works around busted drivers
19Patch0: wpa_supplicant-assoc-timeout.patch
20# ensures that debug output gets flushed immediately to help diagnose driver
21# bugs, not suitable for upstream
22Patch1: wpa_supplicant-flush-debug-output.patch
23# disto specific customization for log paths, not suitable for upstream
24Patch2: wpa_supplicant-dbus-service-file-args.patch
25# quiet an annoying and frequent syslog message
26Patch3: wpa_supplicant-quiet-scan-results-message.patch
27# recover from streams of driver disconnect messages (iwl3945)
28Patch4: wpa_supplicant-squelch-driver-disconnect-spam.patch
29# allow more private key encryption algorithms
30Patch5: wpa_supplicant-openssl-more-algs.patch
31# Send PropertyChanged notificationes when the BSS list changes
32Patch6: wpa_supplicant-bss-changed-prop-notify.patch
33# Don't crash trying to pass NULL to dbus
34Patch7: wpa_supplicant-dbus-null-error.patch
35# Fix signal quality reporting for some drivers when using nl80211
36Patch8: rh752032-0001-nl80211-Fix-UNSPEC-signal-quality-reporting.patch
37
38# Be less aggressive when choosing to roam (rh #837402)
39Patch50: rh837402-less-aggressive-roaming.patch
40
41# Fixes for CVE-2015-0210 (wpa_supplicant: broken certificate subject check)
42Patch51: rh1186806-0001-dbus_server_cert_info.patch
43Patch52: rh1186806-0002-move_calls_to_notify.patch
44Patch53: rh1186806-0003-write_server_cert.patch
45Patch54: rh1186806-0004-domain_match.patch
46Patch55: rh1186806-0005-cert_in_cb.patch
47
48# Fix integer underflow in WMM Action frame parser: rh #1221178
49Patch56: 0056-rh1221178-fix-int-unferflow-AP-WMM.patch
50
51# Do not quote values for scan_freq and freq_list: rh #1254486
52Patch57: rh1254486-dont-qoute-scan_freq-and-freq_list.patch
53
54# Deauthenticate on reconfiguration: rh #1359044
55Patch59: 0058-rh1359044-Deauthenticate-on-reconfiguration.patch
56
57# KRACK
58Patch60: rh1495530-0001-Clear-TK-part-of-PTK-after-driver-key-configuration.patch
59Patch61: rh1495530-0002-Fix-TK-configuration-to-the-driver-in-EAPOL-Key-3-4-.patch
60Patch62: rh1495530-0003-Reduce-the-amount-of-time-PTK-TPTK-GTK-is-kept-in-me.patch
61Patch63: rh1495530-0004-Prevent-reinstallation-of-an-already-in-use-group-ke.patch
62Patch64: rh1495530-0005-Prevent-installation-of-an-all-zero-TK.patch
63Patch65: rh1495530-0006-Fix-PTK-rekeying-to-generate-a-new-ANonce.patch
64Patch66: rh1495530-0007-FT-Do-not-allow-multiple-Reassociation-Response-fram.patch
65
66
67Patch100: wpa_supplicant-0.7.3_gui-build-fix.patch
68
69BuildRoot: %{_tmppath}/%{name}-%{version}-root
70
71BuildRequires: qt4-devel
72BuildRequires: qt4-designer
73BuildRequires: openssl-devel
74BuildRequires: readline-devel
75BuildRequires: dbus-devel
76BuildRequires: libnl-devel
77
78Requires(post): chkconfig
79Requires(preun): chkconfig
80
81Vendor: Project Vine
82Distribution: Vine Linux
83
84%description
85wpa_supplicant is a WPA Supplicant for Linux, BSD and Windows with support
86for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA
87component that is used in the client stations. It implements key negotiation
88with a WPA Authenticator and it controls the roaming and IEEE 802.11
89authentication/association of the wlan driver.
90
91%package gui
92Summary: Graphical User Interface for %{name}
93Summary(ja): wpa_supplicant のグラフィカルユーザインタフェース
94Group: Applications/System
95
96%description gui
97Graphical User Interface for wpa_supplicant written using QT4
98
99%description -l ja gui
100QT4 を用いた wpa_supplicant のグラフィカルユーザインタフェース
101
102%prep
103%setup -q
104%patch0 -p1 -b .assoc-timeout
105%patch1 -p1 -b .flush-debug-output
106%patch2 -p1 -b .dbus-service-file
107%patch3 -p1 -b .quiet-scan-results-msg
108%patch4 -p1 -b .disconnect-spam
109%patch5 -p1 -b .more-openssl-algs
110%patch6 -p1 -b .bss-changed-prop-notify
111%patch7 -p1 -b .dbus-null
112%patch8 -p1 -b .unspec-qual
113
114%patch50 -p1 -b .less-agressive-roaming
115
116%patch51 -p1 -b .dbus-server-cert-info
117%patch52 -p1 -b .move-calls-to-notify
118%patch53 -p1 -b .write-server-cert
119%patch54 -p1 -b .domain-match
120%patch55 -p1 -b .cert-in-cb
121%patch56 -p1 -b .rh1221178-WMM-fix
122
123%patch57 -p1 -b .rh1254486-dont-qoute-scan_freq-and-freq_list
124
125%patch59 -p1 -b .deauthenticate-on-reconfiguration
126
127%patch60 -p1 -b .rh1495530-0001
128%patch61 -p1 -b .rh1495530-0002
129%patch62 -p1 -b .rh1495530-0003
130%patch63 -p1 -b .rh1495530-0004
131%patch64 -p1 -b .rh1495530-0005
132%patch65 -p1 -b .rh1495530-0006
133%patch66 -p1 -b .rh1495530-0007
134
135%patch100 -p1 -b .gui
136
137%build
138pushd wpa_supplicant
139  cp %{SOURCE1} ./.config
140  CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ;
141  CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ;
142  make %{_smp_mflags}
143  PATH=$PATH:%{_libdir}/qt4/bin QTDIR=%{_libdir}/qt4 make wpa_gui-qt4 %{_smp_mflags}
144popd
145
146%install
147rm -rf %{buildroot}
148
149# init scripts
150install -D -m 0755 %{SOURCE3} %{buildroot}/%{_sysconfdir}/rc.d/init.d/%{name}
151install -D -m 0644 %{SOURCE4} %{buildroot}/%{_sysconfdir}/sysconfig/%{name}
152install -D -m 0644 %{SOURCE6} %{buildroot}/%{_sysconfdir}/logrotate.d/%{name}
153
154# config
155install -D -m 0600 %{SOURCE2} %{buildroot}/%{_sysconfdir}/%{name}/%{name}.conf
156
157# binary
158install -d %{buildroot}/%{_sbindir}
159install -m 0755 %{name}/wpa_passphrase %{buildroot}/%{_sbindir}
160install -m 0755 %{name}/wpa_cli %{buildroot}/%{_sbindir}
161install -m 0755 %{name}/wpa_supplicant %{buildroot}/%{_sbindir}
162install -D -m 0644 %{name}/dbus/dbus-wpa_supplicant.conf %{buildroot}/%{_sysconfdir}/dbus-1/system.d/wpa_supplicant.conf
163install -D -m 0644 %{name}/dbus/fi.w1.wpa_supplicant1.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
164install -D -m 0644 %{name}/dbus/fi.epitest.hostap.WPASupplicant.service %{buildroot}/%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
165
166# gui
167install -d %{buildroot}/%{_bindir}
168install -m 0755 %{name}/wpa_gui-qt4/wpa_gui %{buildroot}/%{_bindir}
169
170# running
171mkdir -p %{buildroot}/%{_localstatedir}/run/%{name}
172
173# man pages
174install -d %{buildroot}%{_mandir}/man{5,8}
175install -m 0644 %{name}/doc/docbook/*.8 %{buildroot}%{_mandir}/man8
176install -m 0644 %{name}/doc/docbook/*.5 %{buildroot}%{_mandir}/man5
177
178# some cleanup in docs
179rm -f  %{name}/doc/.cvsignore
180rm -rf %{name}/doc/docbook
181
182
183%clean
184rm -rf %{buildroot}
185
186%post
187if [ $1 = 1 ]; then
188        chkconfig --add %{name}
189fi
190
191%preun
192if [ $1 = 0 ]; then
193        service %{name} stop > /dev/null 2>&1
194        killall -TERM wpa_supplicant >/dev/null 2>&1
195        /sbin/chkconfig --del %{name}
196fi
197
198
199%files
200%defattr(-, root, root)
201%doc COPYING %{name}/ChangeLog README %{name}/eap_testing.txt %{name}/todo.txt %{name}/wpa_supplicant.conf %{name}/examples
202%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
203%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
204%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
205%{_sysconfdir}/rc.d/init.d/%{name}
206%{_sysconfdir}/dbus-1/system.d/%{name}.conf
207%{_datadir}/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service
208%{_datadir}/dbus-1/system-services/fi.w1.wpa_supplicant1.service
209%{_sbindir}/wpa_passphrase
210%{_sbindir}/wpa_supplicant
211%{_sbindir}/wpa_cli
212%dir %{_localstatedir}/run/%{name}
213%dir %{_sysconfdir}/%{name}
214%{_mandir}/man8/*
215%{_mandir}/man5/*
216
217%files gui
218%defattr(-, root, root)
219%{_bindir}/wpa_gui
220
221%changelog
222* Thu Oct 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-4
223- add Vendor/Distri tags
224
225* Thu Oct 19 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
226- add patch7,8 for sync cos6
227- add patch50 - 66 for security fixes from cos6
228- add patch100 gui build fix
229
230* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
231- rebuild with openssl-1.0.0c
232- add BuildRequires: qt4-designer, libnl-devel
233
234* Thu Jan 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.3-1
235- new upstream release
236- update patches
237- change License to BSD due to linkage against OpsnSSL since there is no
238  OpenSSL exception in upstream GPLv2 license text.
239- build with qt4
240- update build config
241
242* Wed Jan 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.4-1
243- new upstream release
244- remove hostap/madwifi/prism54 drivers, use 'wext' instead.
245- drop upstream patches
246- import some fedora patches
247  - Handle encryption keys correctly when switching 802.11 modes (rh #459399)
248  - Better scanning behavior on resume from suspend/hibernate
249  - Better interaction with newer kernels and drivers
250
251* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-2
252- start wpa_supplicant by default.
253
254* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
255- new upstream release
256- import some fedora patches
257
258* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
259- rebuild with new openssl
260
261* Mon May 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
262- new upstream release
263
264* Wed Jun 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.8-0vl1
265- initial build for Vine Linux based on FC package.
266
267* Thu Apr 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-10
268- Add fix for madwifi and WEP (wpa_supplicant/hostap bud #140) (#rh190075#)
269- Fix up madwifi-ng private ioctl()s for r1331 and later
270- Update madwifi headers to r1475
271
272* Tue Apr 25 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-9
273- Enable Wired driver, PKCS12, and Smartcard options (#rh189805#)
274
275* Tue Apr 11 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-8
276- Fix control interface key obfuscation a bit
277
278* Sun Apr  2 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-7
279- Work around older & incorrect drivers that return null-terminated SSIDs
280
281* Mon Mar 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-6
282- Add patch to make orinoco happy with WEP keys
283- Enable Prism54-specific driver
284- Disable ipw-specific driver; ipw2x00 should be using WEXT instead
285
286* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-5
287- Increase association timeout, mainly for drivers that don't
288        fully support WPA ioctls yet
289
290* Fri Mar  3 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-4
291- Add additional BuildRequires #rh181914#
292- Add prereq on chkconfig #rh182905# #rh182906#
293- Own /var/run/wpa_supplicant and /etc/wpa_supplicant #rh183696#
294
295* Wed Mar  1 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-3
296- Install wpa_passphrase too #rh183480#
297
298* Mon Feb 27 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-2
299- Don't expose private data on the control interface unless requested
300
301* Fri Feb 24 2006 Dan Williams <dcbw@redhat.com> - 0.4.8-1
302- Downgrade to 0.4.8 stable release rather than a dev release
303
304* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-3
305- Documentation cleanup (Terje Rosten <terje.rosten@ntnu.no>)
306
307* Sun Feb 12 2006 Dan Williams <dcbw@redhat.com> - 0.5.1-2
308- Move initscript to /etc/rc.d/init.d
309
310* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.2
311- bump again for double-long bug on ppc(64)
312
313* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.5.1-1.1
314- rebuilt for new gcc4.1 snapshot and glibc changes
315
316* Sun Feb  5 2006 Dan Williams <dcbw@redhat.com> 0.5.1-1
317- Update to 0.5.1
318- Add WE auth fallback to actually work with older drivers
319
320* Thu Jan 26 2006 Dan Williams <dcbw@redhat.com> 0.4.7-2
321- Bring package into Fedora Core
322- Add ap_scan control interface patch
323- Enable madwifi-ng driver
324
325* Sun Jan 15 2006 Douglas E. Warner <silfreed@silfreed.net> 0.4.7-1
326- upgrade to 0.4.7
327- added package w/ wpa_gui in it
328
329* Mon Nov 14 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.6-1
330- upgrade to 0.4.6
331- adding ctrl interface changes recommended
332  by Hugo Paredes <hugo.paredes@e-know.org>
333
334* Sun Oct  9 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.5-1
335- upgrade to 0.4.5
336- updated config file wpa_supplicant is built with
337  especially, the ipw2100 driver changed to just ipw
338  and enabled a bunch more EAP
339- disabled dist tag
340
341* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-3
342- fix typo in init script
343
344* Thu Jun 30 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-2
345- fixing init script using fedora-extras' template
346- removing chkconfig default startup
347
348* Tue Jun 21 2005 Douglas E. Warner <silfreed@silfreed.net> 0.4.2-1
349- upgrade to 0.4.2
350- new sample conf file that will use any unrestricted AP
351- make sysconfig config entry
352- new BuildRoot for Fedora Extras
353- adding dist tag to Release
354
355* Fri May 06 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.8-1
356- upgrade to 0.3.8
357
358* Thu Feb 10 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-2
359- compile ipw driver in
360
361* Wed Feb 09 2005 Douglas E. Warner <silfreed@silfreed.net> 0.3.6-1
362- upgrade to 0.3.6
363
364* Thu Dec 23 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-4
365- fixing init script
366
367* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-3
368- fixing init script
369- adding post/preun items to add/remove via chkconfig
370
371* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-2
372- adding sysV scripts
373
374* Mon Dec 20 2004 Douglas E. Warner <silfreed@silfreed.net> 0.2.5-1
375- Initial RPM release.
376
Note: See TracBrowser for help on using the repository browser.