source: projects/specs/branches/6/w/wine/wine-vl.spec @ 4309

Revision 4309, 23.6 KB checked in by Takemikaduchi, 13 years ago (diff)

libdrm,wine: new upstream release, libpciaccess: create compat32 sub packages

Line 
1%define pkg_major_version 1.2.3
2%define pkg_name wine
3%define pkg_release 1%{?_dist_release}
4
5# NEW Release: numbering rule. -- Release: 1%{?_dist_release}
6# spec file for package wine.. # base (SUSE10 and fedora core 9)
7
8Summary:        Allows running Windows 16/32/64 bit programs on Unix.
9Summary(ja):    Unix で 16/32/64ビットWindoowsプログラムを実行させます
10Name:           %{pkg_name}
11Version:        %{pkg_major_version}
12Release:        %{pkg_release}
13URL:            http://www.winehq.org/
14License:        LGPLv2+
15Group:          Applications/System
16
17#--------------------------------------------------------------------
18Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
19#--------------------------------------------------------------------
20
21Source1:        wine.init
22Source3:        wine-README-Fedora
23Source4:        wine-32.conf
24# desktop stuff
25Source100:      wine-notepad.desktop
26Source101:      wine-regedit.desktop
27Source102:      wine-uninstaller.desktop
28Source103:      wine-winecfg.desktop
29Source104:      wine-winefile.desktop
30Source105:      wine-winemine.desktop
31Source106:      wine-winhelp.desktop
32Source107:      wine-wineboot.desktop
33
34# desktop dir
35Source200:      wine.menu
36Source201:      wine.directory
37
38# mime types
39Source300:      wine-mime-msi.desktop
40
41# explain how to use wine with pulseaudio
42Source402:      README-FEDORA-PULSEAUDIO
43Patch400:       http://art.ified.ca/downloads/winepulse-0.30-configure.ac.patch
44Patch401:       http://art.ified.ca/downloads/winepulse-0.30.patch
45Patch402:       http://art.ified.ca/downloads/adding-pulseaudio-to-winecfg-0.4.1.patch
46
47Patch0:         wine-prefixfonts.patch
48Patch1:         wine-1.1.28-rpath.patch
49
50# fix #448338
51## Patch2:         wine-desktop-mime.patch
52
53# enable FontSmoothing by deafult
54Patch1000: wine-1.1.23-vine.patch
55
56# ADD ja
57Source801: wine_README.ja
58Source802: README-FEDORA-PULSEAUDIO.ja
59Source803: wine-README-Fedora.ja
60Source804: wine_README_add.ja
61Source805: fonts-replace-list.txt
62Source806: ja_fonts_replace-js2ipa.reg
63Source807: ja_fonts_replace-js2vl.reg
64Source808: ja_fonts_replace-ms2ipa.reg
65Source809: ja_fonts_replace-ms2vl.reg
66
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: daisuke, Takemikaduchi
71
72ExclusiveArch: %{ix86} x86_64
73
74#--------------------------------------------------------------------
75BuildRoot:      %{_tmppath}/%{name}-%{version}-root
76#--------------------------------------------------------------------
77
78## FedoraCore ##
79BuildRequires: bison, flex
80BuildRequires: audiofile, audiofile-devel
81BuildRequires: alsa-lib-devel
82BuildRequires: freeglut-devel, lcms-devel
83## BuildRequires:  libieee1284-devel
84BuildRequires: libjpeg-devel, libpng-devel
85BuildRequires: libstdc++3-devel, libstdc++34-devel
86BuildRequires: libusb-devel
87BuildRequires: libxml2-devel, libxslt-devel
88BuildRequires: openldap-devel, ncurses-devel
89BuildRequires: unixODBC-devel, openssl-devel
90BuildRequires: sane-devel
91BuildRequires: zlib-devel
92BuildRequires: desktop-file-utils
93BuildRequires: fontforge
94## BuildRequires: gphoto2, gphoto2-devel
95## BuildRequires: jack-audio-connection-kit-devel
96## BuildRequires:  isdn4k-utils-devel
97BuildRequires: cups-devel
98BuildRequires: dbus-devel, hal-devel
99## Requires:       %{_bindir}/xmessage
100
101## X modular(fc) > X 7.2
102BuildRequires:  libX11-devel
103BuildRequires:  mesa-libGL-devel, mesa-libGLU-devel
104BuildRequires:  libXxf86dga-devel, libXxf86vm-devel
105BuildRequires:  libXrandr-devel
106BuildRequires:  libXrender-devel
107BuildRequires:  libXext-devel
108BuildRequires:  libXinerama-devel
109BuildRequires:  libXcomposite-devel
110BuildRequires:  libXmu-devel
111BuildRequires:  libXi-devel
112BuildRequires:  libXcursor-devel
113BuildRequires:  fontconfig-devel
114BuildRequires:  giflib-devel
115BuildRequires:  libtiff-devel
116BuildRequires:  pkgconfig
117BuildRequires:  libicu-devel
118BuildRequires:  freetype2-devel
119
120%ifarch x86_64
121BuildRequires: compat32-glibc-devel
122BuildRequires: compat32-glibc-devel
123BuildRequires: compat32-libX11-devel
124BuildRequires: compat32-libxcb-devel
125BuildRequires: compat32-freetype2-devel
126BuildRequires: compat32-libSM-devel
127BuildRequires: compat32-libXext-devel
128BuildRequires: compat32-libXrender-devel
129BuildRequires: compat32-mesa-libGL-devel
130BuildRequires: compat32-mesa-libGLU-devel
131BuildRequires: compat32-libxml2-devel
132BuildRequires: compat32-libxslt-devel
133BuildRequires: compat32-openssl-devel
134BuildRequires: compat32-libjpeg-devel
135BuildRequires: compat32-libpng-devel
136BuildRequires: compat32-zlib-devel
137BuildRequires: compat32-alsa-lib-devel
138## extension
139BuildRequires: compat32-libXcursor-devel
140BuildRequires: compat32-libXi-devel
141BuildRequires: compat32-libXxf86vm-devel
142BuildRequires: compat32-libXrandr-devel
143BuildRequires: compat32-libXinerama-devel
144BuildRequires: compat32-libXcomposite-devel
145BuildRequires: compat32-ncurses-devel
146BuildRequires: compat32-fontconfig-devel
147BuildRequires: compat32-libtiff-devel
148BuildRequires: compat32-openldap-devel
149
150Requires:       compat32-freetype2
151%endif
152
153Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
154Requires(post): desktop-file-utils >= 0.8
155Requires(preun): /sbin/chkconfig, /sbin/service
156Requires(postun): /sbin/ldconfig
157Requires(postun): desktop-file-utils >= 0.8
158
159#--------------------------------------------------------------------
160
161%description
162(WINE Is Not an Emulator)
163 While Wine is usually thought of as a Windows(TM) emulator,
164the Wine developers would prefer that users thought of
165Wine as a Windows compatibility layer for UNIX.
166 This package includes a program loader, which allows
167unmodified Windows 3.x/9x/NT binaries to run on x86 and
168x86_64 Unixes.
169Wine does not require MS Windows, but it can use native
170system .dll files if they are available.
171
172
173%description -l ja
174(WINE Is Not an Emulator)
175 WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
176開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
177互換レイヤー」と考えてくれる事を好むでしょう。
178 このパッケージはプログラムローダーを含み、これは未修正の
179Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
180させます。
181 WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
182Windows システムの .dll ファイルが存在するのならば、それを使用する
183事もできます
184
185#--------------------------------------------------------------------
186%package devel
187Summary: Wine development environment
188Summary(ja):    WINE の開発ファイルです
189Group: System Environment/Libraries
190Requires: wine = %{version}-%{release}
191
192%description devel
193This RPM contains the header files and development tools
194for the WINE libraries.
195
196%description devel -l ja
197WINEの開発用ライブラリやヘッダーファイル、そして開発用の
198アプリケーション(例:winebuild)のパッケージです
199(development packages)
200
201#--------------------------------------------------------------------
202%package init
203Summary: WINE binfmt_misc kernel function used for init file.
204Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
205Group: System Environment/Libraries
206Requires: wine = %{version}-%{release}
207
208%description init
209WINE binfmt_misc kernel function used for init file.
210WIN32-binary attribute run with a Linux-binary run the same way as possible.
211(init.d packages)
212** example **
213Until now, "$ wine /file/to/path/arege.exe" and then you were running
214 from the usual binary Linux as "$ /file/to/path/arege.exe"
215 and just be able to run.
216Of course, please be mindful of security.
217
218
219%description init -l ja
220カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
221実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
222ようにします。
223(init.d packages)
224※ 例 ※
225これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
226が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
227だけで実行できるようになります。
228無論、セキュリティに留意して下さい。
229
230
231#--------------------------------------------------------------------
232
233%prep
234
235%setup -q -n %{name}-%{version}
236## %patch0
237## %patch1 -p1
238## %patch400 -p1
239%patch401 -p1
240## %patch402 -p1 -b .add-pa-to-winecfg
241%patch1000 -p1
242
243%build
244
245%ifarch x86_64
246export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
247./configure \
248        --prefix=%{_prefix} \
249        --libdir=%{_libdir} \
250        --with-x \
251        --without-jack \
252        --without-capi
253%else
254export CFLAGS="$RPM_OPT_FLAGS"
255%{configure} \
256        --prefix=%{_prefix} \
257        --with-x \
258        --without-jack \
259        --without-capi
260%endif
261
262grep "have_x=yes" config.log || exit 1
263
264%{__make} depend
265
266%{__make} %{?_smp_mflags}
267
268%install
269rm -rf ${RPM_BUILD_ROOT}
270%{__make} install DESTDIR=${RPM_BUILD_ROOT}
271
272#-----------------------------------------------------------FC9
273mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
274
275# Allow users to launch Windows programs by just clicking on the .exe file...
276mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
277install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
278
279# add wine dir to desktop
280mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
281install -p -m 644 %{SOURCE200} \
282${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
283
284mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
285install -p -m 644 %{SOURCE201} \
286${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
287
288## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
289## %%{_datadir}/applications
290
291# install desktop files
292desktop-file-install \
293  --vendor=vine \
294  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
295  %{SOURCE100}
296
297desktop-file-install \
298  --vendor=vine \
299  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
300  %{SOURCE101}
301
302desktop-file-install \
303  --vendor=vine \
304  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
305  %{SOURCE102}
306
307desktop-file-install \
308  --vendor=vine \
309  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
310  %{SOURCE103}
311
312desktop-file-install \
313  --vendor=vine \
314  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
315  %{SOURCE104}
316
317desktop-file-install \
318  --vendor=vine \
319  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
320  %{SOURCE105}
321
322desktop-file-install \
323  --vendor=vine \
324  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
325  %{SOURCE106}
326
327desktop-file-install \
328  --vendor=vine \
329  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
330  %{SOURCE107}
331
332desktop-file-install \
333  --vendor=vine \
334  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
335  --delete-original \
336  ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
337
338#mime-types
339desktop-file-install \
340  --vendor=vine \
341  --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
342  %{SOURCE300}
343
344
345## other files
346cp %{SOURCE3} README-Fedora
347cp %{SOURCE803} README-Fedora.ja
348cp %{SOURCE801} documentation/README.ja
349cp %{SOURCE804} documentation/README_add.ja
350cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
351
352mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
353install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
354
355
356# deploy pulseaudio readme (802jp)
357cp %{SOURCE402} .
358cp %{SOURCE802} .
359
360# check desktop files
361%check
362desktop-file-validate \
363 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
364desktop-file-validate \
365 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
366desktop-file-validate \
367 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
368desktop-file-validate \
369 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
370desktop-file-validate \
371 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
372desktop-file-validate \
373 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
374desktop-file-validate \
375 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
376desktop-file-validate \
377 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
378desktop-file-validate \
379 ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
380
381#--------------------------------------------------------------------
382%clean
383rm -rf ${RPM_BUILD_ROOT}
384
385%post
386/sbin/ldconfig
387update-desktop-database &>/dev/null || :
388### add vinelinux
389if [ "$LANG" = "ja_JP.UTF-8" ]; then
390  echo "WINEのシステムフォントをリプレースするには"
391  echo " fonts-replace-list.txt をお読み下さい。"
392else
393  echo "You need to Japanese fonts name replace, "
394  echo "See fonts-replace-list.txt ."
395fi
396
397%postun
398/sbin/ldconfig
399update-desktop-database &>/dev/null || :
400
401%post init
402if [ $1 = 1 ]; then
403/sbin/chkconfig --add wine
404/sbin/chkconfig --level 2345 wine on
405/sbin/service wine start &>/dev/null || :
406fi
407### add vinelinux
408if [ "$LANG" = "ja_JP.UTF-8" ]; then
409    echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
410    echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
411    echo "(ファイル名は /etc/init.d/wine です)"
412    echo "起動時にファイルシステムのマウントが必要です。"
413    echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
414    echo "(削除も手動でお願いします)"
415    echo ""
416    echo "# cp /etc/fstab /etc/fstab.before  ##バックアップの作成"
417    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
418    echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
419else
420    echo "WINE binfmt_misc feature from the boot files "
421    echo "to be installed and enabled 2,3,4,5 runlevel."
422    echo "(File name in the /etc/init.d/wine )"
423    echo "Filesystem mounted at boot time is required."
424    echo "Root privileges using the following command in the /etc/fstab"
425    echo "please Addenda.(Please delete manually.)"
426    echo ""
427    echo "# cp /etc/fstab /etc/fstab.before   ##(Create backup)"
428    echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
429    echo "See also(en)http://www.linux.com/articles/56032 "
430fi
431
432%preun init
433if [ $1 = 0 ]; then
434        /sbin/service wine stop >/dev/null 2>&1
435        /sbin/chkconfig --del wine
436fi
437
438#--------------------------------------------------------------------
439## deleted /usr/share/applications/wine.desktop
440%files
441%defattr(-,root,root,-)
442%doc ANNOUNCE AUTHORS COPYING.LIB  LICENSE LICENSE.OLD
443%doc README VERSION
444%doc README-FEDORA-PULSEAUDIO
445%doc README-FEDORA-PULSEAUDIO.ja
446%doc README-Fedora
447%doc README-Fedora.ja
448%doc documentation/README* documentation/ChangeLog*
449%doc documentation/ja_fonts_replace*
450%doc documentation/fonts-replace-list.txt
451### %{_bindir}/*
452%{_bindir}/msiexec
453%{_bindir}/regedit
454%{_bindir}/regsvr32
455%{_bindir}/wine
456%{_bindir}/wineboot
457%{_bindir}/wineconsole
458## %{_bindir}/wineprefixcreate
459%{_bindir}/winecfg
460%{_bindir}/wine-preloader
461# winelauncher --> Remove
462%{_bindir}/wineserver
463%{_bindir}/notepad
464%{_bindir}/winedbg
465%{_bindir}/winedump
466%{_bindir}/winefile
467%{_bindir}/winemaker
468%{_bindir}/winemine
469%{_bindir}/winepath
470## winhelp -> renamed winhlp32.exe
471%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
472%{_sysconfdir}/ld.so.conf.d/wine-32.conf
473%{_libdir}/libwine.so.1*
474%dir %{_libdir}/wine
475%{_libdir}/wine/*.cpl.so
476%{_libdir}/wine/*.exe.so
477%{_libdir}/wine/*.exe16.so
478%{_libdir}/wine/*.dll.so
479%{_libdir}/wine/*.dll16.so
480%{_libdir}/wine/*.drv.so
481%{_libdir}/wine/*.drv16.so
482%{_libdir}/wine/*.mod16.so
483## %{_libdir}/wine/*.*16
484%{_libdir}/wine/*.ds.so
485%{_libdir}/wine/*.ocx.so
486%{_libdir}/wine/*.vxd.so
487%{_libdir}/wine/*.acm.so
488%{_libdir}/wine/*.sys.so
489%{_libdir}/wine/*.tlb.so
490%dir %{_libdir}/wine/fakedlls
491%{_libdir}/wine/fakedlls/*
492%dir %{_datadir}/wine
493%{_datadir}/wine/*
494%{_datadir}/applications/vine-wine-mime-msi.desktop
495%{_datadir}/applications/vine-wine.desktop
496%{_datadir}/applications/vine-wine-regedit.desktop
497%{_datadir}/applications/vine-wine-uninstaller.desktop
498%{_datadir}/applications/vine-wine-winecfg.desktop
499%{_datadir}/applications/vine-wine-wineboot.desktop
500%{_datadir}/applications/vine-wine-notepad.desktop
501%{_datadir}/applications/vine-wine-winefile.desktop
502%{_datadir}/applications/vine-wine-winemine.desktop
503%{_datadir}/applications/vine-wine-winhelp.desktop
504%{_datadir}/desktop-directories/Wine.directory
505%{_mandir}/man1/wine.1.*
506%{_mandir}/man1/wineserver.1*
507## %{_mandir}/man1/wineprefixcreate.1*
508%lang(de) %{_mandir}/de.UTF-8/man1/*.1*
509%lang(fr) %{_mandir}/fr.UTF-8/man1/*
510
511#--------------------------------------------------------------------
512%files devel
513%defattr(-,root,root,-)
514%{_bindir}/function_grep.pl
515%{_bindir}/widl
516%{_bindir}/winebuild
517%{_bindir}/winecpp
518%{_bindir}/winedump
519%{_bindir}/wineg++
520%{_bindir}/winegcc
521%{_bindir}/winemaker
522%{_bindir}/wmc
523%{_bindir}/wrc
524%{_includedir}/wine
525%{_libdir}/*.so
526
527%{_libdir}/wine/*.a
528%{_libdir}/wine/*.def
529
530%{_mandir}/man1/widl.1*
531%{_mandir}/man1/winebuild.1*
532%{_mandir}/man1/winedump.1*
533%{_mandir}/man1/winegcc.1*
534%{_mandir}/man1/winemaker.1*
535%{_mandir}/man1/winedbg.1*
536%{_mandir}/man1/wineg++.1*
537%{_mandir}/man1/wmc.1*
538%{_mandir}/man1/wrc.1*
539
540#--------------------------------------------------------------------
541%files init
542%defattr(-,root,root,-)
543%{_initrddir}/wine
544%doc documentation/README_add.ja
545
546#--------------------------------------------------------------------
547%changelog
548* Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
549- update to 1.2.3
550- add Requires: compat32-freetype2 (x86_64 only)
551
552* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
553- new upstream release
554
555* Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
556- new upstream release
557- drop Patch1
558
559* Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
560- new upstream release
561- fix %configure (add configu:e and gcc option of x86_64)
562- fix %install (remove wine.desktop and change make install option)
563- add ExclusiveArch: %{ix86} x86_64
564- add BuildRequires for x86_64 (compat32 packages)
565
566* Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
567- update to 1.2-rc2
568- fix spec file
569  - if [ "$LANG" = "ja_JP.eucJP" ];
570  + if [ "$LANG" = "ja_JP.UTF-8" ];
571- convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
572  - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
573- fix %files
574- drop patches (Patch0, Patch400, Patch402)
575
576* Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
577- update BRs
578  - remove freetype-devel
579  - remove libungif-devel, add giflib-devel
580  - remove gphoto2-devel, add libgphoto2-devel
581
582* Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
583- update to 1.1.29
584
585* Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
586- update to 1.1.28
587- update winepulse patches
588
589* Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
590- update to 1.1.23
591- spec in utf-8
592- add patch1000 to enable FontSmoothing by deafult.
593- update pulseaudio patches
594- remove invalid Provides: Wine HQ
595- remove unneeded patches
596
597* Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
598- Wine development release 1.1.0.
599- Updated specfile (for VineSeed)
600
601#--------------------------------------------------------------------
602
603* Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
604- added  "ja_fonts_replace-*.reg" files.
605- Updated specfile
606
607* Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
608- version upgrade
609- Updated specfile
610- Update to 1.0
611- fix wine.desktop mime types (fc)
612- add desktop package including desktop files and binary handler (fc)
613- pull in some wine alsa/pulseaudio patches (fc)
614-- NEWS "June 17, 2008: Wine 1.0 Released"
615-- read http://www.winehq.org/?issue=348
616
617* Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
618- Updated specfile
619- Update to 1.0-rc4
620- NEWS "June 6, 2008: Wine 1.0-rc4 Released"
621-- ntdll: Add local defines for VIF and VIP flags.
622--  wininet: Include openssl/ssl.h before Windows headers.
623--  shell32: Fixed the French about box.
624--  ChangeLog: Moved to documentation/ChangeLog.BETA.
625--  fonts: Add a non-breaking space glyph to the Tahoma fonts.
626--  ....others , read ChangeLog
627--- Bug fixes only, we are in code freeze.
628
629* Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
630- Updated specfile
631- Update to 1.0-rc3
632- NEWS "May 30, 2008: Wine 1.0-rc3 Released"
633-- The default version is now Windows XP.
634-- Many Richedit improvements.
635-- Beginning of jscript dll support.
636-- Shell folders now respect XDG directory configuration.
637-- Many translation updates.
638-- Lots of bug fixes.
639-- * Bug fixes only, we are in code freeze.
640--- kernel32: Add a builtin 16-bit winhelp.exe.
641--- This should be moved to winhlp32.exe once we support 16-bit modules in
642--- executables.
643---- winhelp -> renamed winhlp32.exe
644---- programs: Remove winelauncher from install rules.
645
646* Mon Apr 04 2008 Seiichirou Babasaki 0.9.59
647- Updated specfile
648- Update to 0.9.59
649- NEWS.. "April 4, 2008: Wine 0.9.59 Released"
650-- * Improved support for the .NET framework.
651-- * Better services handling through a separate services.exe process.
652-- * Support for ATI fragment shader.
653-- * Better support for http proxies.
654-- * Window management fixes.
655-- * Pre-compiled fonts are now available in the source tree.
656-- * Lots of bug fixes.
657
658* Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
659- Updated specfile (split wine-init package)
660- Update to 0.9.58
661- NEWS.. "March 21, 2008: Wine 0.9.58 Released"
662--  * The default version is now Windows XP.
663--  * Many Richedit improvements.
664--  * Beginning of jscript dll support.
665--  * Shell folders now respect XDG directory configuration.
666--  * Many translation updates.
667--  * Lots of bug fixes.
668
669* Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
670- Updated specfile (*.desktop file %check .)
671- Update to 0.9.57
672- NEWS.. "March 7, 2008: Wine 0.9.57 Released"
673--  * Support for multiple OpenGL pixel formats.
674--  * Improved support for color profiles.
675--  * Many window management fixes.
676--  * Better fullscreen support.
677--  * Lots of bug fixes.
678
679* Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
680- Updated specfile
681- ("Build Tool" from the wine-package to move to devel-packages)
682- Update to 0.9.56
683- NEWS.. "February 22, 2008: Wine 0.9.56 Released"
684--  * Proper handling of OpenGL/Direct3D windows with menu bars.
685--  * Stubs for all the d3dx9_xx dlls.
686--  * Several graphics optimizations.
687--  * Many installer fixes.
688--  * Improved MIME message support.
689--  * Lots of bug fixes.
690
691* Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
692- Updated specfile (cf. VineLinux .spec file format)
693- Add Installed messages for "binfmt_misc" .
694- *.desktop file "Name" change to japanese. (UTF8)
695
696* Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
697- Import WINE - Packager: Babasaki
698- Updated specfile (SUSE base + FC9 cfg)
699- Update to 0.9.55
700- Update to 0.9.54 from FC9
701- Update to 0.9.53 from Private package
702
703# FC9 ------------------------------------------------------------- FC9
704
705* Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
706- 0.9.55-1
707- version upgrade
708
709* Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
710- 0.9.54-1
711- version upgrade
712- remove default pulseaudio workaround (#429420,#428745)
713- improve pulseaudio readme
714
715* Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
716- 0.9.53-2
717- add some missing BR
718
719* Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
720- 0.9.53-1
721- version upgrade
722
723* Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
724- 0.9.52-2
725- fix menu bug (#393641)
726
727* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
728- 0.9.52-1
729- version upgrade
730
731* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
732- 0.9.51-3
733- add -n Wine to pulseaudio workaround
734- try to fix menu bug #393641
735
736* Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
737- 0.9.51-2
738- add fix for #344281 pulseaudio workaround
739- fix #253474: wine-jack should require jack-audio-connection-kit
740
741* Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
742- 0.9.51-1
743- version upgrade
744
745# ---- abbreviatio ----------------------------------------------------#
746
747# ----------and suse.
748# * Fri Mar 17 2006 - meissner@suse.de
749# - Avoid ulimit leading to out of memory situations by using
750#  the compat address space layout personality. #152115
751
Note: See TracBrowser for help on using the repository browser.