source: projects/specs/branches/6/w/which/which-vl.spec @ 9293

Revision 9293, 4.8 KB checked in by iwamoto, 9 years ago (diff)

which: update which-2.sh to fix #2860

Line 
1Summary: Displays where a particular program in your path is located.
2Summary(ja): プログラムがパスのどこにあるかを表示する
3Name: which
4Version: 2.20
5Release: 3%{?_dist_release}
6License: GPLv3
7Group: Applications/System
8Source0: ftp://ftp.gnu.org/gnu/which/%{name}-%{version}.tar.gz
9Source1: which-2.sh
10Source2: which-2.csh
11Patch0: which-2.19-afs.patch
12Patch1: which-2.19-broken.patch
13
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15Requires(post): /sbin/install-info
16Requires(preun): /sbin/install-info
17Requires: dev
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22
23%description
24The which command shows the full pathname of a specified program, if
25the specified program is in your PATH.
26
27%description -l ja
28which コマンドを使うと,プログラムのフルパスを表示出来ます
29(ただしプログラムが PATH に存在する場合).
30
31
32%prep
33%setup -q
34%patch0 -p1 -b .afs
35%patch1 -p1 -b .broken
36
37%build
38%configure
39make
40
41%install
42[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
43
44%makeinstall
45mkdir -p $RPM_BUILD_ROOT/etc/profile.d
46install -m 755 %{SOURCE1} %{SOURCE2} \
47        $RPM_BUILD_ROOT/etc/profile.d
48
49rm -f $RPM_BUILD_ROOT%{_infodir}/dir
50
51%post
52/sbin/install-info --quiet --info-dir=%{_infodir} %{_infodir}/which.info.gz > /dev/null 2>&1
53
54%preun
55if [ $1 = 0 ]; then
56   /sbin/install-info --quiet --info-dir=%{_infodir} --delete %{_infodir}/which.info.gz > /dev/null 2>&1
57fi
58
59%clean
60[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
61
62
63%files
64%defattr(-,root,root)
65%doc COPYING EXAMPLES NEWS README README.alias
66%{_bindir}/*
67%config /etc/profile.d/which-2.*
68%{_infodir}/which.info.gz
69%{_mandir}/*/*
70
71%changelog
72* Mon Jan 26 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.20-3
73- update which-2.sh to fix #2860
74- add Vendor/Distri tags
75
76* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20-2
77- rebuilt with new toolchains
78
79* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20-1
80- new upstream release
81- spec in UTF-8
82
83* Fri Mar 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.19-1vl5
84- new upstream release
85- updated Patch0 and 1
86
87* Tue Oct 23 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.17-0vl1
88- new upstream release
89
90* Mon Jul 10 2006 Shu KONNO <owa@bg.wakwak.com> 2.16-0vl5
91- rebuild
92
93* Tue Jun 22 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.16-0vl4
94- /etc/profile.d/which-2.sh: define "which" as function instead of alias
95
96* Thu Dec 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-0vl3
97- rebuild with new toolchains
98
99* Sat Nov 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-0vl2
100- added patches from Fedora
101
102* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16-0vl1
103- updated to 2.16
104
105* Sun Dec  1 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14-0vl2
106- source updated to 2.14
107- rebuild with newer toolchains
108
109* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
110- 2.12-1vl1
111- based on 2.12-1 from Rawhide
112- added Japanese summary and description
113
114* Sun Sep 10 2000 Florian La Roche <Florian.LaRoche@redhat.de>
115- 2.12 (only man-page fix)
116
117* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
118- automatic rebuild
119
120* Sun Jun 18 2000 Than Ngo <than@redhat.de>
121- FHS packaging.
122
123* Sun May 21 2000 Ngo Than <than@redhat.de>
124- put man pages in /usr/share/man/*
125
126* Thu Apr 20 2000 Florian La Roche <Florian.LaRoche@redhat.de>
127- update to 2.11
128- change from root:bin -> root:root
129
130* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
131- rebuild to gzip man page
132
133* Sun Jan 16 2000 Preston Brown <pbrown@redhat.com>
134- newer stuff rom Carlo (2.10).  Author's email: carlo@gnu.org
135
136* Thu Jan 13 2000 Preston Brown <pbrown@redhat.com>
137- adopted Carlo's specfile.
138
139* Fri Sep 24 1999 Carlo Wood <carlo@gnu.org>
140- There should not be a reason anymore to include README.alias in the rpm docs.
141- Don't install as root.root in RPM_BUILD_ROOT, in order to allow to build
142  rpm as non-root.
143- Bug fix
144- Added /etc/profile.d for automatic alias inclusion.
145
146* Wed Aug 25 1999 Carlo Wood <carlo@gnu.org>
147- Added README.alias.
148
149* Wed Aug 11 1999 Carlo Wood <carlo@gnu.org>
150- Typo in comment.
151
152* Thu May 27 1999 Carlo Wood <carlo@gnu.org>
153- Typo fix
154- Moved maintainer targets from makefile to Makefile.am.
155
156* Tue May 18 1999 Carlo Wood <carlo@gnu.org>
157- Typo in appended changelog.
158- Appended the old change log of `which-2.0.spec' to (this) %changelog,
159  which is generated from the CVS log of `which-2.0.spec.in'.
160- Generate which-2.spec from which-2.spec.in with automatic VERSION
161  and CHANGELOG substitution.
162
163* Tue May 14 1999 Carlo Wood <carlo@gnu.org>
164- Moved assignment of CFLAGS to the configure line, using RPM_OPT_FLAGS now.
165- Corrected Source: line to point to ftp.gnu.org.
166
167* Sat Apr 17 1999 Carlo Wood <carlo@gnu.org>
168- Started to use automake and autoconf
169
170* Fri Apr 09 1999 Carlo Wood <carlo@gnu.org>
171- Renamed which-2.0.spec to which-2.spec
Note: See TracBrowser for help on using the repository browser.