source: projects/specs/branches/6/w/w3m/w3m-vl.spec @ 3605

Revision 3605, 12.3 KB checked in by iwaim, 13 years ago (diff)

w3m-0.5.3-1

Line 
1%define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
2
3%define _docdir %{_defaultdocdir}
4
5#%define cvsdate 20060815
6
7Summary: A Pager with WWW capability
8Summary(ja): World Wide Web に対応したページャ
9Name: w3m
10Version: 0.5.3
11Release: 1%{?_dist_release}
12Group: Applications/Internet
13License: BSD
14URL: http://w3m.sourceforge.net/
15Source0: %{name}-%{version}.tar.gz
16Source1: w3m.sh
17Source2: w3m.csh
18Source10: w3m-term
19Source11: filter-requires-w3m.sh
20
21Requires: perl, openssl >= 0.9, gc >= 6.2
22Requires(post,preun): alternatives
23Provides: webclient, pager
24Obsoletes: w3m-m17n
25
26BuildRequires: openssl-devel >= 0.9
27BuildRequires: ncurses-devel
28BuildRequires: gc-devel >= 6.2
29BuildRequires: sed
30BuildRequires: gtk2-devel
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: shaolin
36
37# work around for [VineSeed-x86_64:00178]
38%define __find_requires %{SOURCE11}
39
40%description
41w3m is a pager with WWW capability. It IS a pager, but it can be
42used as a text-mode WWW browser. The features of w3m are as follows:
43- When reading HTML document, you can follow links and view images
44  (using external image viewer).
45- It has 'internet message mode', which determines the type of document
46  from header. If the Content-Type: field of the document is text/html,
47  that document is displayed as HTML document.
48- You can change URL description like 'http://hogege.net' in plain text
49  into link to that URL.
50
51%description -l ja
52w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
53です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
54
55・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
56  り,画像を見ることができる.
57・Internet message 表示のためのモードがある.この時,Content-Type: が
58  text/html の場合は,自動的に HTML の文書として表示する.また,自力で
59 MIME header のデコードをする.
60・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
61  をたどることができる.
62
63%package img
64Summary: inline image extension support utilities for w3m
65Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
66Group: Applications/Internet
67Requires: %{name} = %{version}-%{release}
68
69%description img
70w3m-img provides some utilities to support inline
71images for w3m
72on terminal emulator in X Window System environments.
73
74%description -l ja img
75w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
76表示するためのユーティリティです。
77
78%prep
79%setup -q
80find Bonus -type f | \
81    xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
82
83%build
84%configure \
85        --enable-japanese=E \
86        --with-termlib=ncurses \
87        --enable-image=x11 \
88        --with-imagelib=gtk2 \
89        --with-browser=gnome-open \
90        --with-mailer=gnome-open \
91        --with-editor=%{_sysbindir}/vi
92sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
93sed -i -e 's|\-lgpm||g' Makefile
94make %{?_smp_mflags}
95
96
97%install
98rm -rf %{buildroot}
99make install DESTDIR=%{buildroot}
100
101mkdir -p %{buildroot}/etc/profile.d
102cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
103cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
104
105mkdir -p %{buildroot}%{_bindir}
106cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
107chmod +x %{buildroot}%{_bindir}/w3m-term
108
109mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
110install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
111install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
112# dont include duplicated man pages and CVS directory in doc
113rm -f doc-jp/w3m.1 doc/w3m.1
114find . -type d -name "CVS" | xargs rm -rf
115
116# prepare system-wide preference file
117mkdir -p %{buildroot}%{_sysconfdir}/w3m
118
119# prepare applnk
120%define applnkdir /etc/X11/applnk/Internet
121mkdir -p %{buildroot}/%{applnkdir}
122cat > %{buildroot}/%{applnkdir}/%{name}.desktop <<EOF
123[Desktop Entry]
124Name=%{name}
125Type=Application
126Comment=A Pager with WWW capability
127Comment[ja]=WWW対応ページャ
128Exec=w3m-term
129Terminal=false
130EOF
131
132# eliminate executable bit in %doc
133find Bonus/ -type f -perm +111 | xargs -r chmod -x
134
135
136%clean
137rm -rf %{buildroot}
138
139%post
140%{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
141
142%preun
143if [ "$1" = "0" ]; then
144  %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
145fi
146
147
148%files
149%defattr(-,root,root)
150%doc Bonus ChangeLog NEWS README doc doc-jp
151%attr(755,root,root) %config /etc/profile.d/*
152%config(missingok) %{applnkdir}/%{name}.desktop
153%dir %{_sysconfdir}/w3m
154%{_bindir}/w3m*
155%exclude %{_libexecdir}/w3m/w3mimgdisplay
156%{_libexecdir}/w3m/
157%{_datadir}/w3m/
158%{_datadir}/locale/*/LC_MESSAGES/*
159%{_mandir}/ja/man1/w3m.1*
160%{_mandir}/man1/w3m*
161
162%files img
163%{_libexecdir}/w3m/w3mimgdisplay
164
165%changelog
166* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 0.5.3-1
167- new upstream release
168- drop unnecessary patches: upstream fixed
169 - ambwidth patch (Patch10)
170 - sudden crash patch (Patch11)
171 - x86_64 patch (Patch100)
172
173* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
174- rebuild with openssl-1.0.0c
175- add Patch100 (w3m-0.5.2-x86_64-vine.patch)
176
177* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
178- add Patch10 to fix display utf8 ambiguous width characters
179  (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
180- add Patch11 to fix sudden crash
181  (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
182
183* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
184- rebuilt with gcc-4.4.3-3 on ppc
185
186* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
187- rebuilt with new toolchain
188
189* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
190- spec in utf-8
191- remove Requires: indexhtml
192- set HTTP_HOME to http://vinelinux.org/
193- update w3m-term
194
195* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
196- new upstream release
197- dropped Patch100 (merged into upstream)
198
199* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
200- rebuilt with new toolchain and environment
201
202* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
203- add Provides: pager
204- add Requires(post,preun): alternatives
205
206* Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
207- add update-alternatives: pager in %post and %preun scriptlet
208
209* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
210- 0.5.1.20060815-0vl2
211- rebuilt for VineSeed
212
213* Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
214- 0.5.1.20060815-0vl1.1
215- add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
216
217* Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
218- update to cvs snapshot
219- use gtk2 for w3m-img instead of gdk-pixbuf
220
221* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
222- use filter-requires-w3m.sh as find-requires (rpm's bug?)
223
224* Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
225- use %%{_docdir}/Vine/index.html as default homepage
226
227* Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
228- change default editor to %%{_sysbindir}/vi
229- use ncurses explicitly as termlib
230
231* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
232- fix typo
233- add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
234
235* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
236- rebuild without gpm
237
238* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
239- new upstream release
240- Obsoletes: w3m-m17n
241
242* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
243- add message catalogs to %%files
244
245* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
246- new upstream release
247- fix w3mimgdisplay path in w3m-term
248
249* Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
250- new upstream release
251- split w3mimgdisplay to w3m-img subpackage.
252- Requires: gc >= 6.2
253
254* Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
255- new upstream release
256
257* Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
258- new upstream release
259
260* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
261- new upstream release.
262  w3m 0.3.2.2 - 2002-12-06
263  * security fix: html_quote for img alt attributes
264
265* Fri Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
266- change default page path to /usr/doc/HTML.
267  this should be changed to /usr/share/doc in next release.
268  ( TODO: indexhtml package )
269
270* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
271- new upstream release
272  w3m 0.3.2.1 - 2002-11-27
273  * security fix: html_quote for frame contents
274  * backport from w3m 0.3.2+cvs
275    - fix segmentation fault by large complex table.
276      [w3m-dev 03371][w3m-dev 03438]
277
278* Wed Nov  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
279- new upstream release
280  w3m 0.3.2 - 2002-11-05
281  * ~/.netrc: password for ftp
282  * rc: display_lineinfo: display current line number
283  * rc: passwd_file: passwd file for HTTP auth
284  * func: MARK_WORD
285  * rc: imgsize: obsoleted
286  * w3m-img for framebuffer merged
287
288* Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
289- replace gc with an old version on alpha (Source20)
290
291* Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
292- upstream release
293- coped new configure options
294
295* Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
296- fixed configure option ([VineSeed:06372])
297- added openssl-devel version in {Build,}Requires
298
299* Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
300- updated in sync with upstream 0.3 release
301  (now w3m-img patch is included in the upstream version)
302
303* Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
304- w3m-0.2.5 with 0.2.5+cvs-1.302
305
306* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
307- eliminate executable bit in %doc
308- spec cleanup
309
310* Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
311- updated to current stable release
312
313* Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
314- updated to new upstream release
315- FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
316
317* Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
318- 0.2.1-0vl9
319- added sparc patch
320
321* Thu Aug 23 2001 <shom@vinelinux.org>
322- 0.2.1-0vl8: add w3m-term script
323
324* Mon Aug 06 2001 <sagami@vinelinux.org>
325- 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
326- update img patch to version 1.10 from 1.9
327
328* Mon Aug  6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
329- added img patch
330
331* Mon Jul 16 2001 <sagami@vinelinux.org>
332- 0.2.1-0vl5: spec file clean up
333- openssl-devel for BuildPrereq, not openssl
334- install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
335
336* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
337- 0.2.1-0vl4
338- rebuilt with openssl-0.9.6b
339
340* Sun Jun 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
341- 0.2.1-0vl3
342- security fixes (http://www.lac.co.jp/security/snsadv/32.html)
343
344* Sat Jun 09 2001 <sagami@vinelinux.org>
345- 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
346- actually rebuilt with ncurses5 (i386)
347
348* Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
349- 0.2.1-0vl1
350
351* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
352- 0.1.10-0vl6
353- use better macros
354- rebuilt with ncurses5
355
356* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
357- w3m-0.1.10-0vl5
358- use applnk instead of wmconfig
359- use openssl
360
361* Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
362- w3m-0.1.10-0vl4
363- fix typo in w3m.csh and w3m.wmconfig
364
365* Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
366- w3m-0.1.10-0vl3
367- provide default HTTP_HOME in /etc/profile.d
368
369* Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
370- Provides: webclient, Requires: indexhtml (capability of lynx)
371- added w3m.wmconfig
372- give them(who?) RPM_OPT_FLAGS(what?)
373- dont include duplicated man pages and CVS directory in doc
374
375* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
376- 0.1.10-0vl1
377
378* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
379- fix spec file
380
381* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
382- updated from 0.1.4 to 0.1.6
383
384* Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
385- updated from 991203 to 0.1.4
386
387* Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
388- updated from 991028 to 991203
389
390* Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
391- updated from 990820 to 991028
392
393* Tue Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
394- updated from 990716 to 990820
395
396* Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
397- initial Release to VinePlus
Note: See TracBrowser for help on using the repository browser.