source: projects/specs/branches/6/v/vino/vino-vl.spec @ 4701

Revision 4701, 6.6 KB checked in by Takemikaduchi, 13 years ago (diff)

add BR: libXtst

Line 
1%define gtk2_version 2.22.1
2%define gconf2_version 2.32.0
3%define libgcrypt_version 1.4.6
4%define avahi_version 0.6.25
5
6Summary: A remote desktop system for GNOME
7Summary(ja): GNOME 用リモートデスクトップシステム
8Name: vino
9Version: 2.32.2
10Release: 2%{?_dist_release}
11URL: http://www.gnome.org
12License: GPL
13Group: User Interface/Desktops
14
15Source0: http://ftp.gnome.org/pub/GNOME/sources/vino/2.32/%{name}-%{version}.tar.bz2
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18
19Requires: GConf2 >= %{gconf2_version}
20
21Requires: gtk2 >= %{gtk2_version}
22Requires: GConf2 >= %{gconf2_version}
23Requires: libgcrypt >= %{libgcrypt_version}
24Requires: avahi >= %{avahi_version}
25Requires: avahi-glib >= %{avahi_version}
26Requires: NetworkManager >= 0.8
27
28BuildRequires: gtk2-devel >= %{gtk2_version}
29BuildRequires: GConf2-devel >= %{gconf2_version}
30BuildRequires: dbus-devel >= 1.4.0
31BuildRequires: libsoup-devel >= 2.32.0
32BuildRequires: libnotify-devel >= 0.4.5
33BuildRequires: libgcrypt-devel >= %{libgcrypt_version}
34BuildRequires: avahi-devel >= %{avahi_version}
35BuildRequires: avahi-glib-devel >= %{avahi_version}
36BuildRequires: libgnome-keyring-devel >= 2.32
37BuildRequires: NetworkManager-glib-devel >= 0.8
38BuildRequires: unique-devel >= 1.0.0
39BuildRequires: libSM-devel
40BuildRequires: libXtst-devel
41BuildRequires: desktop-file-utils
42
43%description
44Vino is a VNC server for GNOME. It allows remote users to
45connect to a running GNOME session using VNC.
46
47%description -l ja
48Vine は GNOME 用の VNC サーバです。Vino によりリモートユーザが
49VNC を利用して稼働中のGNOME セッション接続することができるよう
50になります。
51
52%prep
53%setup -q
54
55%build
56%configure \
57        --disable-schemas-install \
58        --enable-avahi \
59        --disable-gnutls \
60        --disable-session-support \
61        --disable-telepathy \
62        --enable-libnotify \
63        --enable-network-manager \
64        --enable-gnome-keyring \
65        --disable-http-server \
66        --enable-libunique=yes
67%__make %{?_smp_mflags}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
73%makeinstall
74unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
75
76desktop-file-install --vendor gnome --delete-original                   \
77  --dir $RPM_BUILD_ROOT%{_datadir}/applications                         \
78  --add-only-show-in GNOME                                              \
79  $RPM_BUILD_ROOT%{_datadir}/applications/vino-preferences.desktop
80
81# stuff we don't want
82rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
83
84%find_lang %{name}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post
90export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
91SCHEMAS="vino-server.schemas"
92for S in $SCHEMAS; do
93  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >& /dev/null ||:
94done
95touch --no-create %{_datadir}/icons/hicolor
96if [ -x /usr/bin/gtk-update-icon-cache ]; then
97  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
98fi
99
100%postun
101touch --no-create %{_datadir}/icons/hicolor
102if [ -x /usr/bin/gtk-update-icon-cache ]; then
103  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
104fi
105
106
107%files -f %{name}.lang
108%defattr(-,root,root)
109%doc AUTHORS ChangeLog COPYING NEWS README docs/TODO docs/remote-desktop.txt
110%{_bindir}/*
111%{_libexecdir}/*
112%{_datadir}/applications/*.desktop
113%{_datadir}/dbus-1/services/*
114%{_datadir}/vino
115%{_sysconfdir}/gconf/schemas/*.schemas
116%{_sysconfdir}/xdg/autostart/vino-server.desktop
117
118%changelog
119* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-2
120- add BuildRequires: libXtst-devel
121
122* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
123- new upstream release
124- change BuildRequires: NetworkManager-glib-devel instead of NetworkManager-devel
125
126* Sun Dec 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
127- new upstream release
128
129* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
130- new upstream release
131
132* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
133- new upstream release
134- add BuildRequires: libSM-devel, desktop-file-utils
135- change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
136
137* Sun Nov  8 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
138- new upstream release
139
140* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
141- new upstream release
142
143* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
144- new upstream release
145
146* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
147- new upstream release
148
149* Wed Oct 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
150- new upstream release
151
152* Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
153- new upstream release
154
155* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
156- new upstream release
157
158* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 2.18.1-1vl5
159- applied new versioning policy, spec in utf-8
160
161* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
162- new upstream release
163
164* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl3
165- run gtk-update-icon-cache in %%post script.
166
167* Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
168- enable avahi, add BuildRequires: avahi-devel
169
170* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
171- new upstream release
172
173* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
174- new upstream release
175
176* Tue Mar 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
177- new upstream version
178
179* Tue Nov 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
180- initial build for Vine Linux
181- add japanese summary and description.
182
183* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.1-1
184- Update to 2.8.1
185- Remove backported fixes
186
187* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
188- Don't hang with metacity's "reduced resources" mode (#134240)
189- Improve the key repeat rate situation a good deal (#134451)
190
191* Wed Sep 29 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1
192- Update to 2.8.0.1
193
194* Tue Sep 21 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-1
195- Update to 2.8.0
196- Remove upstreamed work-without-gnutls patch
197
198* Tue Sep  7 2004 Matthias Clasen <mclasen@redhat.com> 2.7.92-3
199- Disable help button until there is help (#131632)
200 
201* Wed Sep  1 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-2
202- Add patch to fix hang without GNU TLS (bug #131354)
203
204* Mon Aug 30 2004 Mark McLoughlin <markmc@redhat.com> 2.7.92-1
205- Update to 2.7.92
206
207* Tue Aug 17 2004 Mark McLoughlin <markmc@redhat.com> 2.7.91-1
208- Update to 2.7.91
209
210* Mon Aug 16 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-2
211- Define libgcrypt_version
212
213* Thu Aug 12 2004 Mark McLoughlin <markmc@redhat.com> 2.7.90-1
214- Update to 2.7.90
215
216* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 2.7.4-1
217- Update to 2.7.4
218
219* Tue Jul 13 2004 Mark McLoughlin <markmc@redhat.com> 2.7.3.1-1
220- Initial build.
Note: See TracBrowser for help on using the repository browser.