source: projects/specs/branches/6/v/vigra/vigra-vl.spec @ 6364

Revision 6364, 3.6 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild or update packages

Line 
1Summary: Generic Programming for Computer Vision
2Name: vigra
3Version: 1.5.0
4Release: 2%{?_dist_release}
5License: MIT
6Group: Development/Libraries
7Source: http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/%{name}%{version}.tar.gz
8URL: http://kogs-www.informatik.uni-hamburg.de/~koethe/vigra/
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel, fftw3-devel
11
12%description
13VIGRA stands for "Vision with Generic Algorithms". It's a novel computer vision
14library that puts its main emphasis on customizable algorithms and data
15structures. By using template techniques similar to those in the C++ Standard
16Template Library, you can easily adapt any VIGRA component to the needs of your
17application without thereby giving up execution speed.
18
19%package devel
20Summary: Development tools for programs which will use the vigra library
21Summary(ja): Development tools for programs which will use the vigra library
22Group: Development/Libraries
23Requires: vigra = %{version}-%{release}
24Requires: libjpeg-devel, libtiff-devel, libpng-devel, zlib-devel, fftw3-devel
25
26%description devel
27The vigra-devel package includes the header files necessary for developing
28programs that use the vigra library.
29
30%prep
31%setup -q -n %{name}%{version}
32chmod 644 %{_builddir}/%{name}%{version}/doc/vigra/documents/*.ps
33rm -f %{_builddir}/%{name}%{version}/doc/vigra/.cvsignore
34
35%build
36export CXXFLAGS="$RPM_OPT_FLAGS"
37./configure \
38    --prefix=/usr \
39    --with-tiff \
40    --with-jpeg \
41    --with-png \
42    --with-zlib \
43    --with-fftw \
44    --enable-shared \
45    --disable-static \
46    --libdir=%{_libdir}
47make
48
49%install
50rm -rf %{buildroot}
51%makeinstall
52rm -f %{buildroot}/%{_libdir}/libvigraimpex.la
53rm -rf %{buildroot}/usr/doc
54
55%post -p /sbin/ldconfig
56%postun -p /sbin/ldconfig
57
58%clean
59rm -rf %{buildroot}
60
61%files
62%defattr(-, root, root,-)
63%doc LICENSE.txt README.txt
64%{_libdir}/libvigraimpex.so.*
65
66%files devel
67%defattr(-, root, root,-)
68%{_bindir}/vigra-config
69%{_includedir}/vigra
70%{_libdir}/libvigraimpex.so
71%doc doc/vigra/*
72
73%changelog
74* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.0-2
75- rebuild with Vine6 environment
76
77* Fri Jul 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0-1
78- initial build for Vine Linux
79
80* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5.0-4
81- Autorebuild for GCC 4.3
82
83* Tue Aug 21 2007 Bruno Postle <bruno@postle.net> 1.5.0-3
84  - Bumping for Jesse
85
86* Mon Feb 19 2007 Bruno Postle <bruno@postle.net> 1.5.0-2
87  - update to 1.5.0 release
88  - fix bug 228926: vigra: $RPM_OPT_FLAGS not used
89
90* Tue Sep 12 2006 Bruno Postle <bruno@postle.net> 1.4.0-4
91  - remove gcc-c++ dependency
92
93* Fri Sep 08 2006 Bruno Postle <bruno@postle.net> 1.4.0-3
94  - change defattr
95  - require fftw >= 3, gcc-c++
96
97* Tue Sep 05 2006 Bruno Postle <bruno@postle.net> 1.4.0-2
98  - update with review feedback
99
100* Mon Aug 28 2006 Bruno Postle <bruno@postle.net> 1.4.0-1
101  - revive, update to 1.4 with new license, remove patches,
102  - split to devel package
103
104* Fri Jul 02 2004 Bruno Postle <bruno@postle.net>
105  - add pablo's vigra_typetraits_extension.diff patch and shorten
106    the impex patch so it doesn't conflict
107
108* Wed May 05 2004 Bruno Postle <bruno@postle.net>
109  - new build with patches for 16bit tiff and viff bug
110
111* Sun Feb 08 2004 Bruno Postle <bruno@postle.net>
112  - new build with shared libraries
113
114* Wed Jan 04 2004 Bruno Postle <bruno@postle.net>
115  - new build without shared libraries
116
117* Tue Nov 25 2003 Bruno Postle <bruno@postle.net>
118  - new build with shared libraries
119
120* Sun Nov 23 2003 Bruno Postle <bruno@postle.net>
121  - make a horrible mess
122
123
Note: See TracBrowser for help on using the repository browser.