source: projects/specs/branches/6/u/udisks/udisks-vl.spec @ 8300

Revision 8300, 6.8 KB checked in by iwamoto, 10 years ago (diff)

udisks: CVE-2014-0004

Line 
1%define glib2_version           2.6.0
2%define dbus_version            1.2
3%define dbus_glib_version       0.82
4%define polkit_version          0.92
5%define parted_version          2.3
6%define udev_version            145
7%define mdadm_version           2.6.7
8%define device_mapper_version   1.02
9%define libatasmart_version     0.12
10%define sg3_utils_version       1.27
11%define smp_utils_version       0.94
12%define lvm2_version            2.02.78
13
14Summary: Storage Management Service
15Name: udisks
16Version: 1.0.2
17Release: 3%{?_dist_release}
18License: GPLv2+
19Group: System Environment/Libraries
20URL: http://www.freedesktop.org/wiki/Software/udisks
21Source0: http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
22
23Patch0: 10-ide-cd-support.patch
24# security patches
25# CVE-2014-0004
26Patch100: 00git_mount_path_overflow.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: glib2-devel >= %{glib2_version}
30BuildRequires: dbus-devel  >= %{dbus_version}
31BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
32BuildRequires: polkit-devel >= %{polkit_version}
33BuildRequires: parted-devel >= %{parted_version}
34BuildRequires: device-mapper-devel >= %{device_mapper_version}
35BuildRequires: intltool
36BuildRequires: libatasmart-devel >= %{libatasmart_version}
37BuildRequires: libgudev1-devel >= %{udev_version}
38BuildRequires: libudev-devel >= %{udev_version}
39BuildRequires: sg3_utils-devel >= %{sg3_utils_version}
40BuildRequires: lvm2-devel >= %{lvm2_version}
41# needed to pull in the system bus daemon
42Requires: dbus >= %{dbus_version}
43# needed to pull in the udev daemon
44Requires: udev >= %{udev_version}
45# we need at least this version for bugfixes / features etc.
46Requires: libatasmart >= %{libatasmart_version}
47Requires: mdadm >= %{mdadm_version}
48# for smp_rep_manufacturer
49Requires: smp_utils >= %{smp_utils_version}
50# for mount, umount, mkswap
51Requires: util-linux-ng
52# for mkfs.ext3, mkfs.ext3, e2label
53Requires: e2fsprogs
54# for mkfs.xfs, xfs_admin
55Requires: xfsprogs
56# for mkfs.vfat
57Requires: dosfstools
58# for mlabel
59Requires: mtools
60# for mkntfs - no ntfsprogs on ppc, though
61%ifnarch ppc ppc64
62Requires: ntfsprogs
63%endif
64
65# for /proc/self/mountinfo, only available in 2.6.26 or higher
66Conflicts: kernel < 2.6.26
67
68# we need liblvm2app at least this recent since the ABI changed (sizes
69# reported in number of bytes instead of number of sectors) without
70# the sonumber changing
71#
72Requires: lvm2-libs >= %{lvm2_version}
73
74# Obsolete and Provide DeviceKit-disks - udisks provides exactly the same
75# ABI just with a different name and versioning-scheme
76#
77Obsoletes: DeviceKit-disks <= 009
78Provides: DeviceKit-disks = 010
79
80Vendor: Project Vine
81Distribution: Vine Linux
82
83%description
84udisks provides a daemon, D-Bus API and command line tools
85for managing disks and storage devices.
86
87%package devel
88Summary: D-Bus interface definitions for udisks
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91Requires: gtk-doc
92
93# See comment above
94#
95Obsoletes: DeviceKit-disks-devel <= 009
96Provides: DeviceKit-disks-devel = 010
97
98%description devel
99D-Bus interface definitions and documentation for udisks.
100
101%prep
102%setup -q
103%patch0 -p1
104
105# security patches
106%patch100 -p1 -b .CVE-2014-0004
107
108%build
109%configure --enable-gtk-doc
110make
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115make install DESTDIR=$RPM_BUILD_ROOT
116
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
118rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
119
120rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.la
121rm -f $RPM_BUILD_ROOT%{_libdir}/polkit-1/extensions/*.a
122
123# for now, include a compat symlink for the command-line tool
124# and man page
125ln -s udisks $RPM_BUILD_ROOT%{_bindir}/devkit-disks
126ln -s udisks.1 $RPM_BUILD_ROOT%{_datadir}/man/man1/devkit-disks.1
127
128# TODO: should be fixed upstream
129chmod 0644 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/udisks-bash-completion.sh
130
131%find_lang %{name}
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%files -f %{name}.lang
137%defattr(-,root,root,-)
138
139%doc README AUTHORS NEWS COPYING HACKING doc/TODO
140
141%{_sysconfdir}/avahi/services/udisks.service
142%{_sysconfdir}/dbus-1/system.d/*.conf
143%{_sysconfdir}/profile.d/*.sh
144/lib/udev/rules.d/*.rules
145
146/lib/udev/udisks-part-id
147/lib/udev/udisks-dm-export
148/lib/udev/udisks-probe-ata-smart
149/lib/udev/udisks-probe-sas-expander
150/lib/udev/udisks-lvm-pv-export
151/sbin/umount.udisks
152
153%{_bindir}/*
154%{_libexecdir}/*
155
156%{_mandir}/man1/*
157%{_mandir}/man7/*
158%{_mandir}/man8/*
159
160%{_datadir}/polkit-1/actions/*.policy
161
162%{_libdir}/polkit-1/extensions/*.so
163
164%{_datadir}/dbus-1/system-services/*.service
165
166%attr(0700,root,root) %dir %{_localstatedir}/run/udisks
167%attr(0700,root,root) %dir %{_localstatedir}/lib/udisks
168
169%files devel
170%defattr(-,root,root,-)
171
172%{_datadir}/dbus-1/interfaces/*.xml
173%{_datadir}/pkgconfig/udisks.pc
174
175%dir %{_datadir}/gtk-doc/html/udisks
176%{_datadir}/gtk-doc/html/udisks/*
177
178# Note: please don't forget the %{?dist} in the changelog. Thanks
179#
180%changelog
181* Tue Mar 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2-3
182- add patch100 for fix CVE-2014-0004 (mount path)
183  - this patch is from debian, thanks
184- add Vendor/Distri tags
185
186* Sun Aug 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-2
187- add Patch0 (10-ide-cd-support.patch) from ubuntu
188
189* Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-1
190- new upstream release
191
192* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1-2
193- rebuilt with parted 2.3
194
195* Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.1-1
196- new upstream release
197
198* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.0.0-1
199- Initial build for Vine Linux
200
201
202* Tue Mar 30 2010 Richard W.M. Jones <rjones@redhat.com> - 1.0.0-2%{?dist}
203- Bump release and rebuild so we link to the new libparted.
204
205* Mon Mar 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-1%{?dist}
206- Update to release 1.0.0
207
208* Tue Feb 23 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100223.1%{?dist}
209- Update to new git snapshot
210
211* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.3%{?dist}
212- Require lvm2-libs >= 2.02.61 to get the right ABI for liblvm2app
213
214* Tue Feb 16 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.2%{?dist}
215- Update for new liblvm2app library
216
217* Mon Feb 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100215.1%{?dist}
218- Update to git snapshot
219
220* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.2%{?dist}
221- Rebuild
222
223* Fri Jan 15 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20100115.1%{?dist}
224- New git snapshot with LVM support
225
226* Tue Jan 12 2010 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.3%{?dist}
227- Rebuild for new libparted
228
229* Mon Dec 07 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.2%{?dist}
230- Rebuild
231
232* Fri Dec 04 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202.1%{?dist}
233- Updated for package review (#543608)
234
235* Wed Dec 02 2009 David Zeuthen <davidz@redhat.com> - 1.0.0-0.git20091202%{?dist}
236- Git snapshot for upcoming 1.0.0 release
Note: See TracBrowser for help on using the repository browser.