source: projects/specs/branches/6/t/tzdata/tzdata-vl.spec @ 9609

Revision 9609, 11.4 KB checked in by tomop, 9 years ago (diff)

tzdata-2015e-1

Line 
1%bcond_with java18
2
3Summary: Timezone data
4Summary(ja): タイムゾーンのデータ
5Name: tzdata
6Version: 2015e
7%define tzdata_version 2015e
8%define tzcode_version 2015e
9Release: 1%{?_dist_release}
10
11License: Public Domain
12Group: System Environment/Base
13URL: https://www.iana.org/time-zones
14
15# These are official upstream.
16Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
17Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
18Source2: javazic.tar.gz
19Source3: javazic-1.8-37392f2f5d59.tar.xz
20
21Patch100: javazic-fixup.patch
22Patch101: rebase-01.patch
23Patch102: rebase-02.patch
24Patch103: 7090844.patch
25Patch104: 7133138.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildArch: noarch
29BuildRequires: gawk, glibc, perl
30BuildRequires: java-devel
31BuildRequires: glibc-common >= 2.5.90-7
32Conflicts: glibc-common <= 2.3.2-63
33
34
35%description
36This package contains data files with rules for various timezones around
37the world.
38
39%description -l ja
40このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
41
42%package java
43Summary: Timezone data for Java
44Group: System Environment/Base
45
46%description java
47This package contains timezone information for use by Java runtimes.
48
49
50%prep
51%setup -q -c -a 1
52
53mkdir javazic
54tar zxf %{SOURCE2} -C javazic
55pushd javazic
56%patch100
57%patch101
58%patch102
59%patch103
60%patch104
61
62# Hack alert! sun.tools may be defined and installed in the
63# VM. In order to guarantee that we are using IcedTea/OpenJDK
64# for creating the zoneinfo files, rebase all the packages
65# from "sun." to "rht.". Unfortunately, gcj does not support
66# any of the -Xclasspath options, so we must go this route
67# to ensure the greatest compatibility.
68mv sun rht
69find . -type f -name '*.java' -print0 \
70    | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
71                         -e 's:sun\.util\.:rht.util.:g'
72popd
73
74tar xf %{SOURCE3}
75
76echo "%{name}%{tzdata_version}" >> VERSION
77
78
79%build
80FILES="africa antarctica asia australasia europe northamerica southamerica
81       pacificnew etcetera backward"
82
83mkdir zoneinfo/{,posix,right}
84zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
85zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
86zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
87
88grep -v tz-art.htm tz-link.htm > tz-link.html
89
90# Java 6/7 tzdata
91pushd javazic
92javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
93popd
94
95java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
96  -d javazi \
97  $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
98
99%if %{with java18}
100# Java 8 tzdata
101pushd javazic-1.8
102javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
103popd
104
105java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
106    -srcdir . -dstfile tzdb.dat \
107    -verbose \
108    $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
109%endif
110
111
112%install
113rm -fr $RPM_BUILD_ROOT
114install -d $RPM_BUILD_ROOT%{_datadir}
115cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
116install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
117cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
118
119%if %{with java18}
120mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
121install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
122%endif
123
124%clean
125rm -fr $RPM_BUILD_ROOT
126
127%files
128%defattr(-,root,root)
129%{_datadir}/zoneinfo
130%doc README
131%doc Theory
132%doc tz-link.html
133
134%files java
135%defattr(-,root,root)
136%{_datadir}/javazi
137%if %{with java18}
138%{_datadir}/javazi-1.8
139%endif
140
141%changelog
142* Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
143- updated to 2015e.
144
145* Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
146- update to tzdata-2012c, tzcode-2012b
147
148* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
149- rebuilt with rpm-4.8.1-3
150
151* Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
152- update to tzdata-2010l, tzcode-2010l
153- added java subpackage
154
155* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
156- update to tzdata-2009d, tzcode-2009d
157- spec in utf-8
158
159* Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
160- update to tzdata-2008b, tzcode-2008a
161
162* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
163- initial build for VineSeed
164
165* Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
166- Upstream 2007d
167  - Mongolia has abolished DST.
168  - Turkey will use EU rules this year, changing at 01:00 UTC rather
169    than 01:00 standard time.
170  - Cuba observed DST starting Sunday.
171  - Resolute, Nunavut switched from Central to Eastern time last
172    November.
173
174* Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
175- Upstream 2007c
176  - Pulaski County, Indiana, switched back to eastern time.
177  - Turkey switches at 01:00 standard time, not at 01:00 UTC.
178- Upstream 2007b
179  - Changes to the commentary in "leapseconds".
180- Upstream 2007a
181  - Updates to Bahamas, they will be in sync with 2007 US DST change
182  - New zone Australia/Eucla
183  - Africa/Asmera renamed to Africa/Asmara, link created
184  - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
185
186* Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
187- Upstream 2006p
188  - Covers changes from 2006m-2 and 2006m-3
189  - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
190
191* Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
192- Patch for Western Australia DST trial
193
194* Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
195- Proposed upstream patch (#210058)
196  - Jordan will switch to winter time on October 27, not September 29
197  - Brazil's DST this year is the first Sunday in November to the last
198    Sunday in February.  (Thanks to Frederico A. C. Neves.)
199  - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
200  - Commentary and past timestamps changes
201
202* Tue Oct  3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
203- Upstream 2006m:
204  - Adjustments for Egypt, Palestine, Uruguay
205  - Better description of `until' field in zic (8) manpage
206
207* Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
208- Upstream 2006k, 2006l:
209  - Adjustments for Egypt, Palestine, Cuba, Honduras
210  - Documentation changes
211
212* Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
213- Upstream 2006j
214  - Honduras stopped observing DST on Monday at 00:00
215  - America/Bermuda will follow the US's lead next year
216  - America/Moncton will use US-style rules next year
217  - New Zone America/Blanc-Sablon, for Canadians who observe AST all
218    year
219  - New zone: America/Atikokan instead of America/Coral_Harbour
220  - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
221  - Historical changes
222  - Commentary updates
223- Upstream 2006i
224  - localtime.c fixes
225- Upstream 2006h
226  - zic leapsecond fix
227
228* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
229- rebuild
230
231* Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
232- Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
233- Nicaragua updates
234
235* Tue May  2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
236- Upstream 2006f
237  - America/Guatemala observes DST between Apr/30 and Oct/1
238  - Historical changes for Nicaragua
239  - Update of America/Indiana/Vincennes in zone table
240
241* Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
242- Upstream 2006d
243  - Haiti observes DST
244  - Sri Lanka change actually took effect Apr/15
245  - All Canada is now scheduled for 2007 US DST rules
246  - Some historical fixes
247
248* Thu Apr  6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
249- Upstream 2006c
250  - Time-related changes:
251    - dozens of historical and commentary changes
252    - Iran stopped observing DST
253    - Sri Lanka switches from UTC+6 to UTC+5:30
254    - America/Thule and America/Edmonton will adopt new US rules,
255      starting 2007
256    - Tunisia is adopting regular DST
257  - Code:
258    - asctime.c: Chages in format strings to silent gcc warnings
259    - removing K&R notation from function signatures
260    - few fixes across the code
261
262* Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
263- Patch for Sri Lanka time zone change (#184514)
264
265* Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
266- Upstream 2006b:
267  - using tz64code version, as 32 is legacy according to tzdata ML
268  - new manual pages for ctime, strftime, tzset
269  - some source code reorganizations
270  - no timezone/dst rule updates
271
272* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
273- Small changes in tst-timezone.c
274
275* Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
276- Upstream 2006a:
277  - private.h(scheck): changing char* to char const*
278  - Rule changes for Palestine, zone changes for Indiana/US, both
279    changes for Canada.
280  - Many related doc changes.
281- Naming scheme in spec file doesn't use %%{name}, but tzdata.
282
283* Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
284- 2005r-3
285  - Meta changes.  Renaming tzdata.tar.bz2 file to tzdata$ver-base,
286    so that it won't clash across updates.
287
288* Thu Jan  5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
289- 2005r
290  - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
291    northamerica to guard against old files with obsolete information
292    being left in the time zone binary directory.
293  - Changes for countries that are supposed to join 2007 US DST
294    change.  This includes most of Canada, however entries already in
295    the database (Alberta, British Columbia, Newfoundland, Northwest
296    Territories, and Yukon) were left alone for the time being.
297  - Fixes in zdump.c (abbrok): conditions are chained, and the string
298    is checked for emptiness.
299
300* Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
301- 2005q
302  - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
303  - SystemV timezone changes
304
305* Wed Nov  2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
306- 2005n
307  - changes for Kyrgyzstan and Uruguay
308- fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
309  make check), update tst-timezone.c from glibc CVS (#172102)
310
311* Tue Sep  6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
312- 2005m
313  - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
314    Australia, Kazakhstan
315  - historical timezone data changes for Japan, Poland, Northern Ireland and
316    Mali
317  - timezone name change for East Timor
318
319* Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
320- 2005k
321  - leap seconds update
322
323* Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
324- 2005i
325  - updates for Iran, Haiti and Nicaragua
326
327* Mon Apr  4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
328- 2005h
329  - fixes for Kazakhstan
330
331* Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
332- 2005g
333  - fixes for Uruguay
334- include README and Theory from tzcode tarball in %{_docdir};
335  Theory includes a good summary of how the timezone data files
336  are supposed to be named
337
338* Tue Mar  1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
339- 2005f
340  - more updates for Israel, updates for Azerbaijan
341
342* Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
343- 2005c
344  - updates for Israel and Paraguay
345
346* Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
347- 2004g (#141107)
348  - updates for Cuba
349
350* Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
351- 2004e (#135194)
352  - updates for Brazil, Uruguay and Argentina
353
354* Wed Aug  4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
355- 2004b
356
357* Mon Oct  6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
358- 2003d
359
360* Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
361- 2003c
362- updates for Brazil (#104840)
363
364* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
365- rebuilt
366
367* Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
368- initial package
Note: See TracBrowser for help on using the repository browser.