source: projects/specs/branches/6/t/totem/totem-vl.spec @ 2041

Revision 2041, 16.5 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1# build browser plugins
2%define build_plugin    %{!?_without_mozilla:1}%{?_without_mozilla:0}
3
4# define versions
5%define _glib_ver               2.26.0
6%define _gtk_ver                2.22.0
7%define _gnomeicon_ver          2.31.0
8%define _gnome_doc_utils_ver    0.20.0
9%define _dbus_ver               1.4.0
10%define _gst_ver                0.10.30
11%define _gstpb_ver              0.10.30
12%define _gstpg_ver              0.10.24
13%define _xulrunner_ver          1.9
14%define _nautilus_ver           2.32.0
15%define _shared_mime_info_ver   0.17
16%define _unique_ver             1.0
17%define _vala_ver               0.10.0
18%define _totem_pl_parser_ver    2.32.0
19%define _libgdata_ver           0.6.5
20
21%define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
22%define mozplug_dir %{_libdir}/mozilla/plugins
23
24Summary:        Movie player for GNOME 2
25Summary(ja):    GNOME2 用動画プレイヤー
26Name:           totem
27Version:        2.32.0
28Release:        1%{?_dist_release}
29License:        GPL
30Group:          Applications/Multimedia
31URL:            http://www.gnome.org/projects/totem/
32Source0:        http://ftp.gnome.org/pub/GNOME/sources/totem/2.32/totem-%{version}.tar.bz2
33
34BuildRoot:      %{_tmppath}/%{name}-%{version}-root
35Vendor:         Project Vine
36Distribution:   Vine Linux
37
38BuildRequires:  gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
39BuildRequires:  gnome-icon-theme >= %{_gnomeicon_ver}
40BuildRequires:  gnome-doc-utils >= %{_gnome_doc_utils_ver}
41BuildRequires:  dbus-devel >= %{_dbus_ver}
42BuildRequires:  nautilus-devel >= %{_nautilus_ver}
43BuildRequires:  gettext, scrollkeeper
44BuildRequires:  perl-XML-Parser
45BuildRequires:  iso-codes
46BuildRequires:  totem-pl-parser-devel >= %{_totem_pl_parser_ver}
47BuildRequires:  bluez-libs-devel >= 4.15
48BuildRequires:  lirc
49BuildRequires:  unique-devel >= %{_unique_ver}
50BuildRequires:  vala-devel >= %{_vala_ver}
51BuildRequires:  python-devel
52BuildRequires:  pygtk2-devel
53BuildRequires:  libgdata-devel >= %{_libgdata_ver}
54
55BuildRequires:  gstreamer-devel >= %{_gst_ver}
56BuildRequires:  gstreamer-plugins-base-devel >= %{_gstpb_ver}
57BuildRequires:  gstreamer-plugins-good >= %{_gstpg_ver}
58
59%if %{build_plugin}
60BuildRequires:  xulrunner-devel >= %{_xulrunner_ver}
61BuildRequires:  nautilus-devel >= %{_nautilus_ver}
62BuildRequires:  shared-mime-info >= %{_shared_mime_info_ver}
63%endif
64
65Requires:       gstreamer >= %{_gst_ver}
66Requires:       gstreamer-plugins-base >= %{_gstpb_ver}
67Requires:       gstreamer-plugins-good >= %{_gstpg_ver}
68Requires:       iso-codes
69# for opensubtitles plugin
70Requires:       pyxdg
71# for python plugins
72Requires:       pygtk2
73# for coherence plugins
74Requires:       python-Coherence >= 0.6.6.2
75
76Obsoletes:      nautilus-media
77Obsoletes:      %{name}-gstreamer < 2.30.1-2
78Obsoletes:      %{name}-xine < 2.30.1-2
79Obsoletes:      %{name}-common < 2.30.1-3
80
81Provides:       nautilus-media
82Provides:       %{name}-common = %{version}-%{release}
83
84Requires(post):     ldconfig, scrollkeeper, desktop-file-utils, GConf2
85Requires(postun):   ldconfig, scrollkeeper, desktop-file-utils
86Requires(preun):    GConf2
87
88%description
89Totem is simple movie player for the Gnome desktop. It features a
90simple playlist, a full-screen mode, seek and volume controls, as well as
91a pretty complete keyboard navigation.
92
93%if %{build_plugin}
94%package mozilla
95Summary:        Totem movie plugin for Mozilla
96Summary(ja):    Mozilla 用 Totem 動画プラグイン
97Group:          Applications/Internet
98Requires:       %{name} = %{version}-%{release}
99Obsoletes:      %{name}-mozilla-common
100Obsoletes:      %{name}-mozilla-gstreamer
101Obsoletes:      %{name}-mozilla-xine
102
103%description mozilla
104Totem is simple movie player for the Gnome desktop. It features a
105simple playlist, a full-screen mode, seek and volume controls, as well as
106a pretty complete keyboard navigation.
107
108This package contains a Totem video plugin for Mozilla. It allows Totem
109movie player to be embedded into a web browser.
110
111%endif
112
113%prep
114%setup -q
115
116%build
117DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
118export MOZILLA_PLUGINDIR=%{mozplug_dir}
119%configure \
120        --disable-schemas-install \
121        --disable-scrollkeeper \
122        --enable-python \
123        --enable-nautilus \
124        --enable-gmp-plugin \
125        --enable-narrowspace-plugin \
126        --enable-mully-plugin \
127%if %{build_plugin}
128        --enable-browser-plugins
129%else
130        --disable-browser-plugins
131%endif
132
133make %{?_smp_mflags}
134
135%install
136rm -rf $RPM_BUILD_ROOT
137export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
138
139make install DESTDIR=$RPM_BUILD_ROOT
140
141# remove unneeded files
142%__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
143%__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
144%__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
145%__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
146%__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
147%__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
148 
149%find_lang %{name} --with-gnome
150
151# save space by linking identical images in translated docs
152helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
153for f in $helpdir/C/figures/*.png; do
154  b="$(basename $f)"
155  for d in $helpdir/*; do
156    if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
157      g="$d/figures/$b"
158      if [ -f "$g" ]; then
159        if cmp -s $f $g; then
160          rm "$g"; ln -s "../../C/figures/$b" "$g"
161        fi
162      fi
163    fi
164  done
165done
166
167
168%clean
169%__rm -rf %{buildroot}
170
171%post
172%{_bindir}/scrollkeeper-update -q
173%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
174export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
175gconftool-2 --makefile-install-rule \
176        %{_sysconfdir}/gconf/schemas/totem.schemas \
177        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
178        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
179    >& /dev/null || :
180touch %{_datadir}/icons/hicolor
181if [ -x /usr/bin/gtk-update-icon-cache ]; then
182  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
183fi
184
185%pre
186if [ "$1" -gt 1 ]; then
187    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
188    gconftool-2 --makefile-uninstall-rule \
189        %{_sysconfdir}/gconf/schemas/totem.schemas \
190        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
191        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
192        >& /dev/null || :
193fi
194
195%preun
196if [ "$1" -eq 0 ]; then
197    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
198    gconftool-2 --makefile-uninstall-rule \
199        %{_sysconfdir}/gconf/schemas/totem.schemas \
200        %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
201        %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
202 >& /dev/null || :
203fi
204
205%postun
206%{_bindir}/scrollkeeper-update -q
207%{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
208touch %{_datadir}/icons/hicolor
209if [ -x /usr/bin/gtk-update-icon-cache ]; then
210  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
211fi
212
213%files -f %{name}.lang
214%defattr(-,root,root,-)
215%doc AUTHORS COPYING ChangeLog NEWS README TODO
216%config %{_sysconfdir}/gconf/schemas/*.schemas
217%{_bindir}/totem
218%{_bindir}/totem-audio-preview
219%{_bindir}/totem-video-indexer
220%{_bindir}/totem-video-thumbnailer
221%{_datadir}/applications/%{name}.desktop
222%{_datadir}/icons/*/*/apps/*
223%{_datadir}/icons/*/*/devices/*
224%{_datadir}/%{name}
225%{_datadir}/gtk-doc/html/totem
226%dir %{_libdir}/totem
227%dir %{_libdir}/totem/plugins
228%{_libdir}/totem/plugins/brasero-disc-recorder
229%{_libdir}/totem/plugins/chapters
230%{_libdir}/totem/plugins/coherence_upnp
231%{_libdir}/totem/plugins/dbus
232%{_libdir}/totem/plugins/gromit
233%{_libdir}/totem/plugins/iplayer
234%{_libdir}/totem/plugins/jamendo
235%{_libdir}/totem/plugins/lirc
236%{_libdir}/totem/plugins/media-player-keys
237%{_libdir}/totem/plugins/ontop
238%{_libdir}/totem/plugins/opensubtitles
239%{_libdir}/totem/plugins/properties
240%{_libdir}/totem/plugins/pythonconsole
241%{_libdir}/totem/plugins/sample-vala
242%{_libdir}/totem/plugins/screensaver
243%{_libdir}/totem/plugins/screenshot
244%{_libdir}/totem/plugins/skipto
245%{_libdir}/totem/plugins/thumbnail
246%{_libdir}/totem/plugins/youtube
247%{_libdir}/totem/plugins/totem
248%if %{build_plugin}
249%{_libdir}/nautilus/extensions-2.0/*.so*
250%endif
251%{_libexecdir}/%{name}/totem-bugreport.py
252%{_mandir}/man1/*
253
254%if %{build_plugin}
255%files mozilla
256%defattr(-,root,root,-)
257%{mozplug_dir}/*
258%{_libexecdir}/totem-plugin-viewer
259%endif
260
261%changelog
262* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
263- new upstream release
264- fix %files
265
266* Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
267- new upstream release
268
269* Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
270- clean up spec file
271- remove totem-common and merged to totem main package.
272  - add Obsoletes: totem-common
273- remove unneeded BR: and R:
274  - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
275  - libmusicbrainz, alternatives
276- remove explicit dependency
277  - gtk2, glib2, dbus
278- add R: pygtk2, pyxdg, python-Coherence for python plugins
279- add R: gstreamer-plugins-good
280
281* Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
282- rebuild with libgdata (add youtube plugin)
283- add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
284- add Obsolete: totem-gstreamer, totem-xine)
285
286* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
287- new upstream release
288- chagnge _gst_ver from 0.10.19 to 0.10.29
289
290* Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
291- new upstream release
292- drop totem-tracker package
293- add BuildRequires: unique-devel
294- remove BuildRequires: hal-devel
295- remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
296
297* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
298- remove unneeded autoreconf
299- add BR: lirc
300
301* Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
302- new upstream release
303
304* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
305- remove bemused plugin
306
307* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
308- new upstream release
309
310* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
311- added tracker video search sub-package
312
313* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
314- new upstream release
315
316* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
317- new upstream release
318
319* Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
320- remove libxine dependency from totem-common
321- build xine backend with minimum dependency
322
323* Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
324- add BR: bluez-libs-devel >= 4.15
325- fix typo in %%postun xine
326
327* Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
328- rebuild with bluez-libs-devel-4.15
329
330* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
331- new upstream release
332
333* Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
334- new upstream release
335
336* Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
337- new upstream release
338- add patch1 to build with xulrunner-1.9
339
340* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
341- new upstream release
342
343* Mon Apr  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
344- new upstream release
345- disabled devel package (replaced by totem-pl-parser-devel)
346
347* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
348- new upstream release
349- update version macros
350- enable browser plugins on x86_64
351
352* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
353- new upstream release
354
355* Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
356- upstream release
357- drop obsolete ja.po.patch (patch0)
358- revert change of 1.4.4-0vl2
359
360* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
361- upstream release
362- enable browser plugins (exclude x86_64 arch)
363
364* Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
365- upstream release
366
367* Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
368- update configure options
369- add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
370
371* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
372- fix mistranslation (patch0)
373- add icon symlink
374- add BuildRequires: gstreamer-plugins-good
375
376* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
377- upstream release
378- update %%_glib_ver, %%_xine_ver
379- add BuildRequires: hal
380- update %%configure options
381- update %%files
382
383* Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
384- upstream release
385
386* Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
387- fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
388
389* Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
390- upstream release
391- drop obsolete patch0
392
393* Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
394- upstream release
395- add patch0 to build with intltool-0.35
396
397* Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
398- upstream release
399
400* Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
401- upstream release
402- update alternatives entry
403
404* Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
405- upstream release
406- drop fix-sort-function.patch (was merged to upstream, #331426)
407
408* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
409- rebuild with gnome-2.14rc
410
411* Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
412- upstream release
413- add macros
414  - _gtk_ver, _glib_ver
415  - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
416  - _dbus_ver
417  - _gst_ver, gstpb_ver, _xine_ver
418- add fix-sort-function.patch to build with glib < 2.9.1
419
420* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
421- upstream release
422- add BuildRequires:
423  - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
424  - gnome-vfs2-devel >= 2.9.92
425  - dbus-devel >= 0.35
426- use gstreamer-0.10 as backend for totem-gstreamer
427
428* Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
429- use gstreamer08 instead of gstreamer
430
431* Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
432- upstream release
433
434* Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
435- fix missing links
436  - update file list
437  - update update-alternatives scripts
438- fix totem-gstreamer's %%postun script
439
440* Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
441- upstream release
442- add BuildRequires: iso-codes, libmusicbrainz-devel
443- add Requires: iso-codes, libmusicbrains to -common package
444- remove BuildRequires: nautilus-cd-burner
445- remove Requires: nautilus-cd-burner from -common package
446
447* Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
448- totem-gstreamer obsoletes nautilus-media
449
450* Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
451- upstream release
452- add Requires(post,postun): alternatives for gstreamer,xine
453- add Requires(postun,triggers): alternatives for common
454
455* Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
456- upstream release
457
458* Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
459- build xine backend
460  - move common files to common package
461  - move GStreamer related files to gstreamer package
462  - install xine related files to xine package
463- fix scripts
464
465* Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
466- upstream release
467- update URL
468- move *.{a,la} to devel package
469
470* Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
471- fix %%{post,preun} script (video-thumbnail.schemas)
472- sync with Fedora Core's 1.0.1-1
473
474  * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
475  - Update to upstream version 1.0.1
476  - Break out devel package
477
478* Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
479- add %%{post,pre}un script
480
481* Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
482- initial build for Vine Linux
483
484* Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
485- fix %%post
486
487* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
488- Obsolete nautilus-media
489- Install property page and thumbnailer
490
491* Wed Feb  2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
492- Update to 0.101
493 
494* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
495- Grab patch totem-0.100-desktopfile.patch from CVS to fix
496  missing menu entry (144088)
497- Remove workaround for desktop file being misinstalled, fixed
498  by above patch
499
500* Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
501- New upstream version 0.100
502
503* Sun Dec  5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
504- update to 0.99.22
505
506* Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
507- Add patch to remove removed items from package from help
508
509* Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
510- New upstream 0.99.19
511  - Fixes crasher with CD playback (see NEWS)
512
513* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
514- Call update-desktop-database in post
515
516* Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
517- update to 0.99.18
518
519* Wed Oct  6 2004 Alexander Larsson <alexl@redhat.com> -
520- Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>
521
Note: See TracBrowser for help on using the repository browser.