source: projects/specs/branches/6/t/tomoe/tomoe-vl.spec @ 1985

Revision 1985, 7.0 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define with_python     0
2
3# build ruby extension
4%define with_ruby       %{?_with_ruby:1}%{!?_with_ruby:0}
5
6%define __libtoolize    /bin/true
7
8Summary:        Japanese handwritten input system
9Summary(ja):    日本語手書き文字認識エンジン
10Name:           tomoe
11Version:        0.6.0
12Release:        2%{?_dist_release}
13Group:          System Environment/Libraries
14License:        LGPL
15URL:            http://tomoe.sourceforge.jp/
16Source0:        tomoe-%{version}.tar.gz
17Patch0:         tomoe-0.6.0-multiarch-conflict.patch
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  gtk-doc >= 1.4, libxslt
20BuildRequires:  glib2-devel >= 2.4.0
21#BuildRequires: neon-devel
22#BuildRequires: apr-devel, subversion-devel
23#BUildRequires: MySQL-devel
24BuildRequires:  unzip
25Requires:       glib2 >= 2.4.0
26Requires:               ldconfig
27
28%description
29A program which does Japanese handwriting recognition.
30
31%description -l ja
32日本語の手書き文字を認識するエンジンです。
33
34%package devel
35Summary:        Header files for developing tomoe applications
36Summary(ja):    tomoe アプリケーション開発用ヘッダファイル
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       pkgconfig
40
41%description devel
42The tomoe-devel package includes the header files for the tomoe package.
43Install this package if you want to develop programs which use tomoe.
44
45%description -l ja devel
46tomoe-devel パッケージには、tomoe を使うアプリケーションを開発するための
47ヘッダファイルが含まれています。
48
49%if %{with_python}
50%package -n python-tomoe
51Summary:        Tomoe library for Python
52Summary(ja):    Python から巴を使うためのライブラリ
53Group:          System Environment/Libraries
54Requires:       %{name} = %{version}-%{release}
55Requires:       python
56BuildRequires:  python-devel
57
58%description -n python-tomoe
59Python extension library to use Tomoe
60
61%description -l ja -n python-tomoe
62Python から巴を使うための拡張ライブラリです。
63%endif
64
65
66%if %{with_ruby}
67%package -n ruby-tomoe
68Summary:        Tomoe library for Ruby
69Summary(ja):    Ruby から巴を使うためのライブラリ
70Group:          System Environment/Libraries
71Requires:       %{name} = %{version}-%{release}
72Requires:       ruby
73BuildRequires:  ruby-devel, ruby-gnome2-devel
74
75%description -n ruby-tomoe
76Ruby extension library to use Tomoe
77
78%description -l ja -n ruby-tomoe
79Ruby から巴を使うための拡張ライブラリです。
80
81%package -n ruby-tomoe-devel
82Summary:        Header files for developing ruby-tomoe applications
83Summary(ja):    ruby-tomoe アプリケーション開発用ヘッダファイル
84Group:          Development/Libraries
85Requires:       ruby-tomoe = %{version}-%{release}
86Requires:       %{name}-devel = %{version}-%{release}
87
88%description -n ruby-tomoe-devel
89The ruby-tomoe-devel package includes the header files for the ruby-tomoe
90package.
91Install this package if you want to develop programs which use ruby-tomoe.
92
93%description -l ja -n ruby-tomoe-devel
94ruby-tomoe-devel パッケージには、ruby-tomoe を使うアプリケーションを開発
95するためのヘッダファイルが含まれています。
96%endif
97
98%prep
99%setup -q
100%patch0 -p0 -b .multiarch-conflict
101
102%build
103autoreconf -vif
104%configure \
105        --disable-static \
106        --with-ruby-extdir=%{rarchdir} \
107        --with-ruby-libdir=%{rlibdir}
108%__make %{?_smp_mflags}
109
110%install
111%__rm -rf $RPM_BUILD_ROOT
112%__make DESTDIR=%{buildroot} install
113
114%if !%{with_ruby}
115rm -f $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/tomoe.rb $RPM_BUILD_ROOT%{_libdir}/ruby/site_ruby/*/*-linux/*
116%endif
117chmod 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/xml2est.rb
118
119# remove unneeded files
120%__rm -f %{buildroot}%{_libdir}/tomoe/module/dict/libmysql.*
121%__rm -f %{buildroot}%{_libdir}/tomoe/module/dict/libsvn.*
122find ${RPM_BUILD_ROOT} -name '*.la' | xargs rm
123
124%if !%{with_python}
125%__rm -f %{buildroot}%{_libdir}/python?.?/site-packages/tomoe.so
126%endif
127
128%if !%{with_ruby}
129%__rm -rf %{buildroot}%{rarchdir}
130%__rm -rf %{buildroot}%{rlibdir}
131%endif
132
133%find_lang %{name}
134
135%clean
136%__rm -rf %{buildroot}
137
138%post
139%{_syssbindir}/ldconfig
140
141%postun
142%{_syssbindir}/ldconfig
143
144%files -f %{name}.lang
145%defattr(-,root,root,-)
146%doc AUTHORS COPYING ChangeLog NEWS README TODO
147%dir %{_sysconfdir}/tomoe
148%config(noreplace) %{_sysconfdir}/tomoe/config
149%{_libdir}/*.so.*
150%dir %{_libdir}/tomoe
151%dir %{_libdir}/tomoe/module
152%dir %{_libdir}/tomoe/module/dict
153%{_libdir}/tomoe/module/dict/*.so
154%dir %{_libdir}/tomoe/module/recognizer
155%{_libdir}/tomoe/module/recognizer/*.so
156%{_datadir}/tomoe
157
158
159%files devel
160%defattr(-,root,root,-)
161%{_includedir}/tomoe
162%{_libdir}/pkgconfig/*.pc
163%{_libdir}/*.so
164%{_datadir}/gtk-doc/html/tomoe
165
166
167%if %{with_python}
168%files -n python-tomoe
169%defattr(-,root,root,-)
170%{_libdir}/python?.?/site-packages/tomoe.so
171%endif
172
173
174%if %{with_ruby}
175%files -n ruby-tomoe
176%defattr(-,root,root,-)
177%{rarchdir}/*.so.*
178%{rlibdir}/tomoe.rb
179
180%files -n ruby-tomoe-devel
181%defattr(-,root,root,-)
182%{rarchdir}/*.h
183%{rarchdir}/*.so
184%endif
185
186%changelog
187* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.6.0-2
188- rebuilt with rpm-4.8.1 for pkg-config
189
190* Sun May 31 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.0-1
191- new upstream release
192- added --disable-static in %%configure
193- applied tomoe-0.6.0-multiarch-conflict.patch
194
195* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.5.1-1vl5
196- applied new versioning policy, spec in utf-8
197- remove *.la
198
199* Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.1-0vl1
200- new upstream release
201
202* Sun Jan 07 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl3
203- disable ruby extension by default
204
205* Fri Jan 05 2007 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl2
206- move from tomoe-devel to tomoe
207  - %%{_libdir}/tomoe/module/dict/*.so
208  - %%{_libdir}/tomoe/module/recognizer/*.so
209
210* Sat Dec 31 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.5.0-0vl1
211- new upstream release
212- add BuildRequires: unzip
213- update %%files section
214
215* Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.4.0-0vl1
216- new upstream release
217- update dependencies
218  - drop BuildRequires: libxml2-devel, libxslt-devel, doxygen
219  - add BuildRequires:
220    - gtk-doc, libxslt, glib2-devel
221    - ruby-devel, ruby-gnome2-devel
222  - drop Requires: libxml2, libxslt
223  - add Requires: glib2
224- add new sub-package: ruby-tomoe
225
226* Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl2
227- oops, add Requires: libxml2, libxslt instead of *-devel
228
229* Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.3.0-0vl1
230- new upstream release
231- add BuildRequires: libxml2-devel, libxslt-devel, doxygen
232- add Requires: pkgconfig to -devel package
233- update %%files
234
235* Mon Nov 07 2005 KAZUKI SHIMURA <kazuki@ma.ccna.ne.jp> 0.2.1-3vl1
236- initial release for Vine Linux
237- disable %%__libtoolize
238- add Japanase summary and description
239
240* Sat Sep 3 2005 Warren Togami <wtogami@redhat.com> - 0.2.1-3
241- some spec cleanup
242
243* Sat Sep 2 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-2
244- Sync with Jens's spec file
245
246* Wed Aug 31 2005 Ryo Dairiki <ryo-dairiki@mbm.nifty.com> - 0.2.1-1
247- Initial packaging for Extras
248
249* Fri Jul  1 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
250- (0.2.0-1m)
251- version 0.2.0
252- add a package tomoe-devel
253- add %%post and %%postun sections
254
255* Wed Mar  2 2005 Ichiro Nakai <ichiro@n.email.ne.jp>
256- (0.1.1-1m)
257- initial package for Momonga Linux
258- import %%description from cooker
Note: See TracBrowser for help on using the repository browser.