source: projects/specs/branches/6/t/tix/tix-vl.spec @ 2764

Revision 2764, 9.6 KB checked in by owa, 13 years ago (diff)

tix-8.4.3-2

Line 
1%define tcl_major       8.4
2%define tk_major        8.4
3%define thread_major    2.6
4%define tix_major       8.4
5%define tixversion      %{tix_major}.3
6## can't find all provides
7#define _use_internal_dependency_generator 0
8
9Summary: A Tcl/Tk development environment: tix
10Summary(ja): Tcl/Tk 開発環境: tix
11Name: tix
12Version: %{tixversion}
13Release: 2%{?_dist_release}
14Group: Development/Languages
15License: BSD
16URL: http://tix.sourceforge.net/
17Source0: Tix%{tixversion}-src.tar.gz
18Patch20: tix-8.1.4-perf.patch
19Patch22: tix-8.2.0b1-dirtree.patch
20BuildRequires: tcl >= %{tcl_major}
21BuildRequires: tk >= %{tk_major}
22BuildRequires: thread >= %{thread_major}
23BuildRequires: libX11-devel
24Requires: tcl >= %{tcl_major}
25Requires: tk >= %{tk_major}
26Requires: thread >= %{thread_major}
27Buildroot: %{_tmppath}/%{name}-%{version}-root
28
29%description
30Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
31extensive set of over 40 widgets.  In general, Tix widgets are more
32complex and more capable than the widgets provided in Tk.  Tix widgets
33include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
34FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
35directory tree and a file manager.
36
37Install the tix package if you want to try out more complicated widgets
38for Tk.  You'll also need to have the tcl and tk packages installed.
39
40%description -l ja
41Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
42は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
43Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
44コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
45ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
46ディレクトリツリー、ファイルマネージャを含んでいます。
47
48Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
49してください。tcl と tk のパッケージもインストールする必要があります。
50
51
52%prep
53%setup -q -n Tix%{tixversion}
54#patch20 -p1 -b .perf
55#patch22 -p1 -b .dirtree
56
57%build
58# make the libraries reentrant
59RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
60%configure \
61        --with-tcl=%{_libdir} \
62        --with-tk=%{_libdir} \
63        --enable-shared \
64        --disable-threads \
65        ;
66
67make %{?_smp_mflags} all
68
69%install
70rm -rf ${RPM_BUILD_ROOT}
71%makeinstall
72
73SOFILE=libTix%{version}.so
74mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
75ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
76ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
77ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
78ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
79## internal_dependency_generator can't find provides
80#ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
81cp -p ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
82
83install -d $RPM_BUILD_ROOT%{_mandir}/man1
84install -d $RPM_BUILD_ROOT%{_mandir}/mann
85install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
86install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
87
88install -d $RPM_BUILD_ROOT%{_includedir}
89install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
90
91## others
92SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
93install -d $SHAREDDIR/demos/bitmaps
94install -d $SHAREDDIR/demos/samples
95install -m 755 demos/widget $SHAREDDIR/demos
96install -m 644 demos/{*.tcl,tclIndex}  $SHAREDDIR/demos
97install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
98install -m 644 demos/samples/* $SHAREDDIR/demos/samples
99cp -a tests $SHAREDDIR
100
101## * old scripts *
102## find . -type d -name CVS | xargs -r rm -frv
103## echo "%%defattr(-,root,root)" > tix.files
104## (find ${RPM_BUILD_ROOT}%{_bindir} \
105##         ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
106##  find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
107##         | sort | uniq -u >> tix.files
108##
109## set +x +H
110## for n in `cat tix.files`; do
111##         test -f $n || continue
112##         head -1 $n | grep -q ^#! || continue
113##         chmod u+w $n
114##         perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
115## done
116## set -x -H
117##
118## #==========================================
119## # post process the *.files list, removing build sys references and mark
120## # which are directories
121## set +x
122## for n in *.files; do
123##         mv $n $n.in
124##         sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
125##             if [ -d ${RPM_BUILD_ROOT}/$file ]; then
126##                 echo -n '%dir '
127##             fi
128##             echo $file
129##         done > $n
130##         rm -f $n.in
131## done
132## set -x
133##
134## # Man pages can be compressed
135## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
136
137
138%post -p /sbin/ldconfig
139%postun -p /sbin/ldconfig
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%files
144%defattr(-,root,root,-)
145%{_libdir}/libTix*.so
146%{_libdir}/libtix*.so
147%{_libdir}/Tix%{version}
148%{_datadir}/tix-%{tixversion}
149%{_mandir}/man1/tixwish.1.gz
150%{_mandir}/mann/*.n.gz
151%{_includedir}/*.h
152%doc ChangeLog README.txt man/html man/index.html
153
154
155%changelog
156* Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
157- added BR: libX11-devel
158
159* Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
160- updated tix to 8.4.3
161- dropt tix-8.1.4-perf.patch
162- dropt tix-8.2.0b1-dirtree.patch
163- added "cp -p libTix8.4.3.so libtix8.4.so"
164- rebuilt with file-5.05-2
165
166* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
167- rebuilt with tcl/tk-8.4.19-2
168
169* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
170- applied new versioning policy
171
172* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
173- rebuild with tcl/tk-8.4.18
174
175* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
176- rebuild with tcl/tk-8.4.16
177
178* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
179- updated tix to 8.4.2
180- rebuilt with new toolchain
181
182* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
183- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
184
185* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
186- changed url to http://tix.sourceforge.net/download.shtml
187- rebuild for tcl/tk-8.4.11
188
189* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
190- rebuild for tcl/tk-8.4.6
191
192* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
193- rebuild for tcl/tk-8.4.5
194
195* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
196- update based on BitWalk's tcltk-8.4.2-83bw
197
198* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
199- splite source package
200
201* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
202- expand some macros.. (FIXME)
203
204* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
205- use %configure macros
206- add Patch 47,50
207
208* Thu May 31 2001 <sagami@vinelinux.org>
209- 8.0.5_jp-10
210- unexpand old %%{configure}, new one causes build failure
211- fixed missing libtkx.so libtclx.so symlink in /usr/lib
212- install manpages into %%{_mandir} and mode 644
213
214* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
215- 8.0.5_jp-9
216- modified %install section to handle compressed man pages
217- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
218
219* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
220- changed default fonts
221
222* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
223- added defattr
224
225* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
226- added some symlinks, such as libtcl8.0.so.
227- obsoletes version number using _jp, now 8.0.5-31vl1
228
229* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
230- Apply Tcl/Tk 8.0 Japanese Patch 1.7
231
232* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
233- fix tclX symlinks.
234- compile on systems where SIGPWR == SIGLOST.
235
236* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
237- update tcl/tk to 8.0.5.
238- avoid "containing" in Tix (#2332).
239
240* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
241- use /usr/bin/write in kibitz (#1320).
242- use cirrus.sprl.umich.edu in weather (#1926).
243
244* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
245- auto rebuild in the new build environment (release 28)
246
247* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
248- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
249
250* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
251- expect does unaligned access on alpha (#989)
252- upgrade tcl/tk/tclX to 8.0.4
253- upgrade expect to 5.28.
254- add itcl 3.0.1
255
256* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
257- call libtoolize to allow building on the arm
258- build for glibc 2.1
259- strip binaries
260
261* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
262- update tcl/tk/tclX to 8.0.3, expect is updated also.
263
264* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
265- expect: mkpasswd needs delay before sending password (problem #576)
266
267* Thu May 07 1998 Prospector System <bugs@redhat.com>
268- translations modified for de, fr, tr
269
270* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
271- fixed expect binaries exec permissions
272
273* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
274- updated to Tix 4.1.0.006
275- updated version numbers of tcl/tk to relflect includsion of p2
276
277* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
278- updated tcl/tk to patch level 2
279- updated tclX to 8.0.2
280
281* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
282- fixed filelist for tix... replacing path to the expect binary in scripts
283  was leaving junk files around.
284
285* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
286- added patch to remove libieee test in configure.in for tcl and tk.
287  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
288  solution for all systems
289- fixed src urls
290
291* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
292- removed version numbers from descriptions
293
294* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
295- updated to tcl/tk 8.0 and related versions of packages
296
297* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
298- built against glibc
299- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.