source: projects/specs/branches/6/t/tidy/tidy-vl.spec @ 5581

Revision 5581, 8.1 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1%define libname libtidy
2
3%define snap 20091203
4
5Name:    tidy
6Summary: Utility to clean up and pretty print HTML/XHTML/XML
7Version: 0.99.0
8Release: 2.%{snap}%{?_dist_release}
9
10Group:   Applications/Text
11License: W3C
12URL:     http://tidy.sourceforge.net/
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Source0: tidy-%{snap}cvs.tar.gz
16Source10: tidy-cvs_checkout.sh
17
18BuildRequires: libtool
19BuildRequires: doxygen
20BuildRequires: libxslt
21
22Requires: %{libname}%{?_isa} = %{version}-%{release}
23
24%description
25When editing HTML it's easy to make mistakes. Wouldn't it be nice if
26there was a simple way to fix these mistakes automatically and tidy up
27sloppy editing into nicely layed out markup? Well now there is! Dave
28Raggett's HTML TIDY is a free utility for doing just that. It also
29works great on the atrociously hard to read markup generated by
30specialized HTML editors and conversion tools, and can help you
31identify where you need to pay further attention on making your pages
32more accessible to people with disabilities.
33
34#'
35
36%package -n %{libname}
37Summary: Shared libraries for %{name}
38Group:   System Environment/Libraries
39%description -n %{libname}
40%{summary}.
41
42%package -n %{libname}-devel
43Summary: Development files for %{name}
44Group:   Development/Libraries
45Obsoletes: tidy-devel < 0.99.0-10
46Provides:  tidy-devel = %{version}-%{release}
47Requires: %{libname}%{?_isa} = %{version}-%{release}
48%description -n %{libname}-devel
49%{summary}.
50
51
52%prep
53%setup -q -n %{name}
54
55# htmldocs included in cvs checkout
56#setup -q -n %{name} -T -D -b1
57
58sh build/gnuauto/setup.sh
59
60
61%build
62%configure \
63  --disable-static \
64  --disable-dependency-tracking
65
66%__make %{?_smp_mflags}
67
68# api docs
69doxygen htmldoc/doxygen.cfg
70
71# make doc steps gleaned from build/gmake/Makefile
72pushd htmldoc
73../console/tidy -xml-config > tidy-config.xml
74../console/tidy -xml-help   > tidy-help.xml
75xsltproc -o tidy.1 tidy1.xsl tidy-help.xml
76xsltproc -o quickref.html quickref-html.xsl tidy-config.xml
77popd
78
79
80%install
81%__rm -rf $RPM_BUILD_ROOT
82
83%__make install DESTDIR=$RPM_BUILD_ROOT
84
85%__install -p -m644 -D htmldoc/tidy.1 $RPM_BUILD_ROOT%{_mandir}/man1/tidy.1
86
87## Unpackaged files
88%__rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
89
90
91%clean
92%__rm -rf $RPM_BUILD_ROOT
93
94
95%post -n %{libname} -p /sbin/ldconfig
96
97%postun -n %{libname} -p /sbin/ldconfig
98
99
100%files
101%defattr(-,root,root,-)
102%doc htmldoc/*.html htmldoc/*.css htmldoc/*.gif
103%{_bindir}/tab2space
104%{_bindir}/tidy
105%{_mandir}/man1/tidy.1*
106
107%files -n %{libname}
108%defattr(-,root,root,-)
109%{_libdir}/libtidy-0.99.so.0*
110
111%files -n %{libname}-devel
112%defattr(-,root,root,-)
113%doc htmldoc/api/*
114%{_includedir}/*.h
115%{_libdir}/libtidy.so
116
117
118%changelog
119* Sun Feb 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.99.0-2.20091203
120- rebuild with Vine6 environment
121
122* Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.99.0-1.20091203
123- initial build based on Fedora development
124
125* Thu Dec 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.99.0-20.20091203
126- 20091203 snapshot
127- spec housecleaning
128- Tidy erroniously removes whitespace, causing mangled text (#481350)
129
130* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99.0-19.20070615
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
132
133* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99.0-18.20070615
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
135
136* Mon Feb 11 2008 Rex Dieter <rdieter@fedoraproject.org> 0.99.0-17.20070615
137- respin (gcc43)
138
139* Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.99.0-16.20070615
140- respin (BuildID)
141
142* Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.99.0-15.20070615
143- License: W3C
144
145* Tue Jul 31 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.99.0-14.20070615
146- BR: libtool (again)
147
148* Mon Jul 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.99.0-13.20070615
149- 2007-06-15 snapshot
150
151* Wed Feb 28 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 0.99.0-12.20070228
152- 2007-02-28 snapshot
153
154* Tue Aug 29 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.99.0-11.20051025
155- fc6 respin
156
157* Wed Jul 12 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.99.0-10.20051025
158- fc6 respin
159
160* Wed Mar 1 2006 Rex Dieter <rexdieter[AT]users.sf.net>
161- fc5: gcc/glibc respin
162
163* Fri Jan 20 2006 Rex Dieter <rexdieter[AT]users.sf.net> 0.99.0-9.20051025
164- libtidy returns to be multilib friendly
165
166* Wed Oct 26 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.99.0-8.20051025
167- Update to 051025 and docs to 051020
168
169* Tue Aug  9 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.99.0-7.20050803
170- -devel: Provides: libtidy-devel (#165452)
171
172* Tue Aug  9 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.99.0-6.20050803
173- cleanup doc generation
174- add/restore missing docs (manpage, quickref.html)
175
176* Mon Aug  8 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.99.0-5.20050803
177- Update to 050803 and docs to 050705
178- simplify (fedora.us bug #2071)
179- drop missing manpage
180
181* Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 0.99.0-4.20041214
182- rebuild on all arches
183
184* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
185- rebuilt       
186
187* Thu Dec 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-2.20041214
188- Update to 041214 and docs to 041206.
189- Build with dependency tracking disabled.
190
191* Sun Oct  3 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040916
192- Update to 040916 and docs to 040810.
193
194* Fri Aug 13 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040811
195- Update to 040811, patches applied upstream.
196
197* Wed Jul 28 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040720
198- Update to 040720.
199- Add partial fix (still incorrect for XHTML 1.1) for usemap handling.
200
201* Mon Jul  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040704
202- Update to 040704.
203
204* Fri Jun 25 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040622
205- Update to 040622.
206
207* Sat Jun  5 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040603
208- Update to 040603.
209
210* Sat May 15 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040514
211- Update to 040514.
212
213* Sun May  2 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.2.20040318
214- Update docs to 040317, and generate API docs ourselves.
215
216* Fri Mar 19 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040318
217- Update to 040318.
218
219* Tue Mar 16 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040315
220- Update to 040315.
221
222* Mon Mar 15 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040314
223- Update to 040314.
224
225* Sun Mar 14 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040313
226- Update to 040313.
227
228* Sun Feb  8 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040205
229- Update to 040205.
230
231* Wed Feb  4 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040202
232- Update to 040202.
233
234* Sun Feb  1 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040130
235- Update to 040130.
236
237* Sun Jan 25 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040124
238- Update to 040124.
239- Honor optflags more closely.
240
241* Sun Jan 11 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040110
242- Update to 040110.
243
244* Thu Jan  8 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040106
245- Update to 040106.
246
247* Tue Jan  6 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20040104
248- Update to 040104.
249
250* Sun Nov  2 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20031101
251- Update to 031101.
252
253* Thu Oct 30 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20031029
254- Update to 031029.
255
256* Fri Oct  3 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20031002
257- Update to 031002.
258
259* Sat Sep 27 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20030926
260- Update to 030926.
261
262* Wed Sep  3 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20030901
263- Update to 030901.
264
265* Sat Aug 16 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20030815
266- Update to 030815.
267
268* Sat Aug  2 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20030801
269- Update to 030801.
270
271* Mon Jul 21 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.99.0-0.fdr.1.20030716
272- First build.
Note: See TracBrowser for help on using the repository browser.