source: projects/specs/branches/6/t/thunderbird/thunderbird-vl.spec @ 7803

Revision 7803, 30.9 KB checked in by Takemikaduchi, 11 years ago (diff)

rebuild or new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 17.0.8
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-esr17
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
82BuildRequires:  pango-devel
83BuildRequires:  cairo-devel >= %{cairo_version}
84%if %{build_vine7}
85BuildRequires:  nspr-devel >= %{nspr_version}
86BuildRequires:  nss-devel >= %{nss_version}
87BuildRequires:  hunspell-devel
88%endif
89%if %{build_vine6}
90BuildRequires:  hunspell-devel
91BuildRequires:  python-devel
92%endif
93BuildRequires:  pixman-devel
94BuildRequires:  libpng-devel
95BuildRequires:  libjpeg-turbo-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  zlib-devel, gzip, zip, unzip
98BuildRequires:  libIDL-devel
99BuildRequires:  freetype2-devel >= %{freetype_version}
100## disabled libnotify support
101## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
102BuildRequires:  libnotify-devel >= %{libnotify_version}
103BuildRequires:  bzip2-devel
104#BuildRequires: gnome-vfs2-devel
105BuildRequires:  libgnome-devel
106#BuildRequires:  libgnomeui-devel
107BuildRequires:  krb5-devel
108BuildRequires:  pango-devel
109BuildRequires:  libXt-devel
110BuildRequires:  libXrender-devel
111BuildRequires:  curl-devel
112# hunspell is in plus category for vine
113#BuildRequires: hunspell-devel
114%if %{build_vine7}
115BuildRequires:  sqlite3-devel >= %{sqlite_version}
116%endif
117BuildRequires:  startup-notification-devel
118BuildRequires:  desktop-file-utils
119BuildRequires:  alsa-lib-devel
120BuildRequires:  yasm
121BuildRequires:  autoconf213
122%if %{build_vine7}
123Requires:       sqlite3 >= %{sqlite_version}
124%endif
125Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
126Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
127
128Obsoletes:      MozillaThunderbird
129Provides:       MozillaThunderbird = %{version}
130
131Vendor:         Project Vine
132Distribution:   Vine Linux
133Packager:       daisuke, ryoichi, kazutaka
134
135AutoProv: 0
136%define _use_internal_dependency_generator 0
137%define __find_requires %{SOURCE100}
138
139%description
140Thunderbird is a standalone mail and newsgroup client.
141
142%description -l ja
143Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
144
145#===============================================================================
146
147%prep
148%setup -q %{name}-%{version} -c
149cd %{tarballdir}
150
151# Fix for version issue
152sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
153    > version.patch
154%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
155
156cd mozilla
157%patch1 -p1 -b .default-a4
158
159cd -
160%{__rm} -f .mozconfig
161%if %{build_vine6}
162%{__cp} %{SOURCE1010} .mozconfig
163%endif
164%if %{build_vine7}
165%{__cp} %{SOURCE1020} .mozconfig
166%endif
167
168# setup unofficial branding name
169%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
170%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
171
172%patch100 -p1 -b .addons
173
174#===============================================================================
175
176%build
177cd %{tarballdir}
178
179INTERNAL_GECKO=%{version_internal}
180MOZ_APP_DIR=%{mozappdir}
181
182
183#%if %{build_vine7}
184#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
185#%else
186#%ifarch x86_64
187##MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
188#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
189#%else
190#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
191#%endif
192#%endif
193MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
194        %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
195export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
196export CFLAGS="$RPM_OPT_FLAGS"
197#export CFLAGS=""
198export CXXFLAGS="$CFLAGS"
199export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
200
201export PREFIX='%{_prefix}'
202export LIBDIR='%{_libdir}'
203
204MOZ_SMP_FLAGS=-j1
205# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
206# however builds tend to fail on other arches when building in parallel.
207%ifarch %{ix86} x86_64
208[ -z "$RPM_BUILD_NCPUS" ] && \
209     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
210[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
211[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
212[ "$RPM_BUILD_NCPUS" -ge 8 ] && MOZ_SMP_FLAGS=-j8
213 %endif
214
215%__make -f client.mk build STRIP="/bin/true" \
216                           MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
217
218## build locales
219#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
220#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
221#for dir in $LOCALEDIRS
222#do
223#  for lang in %{MOZ_BUILD_LOCALES} ; do
224#    make -C $dir/locales AB_CD=$lang
225#  done
226#done
227
228#===============================================================================
229
230%install
231%{__rm} -rf $RPM_BUILD_ROOT
232cd %{tarballdir}
233
234INTERNAL_GECKO=%{version_internal}
235
236INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
237MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
238
239cd %{moz_objdir}
240DESTDIR=$RPM_BUILD_ROOT make install
241
242# install unofficial icons
243cd -
244
245%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
246%{__cp} mail/branding/aurora/mailicon16.png \
247        $RPM_BUILD_ROOT/%{mozappdir}/icons/
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
249%{__cp} mail/branding/aurora/mailicon16.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
252%{__cp} mail/branding/aurora/mailicon22.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
254%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
255%{__cp} mail/branding/aurora/mailicon24.png \
256        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
257%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
258%{__cp} mail/branding/aurora/mailicon32.png \
259        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
260%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
261%{__cp} mail/branding/aurora/mailicon48.png \
262        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
263%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
264%{__cp} mail/branding/aurora/mailicon256.png \
265        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
266
267desktop-file-install --vendor vine \
268  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
269
270# set up the thunderbird start script
271rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
272%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
273  $RPM_BUILD_ROOT%{_bindir}/thunderbird
274%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
275
276install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
277%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
278
279%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
280                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
281        $RPM_BUILD_ROOT/vine-default-prefs
282%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
283%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
284%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
285
286%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
287
288# own mozilla plugin dir (#135050)
289%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
290
291# own extension directories
292%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
293%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
294
295# install locales
296#for lang in %{MOZ_BUILD_LOCALES} ; do
297#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
298#done
299
300# install ja.xpi to langpacks directory
301#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
302#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
303# also setup unofficial branding name
304#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
305#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
306
307# install ja.xpi to langpack file
308%{__mkdir_p} lang_tmp
309unzip %{SOURCE1} -d lang_tmp
310# also setup unofficial branding name
311%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
312%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
313
314%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
315cd lang_tmp; \
316zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
317
318
319%clean
320%{__rm} -rf $RPM_BUILD_ROOT
321
322#===============================================================================
323
324%post
325update-desktop-database &> /dev/null || :
326touch --no-create %{_datadir}/icons/hicolor
327if [ -x %{_bindir}/gtk-update-icon-cache ]; then
328  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
329fi
330
331%postun
332update-desktop-database &> /dev/null || :
333touch --no-create %{_datadir}/icons/hicolor
334if [ -x %{_bindir}/gtk-update-icon-cache ]; then
335  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
336fi
337
338
339%files
340%defattr(-,root,root,-)
341%attr(755,root,root) %{_bindir}/thunderbird
342%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
343%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
344%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
345%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
346%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
347%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
348%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
349%{mozappdir}
350#%{_libdir}/mozilla
351%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
352%exclude %{_datadir}/idl/%{name}-%{version_internal}
353%exclude %{_includedir}/%{name}-%{version_internal}
354%exclude %{_libdir}/%{name}-devel-%{version_internal}
355
356#===============================================================================
357
358%changelog
359* Tue Aug 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.8-1
360- new upstream release
361
362* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.7-1
363- new upstream release
364
365* Sun May 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.6-1
366- new upstream release
367
368* Wed Mar 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.4-1
369- new upstream release
370
371* Sat Mar 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.3-1
372- new upstream release
373
374* Wed Jan 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0.2-1
375- new upstream release
376- update Source1010,1020
377- fix %% build
378
379* Wed Nov 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 17.0-1
380- new upstream release
381
382* Sun Nov 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-2
383- use --disable-install-strip instead of --enable-install-strip
384- add --disable-debug-symbols
385
386* Tue Oct 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.2-1
387- new upstream release
388
389* Fri Oct 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0.1-1
390- new upstream release
391
392* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
393- new upstream release
394
395* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
396- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
397
398* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
399- new upstream release
400
401* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
402- new upstream release
403- add BuildRequires: python-devel (Vine6 only)
404- remove build rule of Vine5
405
406* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
407- new upstream release
408- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
409
410* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
411- new upstream release
412
413* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
414- new upstream release
415- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
416
417* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
418- new upstream release
419
420* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
421- new upstream release
422- update Source1030 (mozconfig-thunderbird-vine7)
423
424* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
425- new upstream release
426- update Source1020 (mozconfig-thunderbird-vine6)
427
428* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
429- new upstream release
430
431* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
432- new upstream release
433
434* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
435- new upstream release
436
437* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
438- new upstream release
439- update Source1
440
441* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
442- new upstream release
443- update Source1
444- add Source1030 (mozconfig-thunderbird-vine7)
445- add Patch100 (thunderbird-9.0-enable-addons.patch)
446
447* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
448- fix %%version_internal
449
450* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
451- new upstream release
452- update Source1
453
454* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
455- new upstream release
456- update Source1,21,1010,1020
457
458* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
459- rebuild with libnotify-0.7
460
461* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
462- enable-install-strip
463
464* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
465- new upstream release
466- drop obsolete patch and renumber patch26 to patch1
467- add BuildRequires: yasm
468- enable libnotify support
469- add --disable-updater and --disable-installer to mozconfig
470- use ja.xpi instead of l10n source
471- update Source21: add step to setup langpack plugin
472- update Source20: add japanese translation
473- add Source42 & Source43 for localized branding
474- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
475  for mozconfig-thunderbird-vine5
476
477* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
478- new upstream release with security fix
479
480* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
481- new upstream release with security fix
482
483* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
484- new upstream release with security fix
485
486* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
487- new upstream release with security fix
488- add patch5 to fix build failure
489
490* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
491- new upstream release
492
493* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
494- new upstream release with security fix
495- add Patch1030 to fix compilation error
496
497* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
498- change mozconfig (Source1030 & 1040): add --enable-jsd
499
500* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
501- new upstream release
502
503* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
504- new upstream release with security fix
505- add Patch0 from fedora development: fix version issue
506- remove BuildRequires: hunspell-devel
507- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
508
509* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
510- add BuildRequires: alsa-lib-devel
511- remove BuildRequires: libnotify-devel
512  (workaround for known bug)
513- update mozconfig to add --disable-libnotify option
514
515* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
516- new upstream release
517- update spec entirely
518- import patches from fedora (Patch1, 2 & 4)
519- drop outdated patches (Patch22, 24)
520- update Sources:
521  - mozconfig (Source1030 & Source1040)
522  - default prefs.js (Source12)
523  - unofficial branding (Source40 & Source41)
524  - japanese translation (Source1000)
525- update Patch1000 (sjis-alias)
526
527* Mon Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
528- new upstream release
529
530* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
531- new upstream release
532
533* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
534- don't install official branding logos
535
536* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
537- add necessary icons in %%{tbdir}/chrome/icons/default
538- add Packager tag
539
540* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
541- new upstream release
542
543* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
544- new upstream release
545
546* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
547- new upstream release
548
549* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
550- new upstream release
551
552* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
553- rebuilt for VineSeed
554
555* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
556- new upstream release
557
558* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
559- new upstream release
560- built for Vine Linux 4.x
561- dropped Patch1020 (merged into upstream)
562
563* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
564- added Patch1020 for workaround gcc visibility hidden bugs
565
566* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
567- build with new environment/toolchain
568- add build options to build with external nss/nspr libraries
569    ac_add_options --with-system-nspr
570    ac_add_options --with-system-nss
571
572* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
573- new upstream release
574
575* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
576- new upstream release
577
578* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
579- new upstream release
580
581* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
582- new upstream release
583
584* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
585- new upstream release
586- merge changes from firefox
587  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
588
589* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
590- new upstream release
591- build en-US locale
592- merge changes from firefox
593  - add upstream patches
594  - disable pango rendering by default
595    (workaround fix slow rendering in some page)
596
597* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
598- initial build for Vine Linux based on FC package
599- update to 1.5RC2
600
601* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
602- Fix issue with popup dialogs and other actions causing lockups
603
604* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
605- Update to 1.5 rc1
606
607* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
608- Update to 1.5 beta2
609
610* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
611- Update to 1.5 beta1
612- Bring the install phase of the spec file up to speed
613
614* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
615- Rebuild
616
617* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
618- Add patch to make file chooser dialog modal
619
620* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
621- Update to 1.0.6
622
623* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
624- 1.0.6 Release Candidate
625
626* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
627- Use system NSPR
628- Fix crash on 64bit platforms (#160330)
629
630* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
631- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
632  references, fixing the "no fonts" problem.
633
634* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
635- Change the Exec line in the desktop file to `thunderbird`
636
637* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
638- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
639
640* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
641- Add temporary workaround to not create files in the user's $HOME (#149664)
642
643* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
644- Don't have downloads "disappear" when downloading to desktop (#139015)
645- Fix for some more cursor issues in textareas (149991, 150002, 152089)
646- Add upstream patch to fix bidi justification of pango
647- Add patch to fix launching of helper applications
648- Add patch to properly link against libgfxshared_s.a
649- Fix multilib conflicts
650
651* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
652- correct confusing PANGO vars in startup script
653
654* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
655- Thunderbird 1.0.2
656
657* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
658- Add patch to compile against new fortified glibc macros
659
660* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
661- Rebuild against GCC 4.0
662- Add execshield patches
663- Minor specfile cleanup
664
665* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
666- Rebuild
667
668* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
669- Add RPM version to useragent
670
671* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
672- Port over pango patches from firefox
673
674* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
675- Thunderbird 1.0
676
677* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
678- Fix advanced prefs
679
680* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
681- Make this run on s390(x) now for real
682
683* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
684- Update to 1.0 rc1
685
686* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
687- Add patches to build and run on s390(x)
688
689* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
690- Rebuild to fix file chooser
691
692* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
693- Update to 0.9
694
695* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
696- Prevent inlining of stack direction detection (#135255)
697
698* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
699- More file chooser fixes (same as in firefox)
700- Fix for upstream 28327.
701
702* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
703- Update the pango patch
704
705* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
706- Pull over patches from firefox build:
707  - disable default application dialog
708  - don't include software update since it doesn't work
709  - make external app support work
710
711* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
712- Use pango for rendering
713
714* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
715- Fix for 64 bit crash at startup (b.m.o #256603)
716
717* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
718- Add patches to fix xremote (#135036)
719
720* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
721- Add patch to fix button focus issues (#133507)
722- Add patch for fix IMAP race issues (bmo #246439)
723
724* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
725- filter out library Provides: and internal Requires:
726
727* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
728- Backport the GTK+ File Chooser.
729- Add fix for JS math on x86_64 systems
730- Add pkgconfig patch
731
732* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
733- Update to 0.8.0
734- Remove enigmail
735- Update BuildRequires
736- Remove gcc34 and extension manager patches -- they are upstreamed.
737- Fix for gnome-vfs2 error at component registration
738
739* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
740- Build with --disable-xprint
741
742* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
743- remove all Xvfb-related hacks
744
745* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
746- actually apply psfonts
747- add mozilla gnome-uriloader patch to prevent build failure
748
749* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
750- rawhide import
751- apply NetBSD's freetype 2.1.8 patch
752- apply psfonts patch
753- remove BR on /usr/bin/ex, breaks beehive
754
755* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
756- oops, fix %%install
757
758* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
759- update to Thunderbird 0.7.3 and Enigmail 0.85.0
760- remove XUL.mfasl on startup, add Debian enigmail patches
761- add Xvfb hack for -install-global-extension
762
763* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
764- update to 0.7.2, just because it's there
765- update gcc-3.4 patch (Kaj Niemi)
766- add EM registration patch and remove instdir hack
767
768* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
769- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
770
771* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
772- update to 0.7.1
773- remove Enigmail
774
775* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
776- re-enable Enigmail 0.84.1
777- add gcc-3.4 patch (Kaj Niemi)
778- use official branding (with permission)
779
780* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
781- update to 0.7
782- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
783- specify libdir, change BR for apt (V. Skytt辰, #1617)
784
785* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
786- temporary workaround for enigmail skin "modern" bug
787
788* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
789- update to Enigmail 0.84.0
790- update launch script
791
792* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
793- installation directory now versioned
794- allow root to run the program (for installing extensions)
795- remove unnecessary %%pre and %%post
796- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
797
798* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
799- include Enigmail, re-add release notes
800- delete %{_libdir}/thunderbird in %%pre
801
802* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
803- update to Thunderbird 0.6
804
805* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
806- update to Thunderbird 0.6 RC1
807- add new icon, remove release notes
808
809* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
810- update to latest CVS, update mozconfig and %%build accordingly
811- update to Enigmail 0.83.6
812- remove x-remote and x86_64 patches
813- build with -Os
814
815* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
816- update x-remote patch
817- more startup script fixes
818
819* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
820- startup script fixes, and a minor cleanup
821
822* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
823- Minor cleanups
824
825* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
826- minor improvements to open-browser.sh and startup script
827- update to latest version of Blizzard's x-remote patch
828
829* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
830- update open-browser.sh, startup script, and BuildRequires
831
832* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
833- update open-browser script, modify BuildRequires (Warren)
834- add Blizzard's x-remote patch
835- initial attempt at x-remote-enabled startup script
836
837* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
838- refuse to run with excessive privileges
839
840* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
841- add Mozilla x86_64 patch (Oliver Sontag)
842- Enigmail source filenames now include the version
843- modify BuildRoot
844
845* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
846- use the updated official tarball
847
848* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
849- fix %%prep script
850
851* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
852- update Enigmail to 0.83.3
853- use official source tarball (after removing the CRLFs)
854- package renamed to thunderbird
855
856* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
857- update to 0.5
858- check for lockfile before launching
859
860* Fri Feb 06 2004 David Hill <djh[at]ii.net>
861- update to latest cvs
862- update to Enigmail 0.83.2
863
864* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
865- update to Enigmail 0.83.1
866- removed Mozilla/Firebird script patching
867
868* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
869- add startup notification to .desktop file
870
871* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
872- open-browser.sh release 3
873- patch broken /usr/bin/mozilla script during install
874- dir ownership
875- XXX: Source fails build on x86_64... fix later
876
877* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
878- update to Enigmail 0.82.5
879- add Warren's open-browser.sh (#1113)
880
881* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
882- use Thunderbird's mozilla-xremote-client to launch browser
883
884* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
885- update to 0.4
886- make hyperlinks work (with recent versions of Firebird/Mozilla)
887
888* Thu Dec 04 2003 David Hill <djh[at]ii.net>
889- update to 0.4rc2
890
891* Wed Dec 03 2003 David Hill <djh[at]ii.net>
892- update to 0.4rc1 and Enigmail 0.82.4
893
894* Thu Nov 27 2003 David Hill <djh[at]ii.net>
895- update to latest CVS and Enigmail 0.82.3
896
897* Sun Nov 16 2003 David Hill <djh[at]ii.net>
898- update to latest CVS (0.4a)
899- update Enigmail to 0.82.2
900- alter mozconfig for new build requirements
901- add missing BuildReq (#987)
902
903* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
904- update to 0.3
905
906* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
907- update to 0.3rc3
908- update Enigmail to 0.81.7
909
910* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
911- update to 0.3rc2
912
913* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
914- simplify startup script
915
916* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
917- add GPG support (Enigmail 0.81.6)
918- specfile fixes (#679)
919
920* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
921- update to 0.2
922
923* Mon Sep 01 2003 David Hill <djh[at]ii.net>
924- initial RPM
925  (based on the fedora MozillaFirebird-0.6.1 specfile)
926
Note: See TracBrowser for help on using the repository browser.