source: projects/specs/branches/6/t/thunderbird/thunderbird-vl.spec @ 6915

Revision 6915, 29.4 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 16.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30
31%if "%{?_dist_release}" >= "vl7"
32%define build_vine7 1
33%endif
34%if "%{?_dist_release}" == "vl6"
35%define build_vine6 1
36%endif
37
38Summary:        Thunderbird Community Edition, Mail/newsgroup client
39Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
40Name:           thunderbird
41Version:        %{tbversion}
42Release:        %{tbrelease}
43URL:            http://www.mozilla.org/projects/thunderbird/
44License:        MPL
45Group:          Applications/Internet
46
47Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
48Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
49Source1010:     mozconfig-thunderbird-vine6
50Source1020:     mozconfig-thunderbird-vine7
51Source12:       thunderbird-vine-default-prefs.js
52Source20:       thunderbird.desktop
53Source21:       thunderbird.vine.sh.in
54Source30:       thunderbird-open-browser.sh
55Source40:       thunderbird-unofficial-brandig-tb-brand.properties
56Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
57Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
58Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
59Source100:      find-external-requires
60
61# locale sources
62#%define MOZ_BUILD_LOCALES "ja"
63# get from mercurial repository with command,
64# mkdir l10n
65# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
66#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
67
68
69# upstream patch
70
71# Fix for version issues
72Patch0:         thunderbird-version.patch
73
74# customization patches
75Patch1:         firefox-1.5-default-a4-paper.patch
76
77
78# Linux specific
79Patch100:       thunderbird-9.0-enable-addons.patch
80
81BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
82BuildRequires:  pango-devel
83BuildRequires:  cairo-devel >= %{cairo_version}
84%if %{build_vine7}
85BuildRequires:  nspr-devel >= %{nspr_version}
86BuildRequires:  nss-devel >= %{nss_version}
87BuildRequires:  hunspell-devel
88%endif
89%if %{build_vine6}
90BuildRequires:  hunspell-devel
91BuildRequires:  python-devel
92%endif
93BuildRequires:  pixman-devel
94BuildRequires:  libpng-devel
95BuildRequires:  libjpeg-turbo-devel
96BuildRequires:  gtk2-devel
97BuildRequires:  zlib-devel, gzip, zip, unzip
98BuildRequires:  libIDL-devel
99BuildRequires:  freetype2-devel >= %{freetype_version}
100## disabled libnotify support
101## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
102BuildRequires:  libnotify-devel >= %{libnotify_version}
103BuildRequires:  bzip2-devel
104BuildRequires:  gnome-vfs2-devel
105BuildRequires:  libgnome-devel
106BuildRequires:  libgnomeui-devel
107BuildRequires:  krb5-devel
108BuildRequires:  pango-devel
109BuildRequires:  libXt-devel
110BuildRequires:  libXrender-devel
111# hunspell is in plus category for vine
112#BuildRequires: hunspell-devel
113BuildRequires:  sqlite3-devel >= %{sqlite_version}
114BuildRequires:  startup-notification-devel
115BuildRequires:  desktop-file-utils
116BuildRequires:  alsa-lib-devel
117BuildRequires:  yasm
118Requires:       sqlite3 >= %{sqlite_version}
119Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
120Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
121
122Obsoletes:      MozillaThunderbird
123Provides:       MozillaThunderbird = %{version}
124
125Vendor:         Project Vine
126Distribution:   Vine Linux
127Packager:       daisuke, ryoichi, kazutaka
128
129AutoProv: 0
130%define _use_internal_dependency_generator 0
131%define __find_requires %{SOURCE100}
132
133%description
134Thunderbird is a standalone mail and newsgroup client.
135
136%description -l ja
137Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
138
139#===============================================================================
140
141%prep
142%setup -q %{name}-%{version} -c
143cd %{tarballdir}
144
145# Fix for version issue
146sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
147    > version.patch
148%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
149
150cd mozilla
151%patch1 -p1 -b .default-a4
152
153cd -
154%{__rm} -f .mozconfig
155%if %{build_vine6}
156%{__cp} %{SOURCE1010} .mozconfig
157%endif
158%if %{build_vine7}
159%{__cp} %{SOURCE1020} .mozconfig
160%endif
161
162# setup unofficial branding name
163%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
164%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
165
166%patch100 -p1 -b .addons
167
168#===============================================================================
169
170%build
171cd %{tarballdir}
172
173INTERNAL_GECKO=%{version_internal}
174MOZ_APP_DIR=%{mozappdir}
175
176
177%if %{build_vine7}
178MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
179%else
180%ifarch x86_64
181#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
182MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
183%else
184MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
185%endif
186%endif
187export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
188export CFLAGS="$RPM_OPT_FLAGS"
189#export CFLAGS=""
190export CXXFLAGS="$CFLAGS"
191export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
192
193%ifarch ppc ppc64 s390 s390x
194%define moz_make_flags -j1
195%else
196%define moz_make_flags %{?_smp_mflags}
197%endif
198
199export PREFIX='%{_prefix}'
200export LIBDIR='%{_libdir}'
201
202export LDFLAGS="-Wl,-rpath,%{mozappdir}"
203export MAKE="gmake %{moz_make_flags}"
204%{__make} -f client.mk build
205
206## build locales
207#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
208#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
209#for dir in $LOCALEDIRS
210#do
211#  for lang in %{MOZ_BUILD_LOCALES} ; do
212#    make -C $dir/locales AB_CD=$lang
213#  done
214#done
215
216#===============================================================================
217
218%install
219%{__rm} -rf $RPM_BUILD_ROOT
220cd %{tarballdir}
221
222INTERNAL_GECKO=%{version_internal}
223
224INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
225MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
226
227cd %{moz_objdir}
228DESTDIR=$RPM_BUILD_ROOT make install
229
230# install unofficial icons
231cd -
232
233%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
234%{__cp} mail/branding/aurora/mailicon16.png \
235        $RPM_BUILD_ROOT/%{mozappdir}/icons/
236%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
237%{__cp} mail/branding/aurora/mailicon16.png \
238        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
239%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
240%{__cp} mail/branding/aurora/mailicon22.png \
241        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
242%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
243%{__cp} mail/branding/aurora/mailicon24.png \
244        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
245%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
246%{__cp} mail/branding/aurora/mailicon32.png \
247        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
248%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
249%{__cp} mail/branding/aurora/mailicon48.png \
250        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
252%{__cp} mail/branding/aurora/mailicon256.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
254
255desktop-file-install --vendor vine \
256  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
257
258# set up the thunderbird start script
259rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
260%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
261  $RPM_BUILD_ROOT%{_bindir}/thunderbird
262%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
263
264install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
265%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
266
267%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
268                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
269        $RPM_BUILD_ROOT/vine-default-prefs
270%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
271%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
272%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
273
274%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
275
276# own mozilla plugin dir (#135050)
277%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
278
279# own extension directories
280%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
281%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
282
283# install locales
284#for lang in %{MOZ_BUILD_LOCALES} ; do
285#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
286#done
287
288# install ja.xpi to langpacks directory
289#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
290#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
291# also setup unofficial branding name
292#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
293#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
294
295# install ja.xpi to langpack file
296%{__mkdir_p} lang_tmp
297unzip %{SOURCE1} -d lang_tmp
298# also setup unofficial branding name
299%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
300%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
301
302%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
303cd lang_tmp; \
304zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
305
306
307%clean
308%{__rm} -rf $RPM_BUILD_ROOT
309
310#===============================================================================
311
312%post
313update-desktop-database &> /dev/null || :
314touch --no-create %{_datadir}/icons/hicolor
315if [ -x %{_bindir}/gtk-update-icon-cache ]; then
316  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
317fi
318
319%postun
320update-desktop-database &> /dev/null || :
321touch --no-create %{_datadir}/icons/hicolor
322if [ -x %{_bindir}/gtk-update-icon-cache ]; then
323  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
324fi
325
326
327%files
328%defattr(-,root,root,-)
329%attr(755,root,root) %{_bindir}/thunderbird
330%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
331%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
332%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
333%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
334%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
335%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
336%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
337%{mozappdir}
338#%{_libdir}/mozilla
339%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
340%exclude %{_datadir}/idl/%{name}-%{version_internal}
341%exclude %{_includedir}/%{name}-%{version_internal}
342%exclude %{_libdir}/%{name}-devel-%{version_internal}
343
344#===============================================================================
345
346%changelog
347* Thu Oct 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 16.0-1
348- new upstream release
349
350* Tue Oct 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-2
351- use --enable-optimize instead of --enable-optimize="\$RPM_OPT_FLAGS"
352
353* Sun Sep 09 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0.1-1
354- new upstream release
355
356* Wed Aug 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 15.0-1
357- new upstream release
358- add BuildRequires: python-devel (Vine6 only)
359- remove build rule of Vine5
360
361* Wed Jul 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 14.0-1
362- new upstream release
363- remove Patch2 (thunderbird-13.0-buildfix-nspr.patch)
364
365* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
366- new upstream release
367
368* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
369- new upstream release
370- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
371
372* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
373- new upstream release
374
375* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
376- new upstream release
377- update Source1030 (mozconfig-thunderbird-vine7)
378
379* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
380- new upstream release
381- update Source1020 (mozconfig-thunderbird-vine6)
382
383* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
384- new upstream release
385
386* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
387- new upstream release
388
389* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
390- new upstream release
391
392* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
393- new upstream release
394- update Source1
395
396* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
397- new upstream release
398- update Source1
399- add Source1030 (mozconfig-thunderbird-vine7)
400- add Patch100 (thunderbird-9.0-enable-addons.patch)
401
402* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
403- fix %%version_internal
404
405* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
406- new upstream release
407- update Source1
408
409* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
410- new upstream release
411- update Source1,21,1010,1020
412
413* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
414- rebuild with libnotify-0.7
415
416* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
417- enable-install-strip
418
419* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
420- new upstream release
421- drop obsolete patch and renumber patch26 to patch1
422- add BuildRequires: yasm
423- enable libnotify support
424- add --disable-updater and --disable-installer to mozconfig
425- use ja.xpi instead of l10n source
426- update Source21: add step to setup langpack plugin
427- update Source20: add japanese translation
428- add Source42 & Source43 for localized branding
429- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
430  for mozconfig-thunderbird-vine5
431
432* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
433- new upstream release with security fix
434
435* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
436- new upstream release with security fix
437
438* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
439- new upstream release with security fix
440
441* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
442- new upstream release with security fix
443- add patch5 to fix build failure
444
445* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
446- new upstream release
447
448* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
449- new upstream release with security fix
450- add Patch1030 to fix compilation error
451
452* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
453- change mozconfig (Source1030 & 1040): add --enable-jsd
454
455* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
456- new upstream release
457
458* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
459- new upstream release with security fix
460- add Patch0 from fedora development: fix version issue
461- remove BuildRequires: hunspell-devel
462- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
463
464* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
465- add BuildRequires: alsa-lib-devel
466- remove BuildRequires: libnotify-devel
467  (workaround for known bug)
468- update mozconfig to add --disable-libnotify option
469
470* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
471- new upstream release
472- update spec entirely
473- import patches from fedora (Patch1, 2 & 4)
474- drop outdated patches (Patch22, 24)
475- update Sources:
476  - mozconfig (Source1030 & Source1040)
477  - default prefs.js (Source12)
478  - unofficial branding (Source40 & Source41)
479  - japanese translation (Source1000)
480- update Patch1000 (sjis-alias)
481
482* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
483- new upstream release
484
485* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
486- new upstream release
487
488* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
489- don't install official branding logos
490
491* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
492- add necessary icons in %%{tbdir}/chrome/icons/default
493- add Packager tag
494
495* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
496- new upstream release
497
498* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
499- new upstream release
500
501* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
502- new upstream release
503
504* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
505- new upstream release
506
507* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
508- rebuilt for VineSeed
509
510* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
511- new upstream release
512
513* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
514- new upstream release
515- built for Vine Linux 4.x
516- dropped Patch1020 (merged into upstream)
517
518* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
519- added Patch1020 for workaround gcc visibility hidden bugs
520
521* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
522- build with new environment/toolchain
523- add build options to build with external nss/nspr libraries
524    ac_add_options --with-system-nspr
525    ac_add_options --with-system-nss
526
527* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
528- new upstream release
529
530* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
531- new upstream release
532
533* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
534- new upstream release
535
536* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
537- new upstream release
538
539* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
540- new upstream release
541- merge changes from firefox
542  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
543
544* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
545- new upstream release
546- build en-US locale
547- merge changes from firefox
548  - add upstream patches
549  - disable pango rendering by default
550    (workaround fix slow rendering in some page)
551
552* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
553- initial build for Vine Linux based on FC package
554- update to 1.5RC2
555
556* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
557- Fix issue with popup dialogs and other actions causing lockups
558
559* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
560- Update to 1.5 rc1
561
562* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
563- Update to 1.5 beta2
564
565* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
566- Update to 1.5 beta1
567- Bring the install phase of the spec file up to speed
568
569* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
570- Rebuild
571
572* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
573- Add patch to make file chooser dialog modal
574
575* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
576- Update to 1.0.6
577
578* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
579- 1.0.6 Release Candidate
580
581* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
582- Use system NSPR
583- Fix crash on 64bit platforms (#160330)
584
585* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
586- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
587  references, fixing the "no fonts" problem.
588
589* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
590- Change the Exec line in the desktop file to `thunderbird`
591
592* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
593- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
594
595* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
596- Add temporary workaround to not create files in the user's $HOME (#149664)
597
598* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
599- Don't have downloads "disappear" when downloading to desktop (#139015)
600- Fix for some more cursor issues in textareas (149991, 150002, 152089)
601- Add upstream patch to fix bidi justification of pango
602- Add patch to fix launching of helper applications
603- Add patch to properly link against libgfxshared_s.a
604- Fix multilib conflicts
605
606* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
607- correct confusing PANGO vars in startup script
608
609* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
610- Thunderbird 1.0.2
611
612* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
613- Add patch to compile against new fortified glibc macros
614
615* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
616- Rebuild against GCC 4.0
617- Add execshield patches
618- Minor specfile cleanup
619
620* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
621- Rebuild
622
623* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
624- Add RPM version to useragent
625
626* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
627- Port over pango patches from firefox
628
629* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
630- Thunderbird 1.0
631
632* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
633- Fix advanced prefs
634
635* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
636- Make this run on s390(x) now for real
637
638* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
639- Update to 1.0 rc1
640
641* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
642- Add patches to build and run on s390(x)
643
644* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
645- Rebuild to fix file chooser
646
647* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
648- Update to 0.9
649
650* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
651- Prevent inlining of stack direction detection (#135255)
652
653* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
654- More file chooser fixes (same as in firefox)
655- Fix for upstream 28327.
656
657* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
658- Update the pango patch
659
660* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
661- Pull over patches from firefox build:
662  - disable default application dialog
663  - don't include software update since it doesn't work
664  - make external app support work
665
666* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
667- Use pango for rendering
668
669* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
670- Fix for 64 bit crash at startup (b.m.o #256603)
671
672* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
673- Add patches to fix xremote (#135036)
674
675* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
676- Add patch to fix button focus issues (#133507)
677- Add patch for fix IMAP race issues (bmo #246439)
678
679* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
680- filter out library Provides: and internal Requires:
681
682* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
683- Backport the GTK+ File Chooser.
684- Add fix for JS math on x86_64 systems
685- Add pkgconfig patch
686
687* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
688- Update to 0.8.0
689- Remove enigmail
690- Update BuildRequires
691- Remove gcc34 and extension manager patches -- they are upstreamed.
692- Fix for gnome-vfs2 error at component registration
693
694* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
695- Build with --disable-xprint
696
697* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
698- remove all Xvfb-related hacks
699
700* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
701- actually apply psfonts
702- add mozilla gnome-uriloader patch to prevent build failure
703
704* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
705- rawhide import
706- apply NetBSD's freetype 2.1.8 patch
707- apply psfonts patch
708- remove BR on /usr/bin/ex, breaks beehive
709
710* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
711- oops, fix %%install
712
713* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
714- update to Thunderbird 0.7.3 and Enigmail 0.85.0
715- remove XUL.mfasl on startup, add Debian enigmail patches
716- add Xvfb hack for -install-global-extension
717
718* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
719- update to 0.7.2, just because it's there
720- update gcc-3.4 patch (Kaj Niemi)
721- add EM registration patch and remove instdir hack
722
723* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
724- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
725
726* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
727- update to 0.7.1
728- remove Enigmail
729
730* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
731- re-enable Enigmail 0.84.1
732- add gcc-3.4 patch (Kaj Niemi)
733- use official branding (with permission)
734
735* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
736- update to 0.7
737- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
738- specify libdir, change BR for apt (V. Skytt辰, #1617)
739
740* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
741- temporary workaround for enigmail skin "modern" bug
742
743* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
744- update to Enigmail 0.84.0
745- update launch script
746
747* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
748- installation directory now versioned
749- allow root to run the program (for installing extensions)
750- remove unnecessary %%pre and %%post
751- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
752
753* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
754- include Enigmail, re-add release notes
755- delete %{_libdir}/thunderbird in %%pre
756
757* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
758- update to Thunderbird 0.6
759
760* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
761- update to Thunderbird 0.6 RC1
762- add new icon, remove release notes
763
764* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
765- update to latest CVS, update mozconfig and %%build accordingly
766- update to Enigmail 0.83.6
767- remove x-remote and x86_64 patches
768- build with -Os
769
770* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
771- update x-remote patch
772- more startup script fixes
773
774* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
775- startup script fixes, and a minor cleanup
776
777* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
778- Minor cleanups
779
780* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
781- minor improvements to open-browser.sh and startup script
782- update to latest version of Blizzard's x-remote patch
783
784* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
785- update open-browser.sh, startup script, and BuildRequires
786
787* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
788- update open-browser script, modify BuildRequires (Warren)
789- add Blizzard's x-remote patch
790- initial attempt at x-remote-enabled startup script
791
792* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
793- refuse to run with excessive privileges
794
795* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
796- add Mozilla x86_64 patch (Oliver Sontag)
797- Enigmail source filenames now include the version
798- modify BuildRoot
799
800* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
801- use the updated official tarball
802
803* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
804- fix %%prep script
805
806* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
807- update Enigmail to 0.83.3
808- use official source tarball (after removing the CRLFs)
809- package renamed to thunderbird
810
811* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
812- update to 0.5
813- check for lockfile before launching
814
815* Fri Feb 06 2004 David Hill <djh[at]ii.net>
816- update to latest cvs
817- update to Enigmail 0.83.2
818
819* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
820- update to Enigmail 0.83.1
821- removed Mozilla/Firebird script patching
822
823* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
824- add startup notification to .desktop file
825
826* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
827- open-browser.sh release 3
828- patch broken /usr/bin/mozilla script during install
829- dir ownership
830- XXX: Source fails build on x86_64... fix later
831
832* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
833- update to Enigmail 0.82.5
834- add Warren's open-browser.sh (#1113)
835
836* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
837- use Thunderbird's mozilla-xremote-client to launch browser
838
839* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
840- update to 0.4
841- make hyperlinks work (with recent versions of Firebird/Mozilla)
842
843* Thu Dec 04 2003 David Hill <djh[at]ii.net>
844- update to 0.4rc2
845
846* Wed Dec 03 2003 David Hill <djh[at]ii.net>
847- update to 0.4rc1 and Enigmail 0.82.4
848
849* Thu Nov 27 2003 David Hill <djh[at]ii.net>
850- update to latest CVS and Enigmail 0.82.3
851
852* Sun Nov 16 2003 David Hill <djh[at]ii.net>
853- update to latest CVS (0.4a)
854- update Enigmail to 0.82.2
855- alter mozconfig for new build requirements
856- add missing BuildReq (#987)
857
858* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
859- update to 0.3
860
861* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
862- update to 0.3rc3
863- update Enigmail to 0.81.7
864
865* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
866- update to 0.3rc2
867
868* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
869- simplify startup script
870
871* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
872- add GPG support (Enigmail 0.81.6)
873- specfile fixes (#679)
874
875* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
876- update to 0.2
877
878* Mon Sep 01 2003 David Hill <djh[at]ii.net>
879- initial RPM
880  (based on the fedora MozillaFirebird-0.6.1 specfile)
881
Note: See TracBrowser for help on using the repository browser.