source: projects/specs/branches/6/t/thunderbird/thunderbird-vl.spec @ 6352

Revision 6352, 29.1 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 13.0.1
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30%define build_vine5 0
31
32%if "%{?_dist_release}" >= "vl7"
33%define build_vine7 1
34%endif
35%if "%{?_dist_release}" == "vl6"
36%define build_vine6 1
37%endif
38%if "%{?_dist_release}" == "vl5"
39%define build_vine5 1
40%endif
41
42
43Summary:        Thunderbird Community Edition, Mail/newsgroup client
44Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
45Name:           thunderbird
46Version:        %{tbversion}
47Release:        %{tbrelease}
48URL:            http://www.mozilla.org/projects/thunderbird/
49License:        MPL
50Group:          Applications/Internet
51
52Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
53Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
54Source1010:     mozconfig-thunderbird-vine5
55Source1020:     mozconfig-thunderbird-vine6
56Source1030:     mozconfig-thunderbird-vine7
57Source12:       thunderbird-vine-default-prefs.js
58Source20:       thunderbird.desktop
59Source21:       thunderbird.vine.sh.in
60Source30:       thunderbird-open-browser.sh
61Source40:       thunderbird-unofficial-brandig-tb-brand.properties
62Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
63Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
64Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
65Source100:      find-external-requires
66
67# locale sources
68#%define MOZ_BUILD_LOCALES "ja"
69# get from mercurial repository with command,
70# mkdir l10n
71# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
72#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
73
74
75# upstream patch
76
77# Fix for version issues
78Patch0:         thunderbird-version.patch
79
80# customization patches
81Patch1:         firefox-1.5-default-a4-paper.patch
82
83# https://bugzilla.mozilla.org/show_bug.cgi?id=736836
84Patch2:         thunderbird-13.0-buildfix-nspr.patch
85
86# Linux specific
87Patch100:       thunderbird-9.0-enable-addons.patch
88
89BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
90BuildRequires:  pango-devel
91BuildRequires:  cairo-devel >= %{cairo_version}
92%if %{build_vine7}
93BuildRequires:  nspr-devel >= %{nspr_version}
94BuildRequires:  nss-devel >= %{nss_version}
95BuildRequires:  hunspell-devel
96%endif
97%if %{build_vine6}
98BuildRequires:  hunspell-devel
99%endif
100BuildRequires:  pixman-devel
101BuildRequires:  libpng-devel
102%if %{build_vine5}
103BuildRequires:  libjpeg-devel
104%else
105BuildRequires:  libjpeg-turbo-devel
106%endif
107BuildRequires:  gtk2-devel
108BuildRequires:  zlib-devel, gzip, zip, unzip
109BuildRequires:  libIDL-devel
110BuildRequires:  freetype2-devel >= %{freetype_version}
111## disabled libnotify support
112## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
113BuildRequires:  libnotify-devel >= %{libnotify_version}
114BuildRequires:  bzip2-devel
115BuildRequires:  gnome-vfs2-devel
116BuildRequires:  libgnome-devel
117BuildRequires:  libgnomeui-devel
118BuildRequires:  krb5-devel
119BuildRequires:  pango-devel
120BuildRequires:  libXt-devel
121BuildRequires:  libXrender-devel
122# hunspell is in plus category for vine
123#BuildRequires: hunspell-devel
124BuildRequires:  sqlite3-devel >= %{sqlite_version}
125BuildRequires:  startup-notification-devel
126BuildRequires:  desktop-file-utils
127BuildRequires:  alsa-lib-devel
128BuildRequires:  yasm
129Requires:       sqlite3 >= %{sqlite_version}
130Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
131Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
132
133Obsoletes:      MozillaThunderbird
134Provides:       MozillaThunderbird = %{version}
135
136Vendor:         Project Vine
137Distribution:   Vine Linux
138Packager:       daisuke, ryoichi, kazutaka
139
140AutoProv: 0
141%define _use_internal_dependency_generator 0
142%define __find_requires %{SOURCE100}
143
144%description
145Thunderbird is a standalone mail and newsgroup client.
146
147%description -l ja
148Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
149
150#===============================================================================
151
152%prep
153%setup -q %{name}-%{version} -c
154cd %{tarballdir}
155
156# Fix for version issue
157sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
158    > version.patch
159%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
160
161cd mozilla
162%patch1 -p1 -b .default-a4
163%patch2 -p1 -b .buildfix-nspr
164
165cd -
166%{__rm} -f .mozconfig
167%if %{build_vine5}
168%{__cp} %{SOURCE1010} .mozconfig
169%endif
170%if %{build_vine6}
171%{__cp} %{SOURCE1020} .mozconfig
172%endif
173%if %{build_vine7}
174%{__cp} %{SOURCE1030} .mozconfig
175%endif
176
177# setup unofficial branding name
178%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
179%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
180
181%patch100 -p1 -b .addons
182
183#===============================================================================
184
185%build
186cd %{tarballdir}
187
188INTERNAL_GECKO=%{version_internal}
189MOZ_APP_DIR=%{mozappdir}
190
191
192%if %{build_vine7}
193MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
194%else
195%ifarch x86_64
196#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
197MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
198%else
199MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
200%endif
201%endif
202export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
203export CFLAGS="$RPM_OPT_FLAGS"
204#export CFLAGS=""
205export CXXFLAGS="$CFLAGS"
206export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
207
208%ifarch ppc ppc64 s390 s390x
209%define moz_make_flags -j1
210%else
211%define moz_make_flags %{?_smp_mflags}
212%endif
213
214export PREFIX='%{_prefix}'
215export LIBDIR='%{_libdir}'
216
217export LDFLAGS="-Wl,-rpath,%{mozappdir}"
218export MAKE="gmake %{moz_make_flags}"
219%{__make} -f client.mk build
220
221## build locales
222#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
223#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
224#for dir in $LOCALEDIRS
225#do
226#  for lang in %{MOZ_BUILD_LOCALES} ; do
227#    make -C $dir/locales AB_CD=$lang
228#  done
229#done
230
231#===============================================================================
232
233%install
234%{__rm} -rf $RPM_BUILD_ROOT
235cd %{tarballdir}
236
237INTERNAL_GECKO=%{version_internal}
238
239INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
240MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
241
242cd %{moz_objdir}
243DESTDIR=$RPM_BUILD_ROOT make install
244
245# install unofficial icons
246cd -
247
248%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
249%{__cp} mail/branding/aurora/mailicon16.png \
250        $RPM_BUILD_ROOT/%{mozappdir}/icons/
251%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
252%{__cp} mail/branding/aurora/mailicon16.png \
253        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
254%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
255%{__cp} mail/branding/aurora/mailicon22.png \
256        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
257%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
258%{__cp} mail/branding/aurora/mailicon24.png \
259        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
260%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
261%{__cp} mail/branding/aurora/mailicon32.png \
262        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
263%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
264%{__cp} mail/branding/aurora/mailicon48.png \
265        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
266%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
267%{__cp} mail/branding/aurora/mailicon256.png \
268        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
269
270desktop-file-install --vendor vine \
271  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
272
273# set up the thunderbird start script
274rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
275%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
276  $RPM_BUILD_ROOT%{_bindir}/thunderbird
277%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
278
279install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
280%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
281
282%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
283                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
284        $RPM_BUILD_ROOT/vine-default-prefs
285%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
286%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
287%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
288
289%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
290
291# own mozilla plugin dir (#135050)
292%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
293
294# own extension directories
295%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
296%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
297
298# install locales
299#for lang in %{MOZ_BUILD_LOCALES} ; do
300#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
301#done
302
303# install ja.xpi to langpacks directory
304#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
305#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
306# also setup unofficial branding name
307#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
308#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
309
310# install ja.xpi to langpack file
311%{__mkdir_p} lang_tmp
312unzip %{SOURCE1} -d lang_tmp
313# also setup unofficial branding name
314%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
315%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
316
317%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
318cd lang_tmp; \
319zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
320
321
322%clean
323%{__rm} -rf $RPM_BUILD_ROOT
324
325#===============================================================================
326
327%post
328update-desktop-database &> /dev/null || :
329touch --no-create %{_datadir}/icons/hicolor
330if [ -x %{_bindir}/gtk-update-icon-cache ]; then
331  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
332fi
333
334%postun
335update-desktop-database &> /dev/null || :
336touch --no-create %{_datadir}/icons/hicolor
337if [ -x %{_bindir}/gtk-update-icon-cache ]; then
338  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
339fi
340
341
342%files
343%defattr(-,root,root,-)
344%attr(755,root,root) %{_bindir}/thunderbird
345%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
346%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
347%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
348%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
349%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
350%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
351%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
352%{mozappdir}
353#%{_libdir}/mozilla
354%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
355%exclude %{_datadir}/idl/%{name}-%{version_internal}
356%exclude %{_includedir}/%{name}-%{version_internal}
357%exclude %{_libdir}/%{name}-devel-%{version_internal}
358
359#===============================================================================
360
361%changelog
362* Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0.1-1
363- new upstream release
364
365* Thu Jun 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 13.0-1
366- new upstream release
367- add Patch2 (thunderbird-13.0-buildfix-nspr.patch)
368
369* Tue May 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0.1-1
370- new upstream release
371
372* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
373- new upstream release
374- update Source1030 (mozconfig-thunderbird-vine7)
375
376* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
377- new upstream release
378- update Source1020 (mozconfig-thunderbird-vine6)
379
380* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
381- new upstream release
382
383* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
384- new upstream release
385
386* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
387- new upstream release
388
389* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
390- new upstream release
391- update Source1
392
393* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
394- new upstream release
395- update Source1
396- add Source1030 (mozconfig-thunderbird-vine7)
397- add Patch100 (thunderbird-9.0-enable-addons.patch)
398
399* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
400- fix %%version_internal
401
402* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
403- new upstream release
404- update Source1
405
406* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
407- new upstream release
408- update Source1,21,1010,1020
409
410* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
411- rebuild with libnotify-0.7
412
413* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
414- enable-install-strip
415
416* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
417- new upstream release
418- drop obsolete patch and renumber patch26 to patch1
419- add BuildRequires: yasm
420- enable libnotify support
421- add --disable-updater and --disable-installer to mozconfig
422- use ja.xpi instead of l10n source
423- update Source21: add step to setup langpack plugin
424- update Source20: add japanese translation
425- add Source42 & Source43 for localized branding
426- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
427  for mozconfig-thunderbird-vine5
428
429* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
430- new upstream release with security fix
431
432* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
433- new upstream release with security fix
434
435* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
436- new upstream release with security fix
437
438* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
439- new upstream release with security fix
440- add patch5 to fix build failure
441
442* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
443- new upstream release
444
445* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
446- new upstream release with security fix
447- add Patch1030 to fix compilation error
448
449* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
450- change mozconfig (Source1030 & 1040): add --enable-jsd
451
452* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
453- new upstream release
454
455* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
456- new upstream release with security fix
457- add Patch0 from fedora development: fix version issue
458- remove BuildRequires: hunspell-devel
459- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
460
461* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
462- add BuildRequires: alsa-lib-devel
463- remove BuildRequires: libnotify-devel
464  (workaround for known bug)
465- update mozconfig to add --disable-libnotify option
466
467* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
468- new upstream release
469- update spec entirely
470- import patches from fedora (Patch1, 2 & 4)
471- drop outdated patches (Patch22, 24)
472- update Sources:
473  - mozconfig (Source1030 & Source1040)
474  - default prefs.js (Source12)
475  - unofficial branding (Source40 & Source41)
476  - japanese translation (Source1000)
477- update Patch1000 (sjis-alias)
478
479* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
480- new upstream release
481
482* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
483- new upstream release
484
485* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
486- don't install official branding logos
487
488* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
489- add necessary icons in %%{tbdir}/chrome/icons/default
490- add Packager tag
491
492* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
493- new upstream release
494
495* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
496- new upstream release
497
498* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
499- new upstream release
500
501* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
502- new upstream release
503
504* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
505- rebuilt for VineSeed
506
507* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
508- new upstream release
509
510* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
511- new upstream release
512- built for Vine Linux 4.x
513- dropped Patch1020 (merged into upstream)
514
515* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
516- added Patch1020 for workaround gcc visibility hidden bugs
517
518* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
519- build with new environment/toolchain
520- add build options to build with external nss/nspr libraries
521    ac_add_options --with-system-nspr
522    ac_add_options --with-system-nss
523
524* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
525- new upstream release
526
527* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
528- new upstream release
529
530* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
531- new upstream release
532
533* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
534- new upstream release
535
536* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
537- new upstream release
538- merge changes from firefox
539  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
540
541* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
542- new upstream release
543- build en-US locale
544- merge changes from firefox
545  - add upstream patches
546  - disable pango rendering by default
547    (workaround fix slow rendering in some page)
548
549* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
550- initial build for Vine Linux based on FC package
551- update to 1.5RC2
552
553* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
554- Fix issue with popup dialogs and other actions causing lockups
555
556* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
557- Update to 1.5 rc1
558
559* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
560- Update to 1.5 beta2
561
562* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
563- Update to 1.5 beta1
564- Bring the install phase of the spec file up to speed
565
566* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
567- Rebuild
568
569* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
570- Add patch to make file chooser dialog modal
571
572* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
573- Update to 1.0.6
574
575* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
576- 1.0.6 Release Candidate
577
578* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
579- Use system NSPR
580- Fix crash on 64bit platforms (#160330)
581
582* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
583- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
584  references, fixing the "no fonts" problem.
585
586* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
587- Change the Exec line in the desktop file to `thunderbird`
588
589* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
590- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
591
592* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
593- Add temporary workaround to not create files in the user's $HOME (#149664)
594
595* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
596- Don't have downloads "disappear" when downloading to desktop (#139015)
597- Fix for some more cursor issues in textareas (149991, 150002, 152089)
598- Add upstream patch to fix bidi justification of pango
599- Add patch to fix launching of helper applications
600- Add patch to properly link against libgfxshared_s.a
601- Fix multilib conflicts
602
603* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
604- correct confusing PANGO vars in startup script
605
606* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
607- Thunderbird 1.0.2
608
609* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
610- Add patch to compile against new fortified glibc macros
611
612* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
613- Rebuild against GCC 4.0
614- Add execshield patches
615- Minor specfile cleanup
616
617* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
618- Rebuild
619
620* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
621- Add RPM version to useragent
622
623* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
624- Port over pango patches from firefox
625
626* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
627- Thunderbird 1.0
628
629* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
630- Fix advanced prefs
631
632* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
633- Make this run on s390(x) now for real
634
635* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
636- Update to 1.0 rc1
637
638* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
639- Add patches to build and run on s390(x)
640
641* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
642- Rebuild to fix file chooser
643
644* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
645- Update to 0.9
646
647* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
648- Prevent inlining of stack direction detection (#135255)
649
650* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
651- More file chooser fixes (same as in firefox)
652- Fix for upstream 28327.
653
654* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
655- Update the pango patch
656
657* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
658- Pull over patches from firefox build:
659  - disable default application dialog
660  - don't include software update since it doesn't work
661  - make external app support work
662
663* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
664- Use pango for rendering
665
666* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
667- Fix for 64 bit crash at startup (b.m.o #256603)
668
669* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
670- Add patches to fix xremote (#135036)
671
672* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
673- Add patch to fix button focus issues (#133507)
674- Add patch for fix IMAP race issues (bmo #246439)
675
676* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
677- filter out library Provides: and internal Requires:
678
679* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
680- Backport the GTK+ File Chooser.
681- Add fix for JS math on x86_64 systems
682- Add pkgconfig patch
683
684* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
685- Update to 0.8.0
686- Remove enigmail
687- Update BuildRequires
688- Remove gcc34 and extension manager patches -- they are upstreamed.
689- Fix for gnome-vfs2 error at component registration
690
691* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
692- Build with --disable-xprint
693
694* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
695- remove all Xvfb-related hacks
696
697* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
698- actually apply psfonts
699- add mozilla gnome-uriloader patch to prevent build failure
700
701* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
702- rawhide import
703- apply NetBSD's freetype 2.1.8 patch
704- apply psfonts patch
705- remove BR on /usr/bin/ex, breaks beehive
706
707* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
708- oops, fix %%install
709
710* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
711- update to Thunderbird 0.7.3 and Enigmail 0.85.0
712- remove XUL.mfasl on startup, add Debian enigmail patches
713- add Xvfb hack for -install-global-extension
714
715* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
716- update to 0.7.2, just because it's there
717- update gcc-3.4 patch (Kaj Niemi)
718- add EM registration patch and remove instdir hack
719
720* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
721- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
722
723* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
724- update to 0.7.1
725- remove Enigmail
726
727* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
728- re-enable Enigmail 0.84.1
729- add gcc-3.4 patch (Kaj Niemi)
730- use official branding (with permission)
731
732* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
733- update to 0.7
734- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
735- specify libdir, change BR for apt (V. Skytt辰, #1617)
736
737* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
738- temporary workaround for enigmail skin "modern" bug
739
740* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
741- update to Enigmail 0.84.0
742- update launch script
743
744* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
745- installation directory now versioned
746- allow root to run the program (for installing extensions)
747- remove unnecessary %%pre and %%post
748- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
749
750* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
751- include Enigmail, re-add release notes
752- delete %{_libdir}/thunderbird in %%pre
753
754* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
755- update to Thunderbird 0.6
756
757* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
758- update to Thunderbird 0.6 RC1
759- add new icon, remove release notes
760
761* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
762- update to latest CVS, update mozconfig and %%build accordingly
763- update to Enigmail 0.83.6
764- remove x-remote and x86_64 patches
765- build with -Os
766
767* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
768- update x-remote patch
769- more startup script fixes
770
771* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
772- startup script fixes, and a minor cleanup
773
774* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
775- Minor cleanups
776
777* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
778- minor improvements to open-browser.sh and startup script
779- update to latest version of Blizzard's x-remote patch
780
781* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
782- update open-browser.sh, startup script, and BuildRequires
783
784* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
785- update open-browser script, modify BuildRequires (Warren)
786- add Blizzard's x-remote patch
787- initial attempt at x-remote-enabled startup script
788
789* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
790- refuse to run with excessive privileges
791
792* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
793- add Mozilla x86_64 patch (Oliver Sontag)
794- Enigmail source filenames now include the version
795- modify BuildRoot
796
797* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
798- use the updated official tarball
799
800* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
801- fix %%prep script
802
803* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
804- update Enigmail to 0.83.3
805- use official source tarball (after removing the CRLFs)
806- package renamed to thunderbird
807
808* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
809- update to 0.5
810- check for lockfile before launching
811
812* Fri Feb 06 2004 David Hill <djh[at]ii.net>
813- update to latest cvs
814- update to Enigmail 0.83.2
815
816* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
817- update to Enigmail 0.83.1
818- removed Mozilla/Firebird script patching
819
820* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
821- add startup notification to .desktop file
822
823* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
824- open-browser.sh release 3
825- patch broken /usr/bin/mozilla script during install
826- dir ownership
827- XXX: Source fails build on x86_64... fix later
828
829* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
830- update to Enigmail 0.82.5
831- add Warren's open-browser.sh (#1113)
832
833* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
834- use Thunderbird's mozilla-xremote-client to launch browser
835
836* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
837- update to 0.4
838- make hyperlinks work (with recent versions of Firebird/Mozilla)
839
840* Thu Dec 04 2003 David Hill <djh[at]ii.net>
841- update to 0.4rc2
842
843* Wed Dec 03 2003 David Hill <djh[at]ii.net>
844- update to 0.4rc1 and Enigmail 0.82.4
845
846* Thu Nov 27 2003 David Hill <djh[at]ii.net>
847- update to latest CVS and Enigmail 0.82.3
848
849* Sun Nov 16 2003 David Hill <djh[at]ii.net>
850- update to latest CVS (0.4a)
851- update Enigmail to 0.82.2
852- alter mozconfig for new build requirements
853- add missing BuildReq (#987)
854
855* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
856- update to 0.3
857
858* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
859- update to 0.3rc3
860- update Enigmail to 0.81.7
861
862* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
863- update to 0.3rc2
864
865* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
866- simplify startup script
867
868* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
869- add GPG support (Enigmail 0.81.6)
870- specfile fixes (#679)
871
872* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
873- update to 0.2
874
875* Mon Sep 01 2003 David Hill <djh[at]ii.net>
876- initial RPM
877  (based on the fedora MozillaFirebird-0.6.1 specfile)
878
Note: See TracBrowser for help on using the repository browser.