source: projects/specs/branches/6/t/thunderbird/thunderbird-vl.spec @ 6078

Revision 6078, 28.7 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 12.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal %{tbmajor}
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.9
22%define nss_version 3.13.2
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine7 0
29%define build_vine6 0
30%define build_vine5 0
31
32%if "%{?_dist_release}" >= "vl7"
33%define build_vine7 1
34%endif
35%if "%{?_dist_release}" == "vl6"
36%define build_vine6 1
37%endif
38%if "%{?_dist_release}" == "vl5"
39%define build_vine5 1
40%endif
41
42
43Summary:        Thunderbird Community Edition, Mail/newsgroup client
44Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
45Name:           thunderbird
46Version:        %{tbversion}
47Release:        %{tbrelease}
48URL:            http://www.mozilla.org/projects/thunderbird/
49License:        MPL
50Group:          Applications/Internet
51
52Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
53Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
54Source1010:     mozconfig-thunderbird-vine5
55Source1020:     mozconfig-thunderbird-vine6
56Source1030:     mozconfig-thunderbird-vine7
57Source12:       thunderbird-vine-default-prefs.js
58Source20:       thunderbird.desktop
59Source21:       thunderbird.vine.sh.in
60Source30:       thunderbird-open-browser.sh
61Source40:       thunderbird-unofficial-brandig-tb-brand.properties
62Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
63Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
64Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
65Source100:      find-external-requires
66
67# locale sources
68#%define MOZ_BUILD_LOCALES "ja"
69# get from mercurial repository with command,
70# mkdir l10n
71# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
72#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
73
74
75# upstream patch
76
77# Fix for version issues
78Patch0:         thunderbird-version.patch
79
80# customization patches
81Patch1:         firefox-1.5-default-a4-paper.patch
82
83# Linux specific
84Patch100:       thunderbird-9.0-enable-addons.patch
85
86BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
87BuildRequires:  pango-devel
88BuildRequires:  cairo-devel >= %{cairo_version}
89%if %{build_vine7}
90BuildRequires:  nspr-devel >= %{nspr_version}
91BuildRequires:  nss-devel >= %{nss_version}
92BuildRequires:  hunspell-devel
93%endif
94%if %{build_vine6}
95BuildRequires:  hunspell-devel
96%endif
97BuildRequires:  pixman-devel
98BuildRequires:  libpng-devel
99%if %{build_vine5}
100BuildRequires:  libjpeg-devel
101%else
102BuildRequires:  libjpeg-turbo-devel
103%endif
104BuildRequires:  gtk2-devel
105BuildRequires:  zlib-devel, gzip, zip, unzip
106BuildRequires:  libIDL-devel
107BuildRequires:  freetype2-devel >= %{freetype_version}
108## disabled libnotify support
109## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
110BuildRequires:  libnotify-devel >= %{libnotify_version}
111BuildRequires:  bzip2-devel
112BuildRequires:  gnome-vfs2-devel
113BuildRequires:  libgnome-devel
114BuildRequires:  libgnomeui-devel
115BuildRequires:  krb5-devel
116BuildRequires:  pango-devel
117BuildRequires:  libXt-devel
118BuildRequires:  libXrender-devel
119# hunspell is in plus category for vine
120#BuildRequires: hunspell-devel
121BuildRequires:  sqlite3-devel >= %{sqlite_version}
122BuildRequires:  startup-notification-devel
123BuildRequires:  desktop-file-utils
124BuildRequires:  alsa-lib-devel
125BuildRequires:  yasm
126Requires:       sqlite3 >= %{sqlite_version}
127Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
128Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
129
130Obsoletes:      MozillaThunderbird
131Provides:       MozillaThunderbird = %{version}
132
133Vendor:         Project Vine
134Distribution:   Vine Linux
135Packager:       daisuke, ryoichi, kazutaka
136
137AutoProv: 0
138%define _use_internal_dependency_generator 0
139%define __find_requires %{SOURCE100}
140
141%description
142Thunderbird is a standalone mail and newsgroup client.
143
144%description -l ja
145Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
146
147#===============================================================================
148
149%prep
150%setup -q %{name}-%{version} -c
151cd %{tarballdir}
152
153# Fix for version issue
154sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
155    > version.patch
156%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
157
158cd mozilla
159%patch1 -p1 -b .default-a4
160
161cd -
162%{__rm} -f .mozconfig
163%if %{build_vine5}
164%{__cp} %{SOURCE1010} .mozconfig
165%endif
166%if %{build_vine6}
167%{__cp} %{SOURCE1020} .mozconfig
168%endif
169%if %{build_vine7}
170%{__cp} %{SOURCE1030} .mozconfig
171%endif
172
173# setup unofficial branding name
174%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
175%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
176
177%patch100 -p1 -b .addons
178
179#===============================================================================
180
181%build
182cd %{tarballdir}
183
184INTERNAL_GECKO=%{version_internal}
185MOZ_APP_DIR=%{mozappdir}
186
187
188%if %{build_vine7}
189MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
190%else
191%ifarch x86_64
192#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
193MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2//' -e 's/-Wall//')
194%else
195MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
196%endif
197%endif
198export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
199export CFLAGS="$RPM_OPT_FLAGS"
200#export CFLAGS=""
201export CXXFLAGS="$CFLAGS"
202export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
203
204%ifarch ppc ppc64 s390 s390x
205%define moz_make_flags -j1
206%else
207%define moz_make_flags %{?_smp_mflags}
208%endif
209
210export PREFIX='%{_prefix}'
211export LIBDIR='%{_libdir}'
212
213export LDFLAGS="-Wl,-rpath,%{mozappdir}"
214export MAKE="gmake %{moz_make_flags}"
215%{__make} -f client.mk build
216
217## build locales
218#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
219#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
220#for dir in $LOCALEDIRS
221#do
222#  for lang in %{MOZ_BUILD_LOCALES} ; do
223#    make -C $dir/locales AB_CD=$lang
224#  done
225#done
226
227#===============================================================================
228
229%install
230%{__rm} -rf $RPM_BUILD_ROOT
231cd %{tarballdir}
232
233INTERNAL_GECKO=%{version_internal}
234
235INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
236MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
237
238cd %{moz_objdir}
239DESTDIR=$RPM_BUILD_ROOT make install
240
241# install unofficial icons
242cd -
243
244%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
245%{__cp} mail/branding/aurora/mailicon16.png \
246        $RPM_BUILD_ROOT/%{mozappdir}/icons/
247%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
248%{__cp} mail/branding/aurora/mailicon16.png \
249        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
250%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
251%{__cp} mail/branding/aurora/mailicon22.png \
252        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
253%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
254%{__cp} mail/branding/aurora/mailicon24.png \
255        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
256%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
257%{__cp} mail/branding/aurora/mailicon32.png \
258        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
259%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
260%{__cp} mail/branding/aurora/mailicon48.png \
261        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
262%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
263%{__cp} mail/branding/aurora/mailicon256.png \
264        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
265
266desktop-file-install --vendor vine \
267  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
268
269# set up the thunderbird start script
270rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
271%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
272  $RPM_BUILD_ROOT%{_bindir}/thunderbird
273%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
274
275install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
276%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
277
278%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
279                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
280        $RPM_BUILD_ROOT/vine-default-prefs
281%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
282%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
283%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
284
285%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
286
287# own mozilla plugin dir (#135050)
288%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
289
290# own extension directories
291%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
292%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
293
294# install locales
295#for lang in %{MOZ_BUILD_LOCALES} ; do
296#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
297#done
298
299# install ja.xpi to langpacks directory
300#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
301#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
302# also setup unofficial branding name
303#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
304#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
305
306# install ja.xpi to langpack file
307%{__mkdir_p} lang_tmp
308unzip %{SOURCE1} -d lang_tmp
309# also setup unofficial branding name
310%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
311%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
312
313%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
314cd lang_tmp; \
315zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
316
317
318%clean
319%{__rm} -rf $RPM_BUILD_ROOT
320
321#===============================================================================
322
323%post
324update-desktop-database &> /dev/null || :
325touch --no-create %{_datadir}/icons/hicolor
326if [ -x %{_bindir}/gtk-update-icon-cache ]; then
327  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
328fi
329
330%postun
331update-desktop-database &> /dev/null || :
332touch --no-create %{_datadir}/icons/hicolor
333if [ -x %{_bindir}/gtk-update-icon-cache ]; then
334  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
335fi
336
337
338%files
339%defattr(-,root,root,-)
340%attr(755,root,root) %{_bindir}/thunderbird
341%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
342%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
343%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
344%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
345%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
346%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
347%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
348%{mozappdir}
349#%{_libdir}/mozilla
350%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
351%exclude %{_datadir}/idl/%{name}-%{version_internal}
352%exclude %{_includedir}/%{name}-%{version_internal}
353%exclude %{_libdir}/%{name}-devel-%{version_internal}
354
355#===============================================================================
356
357%changelog
358* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 12.0-1
359- new upstream release
360- update Source1020 (mozconfig-thunderbird-vine6)
361- update Source1030 (mozconfig-thunderbird-vine7)
362
363* Sun Mar 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 11.0-1
364- new upstream release
365- update Source1020 (mozconfig-thunderbird-vine6)
366
367* Fri Feb 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.2-1
368- new upstream release
369
370* Mon Feb 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0.1-1
371- new upstream release
372
373* Wed Feb 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.0-1
374- new upstream release
375
376* Sat Dec 24 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0.1-1
377- new upstream release
378- update Source1
379
380* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.0-1
381- new upstream release
382- update Source1
383- add Source1030 (mozconfig-thunderbird-vine7)
384- add Patch100 (thunderbird-9.0-enable-addons.patch)
385
386* Thu Nov 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-2
387- fix %%version_internal
388
389* Wed Nov 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.0-1
390- new upstream release
391- update Source1
392
393* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
394- new upstream release
395- update Source1,21,1010,1020
396
397* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
398- rebuild with libnotify-0.7
399
400* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
401- enable-install-strip
402
403* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
404- new upstream release
405- drop obsolete patch and renumber patch26 to patch1
406- add BuildRequires: yasm
407- enable libnotify support
408- add --disable-updater and --disable-installer to mozconfig
409- use ja.xpi instead of l10n source
410- update Source21: add step to setup langpack plugin
411- update Source20: add japanese translation
412- add Source42 & Source43 for localized branding
413- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
414  for mozconfig-thunderbird-vine5
415
416* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
417- new upstream release with security fix
418
419* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
420- new upstream release with security fix
421
422* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
423- new upstream release with security fix
424
425* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
426- new upstream release with security fix
427- add patch5 to fix build failure
428
429* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
430- new upstream release
431
432* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
433- new upstream release with security fix
434- add Patch1030 to fix compilation error
435
436* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
437- change mozconfig (Source1030 & 1040): add --enable-jsd
438
439* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
440- new upstream release
441
442* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
443- new upstream release with security fix
444- add Patch0 from fedora development: fix version issue
445- remove BuildRequires: hunspell-devel
446- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
447
448* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
449- add BuildRequires: alsa-lib-devel
450- remove BuildRequires: libnotify-devel
451  (workaround for known bug)
452- update mozconfig to add --disable-libnotify option
453
454* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
455- new upstream release
456- update spec entirely
457- import patches from fedora (Patch1, 2 & 4)
458- drop outdated patches (Patch22, 24)
459- update Sources:
460  - mozconfig (Source1030 & Source1040)
461  - default prefs.js (Source12)
462  - unofficial branding (Source40 & Source41)
463  - japanese translation (Source1000)
464- update Patch1000 (sjis-alias)
465
466* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
467- new upstream release
468
469* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
470- new upstream release
471
472* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
473- don't install official branding logos
474
475* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
476- add necessary icons in %%{tbdir}/chrome/icons/default
477- add Packager tag
478
479* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
480- new upstream release
481
482* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
483- new upstream release
484
485* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
486- new upstream release
487
488* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
489- new upstream release
490
491* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
492- rebuilt for VineSeed
493
494* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
495- new upstream release
496
497* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
498- new upstream release
499- built for Vine Linux 4.x
500- dropped Patch1020 (merged into upstream)
501
502* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
503- added Patch1020 for workaround gcc visibility hidden bugs
504
505* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
506- build with new environment/toolchain
507- add build options to build with external nss/nspr libraries
508    ac_add_options --with-system-nspr
509    ac_add_options --with-system-nss
510
511* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
512- new upstream release
513
514* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
515- new upstream release
516
517* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
518- new upstream release
519
520* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
521- new upstream release
522
523* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
524- new upstream release
525- merge changes from firefox
526  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
527
528* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
529- new upstream release
530- build en-US locale
531- merge changes from firefox
532  - add upstream patches
533  - disable pango rendering by default
534    (workaround fix slow rendering in some page)
535
536* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
537- initial build for Vine Linux based on FC package
538- update to 1.5RC2
539
540* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
541- Fix issue with popup dialogs and other actions causing lockups
542
543* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
544- Update to 1.5 rc1
545
546* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
547- Update to 1.5 beta2
548
549* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
550- Update to 1.5 beta1
551- Bring the install phase of the spec file up to speed
552
553* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
554- Rebuild
555
556* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
557- Add patch to make file chooser dialog modal
558
559* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
560- Update to 1.0.6
561
562* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
563- 1.0.6 Release Candidate
564
565* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
566- Use system NSPR
567- Fix crash on 64bit platforms (#160330)
568
569* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
570- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
571  references, fixing the "no fonts" problem.
572
573* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
574- Change the Exec line in the desktop file to `thunderbird`
575
576* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
577- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
578
579* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
580- Add temporary workaround to not create files in the user's $HOME (#149664)
581
582* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
583- Don't have downloads "disappear" when downloading to desktop (#139015)
584- Fix for some more cursor issues in textareas (149991, 150002, 152089)
585- Add upstream patch to fix bidi justification of pango
586- Add patch to fix launching of helper applications
587- Add patch to properly link against libgfxshared_s.a
588- Fix multilib conflicts
589
590* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
591- correct confusing PANGO vars in startup script
592
593* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
594- Thunderbird 1.0.2
595
596* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
597- Add patch to compile against new fortified glibc macros
598
599* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
600- Rebuild against GCC 4.0
601- Add execshield patches
602- Minor specfile cleanup
603
604* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
605- Rebuild
606
607* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
608- Add RPM version to useragent
609
610* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
611- Port over pango patches from firefox
612
613* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
614- Thunderbird 1.0
615
616* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
617- Fix advanced prefs
618
619* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
620- Make this run on s390(x) now for real
621
622* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
623- Update to 1.0 rc1
624
625* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
626- Add patches to build and run on s390(x)
627
628* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
629- Rebuild to fix file chooser
630
631* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
632- Update to 0.9
633
634* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
635- Prevent inlining of stack direction detection (#135255)
636
637* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
638- More file chooser fixes (same as in firefox)
639- Fix for upstream 28327.
640
641* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
642- Update the pango patch
643
644* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
645- Pull over patches from firefox build:
646  - disable default application dialog
647  - don't include software update since it doesn't work
648  - make external app support work
649
650* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
651- Use pango for rendering
652
653* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
654- Fix for 64 bit crash at startup (b.m.o #256603)
655
656* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
657- Add patches to fix xremote (#135036)
658
659* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
660- Add patch to fix button focus issues (#133507)
661- Add patch for fix IMAP race issues (bmo #246439)
662
663* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
664- filter out library Provides: and internal Requires:
665
666* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
667- Backport the GTK+ File Chooser.
668- Add fix for JS math on x86_64 systems
669- Add pkgconfig patch
670
671* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
672- Update to 0.8.0
673- Remove enigmail
674- Update BuildRequires
675- Remove gcc34 and extension manager patches -- they are upstreamed.
676- Fix for gnome-vfs2 error at component registration
677
678* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
679- Build with --disable-xprint
680
681* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
682- remove all Xvfb-related hacks
683
684* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
685- actually apply psfonts
686- add mozilla gnome-uriloader patch to prevent build failure
687
688* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
689- rawhide import
690- apply NetBSD's freetype 2.1.8 patch
691- apply psfonts patch
692- remove BR on /usr/bin/ex, breaks beehive
693
694* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
695- oops, fix %%install
696
697* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
698- update to Thunderbird 0.7.3 and Enigmail 0.85.0
699- remove XUL.mfasl on startup, add Debian enigmail patches
700- add Xvfb hack for -install-global-extension
701
702* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
703- update to 0.7.2, just because it's there
704- update gcc-3.4 patch (Kaj Niemi)
705- add EM registration patch and remove instdir hack
706
707* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
708- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
709
710* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
711- update to 0.7.1
712- remove Enigmail
713
714* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
715- re-enable Enigmail 0.84.1
716- add gcc-3.4 patch (Kaj Niemi)
717- use official branding (with permission)
718
719* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
720- update to 0.7
721- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
722- specify libdir, change BR for apt (V. Skytt辰, #1617)
723
724* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
725- temporary workaround for enigmail skin "modern" bug
726
727* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
728- update to Enigmail 0.84.0
729- update launch script
730
731* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
732- installation directory now versioned
733- allow root to run the program (for installing extensions)
734- remove unnecessary %%pre and %%post
735- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
736
737* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
738- include Enigmail, re-add release notes
739- delete %{_libdir}/thunderbird in %%pre
740
741* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
742- update to Thunderbird 0.6
743
744* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
745- update to Thunderbird 0.6 RC1
746- add new icon, remove release notes
747
748* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
749- update to latest CVS, update mozconfig and %%build accordingly
750- update to Enigmail 0.83.6
751- remove x-remote and x86_64 patches
752- build with -Os
753
754* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
755- update x-remote patch
756- more startup script fixes
757
758* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
759- startup script fixes, and a minor cleanup
760
761* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
762- Minor cleanups
763
764* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
765- minor improvements to open-browser.sh and startup script
766- update to latest version of Blizzard's x-remote patch
767
768* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
769- update open-browser.sh, startup script, and BuildRequires
770
771* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
772- update open-browser script, modify BuildRequires (Warren)
773- add Blizzard's x-remote patch
774- initial attempt at x-remote-enabled startup script
775
776* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
777- refuse to run with excessive privileges
778
779* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
780- add Mozilla x86_64 patch (Oliver Sontag)
781- Enigmail source filenames now include the version
782- modify BuildRoot
783
784* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
785- use the updated official tarball
786
787* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
788- fix %%prep script
789
790* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
791- update Enigmail to 0.83.3
792- use official source tarball (after removing the CRLFs)
793- package renamed to thunderbird
794
795* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
796- update to 0.5
797- check for lockfile before launching
798
799* Fri Feb 06 2004 David Hill <djh[at]ii.net>
800- update to latest cvs
801- update to Enigmail 0.83.2
802
803* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
804- update to Enigmail 0.83.1
805- removed Mozilla/Firebird script patching
806
807* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
808- add startup notification to .desktop file
809
810* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
811- open-browser.sh release 3
812- patch broken /usr/bin/mozilla script during install
813- dir ownership
814- XXX: Source fails build on x86_64... fix later
815
816* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
817- update to Enigmail 0.82.5
818- add Warren's open-browser.sh (#1113)
819
820* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
821- use Thunderbird's mozilla-xremote-client to launch browser
822
823* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
824- update to 0.4
825- make hyperlinks work (with recent versions of Firebird/Mozilla)
826
827* Thu Dec 04 2003 David Hill <djh[at]ii.net>
828- update to 0.4rc2
829
830* Wed Dec 03 2003 David Hill <djh[at]ii.net>
831- update to 0.4rc1 and Enigmail 0.82.4
832
833* Thu Nov 27 2003 David Hill <djh[at]ii.net>
834- update to latest CVS and Enigmail 0.82.3
835
836* Sun Nov 16 2003 David Hill <djh[at]ii.net>
837- update to latest CVS (0.4a)
838- update Enigmail to 0.82.2
839- alter mozconfig for new build requirements
840- add missing BuildReq (#987)
841
842* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
843- update to 0.3
844
845* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
846- update to 0.3rc3
847- update Enigmail to 0.81.7
848
849* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
850- update to 0.3rc2
851
852* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
853- simplify startup script
854
855* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
856- add GPG support (Enigmail 0.81.6)
857- specfile fixes (#679)
858
859* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
860- update to 0.2
861
862* Mon Sep 01 2003 David Hill <djh[at]ii.net>
863- initial RPM
864  (based on the fedora MozillaFirebird-0.6.1 specfile)
865
Note: See TracBrowser for help on using the repository browser.