source: projects/specs/branches/6/t/thunderbird/thunderbird-vl.spec @ 4863

Revision 4863, 27.0 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 7.0.1
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-release
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal 7.0.1
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.8
22%define nss_version 3.12.6
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vine6 0
29%define build_vine5 0
30
31%if "%{?_dist_release}" >= "vl6"
32%define build_vine6 1
33%endif
34%if "%{?_dist_release}" == "vl5"
35%define build_vine5 1
36%endif
37
38
39Summary:        Thunderbird Community Edition, Mail/newsgroup client
40Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
41Name:           thunderbird
42Version:        %{tbversion}
43Release:        %{tbrelease}
44URL:            http://www.mozilla.org/projects/thunderbird/
45License:        MPL
46Group:          Applications/Internet
47
48Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
49Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
50Source1010:     mozconfig-thunderbird-vine5
51Source1020:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55Source30:       thunderbird-open-browser.sh
56Source40:       thunderbird-unofficial-brandig-tb-brand.properties
57Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
58Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
59Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
60Source100:      find-external-requires
61
62# locale sources
63#%define MOZ_BUILD_LOCALES "ja"
64# get from mercurial repository with command,
65# mkdir l10n
66# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
67#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
68
69
70# upstream patch
71
72# Fix for version issues
73Patch0:         thunderbird-version.patch
74
75# customization patches
76Patch1:        firefox-1.5-default-a4-paper.patch
77
78BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
79BuildRequires:  pango-devel
80BuildRequires:  cairo-devel >= %{cairo_version}
81%if %{build_vine6}
82BuildRequires:  nspr-devel >= %{nspr_version}
83BuildRequires:  nss-devel >= %{nss_version}
84BuildRequires:  hunspell-devel
85%endif
86BuildRequires:  pixman-devel
87BuildRequires:  libpng-devel
88%if %{build_vine5}
89BuildRequires:  libjpeg-devel
90%else
91BuildRequires:  libjpeg-turbo-devel
92%endif
93BuildRequires:  gtk2-devel
94BuildRequires:  zlib-devel, gzip, zip, unzip
95BuildRequires:  libIDL-devel
96BuildRequires:  freetype2-devel >= %{freetype_version}
97## disabled libnotify support
98## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
99BuildRequires:  libnotify-devel >= %{libnotify_version}
100BuildRequires:  bzip2-devel
101BuildRequires:  gnome-vfs2-devel
102BuildRequires:  libgnome-devel
103BuildRequires:  libgnomeui-devel
104BuildRequires:  krb5-devel
105BuildRequires:  pango-devel
106BuildRequires:  libXt-devel
107BuildRequires:  libXrender-devel
108# hunspell is in plus category for vine
109#BuildRequires: hunspell-devel
110BuildRequires:  sqlite3-devel >= %{sqlite_version}
111BuildRequires:  startup-notification-devel
112BuildRequires:  desktop-file-utils
113BuildRequires:  alsa-lib-devel
114BuildRequires:  yasm
115Requires:       sqlite3 >= %{sqlite_version}
116Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
117Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
118
119Obsoletes:      MozillaThunderbird
120Provides:       MozillaThunderbird = %{version}
121
122Vendor:         Project Vine
123Distribution:   Vine Linux
124Packager:       daisuke, ryoichi, kazutaka
125
126AutoProv: 0
127%define _use_internal_dependency_generator 0
128%define __find_requires %{SOURCE100}
129
130%description
131Thunderbird is a standalone mail and newsgroup client.
132
133%description -l ja
134Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
135
136#===============================================================================
137
138%prep
139%setup -q %{name}-%{version} -c
140cd %{tarballdir}
141
142# Fix for version issue
143sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
144    > version.patch
145%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
146
147cd mozilla
148%patch1 -p1 -b .default-a4
149
150cd -
151%{__rm} -f .mozconfig
152%if %{build_vine5}
153%{__cp} %{SOURCE1010} .mozconfig
154%endif
155%if %{build_vine6}
156%{__cp} %{SOURCE1020} .mozconfig
157%endif
158
159# setup unofficial branding name
160%{__cp} %{SOURCE40} mail/branding/aurora/locales/en-US/brand.properties
161%{__cp} %{SOURCE41} mail/branding/aurora/locales/en-US/brand.dtd
162
163#===============================================================================
164
165%build
166cd %{tarballdir}
167
168INTERNAL_GECKO=%{version_internal}
169MOZ_APP_DIR=%{mozappdir}
170
171
172#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
173MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
174export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
175export CFLAGS="$RPM_OPT_FLAGS"
176export CXXFLAGS="$CFLAGS"
177export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
178
179%ifarch ppc ppc64 s390 s390x
180%define moz_make_flags -j1
181%else
182%define moz_make_flags %{?_smp_mflags}
183%endif
184
185export PREFIX='%{_prefix}'
186export LIBDIR='%{_libdir}'
187
188export LDFLAGS="-Wl,-rpath,%{mozappdir}"
189export MAKE="gmake %{moz_make_flags}"
190%{__make} -f client.mk build
191
192## build locales
193#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
194#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
195#for dir in $LOCALEDIRS
196#do
197#  for lang in %{MOZ_BUILD_LOCALES} ; do
198#    make -C $dir/locales AB_CD=$lang
199#  done
200#done
201
202#===============================================================================
203
204%install
205%{__rm} -rf $RPM_BUILD_ROOT
206cd %{tarballdir}
207
208INTERNAL_GECKO=%{version_internal}
209
210INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
211MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
212
213cd %{moz_objdir}
214DESTDIR=$RPM_BUILD_ROOT make install
215
216# install unofficial icons
217cd -
218
219%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
220%{__cp} mail/branding/aurora/mailicon16.png \
221        $RPM_BUILD_ROOT/%{mozappdir}/icons/
222%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
223%{__cp} mail/branding/aurora/mailicon16.png \
224        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
225%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
226%{__cp} mail/branding/aurora/mailicon22.png \
227        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
228%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
229%{__cp} mail/branding/aurora/mailicon24.png \
230        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
231%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
232%{__cp} mail/branding/aurora/mailicon32.png \
233        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
234%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
235%{__cp} mail/branding/aurora/mailicon48.png \
236        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
237%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
238%{__cp} mail/branding/aurora/mailicon256.png \
239        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
240
241desktop-file-install --vendor vine \
242  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
243
244# set up the thunderbird start script
245rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
246%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
247  $RPM_BUILD_ROOT%{_bindir}/thunderbird
248%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
249
250install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
251%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
252
253%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
254                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
255        $RPM_BUILD_ROOT/vine-default-prefs
256%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
257%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
258%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
259
260%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
261
262# own mozilla plugin dir (#135050)
263%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
264
265# own extension directories
266%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
267%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
268
269# install locales
270#for lang in %{MOZ_BUILD_LOCALES} ; do
271#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
272#done
273
274# install ja.xpi to langpacks directory
275#%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
276#unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
277# also setup unofficial branding name
278#%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
279#%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
280
281# install ja.xpi to langpack file
282%{__mkdir_p} lang_tmp
283unzip %{SOURCE1} -d lang_tmp
284# also setup unofficial branding name
285%{__cp} %{SOURCE42} lang_tmp/chrome/ja/locale/ja/branding/brand.properties
286%{__cp} %{SOURCE43} lang_tmp/chrome/ja/locale/ja/branding/brand.dtd
287
288%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks
289cd lang_tmp; \
290zip -r $RPM_BUILD_ROOT%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org.xpi chrome chrome.manifest install.rdf
291
292
293%clean
294%{__rm} -rf $RPM_BUILD_ROOT
295
296#===============================================================================
297
298%post
299update-desktop-database &> /dev/null || :
300touch --no-create %{_datadir}/icons/hicolor
301if [ -x %{_bindir}/gtk-update-icon-cache ]; then
302  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
303fi
304
305%postun
306update-desktop-database &> /dev/null || :
307touch --no-create %{_datadir}/icons/hicolor
308if [ -x %{_bindir}/gtk-update-icon-cache ]; then
309  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
310fi
311
312
313%files
314%defattr(-,root,root,-)
315%attr(755,root,root) %{_bindir}/thunderbird
316%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
317%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
318%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
319%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
320%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
321%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
322%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
323%{mozappdir}
324#%{_libdir}/mozilla
325%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
326%exclude %{_datadir}/idl/%{name}-%{version_internal}
327%exclude %{_includedir}/%{name}-%{version_internal}
328%exclude %{_libdir}/%{name}-devel-%{version_internal}
329
330#===============================================================================
331
332%changelog
333* Sat Oct 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.1-1
334- new upstream release
335- update Source1,21,1010,1020
336
337* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
338- enable-install-strip
339
340* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
341- new upstream release
342- drop obsolete patch and renumber patch26 to patch1
343- add BuildRequires: yasm
344- enable libnotify support
345- add --disable-updater and --disable-installer to mozconfig
346- use ja.xpi instead of l10n source
347- update Source21: add step to setup langpack plugin
348- update Source20: add japanese translation
349- add Source42 & Source43 for localized branding
350- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
351  for mozconfig-thunderbird-vine5
352
353* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
354- new upstream release with security fix
355
356* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
357- new upstream release with security fix
358
359* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
360- new upstream release with security fix
361
362* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
363- new upstream release with security fix
364- add patch5 to fix build failure
365
366* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
367- new upstream release
368
369* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
370- new upstream release with security fix
371- add Patch1030 to fix compilation error
372
373* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
374- change mozconfig (Source1030 & 1040): add --enable-jsd
375
376* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
377- new upstream release
378
379* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
380- new upstream release with security fix
381- add Patch0 from fedora development: fix version issue
382- remove BuildRequires: hunspell-devel
383- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
384
385* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
386- add BuildRequires: alsa-lib-devel
387- remove BuildRequires: libnotify-devel
388  (workaround for known bug)
389- update mozconfig to add --disable-libnotify option
390
391* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
392- new upstream release
393- update spec entirely
394- import patches from fedora (Patch1, 2 & 4)
395- drop outdated patches (Patch22, 24)
396- update Sources:
397  - mozconfig (Source1030 & Source1040)
398  - default prefs.js (Source12)
399  - unofficial branding (Source40 & Source41)
400  - japanese translation (Source1000)
401- update Patch1000 (sjis-alias)
402
403* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
404- new upstream release
405
406* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
407- new upstream release
408
409* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
410- don't install official branding logos
411
412* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
413- add necessary icons in %%{tbdir}/chrome/icons/default
414- add Packager tag
415
416* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
417- new upstream release
418
419* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
420- new upstream release
421
422* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
423- new upstream release
424
425* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
426- new upstream release
427
428* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
429- rebuilt for VineSeed
430
431* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
432- new upstream release
433
434* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
435- new upstream release
436- built for Vine Linux 4.x
437- dropped Patch1020 (merged into upstream)
438
439* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
440- added Patch1020 for workaround gcc visibility hidden bugs
441
442* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
443- build with new environment/toolchain
444- add build options to build with external nss/nspr libraries
445    ac_add_options --with-system-nspr
446    ac_add_options --with-system-nss
447
448* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
449- new upstream release
450
451* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
452- new upstream release
453
454* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
455- new upstream release
456
457* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
458- new upstream release
459
460* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
461- new upstream release
462- merge changes from firefox
463  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
464
465* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
466- new upstream release
467- build en-US locale
468- merge changes from firefox
469  - add upstream patches
470  - disable pango rendering by default
471    (workaround fix slow rendering in some page)
472
473* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
474- initial build for Vine Linux based on FC package
475- update to 1.5RC2
476
477* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
478- Fix issue with popup dialogs and other actions causing lockups
479
480* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
481- Update to 1.5 rc1
482
483* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
484- Update to 1.5 beta2
485
486* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
487- Update to 1.5 beta1
488- Bring the install phase of the spec file up to speed
489
490* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
491- Rebuild
492
493* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
494- Add patch to make file chooser dialog modal
495
496* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
497- Update to 1.0.6
498
499* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
500- 1.0.6 Release Candidate
501
502* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
503- Use system NSPR
504- Fix crash on 64bit platforms (#160330)
505
506* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
507- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
508  references, fixing the "no fonts" problem.
509
510* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
511- Change the Exec line in the desktop file to `thunderbird`
512
513* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
514- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
515
516* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
517- Add temporary workaround to not create files in the user's $HOME (#149664)
518
519* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
520- Don't have downloads "disappear" when downloading to desktop (#139015)
521- Fix for some more cursor issues in textareas (149991, 150002, 152089)
522- Add upstream patch to fix bidi justification of pango
523- Add patch to fix launching of helper applications
524- Add patch to properly link against libgfxshared_s.a
525- Fix multilib conflicts
526
527* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
528- correct confusing PANGO vars in startup script
529
530* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
531- Thunderbird 1.0.2
532
533* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
534- Add patch to compile against new fortified glibc macros
535
536* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
537- Rebuild against GCC 4.0
538- Add execshield patches
539- Minor specfile cleanup
540
541* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
542- Rebuild
543
544* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
545- Add RPM version to useragent
546
547* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
548- Port over pango patches from firefox
549
550* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
551- Thunderbird 1.0
552
553* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
554- Fix advanced prefs
555
556* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
557- Make this run on s390(x) now for real
558
559* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
560- Update to 1.0 rc1
561
562* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
563- Add patches to build and run on s390(x)
564
565* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
566- Rebuild to fix file chooser
567
568* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
569- Update to 0.9
570
571* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
572- Prevent inlining of stack direction detection (#135255)
573
574* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
575- More file chooser fixes (same as in firefox)
576- Fix for upstream 28327.
577
578* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
579- Update the pango patch
580
581* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
582- Pull over patches from firefox build:
583  - disable default application dialog
584  - don't include software update since it doesn't work
585  - make external app support work
586
587* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
588- Use pango for rendering
589
590* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
591- Fix for 64 bit crash at startup (b.m.o #256603)
592
593* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
594- Add patches to fix xremote (#135036)
595
596* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
597- Add patch to fix button focus issues (#133507)
598- Add patch for fix IMAP race issues (bmo #246439)
599
600* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
601- filter out library Provides: and internal Requires:
602
603* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
604- Backport the GTK+ File Chooser.
605- Add fix for JS math on x86_64 systems
606- Add pkgconfig patch
607
608* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
609- Update to 0.8.0
610- Remove enigmail
611- Update BuildRequires
612- Remove gcc34 and extension manager patches -- they are upstreamed.
613- Fix for gnome-vfs2 error at component registration
614
615* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
616- Build with --disable-xprint
617
618* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
619- remove all Xvfb-related hacks
620
621* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
622- actually apply psfonts
623- add mozilla gnome-uriloader patch to prevent build failure
624
625* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
626- rawhide import
627- apply NetBSD's freetype 2.1.8 patch
628- apply psfonts patch
629- remove BR on /usr/bin/ex, breaks beehive
630
631* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
632- oops, fix %%install
633
634* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
635- update to Thunderbird 0.7.3 and Enigmail 0.85.0
636- remove XUL.mfasl on startup, add Debian enigmail patches
637- add Xvfb hack for -install-global-extension
638
639* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
640- update to 0.7.2, just because it's there
641- update gcc-3.4 patch (Kaj Niemi)
642- add EM registration patch and remove instdir hack
643
644* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
645- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
646
647* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
648- update to 0.7.1
649- remove Enigmail
650
651* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
652- re-enable Enigmail 0.84.1
653- add gcc-3.4 patch (Kaj Niemi)
654- use official branding (with permission)
655
656* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
657- update to 0.7
658- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
659- specify libdir, change BR for apt (V. Skytt辰, #1617)
660
661* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
662- temporary workaround for enigmail skin "modern" bug
663
664* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
665- update to Enigmail 0.84.0
666- update launch script
667
668* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
669- installation directory now versioned
670- allow root to run the program (for installing extensions)
671- remove unnecessary %%pre and %%post
672- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
673
674* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
675- include Enigmail, re-add release notes
676- delete %{_libdir}/thunderbird in %%pre
677
678* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
679- update to Thunderbird 0.6
680
681* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
682- update to Thunderbird 0.6 RC1
683- add new icon, remove release notes
684
685* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
686- update to latest CVS, update mozconfig and %%build accordingly
687- update to Enigmail 0.83.6
688- remove x-remote and x86_64 patches
689- build with -Os
690
691* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
692- update x-remote patch
693- more startup script fixes
694
695* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
696- startup script fixes, and a minor cleanup
697
698* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
699- Minor cleanups
700
701* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
702- minor improvements to open-browser.sh and startup script
703- update to latest version of Blizzard's x-remote patch
704
705* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
706- update open-browser.sh, startup script, and BuildRequires
707
708* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
709- update open-browser script, modify BuildRequires (Warren)
710- add Blizzard's x-remote patch
711- initial attempt at x-remote-enabled startup script
712
713* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
714- refuse to run with excessive privileges
715
716* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
717- add Mozilla x86_64 patch (Oliver Sontag)
718- Enigmail source filenames now include the version
719- modify BuildRoot
720
721* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
722- use the updated official tarball
723
724* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
725- fix %%prep script
726
727* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
728- update Enigmail to 0.83.3
729- use official source tarball (after removing the CRLFs)
730- package renamed to thunderbird
731
732* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
733- update to 0.5
734- check for lockfile before launching
735
736* Fri Feb 06 2004 David Hill <djh[at]ii.net>
737- update to latest cvs
738- update to Enigmail 0.83.2
739
740* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
741- update to Enigmail 0.83.1
742- removed Mozilla/Firebird script patching
743
744* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
745- add startup notification to .desktop file
746
747* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
748- open-browser.sh release 3
749- patch broken /usr/bin/mozilla script during install
750- dir ownership
751- XXX: Source fails build on x86_64... fix later
752
753* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
754- update to Enigmail 0.82.5
755- add Warren's open-browser.sh (#1113)
756
757* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
758- use Thunderbird's mozilla-xremote-client to launch browser
759
760* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
761- update to 0.4
762- make hyperlinks work (with recent versions of Firebird/Mozilla)
763
764* Thu Dec 04 2003 David Hill <djh[at]ii.net>
765- update to 0.4rc2
766
767* Wed Dec 03 2003 David Hill <djh[at]ii.net>
768- update to 0.4rc1 and Enigmail 0.82.4
769
770* Thu Nov 27 2003 David Hill <djh[at]ii.net>
771- update to latest CVS and Enigmail 0.82.3
772
773* Sun Nov 16 2003 David Hill <djh[at]ii.net>
774- update to latest CVS (0.4a)
775- update Enigmail to 0.82.2
776- alter mozconfig for new build requirements
777- add missing BuildReq (#987)
778
779* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
780- update to 0.3
781
782* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
783- update to 0.3rc3
784- update Enigmail to 0.81.7
785
786* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
787- update to 0.3rc2
788
789* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
790- simplify startup script
791
792* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
793- add GPG support (Enigmail 0.81.6)
794- specfile fixes (#679)
795
796* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
797- update to 0.2
798
799* Mon Sep 01 2003 David Hill <djh[at]ii.net>
800- initial RPM
801  (based on the fedora MozillaFirebird-0.6.1 specfile)
802
Note: See TracBrowser for help on using the repository browser.