source: projects/specs/branches/6/t/thread/thread-vl.spec @ 3506

Revision 3506, 12.3 KB checked in by owa, 13 years ago (diff)

rebuild main

Line 
1%define tclmajor 8.4
2%define majorver 2.6
3
4Summary: A Tcl/Tk development environment: thread
5Summary(ja): Tcl/Tk 開発環境: thread
6Name: thread
7Version: %{majorver}.5
8Release: 3%{?_dist_release}
9License: BSD
10Group: Development/Languages
11BuildRequires: libtool, util-linux, perl, gdbm
12BuildRequires: tcl >= %{tclmajor}
13BuildRequires: tk >= %{tclmajor}
14Requires: tcl >= %{tclmajor}
15Requires: tk >= %{tclmajor}
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17URL: http://tcl.sourceforge.net/
18Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}.tar.gz
19Vendor: Project Vine
20Distribution: Vine Linux
21
22
23%description
24You can use this extension to gain script-level access to Tcl threading capabilities.
25
26%prep
27
28%setup -q -n %{name}%{version}
29
30%build
31chmod 755 ./configure
32%configure \
33--with-tcl=%{_libdir} --with-tk=%{_libdir}  --enable-shared \
34--enable-threads --enable-64bit
35make %{?_smp_mflags}
36
37%install
38rm -rf ${RPM_BUILD_ROOT}
39%makeinstall
40
41echo "%%defattr(-,root,root)" > thread.files
42(find ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
43 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
44        | sort | uniq -u >> thread.files
45
46set +x +H
47for n in `cat thread.files`; do
48        test -f $n || continue
49        head -1 $n | grep -q ^#! || continue
50        chmod u+w $n
51        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
52done
53set -x -H
54
55#
56# post process the *.files list, removing build sys references and mark
57# which are directories
58set +x
59for n in *.files; do
60        mv $n $n.in
61        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
62            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
63                echo -n '%dir '
64            fi
65            echo $file
66        done > $n
67        rm -f $n.in
68done
69set -x
70
71#
72# Man pages can be compressed
73perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
74
75%post -p /sbin/ldconfig -n thread
76
77%postun -p /sbin/ldconfig -n thread
78
79%clean
80rm -rf ${RPM_BUILD_ROOT}
81rm -f *.files
82
83%files -f thread.files -n thread
84
85%changelog
86* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
87- rebuilt with rpm-4.8.1-3
88
89* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
90- rebuilt with new environment
91
92* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1vl5
93- applied new versioning policy and spec in utf-8
94
95* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl3
96- rebuild with tcl/tk-8.4.18
97
98* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl2
99- rebuild with tcl/tk-8.4.16
100
101* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl1
102- update thread to 2.6.5
103- rebuilt with new toolchain
104
105* Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl2
106- rebuild for tcl/tk-8.4.12, and x86_64 architecture support
107
108* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl1
109- update thread to 2.6.2
110- rebuilt for tcl/tk-8.4.11
111
112* Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 2.5.2-0vl2
113- rebuild for tcl/tk-8.4.6
114
115* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.2-0vl1
116- source update
117
118* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.1-0vl1
119- modified for Vine Linux
120- splite source package
121
122* Wed Mar 05 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 83bw
123- update Tcl/Tk 8.4.2
124
125* Wed Feb 12 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 82bw
126- update thread 2.5
127- update expect-20030203 (nightly-cvs)
128- remove xotcl
129
130* Wed Nov 20 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 81bw
131- add config patch for Trf
132- add static libraries of Tcl and Tk
133- add tbcload and tclcompiler again
134
135* Fri Nov 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 80bw
136- build on RH 8.0
137- update expect 5.38.0
138- remove tcllib module, which will be separate RPM from this.
139- remove tbcload module, which will be separate RPM from this.
140- remove tclcompiler module, which will be separate RPM from this.
141- add XOTcl 1.0
142- add Tcl-Trf 2.1p2
143- add Memchan 2.2a4
144
145* Sat Oct 29 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 79bw
146- fix to make XIC free, and eliminate XCloseIM when exiting Tk.
147
148* Sat Oct 26 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 78bw
149- update Tcl/Tk 8.4.1.
150
151* Fri Oct 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 77bw
152- correct install sequence in Tk.
153
154* Sat Sep 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 76bw
155- add TclPro tools:
156- tbcload CVS
157- tclcompiler CVS
158
159* Wed Sep 18 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 75bw
160- add iwidgets4.0.1.
161- correct symbolic link
162
163* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 74bw
164- fix stub problem in itcl.
165
166* Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 73bw
167- adjust libary names to meet compatibility.
168
169* Wed Sep 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 72bw
170- update Tcl/Tk 8.4.0.
171- update TclX 8.4.
172- update tcllib 1.3.
173- add thread2.4.
174
175* Sat Feb 02 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 71bw
176- update tcllib 1.2.
177
178* Fri Jan 04 2002 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 70bw
179- correct to install all of message catalogs for Img.
180
181* Thu Dec 27 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 69bw
182- add tcl-8.3.4-encoding.patch for JIS encoding
183
184* Wed Dec 26 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 68bw
185- update itcl 3.2.1
186
187* Mon Nov 11 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 67bw
188- add link for tclth8.3 and wish8.3
189- add img 1.2.4
190
191* Sun Nov 04 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 66bw
192- update Tcl/Tk 8.3.4
193- update tcllib 1.1
194- update patch tcl-8.3.4-cruft.patch
195- update patch tcl-8.3.4-makecfg.patch
196- update patch tk-8.3.4-makecfg.patch
197
198* Mon Aug 29 2001 Adrian Havill <havill@redhat.com>
199- hard-coded the compat symlink for tix libdir. (bug 52812)
200
201* Mon Aug 28 2001 Adrian Havill <havill@redhat.com>
202- fixed itkwish/itclsh lib problem (bug 52608)
203- make itcl install not need tclsh/wish during config/make (bug 52606)
204- expect's fixline1 busted for expectk scripts (tkpasswd/tknewsbiff/tkterm)
205
206* Mon Aug  8 2001 Adrian Havill <havill@redhat.com>
207- changed rev for tcllib to 1.0
208- added execute bit mode for itclsh and itksh compat shells
209- re-enable glibc string and math inlines; recent gcc is a-ok.
210- optimize at -O2 instead of -O
211- rename "soname" patches related to makefile/autoconf changes
212- added elf "needed" for tk, tclx, tix, itk
213- removed warnings from tclX
214
215* Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
216- added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
217- fixed 64 bit RPM provides for dependencies
218
219* Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
220- updated tclX to the latest version
221- fixed tclX 8.3's busted help install
222- eliminated make TK_LIB kludge for multiple math libs for tclX
223- used %%makeinstall to brute force fix any remaining unflexible makefile dirs
224- fixed bad ref count release in tcl (bug 49406)
225- improved randomness of expect's mkpasswd script via /dev/random (bug 9507)
226- revert --enable-threads, linux is (still) not ready (yet) (bug 49251)
227- fixed DirTree in Tix (bug 45570)
228
229* Sun Jul  8 2001 Adrian Havill <havill@redhat.com>
230- refresh all sources to latest stable (TODO: separate expect/expectk)
231- massage out some build stuff to patches (TODO: libtoolize hacked constants)
232- remove patches already rolled into the upstream
233- remove unneeded autopasswd
234- removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
235- changed shared object filenames to something less gross
236- fixed tclX shell's argv parsing (bug 47710)
237- reenable threads which seem to work now
238- added all necessary header files for itcl (bug 41374)
239- fixed spawn/eof read problem with expect (bug 43310)
240- made compile-friendly for IA64
241
242* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
243- Bump release + rebuild for 7.2.
244
245* Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
246- bzip2 sources
247
248* Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
249- build with -D_GNU_SOURCE - fixes expect on ia64
250
251* Mon Mar 19 2001 Preston Brown <pbrown@redhat.com>
252- build fix from ahavill.
253
254* Wed Feb 21 2001 Tim Powers <timp@redhat.com>
255- fixed weather expect script using wrong server (#28505)
256
257* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
258- added "ja_JP.eucJP" to locale list for tcl
259
260* Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
261- rebuild so make check passes
262
263* Fri Oct 20 2000 Than Ngo <than@redhat.com>
264- rebuild with -O0 on alpha (bug #19461)
265
266* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
267- summaries from specspo.
268
269* Tue Aug  8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
270- remove symlink to libtixsam.so
271
272* Thu Aug  3 2000 Jeff Johnson <jbj@redhat.com>
273- merge "best known" patches from searching, stubs were broken.
274- tix needs -fwritable-strings (#14352).
275- create tixwish symlink.
276
277* Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
278- rebuild against "working" util-linux col.
279
280* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
281- automatic rebuild
282
283* Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
284- make sure that tix shared libraries are installed.
285- don't mess with %%{_libdir}, it's gonna be a FHS pita.
286
287* Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
288- move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940).
289
290* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
291- tclX had wrong version.
292
293* Fri Jun  2 2000 Jeff Johnson <jbj@redhat.com>
294- FHS packaging changes.
295- revert --enable-threads, linux is not ready (yet) (#11789).
296- tcl/tk: update to 8.3.1 (#10779).
297- expect: update to 5.31.7+ (#11595).
298- add tcllib-0.4.
299- abstract major tcltk version for soname expansion etc.
300
301* Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
302- update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
303- use perl to drill out pre-pended RPM_BUILD_ROOT.
304- configure with --enable-threads (experimental).
305- improved version of autopasswd (#4788).
306- autopasswd needs to handle password starting with hyphen (#9917).
307- handle 553 ftp status in rftp expect script (#7869).
308- remove cryptdir/decryptdir, as Linux has not crypt command (#6668).
309- correct hierarchy spelling (#7082).
310- fix "expect -d ...", format string had int printed as string (#7775).
311
312* Tue Mar  7 2000 Jeff Johnson <jbj@redhat.com>
313- rebuild for sparc baud rates > 38400.
314
315* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
316- handle compressed manpages
317
318* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
319- Make changes from bug number 7602
320- Apply patch from bug number 7537
321- Apply fix from bug number 7157
322- Add fixes from bug #7601 to the runtcl patch
323
324* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
325- fix descriptions
326- man pages are compressed (whatapain)
327
328* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
329- fix tclX symlinks.
330- compile on systems where SIGPWR == SIGLOST.
331
332* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
333- update tcl/tk to 8.0.5.
334- avoid "containing" in Tix (#2332).
335
336* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
337- use /usr/bin/write in kibitz (#1320).
338- use cirrus.sprl.umich.edu in weather (#1926).
339
340* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
341- auto rebuild in the new build environment (release 28)
342
343* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
344- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
345
346* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
347- expect does unaligned access on alpha (#989)
348- upgrade tcl/tk/tclX to 8.0.4
349- upgrade expect to 5.28.
350- add itcl 3.0.1
351
352* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
353- call libtoolize to allow building on the arm
354- build for glibc 2.1
355- strip binaries
356
357* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
358- update tcl/tk/tclX to 8.0.3, expect is updated also.
359
360* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
361- expect: mkpasswd needs delay before sending password (problem #576)
362
363* Thu May 07 1998 Prospector System <bugs@redhat.com>
364- translations modified for de, fr, tr
365
366* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
367- fixed expect binaries exec permissions
368
369* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
370- updated to Tix 4.1.0.006
371- updated version numbers of tcl/tk to relflect includsion of p2
372
373* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
374- updated tcl/tk to patch level 2
375- updated tclX to 8.0.2
376
377* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
378- fixed filelist for tix... replacing path to the expect binary in scripts
379  was leaving junk files around.
380
381* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
382- added patch to remove libieee test in configure.in for tcl and tk.
383  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
384  solution for all systems
385- fixed src urls
386
387* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
388- removed version numbers from descriptions
389
390* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
391- updated to tcl/tk 8.0 and related versions of packages
392
393* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
394- built against glibc
395- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.