source: projects/specs/branches/6/t/texmacro-otf/texmacro-otf-vl.spec @ 3944

Revision 3944, 8.8 KB checked in by munepi, 13 years ago (diff)

updated texlive and its related packages: ready for Vine Linux 6 release

Line 
1%define tlversion       2009
2
3%define hirapropver     0.3
4%define kokanaver       1.0b2
5%define otfver          1.5.6.1
6
7%define texmf           %{_datadir}/texmf
8%define texvf           %{texmf}/fonts/vf/public
9%define texofm          %{texmf}/fonts/ofm/public
10%define textfm          %{texmf}/fonts/tfm/public
11%define mapdir          %{texmf}/fonts/map/dvipdfm/otf
12%define build_texmf     %{buildroot}%{texmf}
13%define build_texvf     %{buildroot}%{texvf}
14%define build_texofm    %{buildroot}%{texofm}
15%define build_textfm    %{buildroot}%{textfm}
16%define build_mapdir    %{buildroot}%{mapdir}
17%define dvipdfmconfig   %{texmf}/dvipdfm/config
18
19%define exec_updmap     [ -x %{_bindir}/updmap-sys ] && %{_bindir}/env - %{_bindir}/updmap-sys --nostop 2> /dev/null
20%define exec_updmap_otf [ -x %{_bindir}/updmap-otf ] && %{_bindir}/env - %{_bindir}/updmap-otf auto 2> /dev/null
21
22Summary: TeX Live macro packages for "VF for OpenType Fonts" by S. Saito
23Summary(ja): TeX Live で使うマクロパッケージ (齋藤修三郎氏による「OpenType Font用VF」)
24Name: texmacro-otf
25Version: %{otfver}
26Release: 4%{?_dist_release}
27BuildArch: noarch
28# #Source0: http://psitau.at.infoseek.co.jp/otfstable.zip
29# Source0: otfstable-%{version}.tar.bz2
30# $ md5sum otfcurrent.zip
31# fc38d8384f73ae4b4238698eef4e11fd  otfcurrent.zip
32# $ unzip otfcurrent.zip
33# $ mv otfcurrent otfcurrent-1.5.6.1
34# $ tar jcf otfcurrent-1.5.6.1.tar.bz2 otfcurrent-1.5.6.1
35#Source0: http://psitau.at.infoseek.co.jp/otfstable.zip
36Source0: otfcurrent-%{version}.tar.bz2
37#Source1: http://psitau.at.infoseek.co.jp/hiraprop.zip
38Source1: hiraprop-%{hirapropver}.tar.bz2
39#Source2: http://psitau.at.infoseek.co.jp/kokana.zip
40Source2: kokana-%{kokanaver}.tar.bz2
41Source3: http://psitau.at.infoseek.co.jp/otfmanual.pdf
42Source4: http://psitau.at.infoseek.co.jp/kitunetuki.pdf
43Source5: http://psitau.at.infoseek.co.jp/meijinden.pdf
44Source10: updmap-otf
45Source20: otf-noEmbed.map
46Source21: otf-cktx.map
47
48Patch1: texmacro-otf-RmlGbm.patch
49
50URL: http://psitau.at.infoseek.co.jp/otf.html
51License: distributable
52Group:  Applications/Publishing
53BuildRequires: texlive = %{tlversion}
54BuildRequires: perl, nkf
55Requires:     texlive = %{tlversion}
56Requires:     ghostscript
57
58Buildroot:    %{_tmppath}/%{name}-%{version}-root
59
60Obsoletes: texlive-texmacro-otf <= 1.5.6.1
61
62Distribution: Vine Linux
63Vendor:       Project Vine
64
65%description
66TeX Live macro packages of VF for OpenType Fonts by SAITO Shuzaburo
67Users can use these macros on platex.
68Including
69        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
70        otfaltkana.sty redeffont.sty
71
72%description -l ja
73齋藤修三郎氏作成の TeX Live で用いる追加マクロパッケージです。
74LaTeX(pLaTeX2e)でOpen Type Fontを有効に利用するための
75VF およびスタイルファイルです。
76platex 上で利用できます。
77以下のマクロが含まれています。
78        hiraprop.sty ajmacros.sty mlcid.sty mlutf.sty otf.sty
79        otfaltkana.sty redeffont.sty
80
81%prep
82%setup -q -c -n %{name}-%{version} -a 1 -a 2
83
84#for i in `grep -l -ir ovp2ovf * | grep -v readme`;
85#do
86#       perl -pi -e "s@ovp2ovf@ovp2ovf-1.11@" $i
87#done
88
89## rename from pltotf to ppltotf
90%__sed -i -e "s,^pltotf,ppltotf,g" kokana-%{kokanaver}/makealtkana || exit 1
91
92%build
93
94# ###### otfstable #####
95pushd otfcurrent-%{version}
96./makeotf
97popd
98
99###### kokana #####
100pushd kokana-%{kokanaver}
101nkf -be basepl/base-h.pl > base-h.pl
102nkf -be basepl/base-v.pl > base-v.pl
103%__mv -f base-[hv].pl basepl
104./makealtkana
105popd
106
107%install
108%__rm -rf %{buildroot}
109
110%__mkdir fontmap test pdf
111%__mkdir_p %{buildroot}%{_bindir}
112%__mkdir_p %{build_texmf}/ptex/platex/otf
113%__mkdir_p %{build_texmf}-var/updmap-otf
114%__mkdir_p %{build_texvf}/otf
115%__mkdir_p %{build_textfm}/otf
116%__mkdir_p %{build_mapdir}
117
118%__install -m 644 %{SOURCE3} %{SOURCE4} %{SOURCE5} pdf
119%__install -m 755 %{SOURCE10} %{buildroot}%{_bindir}/updmap-otf
120
121### set prefix dir ###
122%__sed -i -e "s@/usr/local@/usr@" \
123          -e "s@/fonts/map/dvipdfm@/fonts/map/dvipdfm/otf@g" \
124    %{buildroot}%{_bindir}/updmap-otf || exit 1
125
126###### otfstable #####
127pushd otfcurrent-%{version}
128%__install -m 644 sty/*.sty %{build_texmf}/ptex/platex/otf
129%__install -m 644 vf/* %{build_texvf}/otf
130%__install -m 644 tfm/* %{build_textfm}/otf
131
132#install -m 644 fontmap/cktx.map* %{build_mapdir}/otf-cktx.map
133#install -m 644 fontmap/hiraginox.map* %{build_mapdir}/otf-hiraginox.map
134%__sed -e 's/W.$/&.otf/g' fontmap/hiraginox.map* > %{build_mapdir}/otf-hiraginox.map
135%__install -m 644 fontmap/kozukax.map* %{build_mapdir}/otf-kozukax.map
136%__install -m 644 fontmap/morisawax.map* %{build_mapdir}/otf-morisawax.map
137
138## morisawa map files remaped PS Kanji (CIDFont) Name
139%__sed -e 's@A-OTF-@@g' %{build_mapdir}/otf-morisawax.map > %{build_mapdir}/otf-ps-morisawax.map
140%__sed -e 's@A-OTF-@!@g' %{build_mapdir}/otf-morisawax.map > %{build_mapdir}/otf-ps-morisawax-noEmbed.map
141
142# Install our own noFont map
143%__install -m 644 %{SOURCE20}  %{build_mapdir}
144%__install -m 644 %{SOURCE21}  %{build_mapdir}
145
146pushd %{build_mapdir}
147patch -p1 < %{PATCH1}
148popd
149
150%__install -m 644 fontmap/vfontmap.txt ../fontmap
151
152%__install -m 644 test/*.tex ../test
153%__install -m 644 readme.txt ../readme-otfcurrent.txt
154popd
155
156###### hiraprop #####
157%__mkdir_p %{build_texmf}/ptex/platex/hiraprop
158%__mkdir_p %{build_texvf}/hiraprop
159%__mkdir_p %{build_texofm}/hiraprop
160%__mkdir_p %{build_textfm}/hiraprop
161
162pushd hiraprop-%{hirapropver}
163%__install -m 644 sty/* %{build_texmf}/ptex/platex/hiraprop
164%__install -m 644 vf/hiraprop/* %{build_texvf}/hiraprop
165%__install -m 644 ofm/hiraprop/* %{build_texofm}/hiraprop
166%__install -m 644 tfm/hiraprop/* %{build_textfm}/hiraprop
167
168%__install -m 644 *.tex ../test
169%__install -m 644 readme.txt ../readme-hiraprop.txt
170popd
171
172###### kokana #####
173pushd kokana-%{kokanaver}
174%__install -m 644 otfaltkana.sty %{build_texmf}/ptex/platex/otf
175%__install -m 644 vf/* %{build_texvf}/otf
176%__install -m 644 tfm/* %{build_textfm}/otf
177
178%__install -m 644 sample/kokanatest.tex ../test
179%__install -m 644 readme.txt ../readme-kokana.txt
180popd
181
182
183%post
184%{exec_updmap}
185%{exec_updmap_otf}
186exit 0
187
188%postun
189if [ "$1" = 0 ]; then
190        %__rm -rf %{texmf}-var/updmap-otf
191        %{exec_updmap}
192fi
193exit 0
194
195%clean
196%__rm -rf %{buildroot}
197
198%files
199%defattr(-,root,root)
200%doc readme* fontmap test pdf
201%dir %{texmf}-var/updmap-otf
202%{_bindir}/updmap-otf
203%{texmf}/ptex/platex/otf
204%{texmf}/ptex/platex/hiraprop
205%{texvf}
206%{textfm}
207%{texofm}
208%{mapdir}
209
210%changelog
211* Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-4
212- fixed updmap-otf
213  - changed $$MAPDIR to $${TEXMF}/fonts/map/dvipdfm/otf
214
215* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-3
216- changed %%mapdir to %%{texmf}/fonts/map/dvipdfm/otf
217
218* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-2
219- added Obsoletes: texlive-texmacro-otf <= 1.5.6.1
220  - for TeX Live 2009 of VinePlus/5, supported texlive-texmacro-otf
221
222* Sat Jul 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.5.6.1-1
223- new upstream release
224- TeX Linux 2009
225
226* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-3
227- added otf-ps-morisawax{-noEmbed}.map
228
229* Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.2.9-2
230- spec in utf8
231
232* Tue Aug 05 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-1
233- applied new versioning policy
234
235* Sun Apr 07 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.9-0vl1
236- new upstream release
237
238* Sat May 27 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl2
239- updmap-otf v0.9: use noEmbed.map instead of noEmbeddedFont.map
240
241* Fri May 12 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.2.7.1-0vl1
242- resync with ptetex3-20060506
243
244* Sun Nov 06 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl3
245- resync with ptetex3-20051102
246
247* Wed Aug 31 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl2
248- resync with ptetex3-20050830
249
250* Sat Jun 18 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.7-0vl1
251- source update
252- modified for teTeX3
253
254* Thu Feb 03 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.6-0vl1
255- source update
256
257* Thu Jan 20 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.5-0vl1
258- source update
259
260* Sun Nov 07 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl5
261- updmap-0.7
262
263* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl4
264- updmap-0.6
265
266* Mon Oct 11 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl3
267- updmap-0.5
268
269* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl2
270- fixed updmap
271
272* Thu Sep 30 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.4-0vl1
273- source update
274- updmap-0.4
275
276* Thu Apr 08 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl4
277- update updmap-otf: take over before setting in "auto" target
278- remove requires texmacro-sfujita
279
280* Sat Apr 03 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl3
281- fix postun
282
283* Fri Apr 02 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl2
284- drop extrafonts and added hiraprop
285- update updmap-otf and *-udvips.map
286
287* Sun Mar 28 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.2.2-0vl1
288- source update
289- added updmap-otf
290
291* Wed Feb 04 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.9-0vl1
292- first release
Note: See TracBrowser for help on using the repository browser.