source: projects/specs/branches/6/t/texlive-tetex-trans/texlive-tetex-trans-vl.spec @ 2504

Revision 2504, 3.3 KB checked in by munepi, 13 years ago (diff)

NEW: texlive-tetex-trans, texlive-jvf, texlive-texmacro-otf, texlive-mathabx-type1: supported only Vine Linux 5

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%if %{?_dist_release} != "vl5"
5exit 1
6%endif
7
8# From $ apt-cache whatdepends jadetex
9# docbook-utils-0.6.14-2vl5
10#   Depends: jadetex
11Provides:    jadetex
12Conflicts:   tetex dvipdfmx xdvik xdvik-motif jvf
13Conflicts:   texlive
14
15%define tex_destdir     %{_datadir}
16%define texmf           %{tex_destdir}/texmf
17
18Summary: TeX Live: teTeX transitional package
19Summary(ja): TeX Live: teTeX から TeX Live への移行用パッケージ
20Name: texlive-tetex-trans
21Version: 2009
22Release: 2%{?_dist_release}
23License: distributable
24Group: Applications/Publishing
25URL: http://www.tug.org/texlive/
26
27BuildArch:      noarch
28Buildroot:    %{_tmppath}/%{name}-%{version}-root
29
30Vendor:       Project Vine
31Distribution: Vine Linux
32Packager:     munepi
33
34
35%description
36The TeX Live software distribution offers a complete TeX system for a
37variety of Unix, Macintosh, Windows and other platforms. It
38encompasses programs for editing, typesetting, previewing and printing
39of TeX documents in many different languages, and a large collection
40of TeX macros and font libraries.
41
42The distribution includes extensive general documentation about TeX,
43as well as the documentation for the included software packages.
44
45This package is a transitional package to bring teTeX environment
46TeX Live environment.
47If your system has installed teTeX environment,
48you can install TeX Live environment to execute the following steps:
49  \# apt-get install %{name}
50  \# apt-get install task-texlive
51
52
53%description -l ja
54TeX Live ソフトウェアディストリビューションは、
55さまざまな Unix, Macintosh, Windows、および
56他のプラットホームに対して完全な TeX システムを提供します。
57多くの異なった言語を含む TeX ドキュメントの
58編集、組版、閲覧、印刷するためのプログラム、
59そして、TeX マクロやフォントライブラリの大きなコレクションを
60同梱しています。
61
62このディストリビューションは
63同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
64TeX に関するたくさんの一般的なドキュメントを含んでいます。
65
66このパッケージは teTeX 環境から TeX Live 環境へ移行するための
67パッケージです。
68teTeX 環境がインストールされていたら、
69以下のコマンドを実行することで TeX Live 環境をインストールできます。
70  \# apt-get install %{name}
71  \# apt-get install task-texlive
72
73
74%files
75
76
77%posttrans
78_trans_time=$(date +%Y%m%d)
79echo "Running transitional process of your TeX system ... "
80for dir in %{texmf}-var %{texmf}-config; do
81    _trans_dir=${dir}.${_trans_time}.rpmorig
82    [ -d ${_trans_dir}.old ] && \
83        echo -n "  " && \
84        echo "Found ${_trans_dir}.old: " && \
85        echo -n "    " && \
86        %__rm -rvf ${_trans_dir}.old
87    [ -d ${_trans_dir} ] && \
88        echo -n "  " && \
89        echo "Found ${_trans_dir}: " && \
90        echo -n "    " && \
91        %__mv -v ${_trans_dir} ${_trans_dir}.old
92    [ -d ${dir} ] && \
93        echo -n "  " && \
94        echo "Found ${dir}: " && \
95        echo -n "    " && \
96        %__mv -v ${dir} ${_trans_dir}
97done
98echo "done."
99
100exit 0
101
102
103%postun
104exit 0
105
106
107%changelog
108* Tue Jan 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
109- fixed %%posttrans
110
111* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
112- initial package
Note: See TracBrowser for help on using the repository browser.