source: projects/specs/branches/6/t/texlive-sources/texlive-sources-vl.spec @ 2503

Revision 2503, 3.1 KB checked in by munepi, 13 years ago (diff)

updated texlive packages: supported VinePlus?/5, more; improved some %%post scripts

Line 
1## -*- coding: utf-8-unix -*-
2%define texlivesrcver   20091107
3%define texlivever      20091107
4
5%define texlivedir      %{_datadir}/texlive
6%define build_texlive_src       %{buildroot}%{texlivedir}-sources
7
8%define pkgname         texlive
9
10%define __find_provides %{nil}
11%define __find_requires %{nil}
12%define __perl_provides %{nil}
13%define __perl_requires %{nil}
14
15Summary: A collection of sources for TeX Live packages
16Summary(ja): TeX Live のソース集
17Name: texlive-sources
18Version: 2009
19Release: 2%{?_dist_release}
20License: distributable
21Group: Applications/Publishing
22URL: http://www.tug.org/texlive/
23
24## original TeX Live sources
25Source1: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivesrcver}-source.tar.xz
26Source2: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-texmf.tar.xz
27Source3: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-extra.tar.xz
28# Source4: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivever}-bin.tar.xz
29
30# ## from texlive2009.iso:/tlpkg/texlive.tlpdb
31# Source10: texlive2009.tlpdb
32
33%{?nosrc:NoSource: 1}
34%{?nosrc:NoSource: 2}
35%{?nosrc:NoSource: 3}
36
37BuildRequires: tar
38BuildRequires: xz
39
40BuildArch:      noarch
41BuildRoot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:       Project Vine
44Distribution: Vine Linux
45Packager:     munepi
46
47%description
48This package is a collection of sources for TeX Live packages.
49It contains
50  %{pkgname}-%{texlivesrcver}-source.tar.xz,
51  %{pkgname}-%{texlivever}-texmf.tar.xz,
52  %{pkgname}-%{texlivever}-extra.tar.xz
53on ftp://tug.org/historic/systems/texlive/2009/.
54
55This package is used to build texlive package and its related packages
56of Vine Linux.
57
58
59%description -l ja
60このパッケージは TeX Live のソース集です。
61ftp://tug.org/historic/systems/texlive/2009/ 上の
62  %{pkgname}-%{texlivesrcver}-source.tar.xz,
63  %{pkgname}-%{texlivever}-texmf.tar.xz,
64  %{pkgname}-%{texlivever}-extra.tar.xz
65を含んでいます。
66
67このパッケージは Vine Linux の texlive パッケージやその関連パッケージを
68ビルドするために使われます。
69
70
71%prep
72[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
73
74%build
75
76%install
77[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
78
79%__mkdir_p %{build_texlive_src}
80(cd %{build_texlive_src}
81    %__mkdir_p source || exit 1
82    %__install -m0644 %{SOURCE1} source/ || exit 1
83
84    %__tar Jxf %{SOURCE2} || exit 1
85    %__mv %{pkgname}-%{texlivever}-texmf/* . || exit 1
86    %__tar Jxf %{SOURCE3} || exit 1
87    %__mv %{pkgname}-%{texlivever}-extra/* . || exit 1
88
89    # %__mkdir_p tlpkg || exit 1
90    # %__install -m0644 %{SOURCE10} tlpkg/texlive.tlpdb || exit 1
91
92    %__rm -r %{pkgname}-%{texlivever}-{texmf,extra} || exit 1
93
94    ## remove arch dependent binaries
95    %__rm -f texmf-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
96)
97
98%clean
99%__rm -rf %{buildroot}
100
101%files
102%defattr(-,root,root)
103%{texlivedir}-sources
104
105%changelog
106* Sat Nov 06 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
107- supported Vine Linux 5
108
109* Sun May 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
110- TeX Live 2009
Note: See TracBrowser for help on using the repository browser.