source: projects/specs/branches/6/t/texlive-collection-langswedish/texlive-collection-langswedish-vl.spec @ 2505

Revision 2505, 6.6 KB checked in by munepi, 13 years ago (diff)

updated all texlive-collection-* packages: improved %%post

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
3## tlpdb2rpmspec collection-langswedish
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Swedish
28Summary(ja): TeX Live: Swedish
29Name: texlive-collection-langswedish
30Version: 2009
31Release: 3%{?_dist_release}
32License: LPPL
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Swedish:
61Support for typesetting Swedish.
62
63This package contains the following CTAN packages:
64swebib: Swedish bibliography styles.
65hyphen-swedish:
66
67%description -l ja
68TeX Live ソフトウェアディストリビューションは、
69さまざまな Unix, Macintosh, Windows、および
70他のプラットホームに対して完全な TeX システムを提供します。
71多くの異なった言語を含む TeX ドキュメントの
72編集、組版、閲覧、印刷するためのプログラム、
73そして、TeX マクロやフォントライブラリの大きなコレクションを
74同梱しています。
75
76このディストリビューションは
77同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
78TeX に関するたくさんの一般的なドキュメントを含んでいます。
79
80このパッケージは以下のようなパッケージ集です。
81Swedish:
82Support for typesetting Swedish.
83
84このパッケージは以下の CTAN パッケージを含んでいます:
85swebib: Swedish bibliography styles.
86hyphen-swedish:
87
88%package doc
89Summary: TeX Live: Documentation files of %{name}
90Group: Applications/Publishing
91Requires: %{name} = %{version}-%{release}
92
93%description doc
94This package contains documentation files of %{name}.
95
96%prep
97
98%build
99
100%install
101[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
102
103PREF=%{buildroot}%{tex_destdir}
104
105manifest=(
106texmf-dist/doc/latex/swebib/README
107texmf-dist/bibtex/bst/swebib/sweabbrv.bst
108texmf-dist/bibtex/bst/swebib/swealpha.bst
109texmf-dist/bibtex/bst/swebib/sweplain.bst
110texmf-dist/bibtex/bst/swebib/sweplnat.bst
111texmf-dist/bibtex/bst/swebib/sweunsrt.bst
112)
113
114%__mkdir_p ${PREF}/texmf-dist
115for i in "${manifest[@]}"; do
116    %__install -D %{texlive_src}/$i ${PREF}/$i
117done
118
119## info
120%__rm -f %{buildroot}%{_infodir}/dir
121%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
122
123## man
124## man t1* files are provided by t1utils
125for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
126    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
127done
128
129## man some files are provided by psutils
130for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
131    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
132done
133
134## fix perl path
135for i in source/metapost/expressg/expressg.dtx \
136         doc/metapost/expressg/n2mpsprl.prl \
137         doc/latex/songbook/contrib/crd2sb/crd2sb; do
138    [ -f %{build_texmf}-dist/${i} ] && \
139        %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
140done
141
142## remove asymptote directries, which provides asymptote package
143find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
144# find %{buildroot} -name "Makefile" | xargs %__rm -f
145
146# ## remove xindy
147# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
148
149# ## remove tex4ht
150# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
151
152## remove arch dependent binaries
153%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
154
155## remove unpackaging files
156find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
157find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
158
159## Files list
160find %{buildroot} -type f -or -type l | \
161    %__sed -e "s|%{buildroot}||g" > filelist.full
162
163find %{buildroot}%{texmf}-dist -type d | \
164    %__sed -e "s|^%{buildroot}|%dir |" \
165           -e "s|$|/|"             >> filelist.full
166
167## subpackages
168grep "/texmf-dist/doc/" filelist.full > filelist.doc
169cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
170%__mv -f filelist.tmp filelist.full
171
172%clean
173%__rm -rf %{buildroot}
174
175%post
176%{exec_texhash}
177
178rpm -q --quiet texlive-common || exit 0
179
180echo -n "    "
181echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
182
183exit 0
184
185
186%postun
187if [ "$1" = 0 ]; then
188    %{exec_texhash}
189
190fi
191
192exit 0
193
194%files -f filelist.full
195%defattr(-,root,root)
196
197%files -f filelist.doc doc
198%defattr(-,root,root)
199
200%changelog
201* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
202- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langswedish
203- improved %%post
204
205* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
206- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langswedish
207- removed arch dependent binaries (texlive-collection-latexextra)
208- fixed perl path
209- improved updmap process in %%post and %%postun
210
211* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
212- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langswedish
Note: See TracBrowser for help on using the repository browser.